IO.Interfaces.ADC Namespace

Abstract Interface for ADC (Analog to Digital Converter) Inputs
Classes
 | Class | Description
Public class | Input | Encapsulates ADC voltage inputs.
Interfaces
 | Interface | Description
Public interface | Sample | Abstract interface for ADC inputs returning an integer sample value.
Public interface | Voltage | Abstract interface for ADC inputs returning a floating point voltage value.
Send comments on this topic to phil@munts.net


Input Class

Encapsulates ADC voltage inputs.
Inheritance Hierarchy
SystemObject
IO.Interfaces.ADCInput

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class Input : Voltage
Public Class Input
    Implements Voltage
public ref class Input : Voltage
type Input =
    class
        interface Voltage
    end

The Input type exposes the following members.

Constructors
 | Name | Description
Public method | Input | Create an ADC voltage input.
Top
Properties
 | Name | Description
Public property | voltage | Read-only property returning the analog input voltage.
Top
See Also

Reference

IO.Interfaces.ADC Namespace


Input Constructor

Create an ADC voltage input.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public Input(
    Sample input,
    double reference,
    double gain = 1
)
Public Sub New (
    input As Sample,
    reference As Double,
    Optional gain As Double = 1
)
public:
Input(
    Sample^ input,
    double reference,
    double gain = 1
)
new :
        input : Sample *
        reference : float *
        ?gain : float
(* Defaults:
        let _gain = defaultArg gain 1
*)
-> Input

Parameters

input
Type: IO.Interfaces.ADCSample
ADC sample object.
reference
Type: SystemDouble
ADC reference in volts.
gain (Optional)
Type: SystemDouble
ADC input gain in volts per volt.
See Also

Reference

Input Class
IO.Interfaces.ADC Namespace


Input Properties

The Input type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning the analog input voltage.
Top
See Also

Reference

Input Class
IO.Interfaces.ADC Namespace


Input.voltage Property

Raspberry Pi LPC1114 I/O Processor Expansion Board SPIAgent Library for .Net

Inputvoltage Property

Read-only property returning the analog input voltage.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public double voltage { get; }
Public ReadOnly Property voltage As Double
    Get
public:
virtual property double voltage {
    double get () sealed;
}
abstract voltage : float with get
override voltage : float with get

Property Value

Type: Double

Implements

Voltagevoltage
See Also

Reference

Input Class
IO.Interfaces.ADC Namespace


Sample Interface

Abstract interface for ADC inputs returning an integer sample value.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public interface Sample
Public Interface Sample
public interface class Sample
type Sample =  interface end

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample value.
Top
See Also

Reference

IO.Interfaces.ADC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample value.
Top
See Also

Reference

Sample Interface
IO.Interfaces.ADC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
int resolution { get; }
ReadOnly Property resolution As Integer
    Get
property int resolution {
    int get ();
}
abstract resolution : int with get

Property Value

Type: Int32
See Also

Reference

Sample Interface
IO.Interfaces.ADC Namespace


Sample.sample Property

Samplesample Property

Read-only property returning an integer analog sample value.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
int sample { get; }
ReadOnly Property sample As Integer
    Get
property int sample {
    int get ();
}
abstract sample : int with get

Property Value

Type: Int32
See Also

Reference

Sample Interface
IO.Interfaces.ADC Namespace


Voltage Interface

Abstract interface for ADC inputs returning a floating point voltage value.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public interface Voltage
Public Interface Voltage
public interface class Voltage
type Voltage =  interface end

The Voltage type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning a floating point analog voltage value.
Top
See Also

Reference

IO.Interfaces.ADC Namespace


Voltage Properties

The Voltage type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning a floating point analog voltage value.
Top
See Also

Reference

Voltage Interface
IO.Interfaces.ADC Namespace


Voltage.voltage Property

Voltagevoltage Property

Read-only property returning a floating point analog voltage value.

Namespace: IO.Interfaces.ADC
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
double voltage { get; }
ReadOnly Property voltage As Double
    Get
property double voltage {
    double get ();
}
abstract voltage : float with get

Property Value

Type: Double
See Also

Reference

Voltage Interface
IO.Interfaces.ADC Namespace


IO.Interfaces.GPIO Namespace

Abstract Interface for GPIO (General Purpose Input/Ouput) Pins
Interfaces
 | Interface | Description
Public interface | Pin | Abstract interface for GPIO pins.
Enumerations
 | Enumeration | Description
Public enumeration | Direction | GPIO pin data direction settings.


Direction Enumeration

GPIO pin data direction settings.

Namespace: IO.Interfaces.GPIO
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
Input | 0 | Input pin (read only)
Output | 1 | Output pin (read or write)
See Also

Reference

IO.Interfaces.GPIO Namespace


Pin Interface

Abstract interface for GPIO pins.

Namespace: IO.Interfaces.GPIO
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public interface Pin
Public Interface Pin
public interface class Pin
type Pin =  interface end

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Interfaces.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Interface
IO.Interfaces.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Interfaces.GPIO
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
bool state { get; set; }
Property state As Boolean
    Get
    Set
property bool state {
    bool get ();
    void set (bool value);
}
abstract state : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pin Interface
IO.Interfaces.GPIO Namespace


IO.Interfaces.PWM Namespace

Abstract Interface for PWM (Pulse Width Modulated) Outputs
Classes
 | Class | Description
Public class | DutyCycles | PWM dutycycle contants.
Interfaces
 | Interface | Description
Public interface | Output | Abstract interface for PWM outputs.


DutyCycles Class

PWM dutycycle contants.
Inheritance Hierarchy
SystemObject
IO.Interfaces.PWMDutyCycles

Namespace: IO.Interfaces.PWM
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public static class DutyCycles
Public NotInheritable Class DutyCycles
public ref class DutyCycles abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DutyCycles =  class end

The DutyCycles type exposes the following members.

Fields
Name | Description
Maximum | Maximum duty cycle (percent).
Minimum | Minimum duty cycle (percent).
Top
See Also

Reference

IO.Interfaces.PWM Namespace


DutyCycles Fields

The DutyCycles type exposes the following members.

Fields
Name | Description
Maximum | Maximum duty cycle (percent).
Minimum | Minimum duty cycle (percent).
Top
See Also

Reference

DutyCycles Class
IO.Interfaces.PWM Namespace


DutyCycles.Maximum Field

DutyCyclesMaximum Field

Maximum duty cycle (percent).

Namespace: IO.Interfaces.PWM
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double Maximum = 100
Public Const Maximum As Double = 100
public:
literal double Maximum = 100
static val mutable Maximum: float

Field Value

Type: Double
See Also

Reference

DutyCycles Class
IO.Interfaces.PWM Namespace


DutyCycles.Minimum Field

DutyCyclesMinimum Field

Minimum duty cycle (percent).

Namespace: IO.Interfaces.PWM
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double Minimum = 0
Public Const Minimum As Double = 0
public:
literal double Minimum = 0
static val mutable Minimum: float

Field Value

Type: Double
See Also

Reference

DutyCycles Class
IO.Interfaces.PWM Namespace


Output Interface

Abstract interface for PWM outputs.

Namespace: IO.Interfaces.PWM
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public interface Output
Public Interface Output
public interface class Output
type Output =  interface end

The Output type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only PWM duty cycle property.
Top
See Also

Reference

IO.Interfaces.PWM Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only PWM duty cycle property.
Top
See Also

Reference

Output Interface
IO.Interfaces.PWM Namespace


Output.dutycycle Property

Outputdutycycle Property

Write-only PWM duty cycle property.

Namespace: IO.Interfaces.PWM
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
double dutycycle { set; }
WriteOnly Property dutycycle As Double
    Set
property double dutycycle {
    void set (double value);
}
abstract dutycycle : float with set

Property Value

Type: Double
See Also

Reference

Output Interface
IO.Interfaces.PWM Namespace


IO.Interfaces.Servo Namespace

Abstract Interface for Servo Outputs
Classes
 | Class | Description
Public class | Positions | Servo position contants.
Interfaces
 | Interface | Description
Public interface | Output | Abstract interface for servo outputs.


Output Interface

Abstract interface for servo outputs.

Namespace: IO.Interfaces.Servo
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public interface Output
Public Interface Output
public interface class Output
type Output =  interface end

The Output type exposes the following members.

Properties
 | Name | Description
Public property | position | Write-only servo position property.
Top
See Also

Reference

IO.Interfaces.Servo Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | position | Write-only servo position property.
Top
See Also

Reference

Output Interface
IO.Interfaces.Servo Namespace


Output.position Property

Outputposition Property

Write-only servo position property.

Namespace: IO.Interfaces.Servo
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
double position { set; }
WriteOnly Property position As Double
    Set
property double position {
    void set (double value);
}
abstract position : float with set

Property Value

Type: Double
See Also

Reference

Output Interface
IO.Interfaces.Servo Namespace


Positions Class

Servo position contants.
Inheritance Hierarchy
SystemObject
IO.Interfaces.ServoPositions

Namespace: IO.Interfaces.Servo
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public static class Positions
Public NotInheritable Class Positions
public ref class Positions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Positions =  class end

The Positions type exposes the following members.

Fields
Name | Description
Maximum | Maximum displacement position.
Minimum | Minimum displacement position.
Neutral | Zero displacement (neutral) position.
Top
See Also

Reference

IO.Interfaces.Servo Namespace


Positions Fields

The Positions type exposes the following members.

Fields
Name | Description
Maximum | Maximum displacement position.
Minimum | Minimum displacement position.
Neutral | Zero displacement (neutral) position.
Top
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


Positions.Maximum Field

PositionsMaximum Field

Maximum displacement position.

Namespace: IO.Interfaces.Servo
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double Maximum = 1
Public Const Maximum As Double = 1
public:
literal double Maximum = 1
static val mutable Maximum: float

Field Value

Type: Double
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


Positions.Minimum Field

PositionsMinimum Field

Minimum displacement position.

Namespace: IO.Interfaces.Servo
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double Minimum = -1
Public Const Minimum As Double = -1
public:
literal double Minimum = -1
static val mutable Minimum: float

Field Value

Type: Double
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


Positions.Neutral Field

PositionsNeutral Field

Zero displacement (neutral) position.

Namespace: IO.Interfaces.Servo
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double Neutral = 0
Public Const Neutral As Double = 0
public:
literal double Neutral = 0
static val mutable Neutral: float

Field Value

Type: Double
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


SPIAgent Namespace

The SPIAgent namespace provides a .Net binding to the Raspberry Pi LPC1114 I/O Processor Board SPI Agent Firmware.
Classes
 | Class | Description
Public class | ADC | The ADC (Analog to Digital Converter) class implements LPC1114 analog input services.
Public class | GPIO | The GPIO (General Purpose Input Output) class implements LPC1114 digital input/output services.
Public class | LEGORC | The LEGORC class implements LEGO(R) Power Functions Remote Control Services.
Public class | Motor | The Motor class implements LPC1114 H-bridge DC motor driver output services.
Public class | Pins | These are the LPC1114 I/O pins available for use on the Raspberry Pi LPC1114 I/O Processor Expansion Board.
Public class | PWM | The PWM (Pulse With Modulation) class implements LPC1114 PWM output services.
Public class | Servo | The Servo class implements LPC1114 RC servo output services.
Public class | SFR | The SFR class implements LPC1114 Special Function Register services. Use only with great caution!
Public class | SPIAGENT_COMMAND_MSG_t | Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware command message object
Public class | SPIAgent_Exception | This exception is raised upon detection of a Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware error.
Public class | SPIAGENT_RESPONSE_MSG_t | Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware response message object
Public class | SPIAgent_Transport_Exception | This exception is raised upon detection of a Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware transport failure.
Public class | Timer | The Timer class implements LPC1114 32-bit hardware timer services.
Public class | Transport | The Transport class provides transport services to a specified Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware ONC-RPC server.
Interfaces
 | Interface | Description
Public interface | ITransport | Abstract interface for SPIAgent transport implementations.
Enumerations
 | Enumeration | Description
Public enumeration | Commands | Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware commands
Public enumeration | errno | These are well-known errno values that seem to be standard among BSD, Linux, and other Unix derivatives
Public enumeration | GPIODIRECTION | LPC1114 GPIO pin data directions.
Public enumeration | GPIOINTERRUPT | LPC1114 GPIO pin interrupt modes.
Public enumeration | GPIOMODE | LPC1114 GPIO pin configuration modes.
Public enumeration | LEGORCDIRECTION | LEGO(R) Power Functions Remote Control moter direction identifiers.
Public enumeration | LEGORCMOTOR | LEGO(R) Power Functions Remote Control moter identifiers.
Public enumeration | TimerCAPTURE_EDGE | LPC1114 32-bit timer capture modes.
Public enumeration | TimerFEATURES | LPC1114 32-bit timer capture and match features.
Public enumeration | TimerID | LPC1114 32-bit timer identifiers.
Public enumeration | TimerMATCH_OUTPUT | LPC1114 32-bit timer match output actions.
Public enumeration | TimerMATCH_REGISTER | LPC1114 32-bit timer match registers.
Public enumeration | TimerMODE | LPC1114 32-bit timer modes.


ADC Class

The ADC (Analog to Digital Converter) class implements LPC1114 analog input services.
Inheritance Hierarchy
SystemObject
SPIAgentADC

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class ADC : Sample, Voltage
Public Class ADC
    Implements Sample, Voltage
public ref class ADC : Sample, Voltage
type ADC =
    class
        interface Sample
        interface Voltage
    end

The ADC type exposes the following members.

Constructors
 | Name | Description
Public method | ADC | LPC1114 analog input object constructor.
Top
Properties
 | Name | Description
Public property | resolution | This read-only property returns the LPC1114 A/D converter resolution int bits.
Public property | sample | This read-only property returns the LPC1114 analog input sample (0 to 1023).
Public property | voltage | This read-only property returns the LPC1114 analog input voltage (0.0 to 3.3 volts).
Top
Fields
Name | Description
LPC1114_ADC_BITS | The analog input resolution is 10 bits.
LPC1114_ADC_SPAN | The analog input range is 0.0 to 3.3 volts.
LPC1114_ADC_STEPS | There are 1024 discrete analog input levels.
LPC1114_ADC_STEPSIZE | The analog input level steps are 3.22 millivolts per step.
Top
See Also

Reference

SPIAgent Namespace


ADC Constructor

LPC1114 analog input object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public ADC(
    ITransport spiagent,
    int pin
)
Public Sub New (
    spiagent As ITransport,
    pin As Integer
)
public:
ADC(
    ITransport^ spiagent,
    int pin
)
new :
        spiagent : ITransport *
        pin : int -> ADC

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pin
Type: SystemInt32
LPC1114 analog input pin number. LPC1114_AD1 through LPC1114_AD5 are allowed.
See Also

Reference

ADC Class


ADC Properties

The ADC type exposes the following members.

Properties
 | Name | Description
Public property | resolution | This read-only property returns the LPC1114 A/D converter resolution int bits.
Public property | sample | This read-only property returns the LPC1114 analog input sample (0 to 1023).
Public property | voltage | This read-only property returns the LPC1114 analog input voltage (0.0 to 3.3 volts).
Top
See Also

Reference

ADC Class


ADC.resolution Property

ADCresolution Property

This read-only property returns the LPC1114 A/D converter resolution int bits.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int resolution { get; }
Public ReadOnly Property resolution As Integer
    Get
public:
virtual property int resolution {
    int get () sealed;
}
abstract resolution : int with get
override resolution : int with get

Property Value

Type: Int32

Implements

Sampleresolution
See Also

Reference

ADC Class


ADC.sample Property

ADCsample Property

This read-only property returns the LPC1114 analog input sample (0 to 1023).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int sample { get; }
Public ReadOnly Property sample As Integer
    Get
public:
virtual property int sample {
    int get () sealed;
}
abstract sample : int with get
override sample : int with get

Property Value

Type: Int32

Implements

Samplesample
See Also

Reference

ADC Class


ADC.voltage Property

ADCvoltage Property

This read-only property returns the LPC1114 analog input voltage (0.0 to 3.3 volts).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public double voltage { get; }
Public ReadOnly Property voltage As Double
    Get
public:
virtual property double voltage {
    double get () sealed;
}
abstract voltage : float with get
override voltage : float with get

Property Value

Type: Double

Implements

Voltagevoltage
See Also

Reference

ADC Class


ADC Fields

The ADC type exposes the following members.

Fields
Name | Description
LPC1114_ADC_BITS | The analog input resolution is 10 bits.
LPC1114_ADC_SPAN | The analog input range is 0.0 to 3.3 volts.
LPC1114_ADC_STEPS | There are 1024 discrete analog input levels.
LPC1114_ADC_STEPSIZE | The analog input level steps are 3.22 millivolts per step.
Top
See Also

Reference

ADC Class


ADC.LPC1114_ADC_BITS Field

ADCLPC1114_ADC_BITS Field

The analog input resolution is 10 bits.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_ADC_BITS = 10
Public Const LPC1114_ADC_BITS As Integer = 10
public:
literal int LPC1114_ADC_BITS = 10
static val mutable LPC1114_ADC_BITS: int

Field Value

Type: Int32
See Also

Reference

ADC Class


ADC.LPC1114_ADC_SPAN Field

ADCLPC1114_ADC_SPAN Field

The analog input range is 0.0 to 3.3 volts.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const float LPC1114_ADC_SPAN = 3.3f
Public Const LPC1114_ADC_SPAN As Single = 3.3F
public:
literal float LPC1114_ADC_SPAN = 3.3f
static val mutable LPC1114_ADC_SPAN: float32

Field Value

Type: Single
See Also

Reference

ADC Class


ADC.LPC1114_ADC_STEPS Field

ADCLPC1114_ADC_STEPS Field

There are 1024 discrete analog input levels.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_ADC_STEPS = 1024
Public Const LPC1114_ADC_STEPS As Integer = 1024
public:
literal int LPC1114_ADC_STEPS = 1024
static val mutable LPC1114_ADC_STEPS: int

Field Value

Type: Int32
See Also

Reference

ADC Class


ADC.LPC1114_ADC_STEPSIZE Field

ADCLPC1114_ADC_STEPSIZE Field

The analog input level steps are 3.22 millivolts per step.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const float LPC1114_ADC_STEPSIZE = 0.003222656f
Public Const LPC1114_ADC_STEPSIZE As Single = 0.003222656F
public:
literal float LPC1114_ADC_STEPSIZE = 0.003222656f
static val mutable LPC1114_ADC_STEPSIZE: float32

Field Value

Type: Single
See Also

Reference

ADC Class


Commands Enumeration

Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware commands

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum Commands
Public Enumeration Commands
public enum class Commands
type Commands
Members
Member name | Value | Description
SPIAGENT_CMD_NOP | 0 |
SPIAGENT_CMD_LOOPBACK | 1 |
SPIAGENT_CMD_CONFIGURE_ANALOG_INPUT | 2 |
SPIAGENT_CMD_CONFIGURE_GPIO_INPUT | 3 |
SPIAGENT_CMD_CONFIGURE_GPIO_OUTPUT | 4 |
SPIAGENT_CMD_CONFIGURE_PWM_OUTPUT | 5 |
SPIAGENT_CMD_GET_ANALOG | 6 |
SPIAGENT_CMD_GET_GPIO | 7 |
SPIAGENT_CMD_PUT_GPIO | 8 |
SPIAGENT_CMD_PUT_PWM | 9 |
SPIAGENT_CMD_CONFIGURE_GPIO_INTERRUPT | 10 |
SPIAGENT_CMD_CONFIGURE_GPIO | 11 |
SPIAGENT_CMD_PUT_LEGORC | 12 |
SPIAGENT_CMD_GET_SFR | 13 |
SPIAGENT_CMD_PUT_SFR | 14 |
SPIAGENT_CMD_CONFIGURE_TIMER_MODE | 15 |
SPIAGENT_CMD_CONFIGURE_TIMER_PRESCALER | 16 |
SPIAGENT_CMD_CONFIGURE_TIMER_CAPTURE | 17 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH0 | 18 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH1 | 19 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH2 | 20 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH3 | 21 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH0_VALUE | 22 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH1_VALUE | 23 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH2_VALUE | 24 |
SPIAGENT_CMD_CONFIGURE_TIMER_MATCH3_VALUE | 25 |
SPIAGENT_CMD_GET_TIMER_VALUE | 26 |
SPIAGENT_CMD_GET_TIMER_CAPTURE | 27 |
SPIAGENT_CMD_GET_TIMER_CAPTURE_DELTA | 28 |
SPIAGENT_CMD_INIT_TIMER | 29 |
SENTINEL | 30 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


errno Enumeration

These are well-known errno values that seem to be standard among BSD, Linux, and other Unix derivatives

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum errno
Public Enumeration errno
public enum class errno
type errno
Members
Member name | Value | Description
EOK | 0 |
EPERM | 1 |
ENOENT | 2 |
ESRCH | 3 |
EINTR | 4 |
EIO | 5 |
ENXIO | 6 |
E2BIG | 7 |
ENOEXEC | 8 |
EBADF | 9 |
ECHILD | 10 |
EAGAIN | 11 |
ENOMEM | 12 |
EACCES | 13 |
EFAULT | 14 |
ENOTBLK | 15 |
EBUSY | 16 |
EEXIST | 17 |
EXDEV | 18 |
ENODEV | 19 |
ENOTDIR | 20 |
EISDIR | 21 |
EINVAL | 22 |
ENFILE | 23 |
EMFILE | 24 |
ENOTTY | 25 |
ETXTBSY | 26 |
EFBIG | 27 |
ENOSPC | 28 |
ESPIPE | 29 |
EROFS | 30 |
EMLINK | 31 |
EPIPE | 32 |
EDOM | 33 |
ERANGE | 34 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


GPIO Class

The GPIO (General Purpose Input Output) class implements LPC1114 digital input/output services.
Inheritance Hierarchy
SystemObject
SPIAgentGPIO

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class GPIO : Pin
Public Class GPIO
    Implements Pin
public ref class GPIO : Pin
type GPIO =
    class
        interface Pin
    end

The GPIO type exposes the following members.

Constructors
 | Name | Description
Public method | GPIO(ITransport, Int32, GPIOMODE) | Constructor that configures a GPIO pin, given pin number and mode. Use this constructor if you need to configure a high-impedance input or an open-drain output.
Public method | GPIO(ITransport, Int32, GPIODIRECTION, Boolean) | Constructor that configures a GPIO pin, given pin number, data direction, and initial state.
Top
Properties
 | Name | Description
Public property | state | This property gets or sets this LPC1114 GPIO pin's state.
Top
Methods
 | Name | Description
Public method | ConfigureInterrupt | Configure this GPIO pin's interrupt mode. This only makes sense when running on the Raspberry Pi.
Public method | ConfigureMode | Configure this GPIO pin's mode.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


GPIO Constructor

Overload List
 | Name | Description
Public method | GPIO(ITransport, Int32, GPIOMODE) | Constructor that configures a GPIO pin, given pin number and mode. Use this constructor if you need to configure a high-impedance input or an open-drain output.
Public method | GPIO(ITransport, Int32, GPIODIRECTION, Boolean) | Constructor that configures a GPIO pin, given pin number, data direction, and initial state.
Top
See Also

Reference

GPIO Class


GPIO Constructor (ITransport, Int32, GPIO.MODE)

GPIO Constructor (ITransport, Int32, GPIOMODE)

Constructor that configures a GPIO pin, given pin number and mode. Use this constructor if you need to configure a high-impedance input or an open-drain output.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public GPIO(
    ITransport spiagent,
    int pin,
    GPIOMODE mode
)
Public Sub New (
    spiagent As ITransport,
    pin As Integer,
    mode As GPIOMODE
)
public:
GPIO(
    ITransport^ spiagent,
    int pin,
    GPIOMODE mode
)
new :
        spiagent : ITransport *
        pin : int *
        mode : GPIOMODE -> GPIO

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pin
Type: SystemInt32
LPC1114 GPIO pin number. LPC1114_GPIO0 through LPC1114_GPIO7 are allowed.
mode
Type: SPIAgentGPIOMODE
LPC1114 GPIO pin mode.
See Also

Reference

GPIO Class
GPIO Overload


GPIO Constructor (ITransport, Int32, GPIO.DIRECTION, Boolean)

GPIO Constructor (ITransport, Int32, GPIODIRECTION, Boolean)

Constructor that configures a GPIO pin, given pin number, data direction, and initial state.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public GPIO(
    ITransport spiagent,
    int pin,
    GPIODIRECTION dir,
    bool state
)
Public Sub New (
    spiagent As ITransport,
    pin As Integer,
    dir As GPIODIRECTION,
    state As Boolean
)
public:
GPIO(
    ITransport^ spiagent,
    int pin,
    GPIODIRECTION dir,
    bool state
)
new :
        spiagent : ITransport *
        pin : int *
        dir : GPIODIRECTION *
        state : bool -> GPIO

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pin
Type: SystemInt32
LPC1114 GPIO pin number. LPC1114_GPIO0 through LPC1114_GPIO7 are allowed.
dir
Type: SPIAgentGPIODIRECTION
LPC1114 GPIO pin data direction.
state
Type: SystemBoolean
LPC1114 GPIO pin initial state. For an output pin, sets output state to sourcing (1) or sinking (0). For an input pin, sets internal pull-up resistor (1) or pull-down resistor (0).
See Also

Reference

GPIO Class
GPIO Overload


GPIO Properties

The GPIO type exposes the following members.

Properties
 | Name | Description
Public property | state | This property gets or sets this LPC1114 GPIO pin's state.
Top
See Also

Reference

GPIO Class


GPIO.state Property

GPIOstate Property

This property gets or sets this LPC1114 GPIO pin's state.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public bool state { get; set; }
Public Property state As Boolean
    Get
    Set
public:
virtual property bool state {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract state : bool with get, set
override state : bool with get, set

Property Value

Type: Boolean

Implements

Pinstate
See Also

Reference

GPIO Class


GPIO Methods

The GPIO type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureInterrupt | Configure this GPIO pin's interrupt mode. This only makes sense when running on the Raspberry Pi.
Public method | ConfigureMode | Configure this GPIO pin's mode.
Top
See Also

Reference

GPIO Class


GPIO.ConfigureInterrupt Method

GPIOConfigureInterrupt Method

Configure this GPIO pin's interrupt mode. This only makes sense when running on the Raspberry Pi.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void ConfigureInterrupt(
    GPIOINTERRUPT intconfig
)
Public Sub ConfigureInterrupt (
    intconfig As GPIOINTERRUPT
)
public:
void ConfigureInterrupt(
    GPIOINTERRUPT intconfig
)
member ConfigureInterrupt :
        intconfig : GPIOINTERRUPT -> unit

Parameters

intconfig
Type: SPIAgentGPIOINTERRUPT
LPC1114 GPIO pin interrupt mode.
See Also

Reference

GPIO Class


GPIO.ConfigureMode Method

GPIOConfigureMode Method

Configure this GPIO pin's mode.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void ConfigureMode(
    GPIOMODE mode
)
Public Sub ConfigureMode (
    mode As GPIOMODE
)
public:
void ConfigureMode(
    GPIOMODE mode
)
member ConfigureMode :
        mode : GPIOMODE -> unit

Parameters

mode
Type: SPIAgentGPIOMODE
LPC1114 GPIO pin mode.
See Also

Reference

GPIO Class


GPIO.DIRECTION Enumeration

GPIODIRECTION Enumeration

LPC1114 GPIO pin data directions.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum DIRECTION
Public Enumeration DIRECTION
public enum class DIRECTION
type DIRECTION
Members
Member name | Value | Description
INPUT | 0 |
OUTPUT | 1 |
SENTINEL | 2 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


GPIO.INTERRUPT Enumeration

GPIOINTERRUPT Enumeration

LPC1114 GPIO pin interrupt modes.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum INTERRUPT
Public Enumeration INTERRUPT
public enum class INTERRUPT
type INTERRUPT
Members
Member name | Value | Description
DISABLED | 0 |
FALLING | 1 |
RISING | 2 |
BOTH | 3 |
SENTINEL | 4 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


GPIO.MODE Enumeration

GPIOMODE Enumeration

LPC1114 GPIO pin configuration modes.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum MODE
Public Enumeration MODE
public enum class MODE
type MODE
Members
Member name | Value | Description
INPUT | 0 |
INPUT_PULLDOWN | 1 |
INPUT_PULLUP | 2 |
OUTPUT | 3 |
OUTPUT_OPENDRAIN | 4 |
SENTINEL | 5 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


ITransport Interface

Abstract interface for SPIAgent transport implementations.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public interface ITransport
Public Interface ITransport
public interface class ITransport
type ITransport =  interface end

The ITransport type exposes the following members.

Methods
 | Name | Description
Public method | Command | Issue a command to the current server.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


ITransport Methods

The ITransport type exposes the following members.

Methods
 | Name | Description
Public method | Command | Issue a command to the current server.
Top
See Also

Reference

ITransport Interface


ITransport.Command Method

ITransportCommand Method

Issue a command to the current server.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
void Command(
    SPIAGENT_COMMAND_MSG_t cmd,
    ref SPIAGENT_RESPONSE_MSG_t resp
)
Sub Command (
    cmd As SPIAGENT_COMMAND_MSG_t,
    ByRef resp As SPIAGENT_RESPONSE_MSG_t
)
void Command(
    SPIAGENT_COMMAND_MSG_t^ cmd,
    SPIAGENT_RESPONSE_MSG_t^% resp
)
abstract Command :
        cmd : SPIAGENT_COMMAND_MSG_t *
        resp : SPIAGENT_RESPONSE_MSG_t byref -> unit

Parameters

cmd
Type: SPIAgentSPIAGENT_COMMAND_MSG_t
Command message structure.
resp
Type: SPIAgentSPIAGENT_RESPONSE_MSG_t
Response message structure.
See Also

Reference

ITransport Interface


LEGORC Class

The LEGORC class implements LEGO(R) Power Functions Remote Control Services.
Inheritance Hierarchy
SystemObject
SPIAgentLEGORC

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class LEGORC
Public Class LEGORC
public ref class LEGORC
type LEGORC =  class end

The LEGORC type exposes the following members.

Constructors
 | Name | Description
Public method | LEGORC | LEGO(R) Power Functions Remote Control output object constructor.
Top
Methods
 | Name | Description
Public method | Command | Issue a LEGO(R) Power Functions Remote Control command.
Top
Fields
Name | Description
MAX_CHANNEL | The range of LEGO(R) Power Functions Remote Control channels is 1 to 4.
MAX_SPEED | The range of LEGO(R) Power Functions Remote Control speed values is 0 to 255. Some motor selections impose even smaller speed ranges.
MIN_CHANNEL | The range of LEGO(R) Power Functions Remote Control channels is 1 to 4.
MIN_SPEED | The range of LEGO(R) Power Functions Remote Control speed values is 0 to 255. Some motor selections impose even smaller speed ranges.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


LEGORC Constructor

LEGO(R) Power Functions Remote Control output object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public LEGORC(
    ITransport spiagent,
    int pin
)
Public Sub New (
    spiagent As ITransport,
    pin As Integer
)
public:
LEGORC(
    ITransport^ spiagent,
    int pin
)
new :
        spiagent : ITransport *
        pin : int -> LEGORC

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pin
Type: SystemInt32
LPC1114 GPIO pin number. LPC1114_GPIO0 through LPC1114_GPIO7 are allowed.
See Also

Reference

LEGORC Class


LEGORC Methods

The LEGORC type exposes the following members.

Methods
 | Name | Description
Public method | Command | Issue a LEGO(R) Power Functions Remote Control command.
Top
See Also

Reference

LEGORC Class


LEGORC.Command Method

LEGORCCommand Method

Issue a LEGO(R) Power Functions Remote Control command.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void Command(
    int c,
    LEGORCMOTOR m,
    LEGORCDIRECTION d,
    int s
)
Public Sub Command (
    c As Integer,
    m As LEGORCMOTOR,
    d As LEGORCDIRECTION,
    s As Integer
)
public:
void Command(
    int c,
    LEGORCMOTOR m,
    LEGORCDIRECTION d,
    int s
)
member Command :
        c : int *
        m : LEGORCMOTOR *
        d : LEGORCDIRECTION *
        s : int -> unit

Parameters

c
Type: SystemInt32
Channel number.
m
Type: SPIAgentLEGORCMOTOR
Motor identifier.
d
Type: SPIAgentLEGORCDIRECTION
Direction identifier.
s
Type: SystemInt32
Speed.
See Also

Reference

LEGORC Class


LEGORC Fields

The LEGORC type exposes the following members.

Fields
Name | Description
MAX_CHANNEL | The range of LEGO(R) Power Functions Remote Control channels is 1 to 4.
MAX_SPEED | The range of LEGO(R) Power Functions Remote Control speed values is 0 to 255. Some motor selections impose even smaller speed ranges.
MIN_CHANNEL | The range of LEGO(R) Power Functions Remote Control channels is 1 to 4.
MIN_SPEED | The range of LEGO(R) Power Functions Remote Control speed values is 0 to 255. Some motor selections impose even smaller speed ranges.
Top
See Also

Reference

LEGORC Class


LEGORC.MAX_CHANNEL Field

LEGORCMAX_CHANNEL Field

The range of LEGO(R) Power Functions Remote Control channels is 1 to 4.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MAX_CHANNEL = 4
Public Const MAX_CHANNEL As Integer = 4
public:
literal int MAX_CHANNEL = 4
static val mutable MAX_CHANNEL: int

Field Value

Type: Int32
See Also

Reference

LEGORC Class


LEGORC.MAX_SPEED Field

LEGORCMAX_SPEED Field

The range of LEGO(R) Power Functions Remote Control speed values is 0 to 255. Some motor selections impose even smaller speed ranges.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MAX_SPEED = 255
Public Const MAX_SPEED As Integer = 255
public:
literal int MAX_SPEED = 255
static val mutable MAX_SPEED: int

Field Value

Type: Int32
See Also

Reference

LEGORC Class


LEGORC.MIN_CHANNEL Field

LEGORCMIN_CHANNEL Field

The range of LEGO(R) Power Functions Remote Control channels is 1 to 4.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MIN_CHANNEL = 1
Public Const MIN_CHANNEL As Integer = 1
public:
literal int MIN_CHANNEL = 1
static val mutable MIN_CHANNEL: int

Field Value

Type: Int32
See Also

Reference

LEGORC Class


LEGORC.MIN_SPEED Field

LEGORCMIN_SPEED Field

The range of LEGO(R) Power Functions Remote Control speed values is 0 to 255. Some motor selections impose even smaller speed ranges.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MIN_SPEED = 0
Public Const MIN_SPEED As Integer = 0
public:
literal int MIN_SPEED = 0
static val mutable MIN_SPEED: int

Field Value

Type: Int32
See Also

Reference

LEGORC Class


LEGORC.DIRECTION Enumeration

LEGORCDIRECTION Enumeration

LEGO(R) Power Functions Remote Control moter direction identifiers.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum DIRECTION
Public Enumeration DIRECTION
public enum class DIRECTION
type DIRECTION
Members
Member name | Value | Description
REVERSE | 0 |
FORWARD | 1 |
SENTINEL | 2 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


LEGORC.MOTOR Enumeration

LEGORCMOTOR Enumeration

LEGO(R) Power Functions Remote Control moter identifiers.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum MOTOR
Public Enumeration MOTOR
public enum class MOTOR
type MOTOR
Members
Member name | Value | Description
ALLSTOP | 0 |
MOTORA | 1 |
MOTORB | 2 |
COMBODIRECT | 3 |
COMBOPWM | 4 |
SENTINEL | 5 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Motor Class

The Motor class implements LPC1114 H-bridge DC motor driver output services.
Inheritance Hierarchy
SystemObject
SPIAgentMotor

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class Motor
Public Class Motor
public ref class Motor
type Motor =  class end

The Motor type exposes the following members.

Constructors
 | Name | Description
Public method | Motor | LPC1114 H-bridge DC motor driver output object constructor.
Top
Properties
 | Name | Description
Public property | speed | This write-only property sets this motor speed. Allowed values are -1.0 through 1.0 (normalized speed).
Top
Fields
Name | Description
MOTOR_MAX_SPEED | The motor speed maximum value is 1.0 (full forward).
MOTOR_MIN_SPEED | The motor speed minimum value is -1.0 (full reverse).
MOTOR_STOP | The motor speed stop value is 0.0.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Motor Constructor

LPC1114 H-bridge DC motor driver output object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public Motor(
    ITransport spiagent,
    int pwm_pin,
    int dir_pin,
    int frequency = 100
)
Public Sub New (
    spiagent As ITransport,
    pwm_pin As Integer,
    dir_pin As Integer,
    Optional frequency As Integer = 100
)
public:
Motor(
    ITransport^ spiagent,
    int pwm_pin,
    int dir_pin,
    int frequency = 100
)
new :
        spiagent : ITransport *
        pwm_pin : int *
        dir_pin : int *
        ?frequency : int
(* Defaults:
        let _frequency = defaultArg frequency 100
*)
-> Motor

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pwm_pin
Type: SystemInt32
LPC1114 PWM output pin number. Allowed values are LPC1114_PWM1 through LPC1114_PWM4.
dir_pin
Type: SystemInt32
LPC1114 direction output pin number. Allowed values are LPC1114_GPIO0 through LPC1114_GPIO7.
frequency (Optional)
Type: SystemInt32
PWM pulse frequency. Allowed values are 50 to 50000 Hz.
See Also

Reference

Motor Class


Motor Properties

The Motor type exposes the following members.

Properties
 | Name | Description
Public property | speed | This write-only property sets this motor speed. Allowed values are -1.0 through 1.0 (normalized speed).
Top
See Also

Reference

Motor Class


Motor.speed Property

Motorspeed Property

This write-only property sets this motor speed. Allowed values are -1.0 through 1.0 (normalized speed).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public double speed { set; }
Public WriteOnly Property speed As Double
    Set
public:
property double speed {
    void set (double value);
}
member speed : float with set

Property Value

Type: Double
See Also

Reference

Motor Class


Motor Fields

The Motor type exposes the following members.

Fields
Name | Description
MOTOR_MAX_SPEED | The motor speed maximum value is 1.0 (full forward).
MOTOR_MIN_SPEED | The motor speed minimum value is -1.0 (full reverse).
MOTOR_STOP | The motor speed stop value is 0.0.
Top
See Also

Reference

Motor Class


Motor.MOTOR_MAX_SPEED Field

MotorMOTOR_MAX_SPEED Field

The motor speed maximum value is 1.0 (full forward).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double MOTOR_MAX_SPEED = 1
Public Const MOTOR_MAX_SPEED As Double = 1
public:
literal double MOTOR_MAX_SPEED = 1
static val mutable MOTOR_MAX_SPEED: float

Field Value

Type: Double
See Also

Reference

Motor Class


Motor.MOTOR_MIN_SPEED Field

MotorMOTOR_MIN_SPEED Field

The motor speed minimum value is -1.0 (full reverse).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double MOTOR_MIN_SPEED = -1
Public Const MOTOR_MIN_SPEED As Double = -1
public:
literal double MOTOR_MIN_SPEED = -1
static val mutable MOTOR_MIN_SPEED: float

Field Value

Type: Double
See Also

Reference

Motor Class


Motor.MOTOR_STOP Field

MotorMOTOR_STOP Field

The motor speed stop value is 0.0.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double MOTOR_STOP = 1
Public Const MOTOR_STOP As Double = 1
public:
literal double MOTOR_STOP = 1
static val mutable MOTOR_STOP: float

Field Value

Type: Double
See Also

Reference

Motor Class


Pins Class

These are the LPC1114 I/O pins available for use on the Raspberry Pi LPC1114 I/O Processor Expansion Board.
Inheritance Hierarchy
SystemObject
SPIAgentPins

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public static class Pins
Public NotInheritable Class Pins
public ref class Pins abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Pins =  class end

The Pins type exposes the following members.

Methods
Name | Description
IS_ANALOG | Validate analog input pin
IS_GPIO | Validate GPIO pin
IS_PWM | Validate PWM output pin
Top
Fields
Name | Description
LPC1114_AD1 | Analog input 1 aka GPIO0
LPC1114_AD2 | Analog input 2 aka GPIO1
LPC1114_AD3 | Analog input 3 aka GPIO2
LPC1114_AD4 | Analog input 4 aka GPIO3
LPC1114_AD5 | Analog input 5 aka GPIO4
LPC1114_CT32B0_CAP0 | CT32B0 capture input 0 aka GPIO5
LPC1114_CT32B1_CAP0 | CT32B1 capture input 0 aka GPIO0
LPC1114_CT32B1_MAT0 | CT32B1 match output 0 aka GPIO1
LPC1114_CT32B1_MAT1 | CT32B1 match output 1 aka GPIO2
LPC1114_CT32B1_MAT2 | CT32B1 match output 2 aka GPIO3
LPC1114_CT32B1_MAT3 | CT32B1 match output 3 aka GPIO4
LPC1114_GPIO0 | GPIO0 aka LPC1114 PIO1_0
LPC1114_GPIO1 | GPIO1 aka LPC1114 PIO1_1
LPC1114_GPIO2 | GPIO2 aka LPC1114 PIO1_2
LPC1114_GPIO3 | GPIO3 aka LPC1114 PIO1_3
LPC1114_GPIO4 | GPIO4 aka LPC1114 PIO1_4
LPC1114_GPIO5 | GPIO5 aka LPC1114 PIO1_5
LPC1114_GPIO6 | GPIO6 aka LPC1114 PIO1_8
LPC1114_GPIO7 | GPIO7 aka LPC1114 PIO1_9
LPC1114_INT | Interrupt output to Raspberry Pi
LPC1114_LED | On board LED
LPC1114_PWM1 | PWM output 1 aka GPIO1
LPC1114_PWM2 | PWM output 2 aka GPIO2
LPC1114_PWM3 | PWM output 3 aka GPIO3
LPC1114_PWM4 | PWM output 4 aka GPIO7
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Pins Methods

The Pins type exposes the following members.

Methods
Name | Description
IS_ANALOG | Validate analog input pin
IS_GPIO | Validate GPIO pin
IS_PWM | Validate PWM output pin
Top
See Also

Reference

Pins Class


Pins.IS_ANALOG Method

PinsIS_ANALOG Method

Validate analog input pin

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public static bool IS_ANALOG(
    int pin
)
Public Shared Function IS_ANALOG (
    pin As Integer
) As Boolean
public:
static bool IS_ANALOG(
    int pin
)
static member IS_ANALOG :
        pin : int -> bool

Parameters

pin
Type: SystemInt32
LPC1114 GPIO Pin Number

Return Value

Type: Boolean
True if the specified pin can be used as an analog input
See Also

Reference

Pins Class


Pins.IS_GPIO Method

PinsIS_GPIO Method

Validate GPIO pin

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public static bool IS_GPIO(
    int pin
)
Public Shared Function IS_GPIO (
    pin As Integer
) As Boolean
public:
static bool IS_GPIO(
    int pin
)
static member IS_GPIO :
        pin : int -> bool

Parameters

pin
Type: SystemInt32
LPC1114 GPIO Pin Number

Return Value

Type: Boolean
True if the specified pin can be used as a GPIO pin
See Also

Reference

Pins Class


Pins.IS_PWM Method

PinsIS_PWM Method

Validate PWM output pin

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public static bool IS_PWM(
    int pin
)
Public Shared Function IS_PWM (
    pin As Integer
) As Boolean
public:
static bool IS_PWM(
    int pin
)
static member IS_PWM :
        pin : int -> bool

Parameters

pin
Type: SystemInt32
LPC1114 GPIO Pin Number

Return Value

Type: Boolean
True if the specified pin can be used as a PWM output
See Also

Reference

Pins Class


Pins Fields

The Pins type exposes the following members.

Fields
Name | Description
LPC1114_AD1 | Analog input 1 aka GPIO0
LPC1114_AD2 | Analog input 2 aka GPIO1
LPC1114_AD3 | Analog input 3 aka GPIO2
LPC1114_AD4 | Analog input 4 aka GPIO3
LPC1114_AD5 | Analog input 5 aka GPIO4
LPC1114_CT32B0_CAP0 | CT32B0 capture input 0 aka GPIO5
LPC1114_CT32B1_CAP0 | CT32B1 capture input 0 aka GPIO0
LPC1114_CT32B1_MAT0 | CT32B1 match output 0 aka GPIO1
LPC1114_CT32B1_MAT1 | CT32B1 match output 1 aka GPIO2
LPC1114_CT32B1_MAT2 | CT32B1 match output 2 aka GPIO3
LPC1114_CT32B1_MAT3 | CT32B1 match output 3 aka GPIO4
LPC1114_GPIO0 | GPIO0 aka LPC1114 PIO1_0
LPC1114_GPIO1 | GPIO1 aka LPC1114 PIO1_1
LPC1114_GPIO2 | GPIO2 aka LPC1114 PIO1_2
LPC1114_GPIO3 | GPIO3 aka LPC1114 PIO1_3
LPC1114_GPIO4 | GPIO4 aka LPC1114 PIO1_4
LPC1114_GPIO5 | GPIO5 aka LPC1114 PIO1_5
LPC1114_GPIO6 | GPIO6 aka LPC1114 PIO1_8
LPC1114_GPIO7 | GPIO7 aka LPC1114 PIO1_9
LPC1114_INT | Interrupt output to Raspberry Pi
LPC1114_LED | On board LED
LPC1114_PWM1 | PWM output 1 aka GPIO1
LPC1114_PWM2 | PWM output 2 aka GPIO2
LPC1114_PWM3 | PWM output 3 aka GPIO3
LPC1114_PWM4 | PWM output 4 aka GPIO7
Top
See Also

Reference

Pins Class


Pins.LPC1114_AD1 Field

PinsLPC1114_AD1 Field

Analog input 1 aka GPIO0

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_AD1 = 12
Public Const LPC1114_AD1 As Integer = 12
public:
literal int LPC1114_AD1 = 12
static val mutable LPC1114_AD1: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_AD2 Field

PinsLPC1114_AD2 Field

Analog input 2 aka GPIO1

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_AD2 = 13
Public Const LPC1114_AD2 As Integer = 13
public:
literal int LPC1114_AD2 = 13
static val mutable LPC1114_AD2: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_AD3 Field

PinsLPC1114_AD3 Field

Analog input 3 aka GPIO2

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_AD3 = 14
Public Const LPC1114_AD3 As Integer = 14
public:
literal int LPC1114_AD3 = 14
static val mutable LPC1114_AD3: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_AD4 Field

PinsLPC1114_AD4 Field

Analog input 4 aka GPIO3

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_AD4 = 15
Public Const LPC1114_AD4 As Integer = 15
public:
literal int LPC1114_AD4 = 15
static val mutable LPC1114_AD4: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_AD5 Field

PinsLPC1114_AD5 Field

Analog input 5 aka GPIO4

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_AD5 = 16
Public Const LPC1114_AD5 As Integer = 16
public:
literal int LPC1114_AD5 = 16
static val mutable LPC1114_AD5: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_CT32B0_CAP0 Field

PinsLPC1114_CT32B0_CAP0 Field

CT32B0 capture input 0 aka GPIO5

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_CT32B0_CAP0 = 17
Public Const LPC1114_CT32B0_CAP0 As Integer = 17
public:
literal int LPC1114_CT32B0_CAP0 = 17
static val mutable LPC1114_CT32B0_CAP0: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_CT32B1_CAP0 Field

PinsLPC1114_CT32B1_CAP0 Field

CT32B1 capture input 0 aka GPIO0

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_CT32B1_CAP0 = 12
Public Const LPC1114_CT32B1_CAP0 As Integer = 12
public:
literal int LPC1114_CT32B1_CAP0 = 12
static val mutable LPC1114_CT32B1_CAP0: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_CT32B1_MAT0 Field

PinsLPC1114_CT32B1_MAT0 Field

CT32B1 match output 0 aka GPIO1

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_CT32B1_MAT0 = 13
Public Const LPC1114_CT32B1_MAT0 As Integer = 13
public:
literal int LPC1114_CT32B1_MAT0 = 13
static val mutable LPC1114_CT32B1_MAT0: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_CT32B1_MAT1 Field

PinsLPC1114_CT32B1_MAT1 Field

CT32B1 match output 1 aka GPIO2

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_CT32B1_MAT1 = 14
Public Const LPC1114_CT32B1_MAT1 As Integer = 14
public:
literal int LPC1114_CT32B1_MAT1 = 14
static val mutable LPC1114_CT32B1_MAT1: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_CT32B1_MAT2 Field

PinsLPC1114_CT32B1_MAT2 Field

CT32B1 match output 2 aka GPIO3

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_CT32B1_MAT2 = 15
Public Const LPC1114_CT32B1_MAT2 As Integer = 15
public:
literal int LPC1114_CT32B1_MAT2 = 15
static val mutable LPC1114_CT32B1_MAT2: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_CT32B1_MAT3 Field

PinsLPC1114_CT32B1_MAT3 Field

CT32B1 match output 3 aka GPIO4

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_CT32B1_MAT3 = 16
Public Const LPC1114_CT32B1_MAT3 As Integer = 16
public:
literal int LPC1114_CT32B1_MAT3 = 16
static val mutable LPC1114_CT32B1_MAT3: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO0 Field

PinsLPC1114_GPIO0 Field

GPIO0 aka LPC1114 PIO1_0

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO0 = 12
Public Const LPC1114_GPIO0 As Integer = 12
public:
literal int LPC1114_GPIO0 = 12
static val mutable LPC1114_GPIO0: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO1 Field

PinsLPC1114_GPIO1 Field

GPIO1 aka LPC1114 PIO1_1

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO1 = 13
Public Const LPC1114_GPIO1 As Integer = 13
public:
literal int LPC1114_GPIO1 = 13
static val mutable LPC1114_GPIO1: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO2 Field

PinsLPC1114_GPIO2 Field

GPIO2 aka LPC1114 PIO1_2

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO2 = 14
Public Const LPC1114_GPIO2 As Integer = 14
public:
literal int LPC1114_GPIO2 = 14
static val mutable LPC1114_GPIO2: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO3 Field

PinsLPC1114_GPIO3 Field

GPIO3 aka LPC1114 PIO1_3

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO3 = 15
Public Const LPC1114_GPIO3 As Integer = 15
public:
literal int LPC1114_GPIO3 = 15
static val mutable LPC1114_GPIO3: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO4 Field

PinsLPC1114_GPIO4 Field

GPIO4 aka LPC1114 PIO1_4

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO4 = 16
Public Const LPC1114_GPIO4 As Integer = 16
public:
literal int LPC1114_GPIO4 = 16
static val mutable LPC1114_GPIO4: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO5 Field

PinsLPC1114_GPIO5 Field

GPIO5 aka LPC1114 PIO1_5

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO5 = 17
Public Const LPC1114_GPIO5 As Integer = 17
public:
literal int LPC1114_GPIO5 = 17
static val mutable LPC1114_GPIO5: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO6 Field

PinsLPC1114_GPIO6 Field

GPIO6 aka LPC1114 PIO1_8

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO6 = 20
Public Const LPC1114_GPIO6 As Integer = 20
public:
literal int LPC1114_GPIO6 = 20
static val mutable LPC1114_GPIO6: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_GPIO7 Field

PinsLPC1114_GPIO7 Field

GPIO7 aka LPC1114 PIO1_9

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO7 = 21
Public Const LPC1114_GPIO7 As Integer = 21
public:
literal int LPC1114_GPIO7 = 21
static val mutable LPC1114_GPIO7: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_INT Field

PinsLPC1114_INT Field

Interrupt output to Raspberry Pi

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_INT = 3
Public Const LPC1114_INT As Integer = 3
public:
literal int LPC1114_INT = 3
static val mutable LPC1114_INT: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_LED Field

PinsLPC1114_LED Field

On board LED

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_LED = 7
Public Const LPC1114_LED As Integer = 7
public:
literal int LPC1114_LED = 7
static val mutable LPC1114_LED: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_PWM1 Field

PinsLPC1114_PWM1 Field

PWM output 1 aka GPIO1

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_PWM1 = 13
Public Const LPC1114_PWM1 As Integer = 13
public:
literal int LPC1114_PWM1 = 13
static val mutable LPC1114_PWM1: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_PWM2 Field

PinsLPC1114_PWM2 Field

PWM output 2 aka GPIO2

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_PWM2 = 14
Public Const LPC1114_PWM2 As Integer = 14
public:
literal int LPC1114_PWM2 = 14
static val mutable LPC1114_PWM2: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_PWM3 Field

PinsLPC1114_PWM3 Field

PWM output 3 aka GPIO3

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_PWM3 = 15
Public Const LPC1114_PWM3 As Integer = 15
public:
literal int LPC1114_PWM3 = 15
static val mutable LPC1114_PWM3: int

Field Value

Type: Int32
See Also

Reference

Pins Class


Pins.LPC1114_PWM4 Field

PinsLPC1114_PWM4 Field

PWM output 4 aka GPIO7

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_PWM4 = 21
Public Const LPC1114_PWM4 As Integer = 21
public:
literal int LPC1114_PWM4 = 21
static val mutable LPC1114_PWM4: int

Field Value

Type: Int32
See Also

Reference

Pins Class


PWM Class

The PWM (Pulse With Modulation) class implements LPC1114 PWM output services.
Inheritance Hierarchy
SystemObject
SPIAgentPWM
SPIAgentServo

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class PWM : Output
Public Class PWM
    Implements Output
public ref class PWM : Output
type PWM =
    class
        interface Output
    end

The PWM type exposes the following members.

Constructors
 | Name | Description
Public method | PWM | LPC1114 PWM output object constructor.
Top
Properties
 | Name | Description
Public property | dutycycle | This write-only property sets this PWM output's duty cycle. Allowed values are 0.0 through 100.0 percent (from almost always off to almost always on).
Top
Fields
Name | Description
MAX_DUTYCYCLE | The maximum allowed PWM duty cycle is 100.0 percent.
MAX_FREQUENCY | The maximum allowed PWM frequency is 50,000 Hz.
MIN_CHANNELS | The number of available PWM output channels.
MIN_DUTYCYCLE | The minimum allowed PWM duty cycle is 0.0 percent.
MIN_FREQUENCY | The minimum allowed PWM frequency is 50 Hz.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


PWM Constructor

LPC1114 PWM output object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public PWM(
    ITransport spiagent,
    int pin,
    int frequency = 100
)
Public Sub New (
    spiagent As ITransport,
    pin As Integer,
    Optional frequency As Integer = 100
)
public:
PWM(
    ITransport^ spiagent,
    int pin,
    int frequency = 100
)
new :
        spiagent : ITransport *
        pin : int *
        ?frequency : int
(* Defaults:
        let _frequency = defaultArg frequency 100
*)
-> PWM

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pin
Type: SystemInt32
LPC1114 PWM output pin number. Allowed values are LPC1114_PWM1 through LPC1114_PWM4.
frequency (Optional)
Type: SystemInt32
PWM pulse frequency. Allowed values are 50 to 50000 Hz.
See Also

Reference

PWM Class


PWM Properties

The PWM type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | This write-only property sets this PWM output's duty cycle. Allowed values are 0.0 through 100.0 percent (from almost always off to almost always on).
Top
See Also

Reference

PWM Class


PWM.dutycycle Property

PWMdutycycle Property

This write-only property sets this PWM output's duty cycle. Allowed values are 0.0 through 100.0 percent (from almost always off to almost always on).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public double dutycycle { set; }
Public WriteOnly Property dutycycle As Double
    Set
public:
virtual property double dutycycle {
    void set (double value) sealed;
}
abstract dutycycle : float with set
override dutycycle : float with set

Property Value

Type: Double

Implements

Outputdutycycle
See Also

Reference

PWM Class


PWM Fields

The PWM type exposes the following members.

Fields
Name | Description
MAX_DUTYCYCLE | The maximum allowed PWM duty cycle is 100.0 percent.
MAX_FREQUENCY | The maximum allowed PWM frequency is 50,000 Hz.
MIN_CHANNELS | The number of available PWM output channels.
MIN_DUTYCYCLE | The minimum allowed PWM duty cycle is 0.0 percent.
MIN_FREQUENCY | The minimum allowed PWM frequency is 50 Hz.
Top
See Also

Reference

PWM Class


PWM.MAX_DUTYCYCLE Field

PWMMAX_DUTYCYCLE Field

The maximum allowed PWM duty cycle is 100.0 percent.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double MAX_DUTYCYCLE = 100
Public Const MAX_DUTYCYCLE As Double = 100
public:
literal double MAX_DUTYCYCLE = 100
static val mutable MAX_DUTYCYCLE: float

Field Value

Type: Double
See Also

Reference

PWM Class


PWM.MAX_FREQUENCY Field

PWMMAX_FREQUENCY Field

The maximum allowed PWM frequency is 50,000 Hz.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MAX_FREQUENCY = 50000
Public Const MAX_FREQUENCY As Integer = 50000
public:
literal int MAX_FREQUENCY = 50000
static val mutable MAX_FREQUENCY: int

Field Value

Type: Int32
See Also

Reference

PWM Class


PWM.MIN_CHANNELS Field

PWMMIN_CHANNELS Field

The number of available PWM output channels.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MIN_CHANNELS = 4
Public Const MIN_CHANNELS As Integer = 4
public:
literal int MIN_CHANNELS = 4
static val mutable MIN_CHANNELS: int

Field Value

Type: Int32
See Also

Reference

PWM Class


PWM.MIN_DUTYCYCLE Field

PWMMIN_DUTYCYCLE Field

The minimum allowed PWM duty cycle is 0.0 percent.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double MIN_DUTYCYCLE = 0
Public Const MIN_DUTYCYCLE As Double = 0
public:
literal double MIN_DUTYCYCLE = 0
static val mutable MIN_DUTYCYCLE: float

Field Value

Type: Double
See Also

Reference

PWM Class


PWM.MIN_FREQUENCY Field

PWMMIN_FREQUENCY Field

The minimum allowed PWM frequency is 50 Hz.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int MIN_FREQUENCY = 50
Public Const MIN_FREQUENCY As Integer = 50
public:
literal int MIN_FREQUENCY = 50
static val mutable MIN_FREQUENCY: int

Field Value

Type: Int32
See Also

Reference

PWM Class


Servo Class

The Servo class implements LPC1114 RC servo output services.
Inheritance Hierarchy
SystemObject
SPIAgentPWM
SPIAgentServo

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class Servo : PWM, Output
Public Class Servo
    Inherits PWM
    Implements Output
public ref class Servo : public PWM,
    Output
type Servo =
    class
        inherit PWM
        interface Output
    end

The Servo type exposes the following members.

Constructors
 | Name | Description
Public method | Servo | LPC1114 RC servo output object constructor.
Top
Properties
 | Name | Description
Public property | position | This write-only property sets this servo output's position. Allowed values are -1.0 through 1.0 (normalized deflection from the null position).
Top
Fields
Name | Description
SERVO_MAX_POSITION | The maximum servo position is 1.0.
SERVO_MIN_POSITION | The minimum servo position is -1.0.
SERVO_NEUTRAL_POSITION | The midpoint/neutral/null/zero servo position is 0.0.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Servo Constructor

LPC1114 RC servo output object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public Servo(
    ITransport spiagent,
    int pin,
    int frequency = 50
)
Public Sub New (
    spiagent As ITransport,
    pin As Integer,
    Optional frequency As Integer = 50
)
public:
Servo(
    ITransport^ spiagent,
    int pin,
    int frequency = 50
)
new :
        spiagent : ITransport *
        pin : int *
        ?frequency : int
(* Defaults:
        let _frequency = defaultArg frequency 50
*)
-> Servo

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
pin
Type: SystemInt32
LPC1114 PWM output pin number. Allowed values are LPC1114_PWM1 through LPC1114_PWM4.
frequency (Optional)
Type: SystemInt32
PWM pulse frequency. Allowed values are 50 to 400 Hz.
See Also

Reference

Servo Class


Servo Properties

The Servo type exposes the following members.

Properties
 | Name | Description
Public property | position | This write-only property sets this servo output's position. Allowed values are -1.0 through 1.0 (normalized deflection from the null position).
Top
See Also

Reference

Servo Class


Servo.position Property

Servoposition Property

This write-only property sets this servo output's position. Allowed values are -1.0 through 1.0 (normalized deflection from the null position).

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public double position { set; }
Public WriteOnly Property position As Double
    Set
public:
virtual property double position {
    void set (double value) sealed;
}
abstract position : float with set
override position : float with set

Property Value

Type: Double

Implements

Outputposition
See Also

Reference

Servo Class


Servo Fields

The Servo type exposes the following members.

Fields
Name | Description
SERVO_MAX_POSITION | The maximum servo position is 1.0.
SERVO_MIN_POSITION | The minimum servo position is -1.0.
SERVO_NEUTRAL_POSITION | The midpoint/neutral/null/zero servo position is 0.0.
Top
See Also

Reference

Servo Class


Servo.SERVO_MAX_POSITION Field

ServoSERVO_MAX_POSITION Field

The maximum servo position is 1.0.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double SERVO_MAX_POSITION = 1
Public Const SERVO_MAX_POSITION As Double = 1
public:
literal double SERVO_MAX_POSITION = 1
static val mutable SERVO_MAX_POSITION: float

Field Value

Type: Double
See Also

Reference

Servo Class


Servo.SERVO_MIN_POSITION Field

ServoSERVO_MIN_POSITION Field

The minimum servo position is -1.0.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double SERVO_MIN_POSITION = -1
Public Const SERVO_MIN_POSITION As Double = -1
public:
literal double SERVO_MIN_POSITION = -1
static val mutable SERVO_MIN_POSITION: float

Field Value

Type: Double
See Also

Reference

Servo Class


Servo.SERVO_NEUTRAL_POSITION Field

ServoSERVO_NEUTRAL_POSITION Field

The midpoint/neutral/null/zero servo position is 0.0.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const double SERVO_NEUTRAL_POSITION = 1
Public Const SERVO_NEUTRAL_POSITION As Double = 1
public:
literal double SERVO_NEUTRAL_POSITION = 1
static val mutable SERVO_NEUTRAL_POSITION: float

Field Value

Type: Double
See Also

Reference

Servo Class


SFR Class

The SFR class implements LPC1114 Special Function Register services. Use only with great caution!
Inheritance Hierarchy
SystemObject
SPIAgentSFR

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class SFR
Public Class SFR
public ref class SFR
type SFR =  class end

The SFR type exposes the following members.

Constructors
 | Name | Description
Public method | SFR | LPC1114 SFR object constructor.
Top
Properties
 | Name | Description
Public property | data | This property gets or sets the value of this Special Function Register. Use only with great caution!
Top
Fields
Name | Description
LPC1114_DEVICE_ID | LPC1114 device ID register
LPC1114_GPIO1DATA | LPC1114 GPIO1 port data register
LPC1114_U0SCR | LPC1114 UART 0 scratchpad register
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


SFR Constructor

LPC1114 SFR object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SFR(
    ITransport spiagent,
    int address
)
Public Sub New (
    spiagent As ITransport,
    address As Integer
)
public:
SFR(
    ITransport^ spiagent,
    int address
)
new :
        spiagent : ITransport *
        address : int -> SFR

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
address
Type: SystemInt32
32-bit SFR address. See the LPC111x/LPC11Cxx User manual UM10398 for register addresses and contents. Use only with great caution!
See Also

Reference

SFR Class


SFR Properties

The SFR type exposes the following members.

Properties
 | Name | Description
Public property | data | This property gets or sets the value of this Special Function Register. Use only with great caution!
Top
See Also

Reference

SFR Class


SFR.data Property

SFRdata Property

This property gets or sets the value of this Special Function Register. Use only with great caution!

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int data { get; set; }
Public Property data As Integer
    Get
    Set
public:
property int data {
    int get ();
    void set (int value);
}
member data : int with get, set

Property Value

Type: Int32
See Also

Reference

SFR Class


SFR Fields

The SFR type exposes the following members.

Fields
Name | Description
LPC1114_DEVICE_ID | LPC1114 device ID register
LPC1114_GPIO1DATA | LPC1114 GPIO1 port data register
LPC1114_U0SCR | LPC1114 UART 0 scratchpad register
Top
See Also

Reference

SFR Class


SFR.LPC1114_DEVICE_ID Field

SFRLPC1114_DEVICE_ID Field

LPC1114 device ID register

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_DEVICE_ID = 1074037748
Public Const LPC1114_DEVICE_ID As Integer = 1074037748
public:
literal int LPC1114_DEVICE_ID = 1074037748
static val mutable LPC1114_DEVICE_ID: int

Field Value

Type: Int32
See Also

Reference

SFR Class


SFR.LPC1114_GPIO1DATA Field

SFRLPC1114_GPIO1DATA Field

LPC1114 GPIO1 port data register

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_GPIO1DATA = 1342246140
Public Const LPC1114_GPIO1DATA As Integer = 1342246140
public:
literal int LPC1114_GPIO1DATA = 1342246140
static val mutable LPC1114_GPIO1DATA: int

Field Value

Type: Int32
See Also

Reference

SFR Class


SFR.LPC1114_U0SCR Field

SFRLPC1114_U0SCR Field

LPC1114 UART 0 scratchpad register

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const int LPC1114_U0SCR = 1073774620
Public Const LPC1114_U0SCR As Integer = 1073774620
public:
literal int LPC1114_U0SCR = 1073774620
static val mutable LPC1114_U0SCR: int

Field Value

Type: Int32
See Also

Reference

SFR Class


SPIAGENT_COMMAND_MSG_t Class

Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware command message object
Inheritance Hierarchy
SystemObject
SPIAgentSPIAGENT_COMMAND_MSG_t

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class SPIAGENT_COMMAND_MSG_t : XdrAble
Public Class SPIAGENT_COMMAND_MSG_t
    Implements XdrAble
public ref class SPIAGENT_COMMAND_MSG_t : XdrAble
type SPIAGENT_COMMAND_MSG_t =
    class
        interface XdrAble
    end

The SPIAGENT_COMMAND_MSG_t type exposes the following members.

Fields
 | Name | Description
Public field | command | Command code to SPI Agent Firmware
Public field | data | Data item to SPI Agent Firmware
Public field | pin | Pin number to SPI Agent Firmware
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


SPIAGENT_COMMAND_MSG_t Fields

The SPIAGENT_COMMAND_MSG_t type exposes the following members.

Fields
 | Name | Description
Public field | command | Command code to SPI Agent Firmware
Public field | data | Data item to SPI Agent Firmware
Public field | pin | Pin number to SPI Agent Firmware
Top
See Also

Reference

SPIAGENT_COMMAND_MSG_t Class


SPIAGENT_COMMAND_MSG_t.command Field

SPIAGENT_COMMAND_MSG_tcommand Field

Command code to SPI Agent Firmware

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int command
Public command As Integer
public:
int command
val mutable command: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_COMMAND_MSG_t Class


SPIAGENT_COMMAND_MSG_t.data Field

SPIAGENT_COMMAND_MSG_tdata Field

Data item to SPI Agent Firmware

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int data
Public data As Integer
public:
int data
val mutable data: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_COMMAND_MSG_t Class


SPIAGENT_COMMAND_MSG_t.pin Field

SPIAGENT_COMMAND_MSG_tpin Field

Pin number to SPI Agent Firmware

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int pin
Public pin As Integer
public:
int pin
val mutable pin: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_COMMAND_MSG_t Class


SPIAgent_Exception Class

This exception is raised upon detection of a Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware error.
Inheritance Hierarchy
SystemObject
SystemException
SPIAgentSPIAgent_Exception

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class SPIAgent_Exception : Exception
Public Class SPIAgent_Exception
    Inherits Exception
public ref class SPIAgent_Exception : public Exception
type SPIAgent_Exception =
    class
        inherit Exception
    end
Constructors
 | Name | Description
Public method | SPIAgent_Exception | Default parameterless constructor
Public method | SPIAgent_Exception(String) | Constructor including an error message string
Public method | SPIAgent_Exception(String, Exception) | Constructor including an error message string and an inner exception
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


SPIAgent_Exception Constructor

Overload List
 | Name | Description
Public method | SPIAgent_Exception | Default parameterless constructor
Public method | SPIAgent_Exception(String) | Constructor including an error message string
Public method | SPIAgent_Exception(String, Exception) | Constructor including an error message string and an inner exception
Top
See Also

Reference

SPIAgent_Exception Class


SPIAgent_Exception Constructor

Default parameterless constructor

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SPIAgent_Exception()
Public Sub New
public:
SPIAgent_Exception()
new : unit -> SPIAgent_Exception
See Also

Reference

SPIAgent_Exception Class
SPIAgent_Exception Overload


SPIAgent_Exception Constructor (String)

Constructor including an error message string

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SPIAgent_Exception(
    string message
)
Public Sub New (
    message As String
)
public:
SPIAgent_Exception(
    String^ message
)
new :
        message : string -> SPIAgent_Exception

Parameters

message
Type: SystemString
Error message
See Also

Reference

SPIAgent_Exception Class
SPIAgent_Exception Overload


SPIAgent_Exception Constructor (String, Exception)

Constructor including an error message string and an inner exception

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SPIAgent_Exception(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SPIAgent_Exception(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SPIAgent_Exception

Parameters

message
Type: SystemString
Error message
inner
Type: SystemException
Inner exception
See Also

Reference

SPIAgent_Exception Class
SPIAgent_Exception Overload


SPIAGENT_RESPONSE_MSG_t Class

Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware response message object
Inheritance Hierarchy
SystemObject
SPIAgentSPIAGENT_RESPONSE_MSG_t

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class SPIAGENT_RESPONSE_MSG_t : XdrAble
Public Class SPIAGENT_RESPONSE_MSG_t
    Implements XdrAble
public ref class SPIAGENT_RESPONSE_MSG_t : XdrAble
type SPIAGENT_RESPONSE_MSG_t =
    class
        interface XdrAble
    end

The SPIAGENT_RESPONSE_MSG_t type exposes the following members.

Fields
 | Name | Description
Public field | command | Command code from SPI Agent Firmware (echoed from command message)
Public field | data | Data item from SPI Agent Firmware
Public field | error | Error code (errno value) from SPI Agent Firmware
Public field | pin | Pin number from SPI Agent Firmware (echoed from command message)
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


SPIAGENT_RESPONSE_MSG_t Fields

The SPIAGENT_RESPONSE_MSG_t type exposes the following members.

Fields
 | Name | Description
Public field | command | Command code from SPI Agent Firmware (echoed from command message)
Public field | data | Data item from SPI Agent Firmware
Public field | error | Error code (errno value) from SPI Agent Firmware
Public field | pin | Pin number from SPI Agent Firmware (echoed from command message)
Top
See Also

Reference

SPIAGENT_RESPONSE_MSG_t Class


SPIAGENT_RESPONSE_MSG_t.command Field

SPIAGENT_RESPONSE_MSG_tcommand Field

Command code from SPI Agent Firmware (echoed from command message)

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int command
Public command As Integer
public:
int command
val mutable command: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_RESPONSE_MSG_t Class


SPIAGENT_RESPONSE_MSG_t.data Field

SPIAGENT_RESPONSE_MSG_tdata Field

Data item from SPI Agent Firmware

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int data
Public data As Integer
public:
int data
val mutable data: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_RESPONSE_MSG_t Class


SPIAGENT_RESPONSE_MSG_t.error Field

SPIAGENT_RESPONSE_MSG_terror Field

Error code (errno value) from SPI Agent Firmware

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int error
Public error As Integer
public:
int error
val mutable error: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_RESPONSE_MSG_t Class


SPIAGENT_RESPONSE_MSG_t.pin Field

SPIAGENT_RESPONSE_MSG_tpin Field

Pin number from SPI Agent Firmware (echoed from command message)

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public int pin
Public pin As Integer
public:
int pin
val mutable pin: int

Field Value

Type: Int32
See Also

Reference

SPIAGENT_RESPONSE_MSG_t Class


SPIAgent_Transport_Exception Class

This exception is raised upon detection of a Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware transport failure.
Inheritance Hierarchy
SystemObject
SystemException
SPIAgentSPIAgent_Transport_Exception

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class SPIAgent_Transport_Exception : Exception
Public Class SPIAgent_Transport_Exception
    Inherits Exception
public ref class SPIAgent_Transport_Exception : public Exception
type SPIAgent_Transport_Exception =
    class
        inherit Exception
    end
Constructors
 | Name | Description
Public method | SPIAgent_Transport_Exception | Default parameterless constructor
Public method | SPIAgent_Transport_Exception(String) | Constructor including an error message string
Public method | SPIAgent_Transport_Exception(String, Exception) | Constructor including an error message string and an inner exception
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


SPIAgent_Transport_Exception Constructor

Overload List
 | Name | Description
Public method | SPIAgent_Transport_Exception | Default parameterless constructor
Public method | SPIAgent_Transport_Exception(String) | Constructor including an error message string
Public method | SPIAgent_Transport_Exception(String, Exception) | Constructor including an error message string and an inner exception
Top
See Also

Reference

SPIAgent_Transport_Exception Class


SPIAgent_Transport_Exception Constructor

Default parameterless constructor

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SPIAgent_Transport_Exception()
Public Sub New
public:
SPIAgent_Transport_Exception()
new : unit -> SPIAgent_Transport_Exception
See Also

Reference

SPIAgent_Transport_Exception Class
SPIAgent_Transport_Exception Overload


SPIAgent_Transport_Exception Constructor (String)

Constructor including an error message string

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SPIAgent_Transport_Exception(
    string message
)
Public Sub New (
    message As String
)
public:
SPIAgent_Transport_Exception(
    String^ message
)
new :
        message : string -> SPIAgent_Transport_Exception

Parameters

message
Type: SystemString
Error message
See Also

Reference

SPIAgent_Transport_Exception Class
SPIAgent_Transport_Exception Overload


SPIAgent_Transport_Exception Constructor (String, Exception)

Constructor including an error message string and an inner exception

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public SPIAgent_Transport_Exception(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SPIAgent_Transport_Exception(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SPIAgent_Transport_Exception

Parameters

message
Type: SystemString
Error message
inner
Type: SystemException
Inner exception
See Also

Reference

SPIAgent_Transport_Exception Class
SPIAgent_Transport_Exception Overload


Timer Class

The Timer class implements LPC1114 32-bit hardware timer services.
Inheritance Hierarchy
SystemObject
SPIAgentTimer

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class Timer
Public Class Timer
public ref class Timer
type Timer =  class end

The Timer type exposes the following members.

Constructors
 | Name | Description
Public method | Timer | LPC1114 32-bit timer object constructor.
Top
Properties
 | Name | Description
Public property | capture | This read-only property returns the LPC1114 32-bit timer capture register.
Public property | capture_delta | This read-only property returns the most recent LPC1114 32-bit timer capture delta value.
Public property | counter | This read-only property returns the LPC1114 32-bit timer counter register.
Top
Methods
 | Name | Description
Public method | ConfigureCapture | Configure LPC1114 32-bit hardware timer capture mode.
Public method | ConfigureMatch | Configure LPC1114 match register.
Public method | ConfigureMode | Configure LPC1114 hardware timer mode.
Public method | ConfigurePrescaler | Configure LPC1114 32-bit timer prescaler.
Top
Fields
Name | Description
PCLK_FREQUENCY | The LPC1114 system clock frequency is 48 MHz.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Timer Constructor

LPC1114 32-bit timer object constructor.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public Timer(
    ITransport spiagent,
    TimerID timer,
    TimerMODE mode = TimerMODE.DISABLED,
    uint prescaler = 1
)
Public Sub New (
    spiagent As ITransport,
    timer As TimerID,
    Optional mode As TimerMODE = TimerMODE.DISABLED,
    Optional prescaler As UInteger = 1
)
public:
Timer(
    ITransport^ spiagent,
    TimerID timer,
    TimerMODE mode = TimerMODE::DISABLED,
    unsigned int prescaler = 1
)
new :
        spiagent : ITransport *
        timer : TimerID *
        ?mode : TimerMODE *
        ?prescaler : uint32
(* Defaults:
        let _mode = defaultArg mode TimerMODE.DISABLED
        let _prescaler = defaultArg prescaler 1
*)
-> Timer

Parameters

spiagent
Type: SPIAgentITransport
SPI Agent Firmware transport object.
timer
Type: SPIAgentTimerID
Timer identifier.
mode (Optional)
Type: SPIAgentTimerMODE
Timer mode. Default is MODE.DISABLED.
prescaler (Optional)
Type: SystemUInt32
Timer prescaler. Default is 1.
See Also

Reference

Timer Class


Timer Properties

The Timer type exposes the following members.

Properties
 | Name | Description
Public property | capture | This read-only property returns the LPC1114 32-bit timer capture register.
Public property | capture_delta | This read-only property returns the most recent LPC1114 32-bit timer capture delta value.
Public property | counter | This read-only property returns the LPC1114 32-bit timer counter register.
Top
See Also

Reference

Timer Class


Timer.capture Property

Timercapture Property

This read-only property returns the LPC1114 32-bit timer capture register.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public uint capture { get; }
Public ReadOnly Property capture As UInteger
    Get
public:
property unsigned int capture {
    unsigned int get ();
}
member capture : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Timer Class


Timer.capture_delta Property

Timercapture_delta Property

This read-only property returns the most recent LPC1114 32-bit timer capture delta value.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public uint capture_delta { get; }
Public ReadOnly Property capture_delta As UInteger
    Get
public:
property unsigned int capture_delta {
    unsigned int get ();
}
member capture_delta : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Timer Class


Timer.counter Property

Timercounter Property

This read-only property returns the LPC1114 32-bit timer counter register.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public uint counter { get; }
Public ReadOnly Property counter As UInteger
    Get
public:
property unsigned int counter {
    unsigned int get ();
}
member counter : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Timer Class


Timer Methods

The Timer type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureCapture | Configure LPC1114 32-bit hardware timer capture mode.
Public method | ConfigureMatch | Configure LPC1114 match register.
Public method | ConfigureMode | Configure LPC1114 hardware timer mode.
Public method | ConfigurePrescaler | Configure LPC1114 32-bit timer prescaler.
Top
See Also

Reference

Timer Class


Timer.ConfigureCapture Method

TimerConfigureCapture Method

Configure LPC1114 32-bit hardware timer capture mode.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void ConfigureCapture(
    TimerCAPTURE_EDGE edge,
    TimerFEATURES features =
)
Public Sub ConfigureCapture (
    edge As TimerCAPTURE_EDGE,
    Optional features As TimerFEATURES =
)
public:
void ConfigureCapture(
    TimerCAPTURE_EDGE edge,
    TimerFEATURES features =
)
member ConfigureCapture :
        edge : TimerCAPTURE_EDGE *
        ?features : TimerFEATURES
(* Defaults:
        let _features = defaultArg features
*)
-> unit

Parameters

edge
Type: SPIAgentTimerCAPTURE_EDGE
CAP0 input edge.
features (Optional)
Type: SPIAgentTimerFEATURES
Capture features.
See Also

Reference

Timer Class


Timer.ConfigureMatch Method

TimerConfigureMatch Method

Configure LPC1114 match register.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void ConfigureMatch(
    TimerMATCH_REGISTER match,
    uint value,
    TimerMATCH_OUTPUT action,
    TimerFEATURES features
)
Public Sub ConfigureMatch (
    match As TimerMATCH_REGISTER,
    value As UInteger,
    action As TimerMATCH_OUTPUT,
    features As TimerFEATURES
)
public:
void ConfigureMatch(
    TimerMATCH_REGISTER match,
    unsigned int value,
    TimerMATCH_OUTPUT action,
    TimerFEATURES features
)
member ConfigureMatch :
        match : TimerMATCH_REGISTER *
        value : uint32 *
        action : TimerMATCH_OUTPUT *
        features : TimerFEATURES -> unit

Parameters

match
Type: SPIAgentTimerMATCH_REGISTER
Match register identifier.
value
Type: SystemUInt32
Match value.
action
Type: SPIAgentTimerMATCH_OUTPUT
Match output action.
features
Type: SPIAgentTimerFEATURES
Match features.
See Also

Reference

Timer Class


Timer.ConfigureMode Method

TimerConfigureMode Method

Configure LPC1114 hardware timer mode.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void ConfigureMode(
    TimerMODE mode
)
Public Sub ConfigureMode (
    mode As TimerMODE
)
public:
void ConfigureMode(
    TimerMODE mode
)
member ConfigureMode :
        mode : TimerMODE -> unit

Parameters

mode
Type: SPIAgentTimerMODE
Timer mode
See Also

Reference

Timer Class


Timer.ConfigurePrescaler Method

TimerConfigurePrescaler Method

Configure LPC1114 32-bit timer prescaler.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void ConfigurePrescaler(
    uint prescaler
)
Public Sub ConfigurePrescaler (
    prescaler As UInteger
)
public:
void ConfigurePrescaler(
    unsigned int prescaler
)
member ConfigurePrescaler :
        prescaler : uint32 -> unit

Parameters

prescaler
Type: SystemUInt32
Prescaler value.
See Also

Reference

Timer Class


Timer Fields

The Timer type exposes the following members.

Fields
Name | Description
PCLK_FREQUENCY | The LPC1114 system clock frequency is 48 MHz.
Top
See Also

Reference

Timer Class


Timer.PCLK_FREQUENCY Field

TimerPCLK_FREQUENCY Field

The LPC1114 system clock frequency is 48 MHz.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public const uint PCLK_FREQUENCY = 48000000
Public Const PCLK_FREQUENCY As UInteger = 48000000
public:
literal unsigned int PCLK_FREQUENCY = 48000000
static val mutable PCLK_FREQUENCY: uint32

Field Value

Type: UInt32
See Also

Reference

Timer Class


Timer.CAPTURE_EDGE Enumeration

TimerCAPTURE_EDGE Enumeration

LPC1114 32-bit timer capture modes.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum CAPTURE_EDGE
Public Enumeration CAPTURE_EDGE
public enum class CAPTURE_EDGE
type CAPTURE_EDGE
Members
Member name | Value | Description
DISABLED | 0 |
CAP0_RISING | 1 |
CAP0_FALLING | 2 |
CAP0_BOTH | 3 |
SENTINEL | 4 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Timer.FEATURES Enumeration

TimerFEATURES Enumeration

LPC1114 32-bit timer capture and match features.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FEATURES
<FlagsAttribute>
Public Enumeration FEATURES
[FlagsAttribute]
public enum class FEATURES
[<FlagsAttribute>]
type FEATURES
Members
Member name | Value | Description
INTERRUPT | 16 |
RESET | 32 |
STOP | 64 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Timer.ID Enumeration

TimerID Enumeration

LPC1114 32-bit timer identifiers.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum ID
Public Enumeration ID
public enum class ID
type ID
Members
Member name | Value | Description
CT32B0 | 0 |
CT32B1 | 1 |
SENTINEL | 2 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Timer.MATCH_OUTPUT Enumeration

TimerMATCH_OUTPUT Enumeration

LPC1114 32-bit timer match output actions.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum MATCH_OUTPUT
Public Enumeration MATCH_OUTPUT
public enum class MATCH_OUTPUT
type MATCH_OUTPUT
Members
Member name | Value | Description
DISABLED | 0 |
CLEAR | 1 |
SET | 2 |
TOGGLE | 3 |
SENTINEL | 4 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Timer.MATCH_REGISTER Enumeration

TimerMATCH_REGISTER Enumeration

LPC1114 32-bit timer match registers.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum MATCH_REGISTER
Public Enumeration MATCH_REGISTER
public enum class MATCH_REGISTER
type MATCH_REGISTER
Members
Member name | Value | Description
MATCH0 | 0 |
MATCH1 | 1 |
MATCH2 | 2 |
MATCH3 | 3 |
SENTINEL | 4 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Timer.MODE Enumeration

TimerMODE Enumeration

LPC1114 32-bit timer modes.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public enum MODE
Public Enumeration MODE
public enum class MODE
type MODE
Members
Member name | Value | Description
DISABLED | 0 |
RESET | 1 |
PCLK | 2 |
CAP0_RISING | 3 |
CAP0_FALLING | 4 |
CAP0_BOTH | 5 |
SENTINEL | 6 |
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Transport Class

The Transport class provides transport services to a specified Raspberry Pi LPC1114 I/O Processor Expansion Board SPI Agent Firmware ONC-RPC server.
Inheritance Hierarchy
SystemObject
SPIAgentTransport

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public class Transport : ITransport
Public Class Transport
    Implements ITransport
public ref class Transport : ITransport
type Transport =
    class
        interface ITransport
    end

The Transport type exposes the following members.

Constructors
 | Name | Description
Public method | Transport | Transport object constructor. You must also call Open() to establish the connection to the server.
Public method | Transport(String) | Transport object constructor. This constructor opens a connection to the specified server.
Top
Methods
 | Name | Description
Public method | Close | Close the current server connection.
Public method | Command | Issue a command to the current server.
Public method | Open | Open connection to the specified server.
Top
See Also

Reference

SPIAgent Namespace
Send comments on this topic to phil@munts.net


Transport Constructor

Overload List
 | Name | Description
Public method | Transport | Transport object constructor. You must also call Open() to establish the connection to the server.
Public method | Transport(String) | Transport object constructor. This constructor opens a connection to the specified server.
Top
See Also

Reference

Transport Class


Transport Constructor

Transport object constructor. You must also call Open() to establish the connection to the server.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public Transport()
Public Sub New
public:
Transport()
new : unit -> Transport
See Also

Reference

Transport Class
Transport Overload


Transport Constructor (String)

Transport object constructor. This constructor opens a connection to the specified server.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public Transport(
    string servername
)
Public Sub New (
    servername As String
)
public:
Transport(
    String^ servername
)
new :
        servername : string -> Transport

Parameters

servername
Type: SystemString
Server domain name or IP address.
See Also

Reference

Transport Class
Transport Overload


Transport Methods

The Transport type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close the current server connection.
Public method | Command | Issue a command to the current server.
Public method | Open | Open connection to the specified server.
Top
See Also

Reference

Transport Class


Transport.Close Method

TransportClose Method

Close the current server connection.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
See Also

Reference

Transport Class


Transport.Command Method

TransportCommand Method

Issue a command to the current server.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void Command(
    SPIAGENT_COMMAND_MSG_t cmd,
    ref SPIAGENT_RESPONSE_MSG_t resp
)
Public Sub Command (
    cmd As SPIAGENT_COMMAND_MSG_t,
    ByRef resp As SPIAGENT_RESPONSE_MSG_t
)
public:
virtual void Command(
    SPIAGENT_COMMAND_MSG_t^ cmd,
    SPIAGENT_RESPONSE_MSG_t^% resp
) sealed
abstract Command :
        cmd : SPIAGENT_COMMAND_MSG_t *
        resp : SPIAGENT_RESPONSE_MSG_t byref -> unit
override Command :
        cmd : SPIAGENT_COMMAND_MSG_t *
        resp : SPIAGENT_RESPONSE_MSG_t byref -> unit

Parameters

cmd
Type: SPIAgentSPIAGENT_COMMAND_MSG_t
Command message structure.
resp
Type: SPIAgentSPIAGENT_RESPONSE_MSG_t
Response message structure.

Implements

ITransportCommand(SPIAGENT_COMMAND_MSG_t, SPIAGENT_RESPONSE_MSG_t)
See Also

Reference

Transport Class


Transport.Open Method

TransportOpen Method

Open connection to the specified server.

Namespace: SPIAgent
Assembly: SPIAgent-ONC-RPC (in SPIAgent-ONC-RPC.dll) Version: 2.0.6816.24376
Syntax
C#
VB
C++
F#
Copy
public void Open(
    string servername
)
Public Sub Open (
    servername As String
)
public:
void Open(
    String^ servername
)
member Open :
        servername : string -> unit

Parameters

servername
Type: SystemString
Server domain name or IP address.
See Also

Reference

Transport Class