Namespaces

Namespaces
Namespace | Description
IO.Bindings | Wrapper classes for C shared libraries.
IO.Devices.A4988 | A4988 Stepper Motor Controller Services.
IO.Devices.AD5593R | AD5593 Analog/Digital I/O Device Services.
IO.Devices.AD5593R.ADC | AD5593 Analog/Digital I/O Device ADC Input Services.
IO.Devices.AD5593R.DAC | AD5593 Analog/Digital I/O Device DAC Output Services.
IO.Devices.AD5593R.GPIO | AD5593 Analog/Digital I/O Device GPIO Pin Services.
IO.Devices.ADC121C021 | ADC121C021 I2C A/D Converter Services
IO.Devices.ClickBoards.RemoteIO.ADAC | Mikroelektronika ADAC Click MIKROE-2690 Services
IO.Devices.ClickBoards.RemoteIO.Expand | Mikroelektronika Expand Click MIKROE-951 Services
IO.Devices.ClickBoards.RemoteIO.Expand2 | Mikroelektronika Expand 2 Click MIKROE-1838 Services
IO.Devices.ClickBoards.RemoteIO.PWM | Mikroelektronika PWM Click MIKROE-1898 Services
IO.Devices.ClickBoards.RemoteIO.SevenSegment | Mikroelektronika 7Seg Click MIKROE-1201 Services
IO.Devices.ClickBoards.SimpleIO.ADAC | Mikroelektronika ADAC Click MIKROE-2690 Services
IO.Devices.ClickBoards.SimpleIO.Expand | Mikroelektronika Expand Click MIKROE-951 Services
IO.Devices.ClickBoards.SimpleIO.Expand2 | Mikroelektronika Expand 2 Click MIKROE-1838 Services
IO.Devices.ClickBoards.SimpleIO.PWM | Mikroelektronika PWM Click MIKROE-1898 Services
IO.Devices.ClickBoards.SimpleIO.SevenSegment | Mikroelektronika 7Seg Click MIKROE-1201 Services
IO.Devices.Grove.ADC | Seeed Studio Grove I2C ADC (ADC121C021) Services
IO.Devices.Grove.Temperature | Seeed Studio Grove Temperature Sensor (thermistor) Services
IO.Devices.Grove.Temperature_Humidity | Seeed Studio Grove Temperature and Humdity Sensor (TH02) Services.
IO.Devices.HDC1080 | HDC1080 I2C Temperature/Humidity Sensor Services
IO.Devices.MCP23017 | MCP23017 I2C GPIO Expander Device Services.
IO.Devices.MCP23017.GPIO | MCP23017 I2C GPIO Expander GPIO Pin Services.
IO.Devices.MCP23S17 | MCP23S17 SPI GPIO Expander Device Services.
IO.Devices.MCP23S17.GPIO | MCP23S17 SPI GPIO Expander GPIO Pin Services.
IO.Devices.PCA8574 | PCA8574 (and similar) I2C GPIO Expander Device Services
IO.Devices.PCA8574.GPIO | PCA8574 (and similar) I2C GPIO Expander GPIO Pin Services
IO.Devices.PCA9534 | PCA9534 (and similar) I2C GPIO Expander Device Services
IO.Devices.PCA9534.GPIO | PCA9534 (and similar) I2C GPIO Expander GPIO Pin Services
IO.Devices.PCA9685 | PCA9685 I2C PWM Controller Device Services
IO.Devices.PCA9685.GPIO | PCA9685 I2C PWM Controller GPIO Pin Services
IO.Devices.PCA9685.PWM | PCA9685 I2C PWM Controller PWM Output Services
IO.Devices.PCA9685.Servo | PCA9685 I2C PWM Controller Servo Output Services
IO.Devices.Pmod.HYGRO | Digilent Pmod HYGRO Temperature and Humdity Sensor (HDC1080) Services.
IO.Devices.SN74HC595 | SN74HC595 8-Bit Shift Register Device Services
IO.Devices.SN74HC595.GPIO | SN74HC595 8-Bit Shift Register GPIO Pin Services
IO.Devices.TH02 | TH02 I2C Temperature/Humidity Sensor Services
IO.Devices.Thermistor | Thermistor Modeling Services
IO.Devices.USB.Munts | Vendor and Product Identifiers for Munts Technologies (http://tech.munts.com) USB devices
IO.Interfaces.ADC | Abstract Interface for ADC (Analog to Digital Converter) Inputs
IO.Interfaces.DAC | Abstract Interface for DAC (Digital to Analog Converter) Outputs
IO.Interfaces.GPIO | Abstract Interface for GPIO (General Purpose Input/Output) Pins
IO.Interfaces.Humidity | Abstract Interface for Humidity Sensors
IO.Interfaces.I2C | Abstract Interface for I2C (Inter-Integrated Circuit) Bus Controllers
IO.Interfaces.Message.Text | Abstract Interface for Text Message Relays
IO.Interfaces.Message64 | Abstract Interface for 64-Byte Message Services
IO.Interfaces.Motor | Abstract Interface For Variable Speed Motor Outputs
IO.Interfaces.PWM | Abstract Interface for PWM (Pulse Width Modulated) Outputs
IO.Interfaces.Servo | Abstract Interface for Servo Outputs
IO.Interfaces.SPI | Abstract Interface for SPI (Serial Peripheral Interconnect) Slave Devices
IO.Interfaces.Stepper | Abstract Interface for Stepper Motor Outputs
IO.Interfaces.Temperature | Abstract Interface for Temperature Sensors
IO.Interfaces.Watchdog | Abstract Interface for Watchdog Timers
IO.Objects.Email.Mail | Email Sending Services using /usr/bin/mail
IO.Objects.Email.SMTP | Email Sending Services using SMTP to localhost:25
IO.Objects.GPIO.PWM | PWM Controlled GPIO Output Services
IO.Objects.Message64.UDP | 64-Byte Message Services over UDP
IO.Objects.Motor.PWM | PWM Controlled Motor Services
IO.Objects.Motor.Servo | Servo Controlled Motor (e.g. continuous rotation servo) Services
IO.Objects.RemoteIO | Remote I/O Device Framework, for sending commands and receiving response to/from Remote I/O Protocol devices.
IO.Objects.RemoteIO.mikroBUS | Mikroelektronika mikroBUS (https://www.mikroe.com/mikrobus) Remote I/O protocol Server and Socket Services
IO.Objects.RemoteIO.Platforms | I/O Resource Definitions for particular Remote I/O Protocol Server Platforms
IO.Objects.Servo.PWM | PWM Controlled Servo Services
IO.Objects.SimpleIO.ADC | ADC (Analog to Digital Converter) Input Services
IO.Objects.SimpleIO.DAC | DAC (Digital to Analog Converter) Output Services
IO.Objects.SimpleIO.Device | Common device declarations
IO.Objects.SimpleIO.GPIO | GPIO (General Purpose Input/Output) Pin Services
IO.Objects.SimpleIO.HID | Raw HID (Human Interface Device) Services
IO.Objects.SimpleIO.I2C | I2C (Inter-Integrated Circuit) Bus Controller Services
IO.Objects.SimpleIO.mikroBUS | Mikroelektronika mikroBUS (https://www.mikroe.com/mikrobus) Shield and Socket Services
IO.Objects.SimpleIO.Platforms | Platform Definition Classes
IO.Objects.SimpleIO.PWM | PWM (Pulse Width Modulated) Output Services
IO.Objects.SimpleIO.Servo | Servo Output Services
IO.Objects.SimpleIO.SPI | SPI (Serial Peripheral Interconnect) Device Services
IO.Objects.SimpleIO.syslog | Error Logging Services Using the Linux syslog Subsystem
IO.Objects.SimpleIO.Watchdog | Watchdog Timer Services


IO.Bindings Namespace

Wrapper classes for C shared libraries.
Classes
 | Class | Description
Public class | libsimpleio | Wrapper class for the Linux Simple I/O Library libsimpleio.so


libsimpleio Class

Wrapper class for the Linux Simple I/O Library libsimpleio.so
Inheritance Hierarchy
SystemObject
IO.Bindingslibsimpleio

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class libsimpleio

The libsimpleio type exposes the following members.

Methods
Name | Description
ADC_close | Close a Linux IIO A/D converter input device.
ADC_get_name | Get the subsystem name for the specified Linux IIO A/D converter device.
ADC_open | Open a Linux IIO A/D converter input device.
ADC_read | Read a Linux IIO A/D converter input device.
DAC_close | Close a Linux IIO D/A converter output device.
DAC_get_name | Get the subsystem name for the specified Linux IIO D/A converter device.
DAC_open | Open a Linux IIO D/A converter output device.
DAC_write | Write to a Linux IIO D/A converter output device.
EVENT_close | Close an epoll event dispatcher.
EVENT_modify_fd | Modify a file registration.
EVENT_open | Open an epoll event dispatcher.
EVENT_register_fd | Register a file descriptor with an epoll event dispatcher.
EVENT_unregister_fd | Unregister a file from an epoll dispatcher.
EVENT_wait | Wait for events from an epoll dispatcher.
GPIO_chip_info | Get GPIO chip information.
GPIO_close | Close a Linux GPIO pin device.
GPIO_configure | Configure a Linux GPIO pin.
GPIO_line_close | Close a single GPIO line.
GPIO_line_event | Read an edge trigger event from single GPIO line.
GPIO_line_info | Get GPIO line information.
GPIO_line_open | Open a single GPIO line.
GPIO_line_read | Read the state of a single GPIO line.
GPIO_line_write | Write the state of a single GPIO line.
GPIO_open | Open a Linux GPIO pin device.
GPIO_read | Read a Linux GPIO pin.
GPIO_write | Write a Linux GPIO pin.
HIDRAW_close | Close a Linux raw HID.
HIDRAW_get_info | Get Linux raw HID bus type, vendor ID, and product ID.
HIDRAW_get_name | Get Linux raw HID name string.
HIDRAW_open1 | Open a Linux raw HID device by device node name.
HIDRAW_open2 | Open a Linux raw HID device by vendor ID and product ID.
HIDRAW_open3 | Open a Linux raw HID device by vendor ID and product ID and serial number.
HIDRAW_receive | Get a 64-byte report from a Linux HID.
HIDRAW_send | Send a 64-byte report to a Linux HID.
I2C_close | Close a Linux I2C bus controller device.
I2C_open | Open a Linux I2C bus controller device.
I2C_transaction | Send bytes to and/or receive bytes from an I2C slave device.
IPV4_ntoa | Convert an IPv4 address to a dotted notation string (e.g. 1.2.3.4).
IPV4_resolve | Resolve a domain name to an IPv4 host address.
LINUX_closelog | Close the connection to the syslog service.
LINUX_command | Execute a shell command string.
LINUX_detach | Detach the process and run it in the background.
LINUX_drop_privileges | Drop process privileges to those of the specified user. Remarks Only a process running at superuser privilege is allowed to drop privileges.
LINUX_errno | Fetch the value of errno.
LINUX_openlog | Open a connection to the syslog service.
LINUX_poll | Wait for an event on one or more files.
LINUX_strerror | Retrieve the error message for a particular errno error code.
LINUX_syslog | Send a message to the syslog service.
LINUX_usleep | Sleep for the specified number of microseconds.
PWM_close | Close a Linux PWM output device.
PWM_configure | Configure a Linux PWM output device.
PWM_open | Open a Linux PWM output device.
PWM_write | Set a Linux PWM output device duty cycle.
SERIAL_close | Close a Linux serial port device.
SERIAL_open | Open a Linux serial port device.
SERIAL_receive | Receive data from a Linux serial port device.
SERIAL_send | Send data to a Linux serial port device.
SPI_close | Close a Linux SPI device.
SPI_open | Open a Linux SPI device.
SPI_transaction | Send bytes to and/or receive bytes from a Linux SPI device.
STREAM_decode_frame | Decode a frame.
STREAM_encode_frame | Encode a frame.
STREAM_receive_frame | Receive an encoded frame.
STREAM_send_frame | Send an encoded frame.
TCP4_accept | Start TCP server and wait for a single connection.
TCP4_close | Close a TCP connection.
TCP4_connect | Connect to a TCP server.
TCP4_receive | Receive bytes from TCP peer.
TCP4_send | Send bytes to TCP peer.
TCP4_server | Start a TCP server and fork for each connection.
UDP4_close | Close a UDP socket.
UDP4_open | Open a UDP socket.
UDP4_receive | Receive a UDP datagram.
UDP4_send | Send a UDP datagram.
WATCHDOG_close | Close a Linux watchdog timer device.
WATCHDOG_get_timeout | Query a Linux watchdog timer device.
WATCHDOG_kick | Reset the watchdog timer.
WATCHDOG_open | Open a Linux watchdog timer device.
WATCHDOG_set_timeout | Change the watchdog timer period.
Top
Fields
Name | Description
GPIO_DIRECTION_INPUT | Input data direction.
GPIO_DIRECTION_OUTPUT | Out data direction.
GPIO_DRIVER_OPENDRAIN | Open drain (sink only) output driver.
GPIO_DRIVER_OPENSOURCE | Open source (source only) output driver
GPIO_DRIVER_PUSHPULL | Push-pull (source and sink) output driver.
GPIO_EDGE_BOTH | Interrupt on both edges.
GPIO_EDGE_FALLING | Interrupt on falling edge.
GPIO_EDGE_NONE | Interrupts are disabled.
GPIO_EDGE_RISING | Interrupt on rising edge.
GPIO_EVENT_REQUEST_BOTH | Enable GPIO input interrupt on both edges.
GPIO_EVENT_REQUEST_FALLING | Enable GPIO input interrupt on falling edge.
GPIO_EVENT_REQUEST_NONE | Disable GPIO input interrupt.
GPIO_EVENT_REQUEST_RISING | Enable GPIO input interrupt on rising edge.
GPIO_LINE_INFO_ACTIVE_LOW | GPIO line is configured as active low (inverted).
GPIO_LINE_INFO_KERNEL | GPIO line is being used by the kernel.
GPIO_LINE_INFO_OPEN_DRAIN | GPIO line is configured as open drain (current sink only).
GPIO_LINE_INFO_OPEN_SOURCE | GPIO line is configured as open source (current source only).
GPIO_LINE_INFO_OUTPUT | GPIO line is configured as an output.
GPIO_LINE_REQUEST_ACTIVE_HIGH | Select GPIO line polarity active high (normal).
GPIO_LINE_REQUEST_ACTIVE_LOW | Select GPIO line polarity active low (inverted).
GPIO_LINE_REQUEST_INPUT | Select GPIO line direction input.
GPIO_LINE_REQUEST_OPEN_DRAIN | Select GPIO line driver open drain (current sink only).
GPIO_LINE_REQUEST_OPEN_SOURCE | Select GPIO line driver open source (current source only).
GPIO_LINE_REQUEST_OUTPUT | Select GPIO line direction output.
GPIO_LINE_REQUEST_PUSH_PULL | Select GPIO line driver push-pull (current source and sink).
GPIO_POLARITY_ACTIVEHIGH | Active high (normal) polarity.
GPIO_POLARITY_ACTIVELOW | Active low (inverted) polarity.
INADDR_ANY | IPv4 address for binding to all network interfaces.
INADDR_BROADCAST | IPv4 broadcast address.
INADDR_LOOPBACK | IPv4 address for binding to the loopback interface (aka localhost).
LOG_ALERT | Action must be taken immediately.
LOG_AUTH | Security/authorization messages.
LOG_AUTHPRIV | Securit/authorization messages.
LOG_CONS | Write directly to the system console if there is an error while sending to the system logger.
LOG_CRIT | Critical condition.
LOG_CRON | cron daemon messages.
LOG_DAEMON | System daemons.
LOG_DEBUG | Debug message.
LOG_EMERG | System is unusable.
LOG_ERR | Error condition.
LOG_FTP | FTP daemon messages.
LOG_INFO | Informational message.
LOG_KERN | Kernel messages.
LOG_LOCAL0 | Reserved for local use.
LOG_LOCAL1 | Reserved for local use.
LOG_LOCAL2 | Reserved for local use.
LOG_LOCAL3 | Reserved for local use.
LOG_LOCAL4 | Reserved for local use.
LOG_LOCAL5 | Reserved for local use.
LOG_LOCAL6 | Reserved for local use.
LOG_LOCAL7 | Reserved for local use.
LOG_LPR | Line printer subsystem
LOG_MAIL | Mail system.
LOG_NDELAY | Open the connection immediately. Do not wait until syslog() is called for the first time.
LOG_NEWS | Network news subsystem
LOG_NOTICE | Normal but significant condition.
LOG_NOWAIT | Don't wait for child processes that may have been created while logging the message. (Not applicable to glibc.)
LOG_ODELAY | Do not open the connection immediately. Wait until syslog() is called for the first time.
LOG_PERROR | Also log the message to stderr.
LOG_PID | Include the caller's PID (process ID) with each message.
LOG_PROGNAME | Use the program name for the identity string.
LOG_SYSLOG | Messages generated internally by syslogd
LOG_USER | Random user-level messages.
LOG_UUCP | UUCP subsystem
LOG_WARNING | Warning condition.
MSG_DONTROUTE | Don't use a gateway to send out the packet, send to hosts only on directly connected networks.
MSG_DONTWAIT | Enables nonblocking operation; if the operation would block, EAGAIN or EWOULDBLOCK is returned.
MSG_MORE | The caller has more data to send. This flag informs the kernel to package all of the data sent in calls with this flag set into a single datagram which is transmitted only when a call is performed that does not specify this flag.
POLLERR | An error occurred.
POLLHUP | Peer closed connection.
POLLIN | There is data to read.
POLLNVAL | File descriptor is invalid.
POLLOUT | Writing is now possible.
POLLPRI | There is urgent data to read.
PWM_POLARITY_ACTIVEHIGH | Configure the PWM output as active high (normal).
PWM_POLARITY_ACTIVELOW | Configure the PWM output as active low (inverted).
SERIAL_PARITY_EVEN | Request even parity checking.
SERIAL_PARITY_NONE | Disable parity checking.
SERIAL_PARITY_ODD | Request odd parity checking.
SPI_AUTO_CS | Use hardware slave select.
Top
See Also

Reference

IO.Bindings Namespace


libsimpleio Methods

The libsimpleio type exposes the following members.

Methods
Name | Description
ADC_close | Close a Linux IIO A/D converter input device.
ADC_get_name | Get the subsystem name for the specified Linux IIO A/D converter device.
ADC_open | Open a Linux IIO A/D converter input device.
ADC_read | Read a Linux IIO A/D converter input device.
DAC_close | Close a Linux IIO D/A converter output device.
DAC_get_name | Get the subsystem name for the specified Linux IIO D/A converter device.
DAC_open | Open a Linux IIO D/A converter output device.
DAC_write | Write to a Linux IIO D/A converter output device.
EVENT_close | Close an epoll event dispatcher.
EVENT_modify_fd | Modify a file registration.
EVENT_open | Open an epoll event dispatcher.
EVENT_register_fd | Register a file descriptor with an epoll event dispatcher.
EVENT_unregister_fd | Unregister a file from an epoll dispatcher.
EVENT_wait | Wait for events from an epoll dispatcher.
GPIO_chip_info | Get GPIO chip information.
GPIO_close | Close a Linux GPIO pin device.
GPIO_configure | Configure a Linux GPIO pin.
GPIO_line_close | Close a single GPIO line.
GPIO_line_event | Read an edge trigger event from single GPIO line.
GPIO_line_info | Get GPIO line information.
GPIO_line_open | Open a single GPIO line.
GPIO_line_read | Read the state of a single GPIO line.
GPIO_line_write | Write the state of a single GPIO line.
GPIO_open | Open a Linux GPIO pin device.
GPIO_read | Read a Linux GPIO pin.
GPIO_write | Write a Linux GPIO pin.
HIDRAW_close | Close a Linux raw HID.
HIDRAW_get_info | Get Linux raw HID bus type, vendor ID, and product ID.
HIDRAW_get_name | Get Linux raw HID name string.
HIDRAW_open1 | Open a Linux raw HID device by device node name.
HIDRAW_open2 | Open a Linux raw HID device by vendor ID and product ID.
HIDRAW_open3 | Open a Linux raw HID device by vendor ID and product ID and serial number.
HIDRAW_receive | Get a 64-byte report from a Linux HID.
HIDRAW_send | Send a 64-byte report to a Linux HID.
I2C_close | Close a Linux I2C bus controller device.
I2C_open | Open a Linux I2C bus controller device.
I2C_transaction | Send bytes to and/or receive bytes from an I2C slave device.
IPV4_ntoa | Convert an IPv4 address to a dotted notation string (e.g. 1.2.3.4).
IPV4_resolve | Resolve a domain name to an IPv4 host address.
LINUX_closelog | Close the connection to the syslog service.
LINUX_command | Execute a shell command string.
LINUX_detach | Detach the process and run it in the background.
LINUX_drop_privileges | Drop process privileges to those of the specified user. Remarks Only a process running at superuser privilege is allowed to drop privileges.
LINUX_errno | Fetch the value of errno.
LINUX_openlog | Open a connection to the syslog service.
LINUX_poll | Wait for an event on one or more files.
LINUX_strerror | Retrieve the error message for a particular errno error code.
LINUX_syslog | Send a message to the syslog service.
LINUX_usleep | Sleep for the specified number of microseconds.
PWM_close | Close a Linux PWM output device.
PWM_configure | Configure a Linux PWM output device.
PWM_open | Open a Linux PWM output device.
PWM_write | Set a Linux PWM output device duty cycle.
SERIAL_close | Close a Linux serial port device.
SERIAL_open | Open a Linux serial port device.
SERIAL_receive | Receive data from a Linux serial port device.
SERIAL_send | Send data to a Linux serial port device.
SPI_close | Close a Linux SPI device.
SPI_open | Open a Linux SPI device.
SPI_transaction | Send bytes to and/or receive bytes from a Linux SPI device.
STREAM_decode_frame | Decode a frame.
STREAM_encode_frame | Encode a frame.
STREAM_receive_frame | Receive an encoded frame.
STREAM_send_frame | Send an encoded frame.
TCP4_accept | Start TCP server and wait for a single connection.
TCP4_close | Close a TCP connection.
TCP4_connect | Connect to a TCP server.
TCP4_receive | Receive bytes from TCP peer.
TCP4_send | Send bytes to TCP peer.
TCP4_server | Start a TCP server and fork for each connection.
UDP4_close | Close a UDP socket.
UDP4_open | Open a UDP socket.
UDP4_receive | Receive a UDP datagram.
UDP4_send | Send a UDP datagram.
WATCHDOG_close | Close a Linux watchdog timer device.
WATCHDOG_get_timeout | Query a Linux watchdog timer device.
WATCHDOG_kick | Reset the watchdog timer.
WATCHDOG_open | Open a Linux watchdog timer device.
WATCHDOG_set_timeout | Change the watchdog timer period.
Top
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.ADC_close Method

Munts Technologies Linux Simple I/O Library for .Net Standard 2.0

libsimpleioADC_close Method

Close a Linux IIO A/D converter input device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void ADC_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.ADC_get_name Method

libsimpleioADC_get_name Method

Get the subsystem name for the specified Linux IIO A/D converter device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void ADC_get_name(
    int chip,
    StringBuilder name,
    int size,
    out int error
)

Parameters

chip Int32
Linux IIO device number.
name StringBuilder
Destination buffer.
size Int32
Size of destination buffer.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.ADC_open Method

libsimpleioADC_open Method

Open a Linux IIO A/D converter input device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void ADC_open(
    int chip,
    int channel,
    out int fd,
    out int error
)

Parameters

chip Int32
Linux IIO device number.
channel Int32
Input channel number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.ADC_read Method

libsimpleioADC_read Method

Read a Linux IIO A/D converter input device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void ADC_read(
    int fd,
    out int sample,
    out int error
)

Parameters

fd Int32
File descriptor.
sample Int32
Analog sample data.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.DAC_close Method

libsimpleioDAC_close Method

Close a Linux IIO D/A converter output device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void DAC_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.DAC_get_name Method

libsimpleioDAC_get_name Method

Get the subsystem name for the specified Linux IIO D/A converter device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void DAC_get_name(
    int chip,
    StringBuilder name,
    int size,
    out int error
)

Parameters

chip Int32
Linux IIO device number.
name StringBuilder
Destination buffer.
size Int32
Size of destination buffer.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.DAC_open Method

libsimpleioDAC_open Method

Open a Linux IIO D/A converter output device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void DAC_open(
    int chip,
    int channel,
    out int fd,
    out int error
)

Parameters

chip Int32
Linux IIO device number.
channel Int32
Output channel number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.DAC_write Method

libsimpleioDAC_write Method

Write to a Linux IIO D/A converter output device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void DAC_write(
    int fd,
    int sample,
    out int error
)

Parameters

fd Int32
File descriptor.
sample Int32
Analog sample data.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.EVENT_close Method

libsimpleioEVENT_close Method

Close an epoll event dispatcher.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void EVENT_close(
    int epfd,
    out int error
)

Parameters

epfd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.EVENT_modify_fd Method

libsimpleioEVENT_modify_fd Method

Modify a file registration.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void EVENT_modify_fd(
    int epfd,
    int fd,
    int events,
    int handle,
    out int error
)

Parameters

epfd Int32
File descriptor for the dispatcher.
fd Int32
File descriptor to register for events.
events Int32
Events to register for. May be a sum of the individual event flags.
handle Int32
Event handle.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.EVENT_open Method

libsimpleioEVENT_open Method

Open an epoll event dispatcher.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void EVENT_open(
    out int epfd,
    out int error
)

Parameters

epfd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.EVENT_register_fd Method

libsimpleioEVENT_register_fd Method

Register a file descriptor with an epoll event dispatcher.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void EVENT_register_fd(
    int epfd,
    int fd,
    int events,
    int handle,
    out int error
)

Parameters

epfd Int32
File descriptor for the dispatcher.
fd Int32
File descriptor to register for events.
events Int32
Events to register for. May be a sum of the individual event flags.
handle Int32
Event handle.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.EVENT_unregister_fd Method

libsimpleioEVENT_unregister_fd Method

Unregister a file from an epoll dispatcher.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void EVENT_unregister_fd(
    int epfd,
    int fd,
    out int error
)

Parameters

epfd Int32
File descriptor for the dispatcher.>
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.EVENT_wait Method

libsimpleioEVENT_wait Method

Wait for events from an epoll dispatcher.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void EVENT_wait(
    int epfd,
    out int fd,
    out int events,
    out int handle,
    int timeoutms,
    out int error
)

Parameters

epfd Int32
File descriptor for the displatcher.
fd Int32
File descriptor the event is applicable to.
events Int32
Events that occurred. May be a sum of the individual event flags.
handle Int32
Event handle provided whent the file descriptor was registered.
timeoutms Int32
Time in milliseconds to wait for an event.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_chip_info Method

libsimpleioGPIO_chip_info Method

Get GPIO chip information.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_chip_info(
    int chip,
    StringBuilder name,
    int namesize,
    StringBuilder label,
    int labelsize,
    out int lines,
    out int error
)

Parameters

chip Int32
GPIO chip number.
name StringBuilder
GPIO chip name.
namesize Int32
Maximum size of name.
label StringBuilder
GPIO chip label.
labelsize Int32
Maximum size of label.
lines Int32
Number of GPIO lines.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_close Method

libsimpleioGPIO_close Method

Close a Linux GPIO pin device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_configure Method

libsimpleioGPIO_configure Method

Configure a Linux GPIO pin.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_configure(
    int pin,
    int direction,
    int state,
    int edge,
    int polarity,
    out int error
)

Parameters

pin Int32
Pin number.
direction Int32
Data direction.
state Int32
Initial GPIO output state.
edge Int32
Interrupt edge for input pin.
polarity Int32
Polarity
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_line_close Method

libsimpleioGPIO_line_close Method

Close a single GPIO line.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_line_close(
    int fd,
    out int error
)

Parameters

fd Int32
Linux file descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_line_event Method

libsimpleioGPIO_line_event Method

Read an edge trigger event from single GPIO line.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_line_event(
    int fd,
    out int state,
    out int error
)

Parameters

fd Int32
Linux file descriptor.
state Int32
State of the GPIO line after the edge trigger event.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_line_info Method

libsimpleioGPIO_line_info Method

Get GPIO line information.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_line_info(
    int chip,
    int line,
    StringBuilder name,
    int namesize,
    StringBuilder label,
    int labelsize,
    out int error
)

Parameters

chip Int32
GPIO chip number.
line Int32
GPIO line number.
name StringBuilder
GPIO line name.
namesize Int32
Maximum size of name.
label StringBuilder
GPIO line label.
labelsize Int32
Maximum size of label.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_line_open Method

libsimpleioGPIO_line_open Method

Open a single GPIO line.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_line_open(
    int chip,
    int line,
    int flags,
    int events,
    int state,
    out int fd,
    out int error
)

Parameters

chip Int32
GPIO chip number.
line Int32
GPIO line number.
flags Int32
GPIO line configuration flags.
events Int32
GPIO line event flags.
state Int32
Initial GPIO output state.
fd Int32
Linux file descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_line_read Method

libsimpleioGPIO_line_read Method

Read the state of a single GPIO line.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_line_read(
    int fd,
    out int state,
    out int error
)

Parameters

fd Int32
Linux file descriptor.
state Int32
State of the GPIO line.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_line_write Method

libsimpleioGPIO_line_write Method

Write the state of a single GPIO line.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_line_write(
    int fd,
    int state,
    out int error
)

Parameters

fd Int32
Linux file descriptor.
state Int32
State of the GPIO line.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_open Method

libsimpleioGPIO_open Method

Open a Linux GPIO pin device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_open(
    int pin,
    out int fd,
    out int error
)

Parameters

pin Int32
Pin number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_read Method

libsimpleioGPIO_read Method

Read a Linux GPIO pin.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_read(
    int fd,
    out int state,
    out int error
)

Parameters

fd Int32
File descriptor.
state Int32
Pin state.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_write Method

libsimpleioGPIO_write Method

Write a Linux GPIO pin.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void GPIO_write(
    int fd,
    int state,
    out int error
)

Parameters

fd Int32
File descriptor.
state Int32
Pin state.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_close Method

libsimpleioHIDRAW_close Method

Close a Linux raw HID.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_get_info Method

libsimpleioHIDRAW_get_info Method

Get Linux raw HID bus type, vendor ID, and product ID.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_get_info(
    int fd,
    out int bustype,
    out int vendor,
    out int product,
    out int error
)

Parameters

fd Int32
File descriptor.
bustype Int32
Bus type.
vendor Int32
Vendor ID.
product Int32
Product ID.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_get_name Method

libsimpleioHIDRAW_get_name Method

Get Linux raw HID name string.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_get_name(
    int fd,
    StringBuilder name,
    int size,
    out int error
)

Parameters

fd Int32
File descriptor.
name StringBuilder
Destination buffer.
size Int32
Size of destination buffer.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_open1 Method

libsimpleioHIDRAW_open1 Method

Open a Linux raw HID device by device node name.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_open1(
    string devname,
    out int fd,
    out int error
)

Parameters

devname String
Device node name.
fd Int32
Device node name.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_open2 Method

libsimpleioHIDRAW_open2 Method

Open a Linux raw HID device by vendor ID and product ID.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_open2(
    int VID,
    int PID,
    out int fd,
    out int error
)

Parameters

VID Int32
Vendor ID.
PID Int32
Product ID.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_open3 Method

libsimpleioHIDRAW_open3 Method

Open a Linux raw HID device by vendor ID and product ID and serial number.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_open3(
    int VID,
    int PID,
    string serial,
    out int fd,
    out int error
)

Parameters

VID Int32
Vendor ID.
PID Int32
Product ID.
serial String
Serial number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_receive Method

libsimpleioHIDRAW_receive Method

Get a 64-byte report from a Linux HID.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_receive(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Destination buffer.
bufsize Int32
Destination buffer size.
count Int32
Number of bytes actually received.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.HIDRAW_send Method

libsimpleioHIDRAW_send Method

Send a 64-byte report to a Linux HID.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void HIDRAW_send(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Source buffer.
bufsize Int32
Source buffer size.
count Int32
Number of bytes actually sent.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.I2C_close Method

libsimpleioI2C_close Method

Close a Linux I2C bus controller device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void I2C_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.I2C_open Method

libsimpleioI2C_open Method

Open a Linux I2C bus controller device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void I2C_open(
    string devname,
    out int fd,
    out int error
)

Parameters

devname String
Device node name.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.I2C_transaction Method

libsimpleioI2C_transaction Method

Send bytes to and/or receive bytes from an I2C slave device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void I2C_transaction(
    int fd,
    int slaveaddr,
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    out int error
)

Parameters

fd Int32
File descriptor.
slaveaddr Int32
Slave address.
cmd Byte
Source buffer.
cmdlen Int32
Source buffer size.
resp Byte
Response buffer.
resplen Int32
Response buffer size.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.IPV4_ntoa Method

libsimpleioIPV4_ntoa Method

Convert an IPv4 address to a dotted notation string (e.g. 1.2.3.4).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void IPV4_ntoa(
    int host,
    StringBuilder buf,
    int bufsize,
    out int error
)

Parameters

host Int32
IPv4 host address
buf StringBuilder
Destination buffer.
bufsize Int32
Destination buffer size.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.IPV4_resolve Method

libsimpleioIPV4_resolve Method

Resolve a domain name to an IPv4 host address.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void IPV4_resolve(
    string hostname,
    out int host,
    out int error
)

Parameters

hostname String
Host name to resolve.
host Int32
IPv4 host address.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_closelog Method

libsimpleioLINUX_closelog Method

Close the connection to the syslog service.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_closelog(
    out int error
)

Parameters

error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_command Method

libsimpleioLINUX_command Method

Execute a shell command string.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_command(
    string cmd,
    out int error
)

Parameters

cmd String
Command string.
error Int32
Error code.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_detach Method

libsimpleioLINUX_detach Method

Detach the process and run it in the background.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_detach(
    out int error
)

Parameters

error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_drop_privileges Method

libsimpleioLINUX_drop_privileges Method

Drop process privileges to those of the specified user.
Remarks
Only a process running at superuser privilege is allowed to drop privileges.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_drop_privileges(
    string username,
    out int error
)

Parameters

username String
User privileges to assume.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_errno Method

libsimpleioLINUX_errno Method

Fetch the value of errno.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static int LINUX_errno()

Return Value

Int32
Current value of errno.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_openlog Method

libsimpleioLINUX_openlog Method

Open a connection to the syslog service.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_openlog(
    string id,
    int options,
    int facility,
    out int error
)

Parameters

id String
Program identifier.
options Int32
Logging options.
facility Int32
Logging facility identifier.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_poll Method

libsimpleioLINUX_poll Method

Wait for an event on one or more files.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_poll(
    int numfiles,
    int[] files,
    int[] events,
    int[] results,
    int timeoutms,
    out int error
)

Parameters

numfiles Int32
Number elements in each of the following arrays.
files Int32
File descriptors.
events Int32
Events to wait for on each file descriptor.
results Int32
Events that occurred on each file descriptor.
timeoutms Int32
Milliseconds to wait for an event to occur. A value of -1 means wait forever and a value of 0 means do not wait at all.
error Int32
Error code.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_strerror Method

libsimpleioLINUX_strerror Method

Retrieve the error message for a particular errno error code.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_strerror(
    int error,
    StringBuilder buf,
    int bufsize
)

Parameters

error Int32
Error code.
buf StringBuilder
Destination buffer.
bufsize Int32
Destination buffer size.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_syslog Method

libsimpleioLINUX_syslog Method

Send a message to the syslog service.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_syslog(
    int priority,
    string msg,
    out int error
)

Parameters

priority Int32
Message priority
msg String
Message to send.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LINUX_usleep Method

libsimpleioLINUX_usleep Method

Sleep for the specified number of microseconds.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void LINUX_usleep(
    int microsecs,
    out int error
)

Parameters

microsecs Int32
Number of microseconds to sleep.
error Int32
Error code.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.PWM_close Method

libsimpleioPWM_close Method

Close a Linux PWM output device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void PWM_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.PWM_configure Method

libsimpleioPWM_configure Method

Configure a Linux PWM output device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void PWM_configure(
    int chip,
    int channel,
    int period,
    int ontime,
    int polarity,
    out int error
)

Parameters

chip Int32
Chip number.
channel Int32
Channel number.
period Int32
Pulse period in microseconds.
ontime Int32
Initial on time in microseconds.
polarity Int32
PWM output polarity (0 for active low/inverted or 1 for active high/normal).
error Int32
Error code. Zero upon success or an errno value upon failure.
Remarks
On many platforms two more more PWM outputs may share the same clock generator, so configuring different PWM pulse periods may not be possible.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.PWM_open Method

libsimpleioPWM_open Method

Open a Linux PWM output device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void PWM_open(
    int chip,
    int channel,
    out int fd,
    out int error
)

Parameters

chip Int32
Chip number.
channel Int32
Channel number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.PWM_write Method

libsimpleioPWM_write Method

Set a Linux PWM output device duty cycle.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void PWM_write(
    int fd,
    int ontime,
    out int error
)

Parameters

fd Int32
File descriptor.
ontime Int32
On time in microseconds.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_close Method

libsimpleioSERIAL_close Method

Close a Linux serial port device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SERIAL_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_open Method

libsimpleioSERIAL_open Method

Open a Linux serial port device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SERIAL_open(
    string devname,
    int baudrate,
    int parity,
    int databits,
    int stopbits,
    out int fd,
    out int error
)

Parameters

devname String
Device node name.
baudrate Int32
Baud rate.
parity Int32
Parity setting (0 to 2).
databits Int32
Word size setting (5 to 8).
stopbits Int32
Number of stop bits (1 or 2).
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_receive Method

libsimpleioSERIAL_receive Method

Receive data from a Linux serial port device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SERIAL_receive(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Destination buffer.
bufsize Int32
Destination buffer size.
count Int32
Number of bytes actually received.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_send Method

libsimpleioSERIAL_send Method

Send data to a Linux serial port device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SERIAL_send(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Source buffer.
bufsize Int32
Source buffer size.
count Int32
Number of bytes actually sent.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SPI_close Method

libsimpleioSPI_close Method

Close a Linux SPI device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SPI_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SPI_open Method

libsimpleioSPI_open Method

Open a Linux SPI device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SPI_open(
    string devname,
    int mode,
    int wordsize,
    int speed,
    out int fd,
    out int error
)

Parameters

devname String
Device node name.
mode Int32
SPI transfer mode (0 .. 3)
wordsize Int32
SPI transfer word size (8, 16, or 32).
speed Int32
SPI transfer speed in Hz.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
Remarks
The Linux kernel create a device nodes for each SPI slave device, of the form /dev/spidevX.Y where X is the SPI bus controller number and Y is the SPI slave select number.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SPI_transaction Method

libsimpleioSPI_transaction Method

Send bytes to and/or receive bytes from a Linux SPI device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void SPI_transaction(
    int fd,
    int csfd,
    byte[] cmd,
    int cmdlen,
    int delayus,
    byte[] resp,
    int resplen,
    out int error
)

Parameters

fd Int32
File descriptor.
csfd Int32
Chip select file descriptor.
cmd Byte
Source buffer.
cmdlen Int32
Source buffer size.
delayus Int32
Delay in microseconds between the write and read operations.
resp Byte
Destination buffer.
resplen Int32
Destination buffer size.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.STREAM_decode_frame Method

libsimpleioSTREAM_decode_frame Method

Decode a frame.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void STREAM_decode_frame(
    byte[] src,
    int srclen,
    byte[] dst,
    int dstsize,
    out int dstlen,
    out int error
)

Parameters

src Byte
Source buffer.
srclen Int32
Source buffer size.
dst Byte
Destination buffer.
dstsize Int32
Destination buffer size.
dstlen Int32
Size of decoded frame.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.STREAM_encode_frame Method

libsimpleioSTREAM_encode_frame Method

Encode a frame.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void STREAM_encode_frame(
    byte[] src,
    int srclen,
    byte[] dst,
    int dstsize,
    out int dstlen,
    out int error
)

Parameters

src Byte
Source buffer.
srclen Int32
Source buffer size.
dst Byte
Destination buffer.
dstsize Int32
Destination buffer size.
dstlen Int32
Size of encoded frame.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.STREAM_receive_frame Method

libsimpleioSTREAM_receive_frame Method

Receive an encoded frame.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void STREAM_receive_frame(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptior.
buf Byte
Destination buffer.
bufsize Int32
Destination buffer size.
count Int32
Number of bytes actually received.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.STREAM_send_frame Method

libsimpleioSTREAM_send_frame Method

Send an encoded frame.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void STREAM_send_frame(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Source buffer.
bufsize Int32
Source buffer size.
count Int32
Number of bytes actually sent.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.TCP4_accept Method

libsimpleioTCP4_accept Method

Start TCP server and wait for a single connection.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void TCP4_accept(
    int host,
    int port,
    out int fd,
    out int error
)

Parameters

host Int32
IPv4 address, of the interface to listen on. Use 0.0.0.0 to listen on all interfaces.
port Int32
TCP port number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.TCP4_close Method

libsimpleioTCP4_close Method

Close a TCP connection.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void TCP4_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.TCP4_connect Method

libsimpleioTCP4_connect Method

Connect to a TCP server.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void TCP4_connect(
    int host,
    int port,
    out int fd,
    out int error
)

Parameters

host Int32
IPv4 host address.
port Int32
TCP port number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.TCP4_receive Method

libsimpleioTCP4_receive Method

Receive bytes from TCP peer.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void TCP4_receive(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Destination buffer.
bufsize Int32
Destination buffer size.
count Int32
Number of bytes actually received.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.TCP4_send Method

libsimpleioTCP4_send Method

Send bytes to TCP peer.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void TCP4_send(
    int fd,
    byte[] buf,
    int bufsize,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
buf Byte
Source buffer.
bufsize Int32
Source buffer size.
count Int32
Number of bytes actually sent.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.TCP4_server Method

libsimpleioTCP4_server Method

Start a TCP server and fork for each connection.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void TCP4_server(
    int host,
    int port,
    out int fd,
    out int error
)

Parameters

host Int32
IPv4 address, of the interface to listen on. Use 0.0.0.0 to listen on all interfaces.
port Int32
TCP port number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.UDP4_close Method

libsimpleioUDP4_close Method

Close a UDP socket.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void UDP4_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.UDP4_open Method

libsimpleioUDP4_open Method

Open a UDP socket.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void UDP4_open(
    int host,
    int port,
    out int fd,
    out int error
)

Parameters

host Int32
IPv4 host address.
port Int32
UDP port number.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.UDP4_receive Method

libsimpleioUDP4_receive Method

Receive a UDP datagram.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void UDP4_receive(
    int fd,
    out int host,
    out int port,
    byte[] buf,
    int bufsize,
    int flags,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
host Int32
Source IPv4 host address.
port Int32
Source UDP port number.
buf Byte
Destination buffer.
bufsize Int32
Destination buffer size.
flags Int32
Flags for the Linux recvfrom() system call.
count Int32
Number of bytes actually received.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.UDP4_send Method

libsimpleioUDP4_send Method

Send a UDP datagram.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void UDP4_send(
    int fd,
    int host,
    int port,
    byte[] buf,
    int bufsize,
    int flags,
    out int count,
    out int error
)

Parameters

fd Int32
File descriptor.
host Int32
Destination IPv4 host address.
port Int32
Destination UDP port number.
buf Byte
Source buffer.
bufsize Int32
Source buffer size.
flags Int32
Flags for the Linux sendto() system call.
count Int32
Number of bytes actually sent.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.WATCHDOG_close Method

libsimpleioWATCHDOG_close Method

Close a Linux watchdog timer device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void WATCHDOG_close(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.WATCHDOG_get_timeout Method

libsimpleioWATCHDOG_get_timeout Method

Query a Linux watchdog timer device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void WATCHDOG_get_timeout(
    int fd,
    out int timeout,
    out int error
)

Parameters

fd Int32
File descriptor.
timeout Int32
Timeout period in seconds.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.WATCHDOG_kick Method

libsimpleioWATCHDOG_kick Method

Reset the watchdog timer.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void WATCHDOG_kick(
    int fd,
    out int error
)

Parameters

fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.WATCHDOG_open Method

libsimpleioWATCHDOG_open Method

Open a Linux watchdog timer device.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void WATCHDOG_open(
    string devname,
    out int fd,
    out int error
)

Parameters

devname String
Device node name.
fd Int32
File descriptor.
error Int32
Error code. Zero upon success or an errno value upon failure.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.WATCHDOG_set_timeout Method

libsimpleioWATCHDOG_set_timeout Method

Change the watchdog timer period.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static void WATCHDOG_set_timeout(
    int fd,
    int newtimeout,
    out int timeout,
    out int error
)

Parameters

fd Int32
File descriptor.
newtimeout Int32
Requested timeout period in seconds.
timeout Int32
Actual timeout period in seconds.
error Int32
Error code. Zero upon success or an errno value upon failure.
Remarks
Not all platforms allow changing the timeout period. Some platforms may not allow increasing the period.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio Fields

The libsimpleio type exposes the following members.

Fields
Name | Description
GPIO_DIRECTION_INPUT | Input data direction.
GPIO_DIRECTION_OUTPUT | Out data direction.
GPIO_DRIVER_OPENDRAIN | Open drain (sink only) output driver.
GPIO_DRIVER_OPENSOURCE | Open source (source only) output driver
GPIO_DRIVER_PUSHPULL | Push-pull (source and sink) output driver.
GPIO_EDGE_BOTH | Interrupt on both edges.
GPIO_EDGE_FALLING | Interrupt on falling edge.
GPIO_EDGE_NONE | Interrupts are disabled.
GPIO_EDGE_RISING | Interrupt on rising edge.
GPIO_EVENT_REQUEST_BOTH | Enable GPIO input interrupt on both edges.
GPIO_EVENT_REQUEST_FALLING | Enable GPIO input interrupt on falling edge.
GPIO_EVENT_REQUEST_NONE | Disable GPIO input interrupt.
GPIO_EVENT_REQUEST_RISING | Enable GPIO input interrupt on rising edge.
GPIO_LINE_INFO_ACTIVE_LOW | GPIO line is configured as active low (inverted).
GPIO_LINE_INFO_KERNEL | GPIO line is being used by the kernel.
GPIO_LINE_INFO_OPEN_DRAIN | GPIO line is configured as open drain (current sink only).
GPIO_LINE_INFO_OPEN_SOURCE | GPIO line is configured as open source (current source only).
GPIO_LINE_INFO_OUTPUT | GPIO line is configured as an output.
GPIO_LINE_REQUEST_ACTIVE_HIGH | Select GPIO line polarity active high (normal).
GPIO_LINE_REQUEST_ACTIVE_LOW | Select GPIO line polarity active low (inverted).
GPIO_LINE_REQUEST_INPUT | Select GPIO line direction input.
GPIO_LINE_REQUEST_OPEN_DRAIN | Select GPIO line driver open drain (current sink only).
GPIO_LINE_REQUEST_OPEN_SOURCE | Select GPIO line driver open source (current source only).
GPIO_LINE_REQUEST_OUTPUT | Select GPIO line direction output.
GPIO_LINE_REQUEST_PUSH_PULL | Select GPIO line driver push-pull (current source and sink).
GPIO_POLARITY_ACTIVEHIGH | Active high (normal) polarity.
GPIO_POLARITY_ACTIVELOW | Active low (inverted) polarity.
INADDR_ANY | IPv4 address for binding to all network interfaces.
INADDR_BROADCAST | IPv4 broadcast address.
INADDR_LOOPBACK | IPv4 address for binding to the loopback interface (aka localhost).
LOG_ALERT | Action must be taken immediately.
LOG_AUTH | Security/authorization messages.
LOG_AUTHPRIV | Securit/authorization messages.
LOG_CONS | Write directly to the system console if there is an error while sending to the system logger.
LOG_CRIT | Critical condition.
LOG_CRON | cron daemon messages.
LOG_DAEMON | System daemons.
LOG_DEBUG | Debug message.
LOG_EMERG | System is unusable.
LOG_ERR | Error condition.
LOG_FTP | FTP daemon messages.
LOG_INFO | Informational message.
LOG_KERN | Kernel messages.
LOG_LOCAL0 | Reserved for local use.
LOG_LOCAL1 | Reserved for local use.
LOG_LOCAL2 | Reserved for local use.
LOG_LOCAL3 | Reserved for local use.
LOG_LOCAL4 | Reserved for local use.
LOG_LOCAL5 | Reserved for local use.
LOG_LOCAL6 | Reserved for local use.
LOG_LOCAL7 | Reserved for local use.
LOG_LPR | Line printer subsystem
LOG_MAIL | Mail system.
LOG_NDELAY | Open the connection immediately. Do not wait until syslog() is called for the first time.
LOG_NEWS | Network news subsystem
LOG_NOTICE | Normal but significant condition.
LOG_NOWAIT | Don't wait for child processes that may have been created while logging the message. (Not applicable to glibc.)
LOG_ODELAY | Do not open the connection immediately. Wait until syslog() is called for the first time.
LOG_PERROR | Also log the message to stderr.
LOG_PID | Include the caller's PID (process ID) with each message.
LOG_PROGNAME | Use the program name for the identity string.
LOG_SYSLOG | Messages generated internally by syslogd
LOG_USER | Random user-level messages.
LOG_UUCP | UUCP subsystem
LOG_WARNING | Warning condition.
MSG_DONTROUTE | Don't use a gateway to send out the packet, send to hosts only on directly connected networks.
MSG_DONTWAIT | Enables nonblocking operation; if the operation would block, EAGAIN or EWOULDBLOCK is returned.
MSG_MORE | The caller has more data to send. This flag informs the kernel to package all of the data sent in calls with this flag set into a single datagram which is transmitted only when a call is performed that does not specify this flag.
POLLERR | An error occurred.
POLLHUP | Peer closed connection.
POLLIN | There is data to read.
POLLNVAL | File descriptor is invalid.
POLLOUT | Writing is now possible.
POLLPRI | There is urgent data to read.
PWM_POLARITY_ACTIVEHIGH | Configure the PWM output as active high (normal).
PWM_POLARITY_ACTIVELOW | Configure the PWM output as active low (inverted).
SERIAL_PARITY_EVEN | Request even parity checking.
SERIAL_PARITY_NONE | Disable parity checking.
SERIAL_PARITY_ODD | Request odd parity checking.
SPI_AUTO_CS | Use hardware slave select.
Top
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_DIRECTION_INPUT Field

libsimpleioGPIO_DIRECTION_INPUT Field

Input data direction.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_DIRECTION_INPUT = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_DIRECTION_OUTPUT Field

libsimpleioGPIO_DIRECTION_OUTPUT Field

Out data direction.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_DIRECTION_OUTPUT = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_DRIVER_OPENDRAIN Field

libsimpleioGPIO_DRIVER_OPENDRAIN Field

Open drain (sink only) output driver.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_DRIVER_OPENDRAIN = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_DRIVER_OPENSOURCE Field

libsimpleioGPIO_DRIVER_OPENSOURCE Field

Open source (source only) output driver

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_DRIVER_OPENSOURCE = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_DRIVER_PUSHPULL Field

libsimpleioGPIO_DRIVER_PUSHPULL Field

Push-pull (source and sink) output driver.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_DRIVER_PUSHPULL = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EDGE_BOTH Field

libsimpleioGPIO_EDGE_BOTH Field

Interrupt on both edges.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EDGE_BOTH = 3

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EDGE_FALLING Field

libsimpleioGPIO_EDGE_FALLING Field

Interrupt on falling edge.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EDGE_FALLING = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EDGE_NONE Field

libsimpleioGPIO_EDGE_NONE Field

Interrupts are disabled.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EDGE_NONE = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EDGE_RISING Field

libsimpleioGPIO_EDGE_RISING Field

Interrupt on rising edge.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EDGE_RISING = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EVENT_REQUEST_BOTH Field

libsimpleioGPIO_EVENT_REQUEST_BOTH Field

Enable GPIO input interrupt on both edges.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EVENT_REQUEST_BOTH = 3

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EVENT_REQUEST_FALLING Field

libsimpleioGPIO_EVENT_REQUEST_FALLING Field

Enable GPIO input interrupt on falling edge.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EVENT_REQUEST_FALLING = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EVENT_REQUEST_NONE Field

libsimpleioGPIO_EVENT_REQUEST_NONE Field

Disable GPIO input interrupt.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EVENT_REQUEST_NONE = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_EVENT_REQUEST_RISING Field

libsimpleioGPIO_EVENT_REQUEST_RISING Field

Enable GPIO input interrupt on rising edge.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_EVENT_REQUEST_RISING = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_INFO_ACTIVE_LOW Field

libsimpleioGPIO_LINE_INFO_ACTIVE_LOW Field

GPIO line is configured as active low (inverted).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_INFO_ACTIVE_LOW = 4

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_INFO_KERNEL Field

libsimpleioGPIO_LINE_INFO_KERNEL Field

GPIO line is being used by the kernel.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_INFO_KERNEL = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_INFO_OPEN_DRAIN Field

libsimpleioGPIO_LINE_INFO_OPEN_DRAIN Field

GPIO line is configured as open drain (current sink only).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_INFO_OPEN_DRAIN = 8

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_INFO_OPEN_SOURCE Field

libsimpleioGPIO_LINE_INFO_OPEN_SOURCE Field

GPIO line is configured as open source (current source only).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_INFO_OPEN_SOURCE = 16

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_INFO_OUTPUT Field

libsimpleioGPIO_LINE_INFO_OUTPUT Field

GPIO line is configured as an output.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_INFO_OUTPUT = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_ACTIVE_HIGH Field

libsimpleioGPIO_LINE_REQUEST_ACTIVE_HIGH Field

Select GPIO line polarity active high (normal).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_ACTIVE_HIGH = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_ACTIVE_LOW Field

libsimpleioGPIO_LINE_REQUEST_ACTIVE_LOW Field

Select GPIO line polarity active low (inverted).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_ACTIVE_LOW = 4

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_INPUT Field

libsimpleioGPIO_LINE_REQUEST_INPUT Field

Select GPIO line direction input.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_INPUT = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_OPEN_DRAIN Field

libsimpleioGPIO_LINE_REQUEST_OPEN_DRAIN Field

Select GPIO line driver open drain (current sink only).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_OPEN_DRAIN = 8

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_OPEN_SOURCE Field

libsimpleioGPIO_LINE_REQUEST_OPEN_SOURCE Field

Select GPIO line driver open source (current source only).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_OPEN_SOURCE = 16

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_OUTPUT Field

libsimpleioGPIO_LINE_REQUEST_OUTPUT Field

Select GPIO line direction output.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_OUTPUT = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_LINE_REQUEST_PUSH_PULL Field

libsimpleioGPIO_LINE_REQUEST_PUSH_PULL Field

Select GPIO line driver push-pull (current source and sink).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_LINE_REQUEST_PUSH_PULL = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_POLARITY_ACTIVEHIGH Field

libsimpleioGPIO_POLARITY_ACTIVEHIGH Field

Active high (normal) polarity.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_POLARITY_ACTIVEHIGH = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.GPIO_POLARITY_ACTIVELOW Field

libsimpleioGPIO_POLARITY_ACTIVELOW Field

Active low (inverted) polarity.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO_POLARITY_ACTIVELOW = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.INADDR_ANY Field

libsimpleioINADDR_ANY Field

IPv4 address for binding to all network interfaces.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int INADDR_ANY = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.INADDR_BROADCAST Field

libsimpleioINADDR_BROADCAST Field

IPv4 broadcast address.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int INADDR_BROADCAST = -1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.INADDR_LOOPBACK Field

libsimpleioINADDR_LOOPBACK Field

IPv4 address for binding to the loopback interface (aka localhost).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int INADDR_LOOPBACK = 2130706433

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_ALERT Field

libsimpleioLOG_ALERT Field

Action must be taken immediately.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_ALERT = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_AUTH Field

libsimpleioLOG_AUTH Field

Security/authorization messages.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_AUTH = 32

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_AUTHPRIV Field

libsimpleioLOG_AUTHPRIV Field

Securit/authorization messages.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_AUTHPRIV = 80

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_CONS Field

libsimpleioLOG_CONS Field

Write directly to the system console if there is an error while sending to the system logger.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_CONS = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_CRIT Field

libsimpleioLOG_CRIT Field

Critical condition.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_CRIT = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_CRON Field

libsimpleioLOG_CRON Field

cron daemon messages.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_CRON = 72

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_DAEMON Field

libsimpleioLOG_DAEMON Field

System daemons.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_DAEMON = 24

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_DEBUG Field

libsimpleioLOG_DEBUG Field

Debug message.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_DEBUG = 7

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_EMERG Field

libsimpleioLOG_EMERG Field

System is unusable.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_EMERG = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_ERR Field

libsimpleioLOG_ERR Field

Error condition.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_ERR = 3

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_FTP Field

libsimpleioLOG_FTP Field

FTP daemon messages.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_FTP = 88

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_INFO Field

libsimpleioLOG_INFO Field

Informational message.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_INFO = 6

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_KERN Field

libsimpleioLOG_KERN Field

Kernel messages.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_KERN = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL0 Field

libsimpleioLOG_LOCAL0 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL0 = 128

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL1 Field

libsimpleioLOG_LOCAL1 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL1 = 136

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL2 Field

libsimpleioLOG_LOCAL2 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL2 = 144

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL3 Field

libsimpleioLOG_LOCAL3 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL3 = 152

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL4 Field

libsimpleioLOG_LOCAL4 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL4 = 160

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL5 Field

libsimpleioLOG_LOCAL5 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL5 = 168

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL6 Field

libsimpleioLOG_LOCAL6 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL6 = 176

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LOCAL7 Field

libsimpleioLOG_LOCAL7 Field

Reserved for local use.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL7 = 184

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_LPR Field

libsimpleioLOG_LPR Field

Line printer subsystem

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LPR = 48

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_MAIL Field

libsimpleioLOG_MAIL Field

Mail system.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_MAIL = 16

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_NDELAY Field

libsimpleioLOG_NDELAY Field

Open the connection immediately. Do not wait until syslog() is called for the first time.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_NDELAY = 8

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_NEWS Field

libsimpleioLOG_NEWS Field

Network news subsystem

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_NEWS = 56

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_NOTICE Field

libsimpleioLOG_NOTICE Field

Normal but significant condition.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_NOTICE = 5

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_NOWAIT Field

libsimpleioLOG_NOWAIT Field

Don't wait for child processes that may have been created while logging the message. (Not applicable to glibc.)

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_NOWAIT = 16

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_ODELAY Field

libsimpleioLOG_ODELAY Field

Do not open the connection immediately. Wait until syslog() is called for the first time.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_ODELAY = 4

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_PERROR Field

libsimpleioLOG_PERROR Field

Also log the message to stderr.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_PERROR = 32

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_PID Field

libsimpleioLOG_PID Field

Include the caller's PID (process ID) with each message.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_PID = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_PROGNAME Field

libsimpleioLOG_PROGNAME Field

Use the program name for the identity string.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const string LOG_PROGNAME = ""

Field Value

String
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_SYSLOG Field

libsimpleioLOG_SYSLOG Field

Messages generated internally by syslogd

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_SYSLOG = 40

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_USER Field

libsimpleioLOG_USER Field

Random user-level messages.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_USER = 8

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_UUCP Field

libsimpleioLOG_UUCP Field

UUCP subsystem

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_UUCP = 64

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.LOG_WARNING Field

libsimpleioLOG_WARNING Field

Warning condition.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_WARNING = 4

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.MSG_DONTROUTE Field

libsimpleioMSG_DONTROUTE Field

Don't use a gateway to send out the packet, send to hosts only on directly connected networks.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MSG_DONTROUTE = 4

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.MSG_DONTWAIT Field

libsimpleioMSG_DONTWAIT Field

Enables nonblocking operation; if the operation would block, EAGAIN or EWOULDBLOCK is returned.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MSG_DONTWAIT = 64

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.MSG_MORE Field

libsimpleioMSG_MORE Field

The caller has more data to send. This flag informs the kernel to package all of the data sent in calls with this flag set into a single datagram which is transmitted only when a call is performed that does not specify this flag.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MSG_MORE = 32768

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.POLLERR Field

libsimpleioPOLLERR Field

An error occurred.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int POLLERR = 8

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.POLLHUP Field

libsimpleioPOLLHUP Field

Peer closed connection.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int POLLHUP = 16

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.POLLIN Field

libsimpleioPOLLIN Field

There is data to read.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int POLLIN = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.POLLNVAL Field

libsimpleioPOLLNVAL Field

File descriptor is invalid.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int POLLNVAL = 32

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.POLLOUT Field

libsimpleioPOLLOUT Field

Writing is now possible.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int POLLOUT = 4

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.POLLPRI Field

libsimpleioPOLLPRI Field

There is urgent data to read.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int POLLPRI = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.PWM_POLARITY_ACTIVEHIGH Field

libsimpleioPWM_POLARITY_ACTIVEHIGH Field

Configure the PWM output as active high (normal).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int PWM_POLARITY_ACTIVEHIGH = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.PWM_POLARITY_ACTIVELOW Field

libsimpleioPWM_POLARITY_ACTIVELOW Field

Configure the PWM output as active low (inverted).

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int PWM_POLARITY_ACTIVELOW = 0

Field Value

Int32
Remarks
Not all platforms support active low (inverted) PWM outputs.
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_PARITY_EVEN Field

libsimpleioSERIAL_PARITY_EVEN Field

Request even parity checking.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SERIAL_PARITY_EVEN = 1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_PARITY_NONE Field

libsimpleioSERIAL_PARITY_NONE Field

Disable parity checking.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SERIAL_PARITY_NONE = 0

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SERIAL_PARITY_ODD Field

libsimpleioSERIAL_PARITY_ODD Field

Request odd parity checking.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SERIAL_PARITY_ODD = 2

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


libsimpleio.SPI_AUTO_CS Field

libsimpleioSPI_AUTO_CS Field

Use hardware slave select.

Namespace: IO.Bindings
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI_AUTO_CS = -1

Field Value

Int32
See Also

Reference

libsimpleio Class
IO.Bindings Namespace


IO.Devices.A4988 Namespace

A4988 Stepper Motor Controller Services.
Classes
 | Class | Description
Public class | Device | Encapsulates the A4988 Stepper Motor Controller.


Device Class

Encapsulates the A4988 Stepper Motor Controller.
Inheritance Hierarchy
SystemObject
IO.Devices.A4988Device

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Output

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a single A4988 device.
Top
Properties
 | Name | Description
Public property | StepsPerRotation | Read-only property returning the number of steps a stepper motor has.
Top
Methods
 | Name | Description
Public method | Disable | Disable the A4988 device.
Public method | Enable | Enable the A4988 device.
Public method | Move | Move the stepper motor a specified number of steps at a specified rate.
Public method | Reset | Reset the A4988 device.
Public method | Sleep | Put the A4988 device to sleep.
Public method | Spin | Spin (i.e. continuous rotation) the stepper moter at a specified rate.
Public method | Wakeup | Wake up the A4988 device.
Top
See Also

Reference

IO.Devices.A4988 Namespace


Device Constructor

Constructor for a single A4988 device.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    int StepsPerRotation,
    Pin Step,
    Pin Dir,
    Pin Enable = null,
    Pin Reset = null,
    Pin Sleep = null
)

Parameters

StepsPerRotation Int32
The number of steps per rotation. This is a physical characteristic of the particular stepper motor being driven.
Step Pin
GPIO pin object for the STEP signal.
Dir Pin
GPIO pin object for the DIR signal.
Enable Pin (Optional)
GPIO pin object for the -ENABLE signal.
Reset Pin (Optional)
GPIO pin object for the -RESET signal.
Sleep Pin (Optional)
GPIO pin object for the -SLEEP signal.
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | StepsPerRotation | Read-only property returning the number of steps a stepper motor has.
Top
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.StepsPerRotation Property

DeviceStepsPerRotation Property

Read-only property returning the number of steps a stepper motor has.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int StepsPerRotation { get; }

Property Value

Int32

Implements

OutputStepsPerRotation
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Disable | Disable the A4988 device.
Public method | Enable | Enable the A4988 device.
Public method | Move | Move the stepper motor a specified number of steps at a specified rate.
Public method | Reset | Reset the A4988 device.
Public method | Sleep | Put the A4988 device to sleep.
Public method | Spin | Spin (i.e. continuous rotation) the stepper moter at a specified rate.
Public method | Wakeup | Wake up the A4988 device.
Top
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Disable Method

DeviceDisable Method

Disable the A4988 device.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Disable()
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Enable Method

DeviceEnable Method

Enable the A4988 device.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Enable()
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Move Method

DeviceMove Method

Move the stepper motor a specified number of steps at a specified rate.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Move(
    int steps,
    float rate
)

Parameters

steps Int32
Number of steps to move. Negative values indicate reverse motion and positive values indicate forward motion. (The directions are nominal and depend on how the stepper motor coils are wired). Zero indicates the stepper motor should be stopped.
rate Single
The rate of motion, in steps per second. Negative values indicate reverse motion and positive values indicate forward motion. (The directions are nominal and depend on how the stepper motor coils are wired). Zero indicates the stepper motor should be stopped.

Implements

OutputMove(Int32, Single)
Remarks
This implementation supports a maximum rate of 500 steps per second.
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Reset Method

DeviceReset Method

Reset the A4988 device.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Sleep Method

DeviceSleep Method

Put the A4988 device to sleep.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Sleep()
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Spin Method

DeviceSpin Method

Spin (i.e. continuous rotation) the stepper moter at a specified rate.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Spin(
    float rate
)

Parameters

rate Single
The rate of motion, in steps per second. Negative values indicate reverse motion and positive values indicate forward motion. (The directions are nominal and depend on how the stepper motor coils are wired). Zero indicates the stepper motor should be stopped.

Implements

OutputSpin(Single)
Remarks
The A4988 stepper motor driver does not support continuous rotation and this method will always throw an exception.
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


Device.Wakeup Method

DeviceWakeup Method

Wake up the A4988 device.

Namespace: IO.Devices.A4988
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Wakeup()
See Also

Reference

Device Class
IO.Devices.A4988 Namespace


IO.Devices.AD5593R Namespace

AD5593 Analog/Digital I/O Device Services.
Classes
 | Class | Description
Public class | Device | Enscapsulates the AD5593R I2C Analog/Digital I/O device.
Enumerations
 | Enumeration | Description
Public enumeration | PinMode | AD5593R I/O Pin Modes.
Public enumeration | ReferenceMode | ADC5593R ADC and DAC reference settings.


Device Class

Enscapsulates the AD5593R I2C Analog/Digital I/O device.
Inheritance Hierarchy
SystemObject
IO.Devices.AD5593RDevice

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a single AD5593R device.
Top
Properties
 | Name | Description
Public property | ADC_Reference | Write-only property for setting the AD5593R ADC reference mode.
Public property | DAC_Reference | Write-only property for setting the AD5593R DAC reference mode.
Public property | GPIO_Inputs | GPIO input register state. Any I/O pin that is not configured as a GPIO input will read as zero.
Public property | GPIO_Outputs | GPIO output register state. Any I/O pin that is not configured as a GPIO output will be written as zero.
Top
Methods
 | Name | Description
Public method | ADC_Create | Create an AD5593R ADC input object.
Public method | ConfigureChannel | Configure a single ADC5593R I/O pin.
Public method | DAC_Create | Create an AD5593R DAC output object.
Public method | GPIO_Create | Create an AD5593R GPIO pin object.
Public method | Read_ADC | Read from an ADC channel.
Public method | Write_DAC | Write to a DAC channel.
Top
Fields
Name | Description
ADC_Resolution | ADC resolution in bits.
DAC_Resolution | DAC resolution in bits.
MaxChannel | Maximum I/O channel number.
MinChannel | Minimum I/O channel number.
Top
See Also

Reference

IO.Devices.AD5593R Namespace


Device Constructor

Constructor for a single AD5593R device.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    int addr
)

Parameters

bus Bus
I2C bus controller object.
addr Int32
I2C slave address.
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | ADC_Reference | Write-only property for setting the AD5593R ADC reference mode.
Public property | DAC_Reference | Write-only property for setting the AD5593R DAC reference mode.
Public property | GPIO_Inputs | GPIO input register state. Any I/O pin that is not configured as a GPIO input will read as zero.
Public property | GPIO_Outputs | GPIO output register state. Any I/O pin that is not configured as a GPIO output will be written as zero.
Top
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.ADC_Reference Property

DeviceADC_Reference Property

Write-only property for setting the AD5593R ADC reference mode.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public ReferenceMode ADC_Reference { set; }

Property Value

ReferenceMode
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.DAC_Reference Property

DeviceDAC_Reference Property

Write-only property for setting the AD5593R DAC reference mode.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public ReferenceMode DAC_Reference { set; }

Property Value

ReferenceMode
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.GPIO_Inputs Property

DeviceGPIO_Inputs Property

GPIO input register state. Any I/O pin that is not configured as a GPIO input will read as zero.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte GPIO_Inputs { get; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.GPIO_Outputs Property

DeviceGPIO_Outputs Property

GPIO output register state. Any I/O pin that is not configured as a GPIO output will be written as zero.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte GPIO_Outputs { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | ADC_Create | Create an AD5593R ADC input object.
Public method | ConfigureChannel | Configure a single ADC5593R I/O pin.
Public method | DAC_Create | Create an AD5593R DAC output object.
Public method | GPIO_Create | Create an AD5593R GPIO pin object.
Public method | Read_ADC | Read from an ADC channel.
Public method | Write_DAC | Write to a DAC channel.
Top
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.ADC_Create Method

DeviceADC_Create Method

Create an AD5593R ADC input object.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample ADC_Create(
    int channel
)

Parameters

channel Int32
AD5593R ADC channel number (0 to 7).

Return Value

Sample
ADC input object.
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.ConfigureChannel Method

DeviceConfigureChannel Method

Configure a single ADC5593R I/O pin.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void ConfigureChannel(
    int channel,
    PinMode mode
)

Parameters

channel Int32
ADC5593R I/O channel number (0 to 7).
mode PinMode
ADC5593R I/O pin mode.
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.DAC_Create Method

DeviceDAC_Create Method

Create an AD5593R DAC output object.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample DAC_Create(
    int channel,
    int sample = 0
)

Parameters

channel Int32
AD5593R DAC channel number (0 to 7).
sample Int32 (Optional)
Initial DAC output sample.

Return Value

Sample
DAC output object.
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.GPIO_Create Method

DeviceGPIO_Create Method

Create an AD5593R GPIO pin object.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO_Create(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
AD5593R GPIO channel number (0 to 7).
dir Direction
GPIO pin data direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.Read_ADC Method

DeviceRead_ADC Method

Read from an ADC channel.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int Read_ADC(
    int channel
)

Parameters

channel Int32
ADC channel number (0 to 7).

Return Value

Int32
ADC input sample data (0 to 4095).
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.Write_DAC Method

DeviceWrite_DAC Method

Write to a DAC channel.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write_DAC(
    int channel,
    int data
)

Parameters

channel Int32
DAC channel number (0 to 7).
data Int32
DAC output sample data (0 to 4095).
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
ADC_Resolution | ADC resolution in bits.
DAC_Resolution | DAC resolution in bits.
MaxChannel | Maximum I/O channel number.
MinChannel | Minimum I/O channel number.
Top
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.ADC_Resolution Field

DeviceADC_Resolution Field

ADC resolution in bits.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int ADC_Resolution = 12

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.DAC_Resolution Field

DeviceDAC_Resolution Field

DAC resolution in bits.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int DAC_Resolution = 12

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.MaxChannel Field

DeviceMaxChannel Field

Maximum I/O channel number.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MaxChannel = 7

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


Device.MinChannel Field

DeviceMinChannel Field

Minimum I/O channel number.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MinChannel = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.AD5593R Namespace


PinMode Enumeration

AD5593R I/O Pin Modes.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum PinMode
Members
Member name | Value | Description
ADC_Input | 0 | Analog input.
DAC_Output | 1 | Analog output.
GPIO_Input | 2 | GPIO input.
GPIO_Output | 3 | GPIO output.
GPIO_Output_OpenDrain | 4 | GPIO open drain output.
See Also

Reference

IO.Devices.AD5593R Namespace


ReferenceMode Enumeration

ADC5593R ADC and DAC reference settings.

Namespace: IO.Devices.AD5593R
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum ReferenceMode
Members
Member name | Value | Description
Internalx1 | 0 | The reference voltage is 2.5V using the internal reference.
Internalx2 | 1 | The reference voltage is 5.0V using the internal reference.
Externalx1 | 2 | The reference voltage is 1.0*Vref, using an external reference.
Externalx2 | 3 | The reference voltage is 2.0*Vref, using an external reference.
See Also

Reference

IO.Devices.AD5593R Namespace


IO.Devices.AD5593R.ADC Namespace

AD5593 Analog/Digital I/O Device ADC Input Services.
Classes
 | Class | Description
Public class | Sample | Encapsulates AD5593R ADC inputs.


Sample Class

Encapsulates AD5593R ADC inputs.
Inheritance Hierarchy
SystemObject
IO.Devices.AD5593R.ADCSample

Namespace: IO.Devices.AD5593R.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Sample : Sample

The Sample type exposes the following members.

Constructors
 | Name | Description
Public method | Sample | Create an AD5593R ADC input.
Top
Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample value.
Top
See Also

Reference

IO.Devices.AD5593R.ADC Namespace


Sample Constructor

Create an AD5593R ADC input.

Namespace: IO.Devices.AD5593R.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample(
    Device dev,
    int channel
)

Parameters

dev Device
AD5593R device object.
channel Int32
AD5593R I/O channel number (0 to 7).
See Also

Reference

Sample Class
IO.Devices.AD5593R.ADC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample value.
Top
See Also

Reference

Sample Class
IO.Devices.AD5593R.ADC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Devices.AD5593R.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

Sample Class
IO.Devices.AD5593R.ADC Namespace


Sample.sample Property

Samplesample Property

Read-only property returning an integer analog sample value.

Namespace: IO.Devices.AD5593R.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { get; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

Sample Class
IO.Devices.AD5593R.ADC Namespace


IO.Devices.AD5593R.DAC Namespace

AD5593 Analog/Digital I/O Device DAC Output Services.
Classes
 | Class | Description
Public class | Sample | Encapsulates AD5593R DAC outputs.


Sample Class

Encapsulates AD5593R DAC outputs.
Inheritance Hierarchy
SystemObject
IO.Devices.AD5593R.DACSample

Namespace: IO.Devices.AD5593R.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Sample : Sample

The Sample type exposes the following members.

Constructors
 | Name | Description
Public method | Sample | Create an AD5593R DAC output.
Top
Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for writing an integer analog sample to a DAC output.
Top
See Also

Reference

IO.Devices.AD5593R.DAC Namespace


Sample Constructor

Create an AD5593R DAC output.

Namespace: IO.Devices.AD5593R.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample(
    Device dev,
    int channel,
    int sample = 0
)

Parameters

dev Device
AD5593R device object.
channel Int32
AD5593R I/O channel number (0 to 7).
sample Int32 (Optional)
Initial DAC output sample.
See Also

Reference

Sample Class
IO.Devices.AD5593R.DAC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for writing an integer analog sample to a DAC output.
Top
See Also

Reference

Sample Class
IO.Devices.AD5593R.DAC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Devices.AD5593R.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

Sample Class
IO.Devices.AD5593R.DAC Namespace


Sample.sample Property

Samplesample Property

Write-only property for writing an integer analog sample to a DAC output.

Namespace: IO.Devices.AD5593R.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { set; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

Sample Class
IO.Devices.AD5593R.DAC Namespace


IO.Devices.AD5593R.GPIO Namespace

AD5593 Analog/Digital I/O Device GPIO Pin Services.
Classes
 | Class | Description
Public class | Pin | Encapsulates AD5593R GPIO pins.


Pin Class

Encapsulates AD5593R GPIO pins.
Inheritance Hierarchy
SystemObject
IO.Devices.AD5593R.GPIOPin

Namespace: IO.Devices.AD5593R.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Create an AD5593R GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Devices.AD5593R.GPIO Namespace


Pin Constructor

Create an AD5593R GPIO pin.

Namespace: IO.Devices.AD5593R.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int channel,
    Direction dir,
    bool state = false
)

Parameters

dev Device
AD5593R device object.
channel Int32
AD5593R I/O channel number (0 to 7).
dir Direction
GPIO pin data direction.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.AD5593R.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Devices.AD5593R.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Devices.AD5593R.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.AD5593R.GPIO Namespace


IO.Devices.ADC121C021 Namespace

ADC121C021 I2C A/D Converter Services
Classes
 | Class | Description
Public class | Sample | Encapsulates the ADC121C021 I2C A/D converter.


Sample Class

Encapsulates the ADC121C021 I2C A/D converter.
Inheritance Hierarchy
SystemObject
IO.Devices.ADC121C021Sample

Namespace: IO.Devices.ADC121C021
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Sample : Sample

The Sample type exposes the following members.

Constructors
 | Name | Description
Public method | Sample | Constructor for an ADC121C021 analog input.
Top
Properties
 | Name | Description
Public property | resolution | Return the number of bits of A/D resolution.
Public property | sample | Returns a single 12-bit analog sample.
Top
See Also

Reference

IO.Devices.ADC121C021 Namespace


Sample Constructor

Constructor for an ADC121C021 analog input.

Namespace: IO.Devices.ADC121C021
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample(
    Bus bus,
    byte addr
)

Parameters

bus Bus
I2C bus controller.
addr Byte
I2C slave address.
See Also

Reference

Sample Class
IO.Devices.ADC121C021 Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Return the number of bits of A/D resolution.
Public property | sample | Returns a single 12-bit analog sample.
Top
See Also

Reference

Sample Class
IO.Devices.ADC121C021 Namespace


Sample.resolution Property

Sampleresolution Property

Return the number of bits of A/D resolution.

Namespace: IO.Devices.ADC121C021
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

Sample Class
IO.Devices.ADC121C021 Namespace


Sample.sample Property

Samplesample Property

Returns a single 12-bit analog sample.

Namespace: IO.Devices.ADC121C021
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { get; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

Sample Class
IO.Devices.ADC121C021 Namespace


IO.Devices.ClickBoards.RemoteIO.ADAC Namespace

Mikroelektronika ADAC Click MIKROE-2690 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika ADAC Click Board. MIKROE-2690.


Board Class

Encapsulates the Mikroelektronika ADAC Click Board. MIKROE-2690.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.RemoteIO.ADACBoard

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single ADAC click.
Top
Properties
 | Name | Description
Public property | device | Returns the underlying AD5593R device object.
Top
Methods
 | Name | Description
Public method | ADC | Factory function for creating ADC inputs.
Public method | DAC | Factory function for creating DAC outputs.
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the AD5593R.
Top
Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board Constructor

Constructor for a single ADAC click.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    int addr = 16,
    Device remdev = null
)

Parameters

socknum Int32
mikroBUS socket number.
addr Int32 (Optional)
I2C slave address.
remdev Device (Optional)
Remote I/O server device object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | device | Returns the underlying AD5593R device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board.device Property

Boarddevice Property

Returns the underlying AD5593R device object.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device device { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | ADC | Factory function for creating ADC inputs.
Public method | DAC | Factory function for creating DAC outputs.
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the AD5593R.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board.ADC Method

BoardADC Method

Factory function for creating ADC inputs.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample ADC(
    int channel
)

Parameters

channel Int32
AD5593R I/O channel number (0 to 7).

Return Value

Sample
ADC input object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board.DAC Method

BoardDAC Method

Factory function for creating DAC outputs.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample DAC(
    int channel,
    int sample = 0
)

Parameters

channel Int32
AD5593R I/O channel number (0 to 7).
sample Int32 (Optional)
Initial DAC output sample.

Return Value

Sample
DAC output object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO pins.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
AD5593R I/O channel number (0 to 7).
dir Direction
GPIO pin direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the AD5593R.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board Fields

The Board type exposes the following members.

Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


Board.DefaultAddress Field

BoardDefaultAddress Field

Default I2C slave address.

Namespace: IO.Devices.ClickBoards.RemoteIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte DefaultAddress = 16

Field Value

Byte
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.ADAC Namespace


IO.Devices.ClickBoards.RemoteIO.Expand Namespace

Mikroelektronika Expand Click MIKROE-951 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika Expand Click Board.


Board Class

Encapsulates the Mikroelektronika Expand Click Board.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.RemoteIO.ExpandBoard

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single Expand click.
Top
Properties
 | Name | Description
Public property | device | Returns the underlying MCP23S17 device object.
Top
Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23S17.
Top
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.Expand Namespace


Board Constructor

Constructor for a single Expand click.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    Device remdev = null
)

Parameters

socknum Int32
mikroBUS socket number.
remdev Device (Optional)
Remote I/O server device object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | device | Returns the underlying MCP23S17 device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand Namespace


Board.device Property

Boarddevice Property

Returns the underlying MCP23S17 device object.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device device { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23S17.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO pins.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
MCP23S17 channel number (0 to 15).
dir Direction
GPIO pin direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the MCP23S17.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand Namespace


IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace

Mikroelektronika Expand 2 Click MIKROE-1838 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika Expand 2 Click Board.


Board Class

Encapsulates the Mikroelektronika Expand 2 Click Board.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.RemoteIO.Expand2Board

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single Expand 2 click.
Top
Properties
 | Name | Description
Public property | device | Returns the underlying MCP23017 device object.
Top
Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23017.
Top
Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board Constructor

Constructor for a single Expand 2 click.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    int addr = 32,
    Device remdev = null
)

Parameters

socknum Int32
mikroBUS socket number.
addr Int32 (Optional)
I2C slave address.
remdev Device (Optional)
Remote I/O server device object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | device | Returns the underlying MCP23017 device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board.device Property

Boarddevice Property

Returns the underlying MCP23017 device object.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device device { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23017.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO pins.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
MCP23017 channel number (0 to 15).
dir Direction
GPIO pin direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the MCP23017.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board Fields

The Board type exposes the following members.

Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


Board.DefaultAddress Field

BoardDefaultAddress Field

Default I2C slave address.

Namespace: IO.Devices.ClickBoards.RemoteIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int DefaultAddress = 32

Field Value

Int32
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.Expand2 Namespace


IO.Devices.ClickBoards.RemoteIO.PWM Namespace

Mikroelektronika PWM Click MIKROE-1898 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika PWM Click Board. MIKROE-1898.


Board Class

Encapsulates the Mikroelektronika PWM Click Board. MIKROE-1898.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.RemoteIO.PWMBoard

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single PWM click.
Top
Properties
 | Name | Description
Public property | dev | Returns the underlying PCA9685 device object.
Top
Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO output pins.
Public method | PWM | Factory function for creating PWM outputs.
Public method | Servo | Factory function for creating servo outputs.
Top
Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board Constructor

Constructor for a single PWM click.

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    int freq,
    int addr = 64,
    Device remdev = null
)

Parameters

socknum Int32
mikroBUS socket number.
freq Int32
PWM pulse frequency in Hz.
addr Int32 (Optional)
I2C slave address.
remdev Device (Optional)
Remote I/O device object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | dev | Returns the underlying PCA9685 device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board.dev Property

Boarddev Property

Returns the underlying PCA9685 device object.

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device dev { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO output pins.
Public method | PWM | Factory function for creating PWM outputs.
Public method | Servo | Factory function for creating servo outputs.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO output pins.

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    bool state = false
)

Parameters

channel Int32
PCA9685 output channel number.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO output pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board.PWM Method

BoardPWM Method

Factory function for creating PWM outputs.

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output PWM(
    int channel,
    double dutycycle = 0
)

Parameters

channel Int32
PCA9685 output channel number.
dutycycle Double (Optional)
Initial PWM output duty cycle.

Return Value

Output
PWM output object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board.Servo Method

BoardServo Method

Factory function for creating servo outputs.

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output Servo(
    int channel,
    double position = 0
)

Parameters

channel Int32
PCA9685 output channel number.
position Double (Optional)
Initial servo position.>

Return Value

Output
Servo output object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board Fields

The Board type exposes the following members.

Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


Board.DefaultAddress Field

BoardDefaultAddress Field

Default I2C slave address.

Namespace: IO.Devices.ClickBoards.RemoteIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte DefaultAddress = 64

Field Value

Byte
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.PWM Namespace


IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace

Mikroelektronika 7Seg Click MIKROE-1201 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika 7Seg Click Board. MIKROE-1201.
Enumerations
 | Enumeration | Description
Public enumeration | BoardBase | Numeral systems.
Public enumeration | BoardZeroBlanking | Zero blanking modes.


Board Class

Encapsulates the Mikroelektronika 7Seg Click Board. MIKROE-1201.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.RemoteIO.SevenSegmentBoard

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single 7seg click.
Top
Properties
 | Name | Description
Public property | blanking | Zero blanking mode. Allowed values are None, Leading, and Full.
Public property | brightness | Write-only property for setting the brightness of the display. Allowed values are 0.0 to 100.0 percent.
Public property | leftdp | Write-only property for setting the left digit decimal point.
Public property | radix | Numerical base or radix. Allowed values are Decimal and Hexadecimal.
Public property | rightdp | Write-only property for setting the right digit decimal point.
Public property | state | Write-only property for setting the state of the display. Allowed values are 0 to 99 for decimal mode and 0 to 255 for hexadecimal mode.
Top
Methods
 | Name | Description
Public method | Clear | Clear the display.
Public method | Reset | Issue hardware reset to the 74HC595 shift register chain.
Top
Remarks
The MISO aka SDI pin should be removed from the 7seg click, because it is not tri-state and will interfere with other devices on the same SPI bus.
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board Constructor

Constructor for a single 7seg click.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socket,
    BoardBase radix = BoardBase.Decimal,
    BoardZeroBlanking blanking = BoardZeroBlanking.None,
    int pwmfreq = 100,
    Device remdev = null
)

Parameters

socket Int32
mikroBUS socket number.
radix BoardBase (Optional)
Numerical base or radix. Allowed values are Decimal and Hexadecimal.
blanking BoardZeroBlanking (Optional)
Zero blanking. Allowed values are None, Leading, and Full.
pwmfreq Int32 (Optional)
PWM frequency. Set to zero to use GPIO instead of PWM.
remdev Device (Optional)
Remote I/O server device object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | blanking | Zero blanking mode. Allowed values are None, Leading, and Full.
Public property | brightness | Write-only property for setting the brightness of the display. Allowed values are 0.0 to 100.0 percent.
Public property | leftdp | Write-only property for setting the left digit decimal point.
Public property | radix | Numerical base or radix. Allowed values are Decimal and Hexadecimal.
Public property | rightdp | Write-only property for setting the right digit decimal point.
Public property | state | Write-only property for setting the state of the display. Allowed values are 0 to 99 for decimal mode and 0 to 255 for hexadecimal mode.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.blanking Property

Boardblanking Property

Zero blanking mode. Allowed values are None, Leading, and Full.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public BoardZeroBlanking blanking { get; set; }

Property Value

BoardZeroBlanking
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.brightness Property

Boardbrightness Property

Write-only property for setting the brightness of the display. Allowed values are 0.0 to 100.0 percent.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double brightness { set; }

Property Value

Double
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.leftdp Property

Boardleftdp Property

Write-only property for setting the left digit decimal point.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool leftdp { set; }

Property Value

Boolean
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.radix Property

Boardradix Property

Numerical base or radix. Allowed values are Decimal and Hexadecimal.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public BoardBase radix { get; set; }

Property Value

BoardBase
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.rightdp Property

Boardrightdp Property

Write-only property for setting the right digit decimal point.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool rightdp { set; }

Property Value

Boolean
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.state Property

Boardstate Property

Write-only property for setting the state of the display. Allowed values are 0 to 99 for decimal mode and 0 to 255 for hexadecimal mode.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int state { set; }

Property Value

Int32
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the display.
Public method | Reset | Issue hardware reset to the 74HC595 shift register chain.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.Clear Method

BoardClear Method

Clear the display.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Clear()
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the 74HC595 shift register chain.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.Base Enumeration

BoardBase Enumeration

Numeral systems.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Base
Members
Member name | Value | Description
Decimal | 0 | Base 10.
Hexadecimal | 1 | Base 16.
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


Board.ZeroBlanking Enumeration

BoardZeroBlanking Enumeration

Zero blanking modes.

Namespace: IO.Devices.ClickBoards.RemoteIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum ZeroBlanking
Members
Member name | Value | Description
None | 0 | No zero blanking.
Leading | 1 | Leading zero blanking.
Full | 2 | Full zero blanking.
See Also

Reference

IO.Devices.ClickBoards.RemoteIO.SevenSegment Namespace


IO.Devices.ClickBoards.SimpleIO.ADAC Namespace

Mikroelektronika ADAC Click MIKROE-2690 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika ADAC Click Board. MIKROE-2690.


Board Class

Encapsulates the Mikroelektronika ADAC Click Board. MIKROE-2690.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.SimpleIO.ADACBoard

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single ADAC click.
Top
Properties
 | Name | Description
Public property | device | Returns the underlying AD5593R device object.
Top
Methods
 | Name | Description
Public method | ADC | Factory function for creating ADC inputs.
Public method | DAC | Factory function for creating DAC outputs.
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the AD5593R.
Top
Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board Constructor

Constructor for a single ADAC click.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    int addr = 16
)

Parameters

socknum Int32
mikroBUS socket number.
addr Int32 (Optional)
I2C slave address.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | device | Returns the underlying AD5593R device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board.device Property

Boarddevice Property

Returns the underlying AD5593R device object.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device device { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | ADC | Factory function for creating ADC inputs.
Public method | DAC | Factory function for creating DAC outputs.
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the AD5593R.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board.ADC Method

BoardADC Method

Factory function for creating ADC inputs.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample ADC(
    int channel
)

Parameters

channel Int32
AD5593R I/O channel number (0 to 7).

Return Value

Sample
ADC input object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board.DAC Method

BoardDAC Method

Factory function for creating DAC outputs.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample DAC(
    int channel,
    int sample = 0
)

Parameters

channel Int32
AD5593R I/O channel number (0 to 7).
sample Int32 (Optional)
Initial DAC output sample.

Return Value

Sample
DAC output object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO pins.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
AD5593R I/O channel number (0 to 7).
dir Direction
GPIO pin direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the AD5593R.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board Fields

The Board type exposes the following members.

Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


Board.DefaultAddress Field

BoardDefaultAddress Field

Default I2C slave address.

Namespace: IO.Devices.ClickBoards.SimpleIO.ADAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte DefaultAddress = 16

Field Value

Byte
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.ADAC Namespace


IO.Devices.ClickBoards.SimpleIO.Expand Namespace

Mikroelektronika Expand Click MIKROE-951 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika Expand Click Board.


Board Class

Encapsulates the Mikroelektronika Expand Click Board.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.SimpleIO.ExpandBoard

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single Expand 2 click.
Top
Properties
 | Name | Description
Public property | device | Returns the underlying MCP23S17 device object.
Top
Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23S17.
Top
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.Expand Namespace


Board Constructor

Constructor for a single Expand 2 click.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum
)

Parameters

socknum Int32
mikroBUS socket number.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | device | Returns the underlying MCP23S17 device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand Namespace


Board.device Property

Boarddevice Property

Returns the underlying MCP23S17 device object.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device device { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23S17.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO pins.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
MCP23S17 channel number (0 to 15).
dir Direction
GPIO pin direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the MCP23S17.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand Namespace


IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace

Mikroelektronika Expand 2 Click MIKROE-1838 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika Expand 2 Click Board.


Board Class

Encapsulates the Mikroelektronika Expand 2 Click Board.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.SimpleIO.Expand2Board

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single Expand 2 click.
Top
Properties
 | Name | Description
Public property | device | Returns the underlying MCP23017 device object.
Top
Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23017.
Top
Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board Constructor

Constructor for a single Expand 2 click.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    int addr = 32
)

Parameters

socknum Int32
mikroBUS socket number.
addr Int32 (Optional)
I2C slave address.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | device | Returns the underlying MCP23017 device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board.device Property

Boarddevice Property

Returns the underlying MCP23017 device object.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device device { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO pins.
Public method | Reset | Issue hardware reset to the MCP23017.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO pins.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
MCP23017 channel number (0 to 15).
dir Direction
GPIO pin direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the MCP23017.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board Fields

The Board type exposes the following members.

Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


Board.DefaultAddress Field

BoardDefaultAddress Field

Default I2C slave address.

Namespace: IO.Devices.ClickBoards.SimpleIO.Expand2
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int DefaultAddress = 32

Field Value

Int32
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.Expand2 Namespace


IO.Devices.ClickBoards.SimpleIO.PWM Namespace

Mikroelektronika PWM Click MIKROE-1898 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika PWM Click Board. MIKROE-1898.


Board Class

Encapsulates the Mikroelektronika PWM Click Board. MIKROE-1898.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.SimpleIO.PWMBoard

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single PWM click.
Top
Properties
 | Name | Description
Public property | dev | Returns the underlying PCA9685 device object.
Top
Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO output pins.
Public method | PWM | Factory function for creating PWM outputs.
Public method | Servo | Factory function for creating servo outputs.
Top
Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board Constructor

Constructor for a single PWM click.

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socknum,
    int freq,
    int addr = 64
)

Parameters

socknum Int32
mikroBUS socket number.
freq Int32
PWM pulse frequency in Hz.
addr Int32 (Optional)
I2C slave address.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | dev | Returns the underlying PCA9685 device object.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board.dev Property

Boarddev Property

Returns the underlying PCA9685 device object.

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device dev { get; }

Property Value

Device
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | GPIO | Factory function for creating GPIO output pins.
Public method | PWM | Factory function for creating PWM outputs.
Public method | Servo | Factory function for creating servo outputs.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board.GPIO Method

BoardGPIO Method

Factory function for creating GPIO output pins.

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO(
    int channel,
    bool state = false
)

Parameters

channel Int32
PCA9685 output channel number.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO output pin object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board.PWM Method

BoardPWM Method

Factory function for creating PWM outputs.

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output PWM(
    int channel,
    double dutycycle = 0
)

Parameters

channel Int32
PCA9685 output channel number.
dutycycle Double (Optional)
Initial PWM output duty cycle.

Return Value

Output
PWM output object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board.Servo Method

BoardServo Method

Factory function for creating servo outputs.

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output Servo(
    int channel,
    double position = 0
)

Parameters

channel Int32
PCA9685 output channel number.
position Double (Optional)
Initial servo position.>

Return Value

Output
Servo output object.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board Fields

The Board type exposes the following members.

Fields
Name | Description
DefaultAddress | Default I2C slave address.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


Board.DefaultAddress Field

BoardDefaultAddress Field

Default I2C slave address.

Namespace: IO.Devices.ClickBoards.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte DefaultAddress = 64

Field Value

Byte
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.PWM Namespace


IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace

Mikroelektronika 7Seg Click MIKROE-1201 Services
Classes
 | Class | Description
Public class | Board | Encapsulates the Mikroelektronika 7Seg Click Board. MIKROE-1201.
Enumerations
 | Enumeration | Description
Public enumeration | BoardBase | Numeral systems.
Public enumeration | BoardZeroBlanking | Zero blanking modes.


Board Class

Encapsulates the Mikroelektronika 7Seg Click Board. MIKROE-1201.
Inheritance Hierarchy
SystemObject
IO.Devices.ClickBoards.SimpleIO.SevenSegmentBoard

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Board

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor for a single 7seg click.
Top
Properties
 | Name | Description
Public property | blanking | Zero blanking mode. Allowed values are None, Leading, and Full.
Public property | brightness | Write-only property for setting the brightness of the display. Allowed values are 0.0 to 100.0 percent.
Public property | leftdp | Write-only property for setting the left digit decimal point.
Public property | radix | Numerical base or radix. Allowed values are Decimal and Hexadecimal.
Public property | rightdp | Write-only property for setting the right digit decimal point.
Public property | state | Write-only property for setting the state of the display. Allowed values are 0 to 99 for decimal mode and 0 to 255 for hexadecimal mode.
Top
Methods
 | Name | Description
Public method | Clear | Clear the display.
Public method | Reset | Issue hardware reset to the 74HC595 shift register chain.
Top
Remarks
The MISO aka SDI pin should be removed from the 7seg click, because it is not tri-state and will interfere with other devices on the same SPI bus.
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board Constructor

Constructor for a single 7seg click.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Board(
    int socket,
    BoardBase radix = BoardBase.Decimal,
    BoardZeroBlanking blanking = BoardZeroBlanking.None,
    int pwmfreq = 100
)

Parameters

socket Int32
mikroBUS socket number.
radix BoardBase (Optional)
Numerical base or radix. Allowed values are Decimal and Hexadecimal.
blanking BoardZeroBlanking (Optional)
Zero blanking. Allowed values are None, Leading, and Full.
pwmfreq Int32 (Optional)
PWM frequency. Set to zero to use GPIO instead of PWM.
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | blanking | Zero blanking mode. Allowed values are None, Leading, and Full.
Public property | brightness | Write-only property for setting the brightness of the display. Allowed values are 0.0 to 100.0 percent.
Public property | leftdp | Write-only property for setting the left digit decimal point.
Public property | radix | Numerical base or radix. Allowed values are Decimal and Hexadecimal.
Public property | rightdp | Write-only property for setting the right digit decimal point.
Public property | state | Write-only property for setting the state of the display. Allowed values are 0 to 99 for decimal mode and 0 to 255 for hexadecimal mode.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.blanking Property

Boardblanking Property

Zero blanking mode. Allowed values are None, Leading, and Full.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public BoardZeroBlanking blanking { get; set; }

Property Value

BoardZeroBlanking
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.brightness Property

Boardbrightness Property

Write-only property for setting the brightness of the display. Allowed values are 0.0 to 100.0 percent.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double brightness { set; }

Property Value

Double
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.leftdp Property

Boardleftdp Property

Write-only property for setting the left digit decimal point.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool leftdp { set; }

Property Value

Boolean
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.radix Property

Boardradix Property

Numerical base or radix. Allowed values are Decimal and Hexadecimal.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public BoardBase radix { get; set; }

Property Value

BoardBase
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.rightdp Property

Boardrightdp Property

Write-only property for setting the right digit decimal point.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool rightdp { set; }

Property Value

Boolean
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.state Property

Boardstate Property

Write-only property for setting the state of the display. Allowed values are 0 to 99 for decimal mode and 0 to 255 for hexadecimal mode.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int state { set; }

Property Value

Int32
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the display.
Public method | Reset | Issue hardware reset to the 74HC595 shift register chain.
Top
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.Clear Method

BoardClear Method

Clear the display.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Clear()
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.Reset Method

BoardReset Method

Issue hardware reset to the 74HC595 shift register chain.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Reset()
See Also

Reference

Board Class
IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.Base Enumeration

BoardBase Enumeration

Numeral systems.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Base
Members
Member name | Value | Description
Decimal | 0 | Base 10.
Hexadecimal | 1 | Base 16.
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


Board.ZeroBlanking Enumeration

BoardZeroBlanking Enumeration

Zero blanking modes.

Namespace: IO.Devices.ClickBoards.SimpleIO.SevenSegment
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum ZeroBlanking
Members
Member name | Value | Description
None | 0 | No zero blanking.
Leading | 1 | Leading zero blanking.
Full | 2 | Full zero blanking.
See Also

Reference

IO.Devices.ClickBoards.SimpleIO.SevenSegment Namespace


IO.Devices.Grove.ADC Namespace

Seeed Studio Grove I2C ADC (ADC121C021) Services
Classes
 | Class | Description
Public class | Device | Encapsulates the Seeed Studio Grove I2C ADC (ADC121C021).


Device Class

Encapsulates the Seeed Studio Grove I2C ADC (ADC121C021).
Inheritance Hierarchy
SystemObject
IO.Devices.Grove.ADCDevice

Namespace: IO.Devices.Grove.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a Seeed Studio Grove I2C ADC (ADC121C021).
Top
Properties
 | Name | Description
Public property | voltage | Read-only property returning an analog input voltage measurement.
Top
See Also

Reference

IO.Devices.Grove.ADC Namespace


Device Constructor

Constructor for a Seeed Studio Grove I2C ADC (ADC121C021).

Namespace: IO.Devices.Grove.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    byte addr = 80
)

Parameters

bus Bus
I2C bus object.
addr Byte (Optional)
I2C device address.
See Also

Reference

Device Class
IO.Devices.Grove.ADC Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning an analog input voltage measurement.
Top
See Also

Reference

Device Class
IO.Devices.Grove.ADC Namespace


Device.voltage Property

Devicevoltage Property

Read-only property returning an analog input voltage measurement.

Namespace: IO.Devices.Grove.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double voltage { get; }

Property Value

Double
See Also

Reference

Device Class
IO.Devices.Grove.ADC Namespace


IO.Devices.Grove.Temperature Namespace

Seeed Studio Grove Temperature Sensor (thermistor) Services
Classes
 | Class | Description
Public class | Device | Encapsulates the Seeed Studio Grove Temperature Sensor (thermistor).


Device Class

Encapsulates the Seeed Studio Grove Temperature Sensor (thermistor).
Inheritance Hierarchy
SystemObject
IO.Devices.Grove.TemperatureDevice

Namespace: IO.Devices.Grove.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Sensor

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a Seeed Studio Grove Temperature Sensor (thermistor).
Top
Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Top
See Also

Reference

IO.Devices.Grove.Temperature Namespace


Device Constructor

Constructor for a Seeed Studio Grove Temperature Sensor (thermistor).

Namespace: IO.Devices.Grove.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Voltage Vin,
    double Vcc = 3.3
)

Parameters

Vin Voltage
Voltage input object.
Vcc Double (Optional)
Reference voltage.
See Also

Reference

Device Class
IO.Devices.Grove.Temperature Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Top
See Also

Reference

Device Class
IO.Devices.Grove.Temperature Namespace


Device.Celsius Property

DeviceCelsius Property

Read-only property returning the temperature in degrees Celsius.

Namespace: IO.Devices.Grove.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Celsius { get; }

Property Value

Double

Implements

SensorCelsius
See Also

Reference

Device Class
IO.Devices.Grove.Temperature Namespace


Device.Fahrenheit Property

DeviceFahrenheit Property

Read-only property returning the temperature in degrees Fahrenheit.

Namespace: IO.Devices.Grove.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Fahrenheit { get; }

Property Value

Double

Implements

SensorFahrenheit
See Also

Reference

Device Class
IO.Devices.Grove.Temperature Namespace


Device.Kelvins Property

DeviceKelvins Property

Read-only property returning the temperature in Kelvins.

Namespace: IO.Devices.Grove.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Kelvins { get; }

Property Value

Double

Implements

SensorKelvins
See Also

Reference

Device Class
IO.Devices.Grove.Temperature Namespace


IO.Devices.Grove.Temperature_Humidity Namespace

Seeed Studio Grove Temperature and Humdity Sensor (TH02) Services.
Classes
 | Class | Description
Public class | Device | Encapsulate the Seeed Studio Grove Temperature and Humidity Sensor (TH02).


Device Class

Encapsulate the Seeed Studio Grove Temperature and Humidity Sensor (TH02).
Inheritance Hierarchy
SystemObject
IO.Devices.TH02Device
IO.Devices.Grove.Temperature_HumidityDevice

Namespace: IO.Devices.Grove.Temperature_Humidity
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a Seeed Studio Grove Temperature and Humidity Sensor (TH02).
Top
Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius. (Inherited from Device)
Public property | DeviceID | Read-only property returning the device ID. (Inherited from Device)
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit. (Inherited from Device)
Public property | Humidity | Read-only property returning the percentage relative humidity. (Inherited from Device)
Public property | Kelvins | Read-only property returning the temperature in Kelvins. (Inherited from Device)
Top
See Also

Reference

IO.Devices.Grove.Temperature_Humidity Namespace


Device Constructor

Constructor for a Seeed Studio Grove Temperature and Humidity Sensor (TH02).

Namespace: IO.Devices.Grove.Temperature_Humidity
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus
)

Parameters

bus Bus
I2 bus object.
See Also

Reference

Device Class
IO.Devices.Grove.Temperature_Humidity Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius. (Inherited from Device)
Public property | DeviceID | Read-only property returning the device ID. (Inherited from Device)
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit. (Inherited from Device)
Public property | Humidity | Read-only property returning the percentage relative humidity. (Inherited from Device)
Public property | Kelvins | Read-only property returning the temperature in Kelvins. (Inherited from Device)
Top
See Also

Reference

Device Class
IO.Devices.Grove.Temperature_Humidity Namespace


IO.Devices.HDC1080 Namespace

HDC1080 I2C Temperature/Humidity Sensor Services
Classes
 | Class | Description
Public class | Device | Encapsulates the HDC1080 temperature and humidity sensor.


Device Class

Encapsulates the HDC1080 temperature and humidity sensor.
Inheritance Hierarchy
SystemObject
IO.Devices.HDC1080Device
IO.Devices.Pmod.HYGRODevice

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Sensor, Sensor

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for an HDC1080 temperature and humidity sensor object.
Top
Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | DeviceID | Read-only property returning the device ID.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Humidity | Read-only property returning the percentage relative humidity.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Public property | ManufacturerID | Read-only property returning the manufacturer ID.
Top
Methods
 | Name | Description
Public method | Read | Read from an HDC1080 device register.
Public method | Write | Write to an HDC1080 device register.
Top
Fields
Name | Description
RegConfiguration | Configuration Register address.
RegDeviceID | Device ID Register address.
RegHumidity | Humidity Register address.
RegManufacturerID | Manufacturer ID Register address.
RegSerialNumberFirst | Serial Number First Bits Register address.
RegSerialNumberLast | Serial Number Last Bits Register address.
RegSerialNumberMid | Serial Number Middle Bits Register address.
RegTemperature | Temperature Register address.
Top
See Also

Reference

IO.Devices.HDC1080 Namespace


Device Constructor

Constructor for an HDC1080 temperature and humidity sensor object.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus
)

Parameters

bus Bus
I2C bus controller.
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | DeviceID | Read-only property returning the device ID.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Humidity | Read-only property returning the percentage relative humidity.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Public property | ManufacturerID | Read-only property returning the manufacturer ID.
Top
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.Celsius Property

DeviceCelsius Property

Read-only property returning the temperature in degrees Celsius.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Celsius { get; }

Property Value

Double

Implements

SensorCelsius
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.DeviceID Property

DeviceDeviceID Property

Read-only property returning the device ID.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public ushort DeviceID { get; }

Property Value

UInt16
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.Fahrenheit Property

DeviceFahrenheit Property

Read-only property returning the temperature in degrees Fahrenheit.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Fahrenheit { get; }

Property Value

Double

Implements

SensorFahrenheit
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.Humidity Property

DeviceHumidity Property

Read-only property returning the percentage relative humidity.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Humidity { get; }

Property Value

Double

Implements

SensorHumidity
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.Kelvins Property

DeviceKelvins Property

Read-only property returning the temperature in Kelvins.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Kelvins { get; }

Property Value

Double

Implements

SensorKelvins
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.ManufacturerID Property

DeviceManufacturerID Property

Read-only property returning the manufacturer ID.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public ushort ManufacturerID { get; }

Property Value

UInt16
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read from an HDC1080 device register.
Public method | Write | Write to an HDC1080 device register.
Top
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.Read Method

DeviceRead Method

Read from an HDC1080 device register.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public ushort Read(
    byte reg
)

Parameters

reg Byte
8-bit register address.

Return Value

UInt16
16-bit register data
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.Write Method

DeviceWrite Method

Write to an HDC1080 device register.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte reg,
    ushort data
)

Parameters

reg Byte
8-bit register address.
data UInt16
16-bit register data.
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
RegConfiguration | Configuration Register address.
RegDeviceID | Device ID Register address.
RegHumidity | Humidity Register address.
RegManufacturerID | Manufacturer ID Register address.
RegSerialNumberFirst | Serial Number First Bits Register address.
RegSerialNumberLast | Serial Number Last Bits Register address.
RegSerialNumberMid | Serial Number Middle Bits Register address.
RegTemperature | Temperature Register address.
Top
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegConfiguration Field

DeviceRegConfiguration Field

Configuration Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegConfiguration = 2

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegDeviceID Field

DeviceRegDeviceID Field

Device ID Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegDeviceID = 255

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegHumidity Field

DeviceRegHumidity Field

Humidity Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegHumidity = 1

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegManufacturerID Field

DeviceRegManufacturerID Field

Manufacturer ID Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegManufacturerID = 254

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegSerialNumberFirst Field

DeviceRegSerialNumberFirst Field

Serial Number First Bits Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegSerialNumberFirst = 251

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegSerialNumberLast Field

DeviceRegSerialNumberLast Field

Serial Number Last Bits Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegSerialNumberLast = 253

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegSerialNumberMid Field

DeviceRegSerialNumberMid Field

Serial Number Middle Bits Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegSerialNumberMid = 252

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


Device.RegTemperature Field

DeviceRegTemperature Field

Temperature Register address.

Namespace: IO.Devices.HDC1080
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte RegTemperature = 0

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.HDC1080 Namespace


IO.Devices.MCP23017 Namespace

MCP23017 I2C GPIO Expander Device Services.
Classes
 | Class | Description
Public class | Device | Encapsulates the MCP23017 I2C I/O GPIO Expander.


Device Class

Encapsulates the MCP23017 I2C I/O GPIO Expander.
Inheritance Hierarchy
SystemObject
IO.Devices.MCP23017Device

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a single MCP23017 device.
Top
Properties
 | Name | Description
Public property | Direction | Data Direction Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | DirectionA | Port A Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | DirectionB | Port B Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | Polarity | Data Polarity Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | PolarityA | Port A Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | PolarityB | Port B Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | Port | Port Data Property (16 bites). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B.
Public property | PortA | Port A Data Property (8 bits).
Public property | PortB | Port B Data Property (8 bits).
Public property | Pullups | Input Pullup Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsA | Port A Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsB | Port B Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Top
Methods
 | Name | Description
Public method | GPIO_Create | Create an MCP23017 GPIO pin object.
Top
Fields
Name | Description
MaxChannel | Maximum I/O channel number.
MinChannel | Minimum I/O channel number.
Top
See Also

Reference

IO.Devices.MCP23017 Namespace


Device Constructor

Constructor for a single MCP23017 device.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    int addr
)

Parameters

bus Bus
I2C bus controller object.
addr Int32
I2C slave address.
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Data Direction Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | DirectionA | Port A Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | DirectionB | Port B Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | Polarity | Data Polarity Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | PolarityA | Port A Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | PolarityB | Port B Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | Port | Port Data Property (16 bites). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B.
Public property | PortA | Port A Data Property (8 bits).
Public property | PortB | Port B Data Property (8 bits).
Public property | Pullups | Input Pullup Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsA | Port A Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsB | Port B Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Top
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.Direction Property

DeviceDirection Property

Data Direction Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Direction { get; set; }

Property Value

UInt32
Remarks
This property follows the industry standard convention for data direction bit polarity (1=output) rather than the MCP23017 IODIR register polarity (0=output).
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.DirectionA Property

DeviceDirectionA Property

Port A Data Direction Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte DirectionA { get; set; }

Property Value

Byte
Remarks
This property follows the industry standard convention for data direction bit polarity (1=output) rather than the MCP23017 IODIRA register polarity (0=output).
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.DirectionB Property

DeviceDirectionB Property

Port B Data Direction Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte DirectionB { get; set; }

Property Value

Byte
Remarks
This property follows the industry standard convention for data direction bit polarity (1=output) rather than the MCP23017 IODIRA register polarity (0=output).
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.Polarity Property

DevicePolarity Property

Data Polarity Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Polarity { get; set; }

Property Value

UInt32
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.PolarityA Property

DevicePolarityA Property

Port A Data Polarity Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PolarityA { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.PolarityB Property

DevicePolarityB Property

Port B Data Polarity Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PolarityB { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.Port Property

DevicePort Property

Port Data Property (16 bites). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Port { get; set; }

Property Value

UInt32
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.PortA Property

DevicePortA Property

Port A Data Property (8 bits).

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PortA { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.PortB Property

DevicePortB Property

Port B Data Property (8 bits).

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PortB { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.Pullups Property

DevicePullups Property

Input Pullup Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=high impedance and 1=100k pullup.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Pullups { get; set; }

Property Value

UInt32
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.PullupsA Property

DevicePullupsA Property

Port A Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PullupsA { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.PullupsB Property

DevicePullupsB Property

Port B Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PullupsB { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | GPIO_Create | Create an MCP23017 GPIO pin object.
Top
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.GPIO_Create Method

DeviceGPIO_Create Method

Create an MCP23017 GPIO pin object.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO_Create(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
MCP23017 channel number (0 to 15).
dir Direction
GPIO pin data direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
MaxChannel | Maximum I/O channel number.
MinChannel | Minimum I/O channel number.
Top
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.MaxChannel Field

DeviceMaxChannel Field

Maximum I/O channel number.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MaxChannel = 15

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


Device.MinChannel Field

DeviceMinChannel Field

Minimum I/O channel number.

Namespace: IO.Devices.MCP23017
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MinChannel = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.MCP23017 Namespace


IO.Devices.MCP23017.GPIO Namespace

MCP23017 I2C GPIO Expander GPIO Pin Services.
Classes
 | Class | Description
Public class | Pin | Encapsulates MCP23017 GPIO pins.


Pin Class

Encapsulates MCP23017 GPIO pins.
Inheritance Hierarchy
SystemObject
IO.Devices.MCP23017.GPIOPin

Namespace: IO.Devices.MCP23017.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Create a single MCP23017 GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Devices.MCP23017.GPIO Namespace


Pin Constructor

Create a single MCP23017 GPIO pin.

Namespace: IO.Devices.MCP23017.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int channel,
    Direction dir,
    bool state = false
)

Parameters

dev Device
MCP23017 device object.
channel Int32
MCP23017 I/O channel number.
dir Direction
GPIO pin data direction.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.MCP23017.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Devices.MCP23017.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Devices.MCP23017.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.MCP23017.GPIO Namespace


IO.Devices.MCP23S17 Namespace

MCP23S17 SPI GPIO Expander Device Services.
Classes
 | Class | Description
Public class | Device | Encapsulates the MCP23S17 SPI I/O GPIO Expander.


Device Class

Encapsulates the MCP23S17 SPI I/O GPIO Expander.
Inheritance Hierarchy
SystemObject
IO.Devices.MCP23S17Device

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a single MCP23S17 device.
Top
Properties
 | Name | Description
Public property | Direction | Data Direction Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | DirectionA | Port A Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | DirectionB | Port B Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | Polarity | Data Polarity Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | PolarityA | Port A Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | PolarityB | Port B Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | Port | Port Data Property (16 bites). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B.
Public property | PortA | Port A Data Property (8 bits).
Public property | PortB | Port B Data Property (8 bits).
Public property | Pullups | Input Pullup Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsA | Port A Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsB | Port B Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Top
Methods
 | Name | Description
Public method | GPIO_Create | Create an MCP23S17 GPIO pin object.
Top
Fields
Name | Description
MaxChannel | Maximum I/O channel number.
MinChannel | Minimum I/O channel number.
SPI_Frequency | SPI maximum clock frequency in Hz.
SPI_Mode | SPI transfer mode.
SPI_WordSize | SPI transaction word size.
Top
See Also

Reference

IO.Devices.MCP23S17 Namespace


Device Constructor

Constructor for a single MCP23S17 device.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Device dev
)

Parameters

dev Device
SPI slave device object.
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Data Direction Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | DirectionA | Port A Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | DirectionB | Port B Data Direction Property (8 bits). For each bit, 0=input and 1=output.
Public property | Polarity | Data Polarity Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.
Public property | PolarityA | Port A Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | PolarityB | Port B Data Polarity Property (8 bits). For each bit, 0=input and 1=output.
Public property | Port | Port Data Property (16 bites). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B.
Public property | PortA | Port A Data Property (8 bits).
Public property | PortB | Port B Data Property (8 bits).
Public property | Pullups | Input Pullup Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsA | Port A Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Public property | PullupsB | Port B Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.
Top
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.Direction Property

DeviceDirection Property

Data Direction Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Direction { get; set; }

Property Value

UInt32
Remarks
This property follows the industry standard convention for data direction bit polarity (1=output) rather than the MCP23S17 IODIR register polarity (0=output).
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.DirectionA Property

DeviceDirectionA Property

Port A Data Direction Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte DirectionA { get; set; }

Property Value

Byte
Remarks
This property follows the industry standard convention for data direction bit polarity (1=output) rather than the MCP23S17 IODIRA register polarity (0=output).
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.DirectionB Property

DeviceDirectionB Property

Port B Data Direction Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte DirectionB { get; set; }

Property Value

Byte
Remarks
This property follows the industry standard convention for data direction bit polarity (1=output) rather than the MCP23S17 IODIRA register polarity (0=output).
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.Polarity Property

DevicePolarity Property

Data Polarity Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Polarity { get; set; }

Property Value

UInt32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.PolarityA Property

DevicePolarityA Property

Port A Data Polarity Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PolarityA { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.PolarityB Property

DevicePolarityB Property

Port B Data Polarity Property (8 bits). For each bit, 0=input and 1=output.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PolarityB { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.Port Property

DevicePort Property

Port Data Property (16 bites). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Port { get; set; }

Property Value

UInt32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.PortA Property

DevicePortA Property

Port A Data Property (8 bits).

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PortA { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.PortB Property

DevicePortB Property

Port B Data Property (8 bits).

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PortB { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.Pullups Property

DevicePullups Property

Input Pullup Property (16 bits). Bits 0 to 7 correspond to PORT A and bits 8 to 15 correspond to PORT B. For each bit, 0=high impedance and 1=100k pullup.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint Pullups { get; set; }

Property Value

UInt32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.PullupsA Property

DevicePullupsA Property

Port A Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PullupsA { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.PullupsB Property

DevicePullupsB Property

Port B Input Pullup Property (16 bits). For each bit, 0=high impedance and 1=100k pullup.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte PullupsB { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | GPIO_Create | Create an MCP23S17 GPIO pin object.
Top
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.GPIO_Create Method

DeviceGPIO_Create Method

Create an MCP23S17 GPIO pin object.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO_Create(
    int channel,
    Direction dir,
    bool state = false
)

Parameters

channel Int32
MCP23S17 channel number (0 to 15).
dir Direction
GPIO pin data direction.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
MaxChannel | Maximum I/O channel number.
MinChannel | Minimum I/O channel number.
SPI_Frequency | SPI maximum clock frequency in Hz.
SPI_Mode | SPI transfer mode.
SPI_WordSize | SPI transaction word size.
Top
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.MaxChannel Field

DeviceMaxChannel Field

Maximum I/O channel number.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MaxChannel = 15

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.MinChannel Field

DeviceMinChannel Field

Minimum I/O channel number.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MinChannel = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.SPI_Frequency Field

DeviceSPI_Frequency Field

SPI maximum clock frequency in Hz.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI_Frequency = 10000000

Field Value

Int32
Remarks
Guaranteed only for 2.7V to 5.5V and -40°C to +85°C.
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.SPI_Mode Field

DeviceSPI_Mode Field

SPI transfer mode.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI_Mode = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


Device.SPI_WordSize Field

DeviceSPI_WordSize Field

SPI transaction word size.

Namespace: IO.Devices.MCP23S17
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI_WordSize = 8

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.MCP23S17 Namespace


IO.Devices.MCP23S17.GPIO Namespace

MCP23S17 SPI GPIO Expander GPIO Pin Services.
Classes
 | Class | Description
Public class | Pin | Encapsulates MCP23S17 GPIO pins.


Pin Class

Encapsulates MCP23S17 GPIO pins.
Inheritance Hierarchy
SystemObject
IO.Devices.MCP23S17.GPIOPin

Namespace: IO.Devices.MCP23S17.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Create a single MCP23S17 GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Devices.MCP23S17.GPIO Namespace


Pin Constructor

Create a single MCP23S17 GPIO pin.

Namespace: IO.Devices.MCP23S17.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int channel,
    Direction dir,
    bool state = false
)

Parameters

dev Device
MCP23S17 device object.
channel Int32
MCP23S17 I/O channel number.
dir Direction
GPIO pin data direction.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.MCP23S17.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Devices.MCP23S17.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Devices.MCP23S17.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.MCP23S17.GPIO Namespace


IO.Devices.PCA8574 Namespace

PCA8574 (and similar) I2C GPIO Expander Device Services
Classes
 | Class | Description
Public class | Device | Encapsulates PCA8574 (and similar) I2C GPIO Expanders.


Device Class

Encapsulates PCA8574 (and similar) I2C GPIO Expanders.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA8574Device

Namespace: IO.Devices.PCA8574
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a PCA8574 (or similar) GPIO Expander.
Top
Properties
 | Name | Description
Public property | Latch | This read-only property returns the last value written to the output latch.
Top
Methods
 | Name | Description
Public method | Read | Return actual state of the GPIO pins.
Public method | Write | Write all GPIO pins.
Top
Fields
Name | Description
MAX_PINS | The number of available GPIO pins per chip.
Top
See Also

Reference

IO.Devices.PCA8574 Namespace


Device Constructor

Constructor for a PCA8574 (or similar) GPIO Expander.

Namespace: IO.Devices.PCA8574
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    int addr,
    byte states = 255
)

Parameters

bus Bus
I2C bus controller.
addr Int32
I2C slave address.
states Byte (Optional)
Initial output states.
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Latch | This read-only property returns the last value written to the output latch.
Top
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device.Latch Property

DeviceLatch Property

This read-only property returns the last value written to the output latch.

Namespace: IO.Devices.PCA8574
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte Latch { get; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Return actual state of the GPIO pins.
Public method | Write | Write all GPIO pins.
Top
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device.Read Method

DeviceRead Method

Return actual state of the GPIO pins.

Namespace: IO.Devices.PCA8574
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte Read()

Return Value

Byte
Pin states (MSB = GPIO7).
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device.Write Method

DeviceWrite Method

Write all GPIO pins.

Namespace: IO.Devices.PCA8574
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte data
)

Parameters

data Byte
Data to write to pins (MSB = GPIO7).
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
MAX_PINS | The number of available GPIO pins per chip.
Top
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


Device.MAX_PINS Field

DeviceMAX_PINS Field

The number of available GPIO pins per chip.

Namespace: IO.Devices.PCA8574
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MAX_PINS = 8

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA8574 Namespace


IO.Devices.PCA8574.GPIO Namespace

PCA8574 (and similar) I2C GPIO Expander GPIO Pin Services
Classes
 | Class | Description
Public class | Pin | Encapsulates PCA8574 (and similar) I2C GPIO Expander pins.


Pin Class

Encapsulates PCA8574 (and similar) I2C GPIO Expander pins.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA8574.GPIOPin

Namespace: IO.Devices.PCA8574.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Constructor for a single GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Devices.PCA8574.GPIO Namespace


Pin Constructor

Constructor for a single GPIO pin.

Namespace: IO.Devices.PCA8574.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int num,
    Direction dir,
    bool state = false
)

Parameters

dev Device
PCA8574 (or similar) device.
num Int32
GPIO pin number.
dir Direction
Data direction.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.PCA8574.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Devices.PCA8574.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Devices.PCA8574.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.PCA8574.GPIO Namespace


IO.Devices.PCA9534 Namespace

PCA9534 (and similar) I2C GPIO Expander Device Services
Classes
 | Class | Description
Public class | Device | Encapsulates PCA9534 (and similar) I2C GPIO Expanders.


Device Class

Encapsulates PCA9534 (and similar) I2C GPIO Expanders.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA9534Device

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a PCA9534 (or similar) GPIO Expander.
Top
Properties
 | Name | Description
Public property | Config | This read-only property returns the last value written to the configuration register.
Public property | Latch | This read-only property returns the last value written to the output port register.
Top
Methods
 | Name | Description
Public method | Read | Return actual state of the GPIO pins.
Public method | Read(Byte) | Read from the specified PCA9534 device register.
Public method | Write(Byte) | Write all GPIO pins.
Public method | Write(Byte, Byte) | Write to the specified PCA9534 device register.
Top
Fields
Name | Description
AllInputs | Configure all pins as inputs.
AllNormal | Configure all inputs as normal polarity.
AllOff | Turn all outputs off.
AllOutputs | Configure all pins as outputs.
ConfigurationReg | Configuration Register address.
InputPolarityReg | Input Port Polarity Register address.
InputPortReg | Input Port Register address.
MAX_PINS | The number of available GPIO pins per chip.
OutputPortReg | Output Port Register address.
Top
See Also

Reference

IO.Devices.PCA9534 Namespace


Device Constructor

Constructor for a PCA9534 (or similar) GPIO Expander.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    int addr,
    byte config = 255,
    byte states = 0
)

Parameters

bus Bus
I2C bus controller.
addr Int32
I2C slave address.
config Byte (Optional)
GPIO pin configuration.
states Byte (Optional)
Initial output states.
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Config | This read-only property returns the last value written to the configuration register.
Public property | Latch | This read-only property returns the last value written to the output port register.
Top
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.Config Property

DeviceConfig Property

This read-only property returns the last value written to the configuration register.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte Config { get; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.Latch Property

DeviceLatch Property

This read-only property returns the last value written to the output port register.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte Latch { get; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Return actual state of the GPIO pins.
Public method | Read(Byte) | Read from the specified PCA9534 device register.
Public method | Write(Byte) | Write all GPIO pins.
Public method | Write(Byte, Byte) | Write to the specified PCA9534 device register.
Top
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.Read Method

DeviceRead Method

Overload List
 | Name | Description
Public method | Read | Return actual state of the GPIO pins.
Public method | Read(Byte) | Read from the specified PCA9534 device register.
Top
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.Read Method

DeviceRead Method

Return actual state of the GPIO pins.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte Read()

Return Value

Byte
Pin states (MSB = GPIO7).
See Also

Reference

Device Class
Read Overload
IO.Devices.PCA9534 Namespace


Device.Read(Byte) Method

DeviceRead(Byte) Method

Read from the specified PCA9534 device register.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte Read(
    byte addr
)

Parameters

addr Byte
Register address.

Return Value

Byte
Register contents.
See Also

Reference

Device Class
Read Overload
IO.Devices.PCA9534 Namespace


Device.Write Method

DeviceWrite Method

Overload List
 | Name | Description
Public method | Write(Byte) | Write all GPIO pins.
Public method | Write(Byte, Byte) | Write to the specified PCA9534 device register.
Top
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.Write(Byte) Method

DeviceWrite(Byte) Method

Write all GPIO pins.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte data
)

Parameters

data Byte
Data to write to pins (MSB = GPIO7).
See Also

Reference

Device Class
Write Overload
IO.Devices.PCA9534 Namespace


Device.Write(Byte, Byte) Method

DeviceWrite(Byte, Byte) Method

Write to the specified PCA9534 device register.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte addr,
    byte data
)

Parameters

addr Byte
Register address.
data Byte
Data to written.
See Also

Reference

Device Class
Write Overload
IO.Devices.PCA9534 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
AllInputs | Configure all pins as inputs.
AllNormal | Configure all inputs as normal polarity.
AllOff | Turn all outputs off.
AllOutputs | Configure all pins as outputs.
ConfigurationReg | Configuration Register address.
InputPolarityReg | Input Port Polarity Register address.
InputPortReg | Input Port Register address.
MAX_PINS | The number of available GPIO pins per chip.
OutputPortReg | Output Port Register address.
Top
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.AllInputs Field

DeviceAllInputs Field

Configure all pins as inputs.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte AllInputs = 255

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.AllNormal Field

DeviceAllNormal Field

Configure all inputs as normal polarity.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte AllNormal = 0

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.AllOff Field

DeviceAllOff Field

Turn all outputs off.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte AllOff = 0

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.AllOutputs Field

DeviceAllOutputs Field

Configure all pins as outputs.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte AllOutputs = 0

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.ConfigurationReg Field

DeviceConfigurationReg Field

Configuration Register address.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte ConfigurationReg = 3

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.InputPolarityReg Field

DeviceInputPolarityReg Field

Input Port Polarity Register address.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte InputPolarityReg = 2

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.InputPortReg Field

DeviceInputPortReg Field

Input Port Register address.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte InputPortReg = 0

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.MAX_PINS Field

DeviceMAX_PINS Field

The number of available GPIO pins per chip.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MAX_PINS = 8

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


Device.OutputPortReg Field

DeviceOutputPortReg Field

Output Port Register address.

Namespace: IO.Devices.PCA9534
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const byte OutputPortReg = 1

Field Value

Byte
See Also

Reference

Device Class
IO.Devices.PCA9534 Namespace


IO.Devices.PCA9534.GPIO Namespace

PCA9534 (and similar) I2C GPIO Expander GPIO Pin Services
Classes
 | Class | Description
Public class | Pin | Encapsulates PCA9534 (and similar) I2C GPIO Expander pins.


Pin Class

Encapsulates PCA9534 (and similar) I2C GPIO Expander pins.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA9534.GPIOPin

Namespace: IO.Devices.PCA9534.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Constructor for a single GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Devices.PCA9534.GPIO Namespace


Pin Constructor

Constructor for a single GPIO pin.

Namespace: IO.Devices.PCA9534.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int num,
    Direction dir,
    bool state = false
)

Parameters

dev Device
PCA9534 (or similar) device.
num Int32
GPIO pin number.
dir Direction
Data direction.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.PCA9534.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Devices.PCA9534.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Devices.PCA9534.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.PCA9534.GPIO Namespace


IO.Devices.PCA9685 Namespace

PCA9685 I2C PWM Controller Device Services
Classes
 | Class | Description
Public class | Device | Encapsulates the PCA9685 I2C PWM Controller.


Device Class

Encapsulates the PCA9685 I2C PWM Controller.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA9685Device

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a single PCA9685 device.
Top
Properties
 | Name | Description
Public property | Frequency | Read-only property returning the configured PWM pulse frequency.
Top
Methods
 | Name | Description
Public method | ReadChannel | Read PCA9685 output channel data.
Public method | WriteChannel | Write PCA9685 output channel data.
Top
Fields
Name | Description
INTERNAL_CLOCK | Select internal 25 MHz clock oscillator.
MAX_CHANNEL | Maximum PCA9685 output channel number.
MAX_CLOCK | Maximum clock frequency.
MIN_CHANNEL | Minimum PCA9685 output channel number.
MIN_CLOCK | Minimum clock frequency.
Top
See Also

Reference

IO.Devices.PCA9685 Namespace


Device Constructor

Constructor for a single PCA9685 device.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    int addr,
    int freq = 50,
    int clock = 0
)

Parameters

bus Bus
I2C bus controller object.
addr Int32
I2C slave address.
freq Int32 (Optional)
PWM pulse frequency. Default is 50 Hz.
clock Int32 (Optional)
PCA9685 clock source. Use INTERNAL_CLOCKc> to select the internal 25 MHz clock generator.
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Frequency | Read-only property returning the configured PWM pulse frequency.
Top
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.Frequency Property

DeviceFrequency Property

Read-only property returning the configured PWM pulse frequency.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int Frequency { get; }

Property Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | ReadChannel | Read PCA9685 output channel data.
Public method | WriteChannel | Write PCA9685 output channel data.
Top
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.ReadChannel Method

DeviceReadChannel Method

Read PCA9685 output channel data.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void ReadChannel(
    byte channel,
    ref byte[] data
)

Parameters

channel Byte
Output channel number.
data Byte
Output channel data (4 bytes).
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.WriteChannel Method

DeviceWriteChannel Method

Write PCA9685 output channel data.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void WriteChannel(
    byte channel,
    byte[] data
)

Parameters

channel Byte
Output channel number.
data Byte
Output channel data.
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
INTERNAL_CLOCK | Select internal 25 MHz clock oscillator.
MAX_CHANNEL | Maximum PCA9685 output channel number.
MAX_CLOCK | Maximum clock frequency.
MIN_CHANNEL | Minimum PCA9685 output channel number.
MIN_CLOCK | Minimum clock frequency.
Top
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.INTERNAL_CLOCK Field

DeviceINTERNAL_CLOCK Field

Select internal 25 MHz clock oscillator.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int INTERNAL_CLOCK = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.MAX_CHANNEL Field

DeviceMAX_CHANNEL Field

Maximum PCA9685 output channel number.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MAX_CHANNEL = 15

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.MAX_CLOCK Field

DeviceMAX_CLOCK Field

Maximum clock frequency.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MAX_CLOCK = 50000000

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.MIN_CHANNEL Field

DeviceMIN_CHANNEL Field

Minimum PCA9685 output channel number.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MIN_CHANNEL = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


Device.MIN_CLOCK Field

DeviceMIN_CLOCK Field

Minimum clock frequency.

Namespace: IO.Devices.PCA9685
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MIN_CLOCK = 1

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.PCA9685 Namespace


IO.Devices.PCA9685.GPIO Namespace

PCA9685 I2C PWM Controller GPIO Pin Services
Classes
 | Class | Description
Public class | Pin | Encapsulates PCA9685 GPIO outputs.


Pin Class

Encapsulates PCA9685 GPIO outputs.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA9685.GPIOPin

Namespace: IO.Devices.PCA9685.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Constructor for a single GPIO output pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO output state property.
Top
See Also

Reference

IO.Devices.PCA9685.GPIO Namespace


Pin Constructor

Constructor for a single GPIO output pin.

Namespace: IO.Devices.PCA9685.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int channel,
    bool state = false
)

Parameters

dev Device
PCA9685 device object.
channel Int32
Output channel number.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.PCA9685.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO output state property.
Top
See Also

Reference

Pin Class
IO.Devices.PCA9685.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO output state property.

Namespace: IO.Devices.PCA9685.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.PCA9685.GPIO Namespace


IO.Devices.PCA9685.PWM Namespace

PCA9685 I2C PWM Controller PWM Output Services
Classes
 | Class | Description
Public class | Output | Encapsulates PCA9685 PWM outputs.


Output Class

Encapsulates PCA9685 PWM outputs.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA9685.PWMOutput

Namespace: IO.Devices.PCA9685.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Constructor for a single PWM output.
Top
Properties
 | Name | Description
Public property | dutycycle | Write-only property for setting the PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.
Top
See Also

Reference

IO.Devices.PCA9685.PWM Namespace


Output Constructor

Constructor for a single PWM output.

Namespace: IO.Devices.PCA9685.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Device dev,
    int channel,
    double dutycycle = 0
)

Parameters

dev Device
PCA9685 device object.
channel Int32
Output channel number.
dutycycle Double (Optional)
Initial PWM output duty cycle.
See Also

Reference

Output Class
IO.Devices.PCA9685.PWM Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only property for setting the PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.
Top
See Also

Reference

Output Class
IO.Devices.PCA9685.PWM Namespace


Output.dutycycle Property

Outputdutycycle Property

Write-only property for setting the PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.

Namespace: IO.Devices.PCA9685.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double dutycycle { set; }

Property Value

Double

Implements

Outputdutycycle
See Also

Reference

Output Class
IO.Devices.PCA9685.PWM Namespace


IO.Devices.PCA9685.Servo Namespace

PCA9685 I2C PWM Controller Servo Output Services
Classes
 | Class | Description
Public class | Output | Encapsulates PCA9685 servo outputs.


Output Class

Encapsulates PCA9685 servo outputs.
Inheritance Hierarchy
SystemObject
IO.Devices.PCA9685.ServoOutput

Namespace: IO.Devices.PCA9685.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Constructor for a single servo output.
Top
Properties
 | Name | Description
Public property | position | Write-only property for setting the normalized servo position. Allowed values are -0.0 to+1.0.
Top
See Also

Reference

IO.Devices.PCA9685.Servo Namespace


Output Constructor

Constructor for a single servo output.

Namespace: IO.Devices.PCA9685.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Device dev,
    int channel,
    double position = 0
)

Parameters

dev Device
PCA9685 device object.
channel Int32
Output channel number.
position Double (Optional)
Initial servo position.
See Also

Reference

Output Class
IO.Devices.PCA9685.Servo Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | position | Write-only property for setting the normalized servo position. Allowed values are -0.0 to+1.0.
Top
See Also

Reference

Output Class
IO.Devices.PCA9685.Servo Namespace


Output.position Property

Outputposition Property

Write-only property for setting the normalized servo position. Allowed values are -0.0 to+1.0.

Namespace: IO.Devices.PCA9685.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double position { set; }

Property Value

Double

Implements

Outputposition
See Also

Reference

Output Class
IO.Devices.PCA9685.Servo Namespace


IO.Devices.Pmod.HYGRO Namespace

Digilent Pmod HYGRO Temperature and Humdity Sensor (HDC1080) Services.
Classes
 | Class | Description
Public class | Device | Encapsulate the Digilent Pmod HYGRO Temperature and Humidity Sensor (HDC1080).


Device Class

Encapsulate the Digilent Pmod HYGRO Temperature and Humidity Sensor (HDC1080).
Inheritance Hierarchy
SystemObject
IO.Devices.HDC1080Device
IO.Devices.Pmod.HYGRODevice

Namespace: IO.Devices.Pmod.HYGRO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a Digilent Pmod HYGRO Temperature and Humidity Sensor (HDC1080).
Top
Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius. (Inherited from Device)
Public property | DeviceID | Read-only property returning the device ID. (Inherited from Device)
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit. (Inherited from Device)
Public property | Humidity | Read-only property returning the percentage relative humidity. (Inherited from Device)
Public property | Kelvins | Read-only property returning the temperature in Kelvins. (Inherited from Device)
Public property | ManufacturerID | Read-only property returning the manufacturer ID. (Inherited from Device)
Top
Methods
 | Name | Description
Public method | Read | Read from an HDC1080 device register. (Inherited from Device)
Public method | Write | Write to an HDC1080 device register. (Inherited from Device)
Top
See Also

Reference

IO.Devices.Pmod.HYGRO Namespace


Device Constructor

Constructor for a Digilent Pmod HYGRO Temperature and Humidity Sensor (HDC1080).

Namespace: IO.Devices.Pmod.HYGRO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus
)

Parameters

bus Bus
I2 bus object.
See Also

Reference

Device Class
IO.Devices.Pmod.HYGRO Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius. (Inherited from Device)
Public property | DeviceID | Read-only property returning the device ID. (Inherited from Device)
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit. (Inherited from Device)
Public property | Humidity | Read-only property returning the percentage relative humidity. (Inherited from Device)
Public property | Kelvins | Read-only property returning the temperature in Kelvins. (Inherited from Device)
Public property | ManufacturerID | Read-only property returning the manufacturer ID. (Inherited from Device)
Top
See Also

Reference

Device Class
IO.Devices.Pmod.HYGRO Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read from an HDC1080 device register. (Inherited from Device)
Public method | Write | Write to an HDC1080 device register. (Inherited from Device)
Top
See Also

Reference

Device Class
IO.Devices.Pmod.HYGRO Namespace


IO.Devices.SN74HC595 Namespace

SN74HC595 8-Bit Shift Register Device Services
Classes
 | Class | Description
Public class | Device | Encapsulates a chain of one or more SN74HC595 8-bit shift registers.


Device Class

Encapsulates a chain of one or more SN74HC595 8-bit shift registers.
Inheritance Hierarchy
SystemObject
IO.Devices.SN74HC595Device

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a chain of one or more SN74HC595 shift registers.
Top
Properties
 | Name | Description
Public property | Length | Read-only property returning the number of stages in the chain.
Public property | state | Read/Write shift register chain state property.
Top
Methods
 | Name | Description
Public method | ClrBit | Clear a single bit in the shift register chain.
Public method | ReadBit | Read a single bit in the shift register chain.
Public method | SetBit | Set a single bit in the shift register chain.
Top
Fields
Name | Description
SPI_MaxFreq | SPI maximum clock frequency for the SNHC74HC595 shift register. (Most pessimistic datasheet limit at 2V.)
SPI_Mode | SPI clock mode for the SNHC74HC595 shift register.
Top
See Also

Reference

IO.Devices.SN74HC595 Namespace


Device Constructor

Constructor for a chain of one or more SN74HC595 shift registers.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Device dev,
    int stages = 1,
    byte[] initialstate = null
)

Parameters

dev Device
SPI device object.
stages Int32 (Optional)
Number of stages in the chain.
initialstate Byte (Optional)
Initial shift register chain state.
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Length | Read-only property returning the number of stages in the chain.
Public property | state | Read/Write shift register chain state property.
Top
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.Length Property

DeviceLength Property

Read-only property returning the number of stages in the chain.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int Length { get; }

Property Value

Int32
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.state Property

Devicestate Property

Read/Write shift register chain state property.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte[] state { get; set; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | ClrBit | Clear a single bit in the shift register chain.
Public method | ReadBit | Read a single bit in the shift register chain.
Public method | SetBit | Set a single bit in the shift register chain.
Top
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.ClrBit Method

DeviceClrBit Method

Clear a single bit in the shift register chain.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void ClrBit(
    int index,
    byte mask
)

Parameters

index Int32
Shift register stage number. Zero indicates the first register stage.
mask Byte
Shift register bit mask.
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.ReadBit Method

DeviceReadBit Method

Read a single bit in the shift register chain.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool ReadBit(
    int index,
    byte mask
)

Parameters

index Int32
Shift register stage number. Zero indicates the first register stage.
mask Byte
Shift register bit mask.

Return Value

Boolean
Boolean bit value.
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.SetBit Method

DeviceSetBit Method

Set a single bit in the shift register chain.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void SetBit(
    int index,
    byte mask
)

Parameters

index Int32
Shift register stage number. Zero indicates the first register stage.
mask Byte
Shift register bit mask.
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
SPI_MaxFreq | SPI maximum clock frequency for the SNHC74HC595 shift register. (Most pessimistic datasheet limit at 2V.)
SPI_Mode | SPI clock mode for the SNHC74HC595 shift register.
Top
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.SPI_MaxFreq Field

DeviceSPI_MaxFreq Field

SPI maximum clock frequency for the SNHC74HC595 shift register. (Most pessimistic datasheet limit at 2V.)

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI_MaxFreq = 4000000

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


Device.SPI_Mode Field

DeviceSPI_Mode Field

SPI clock mode for the SNHC74HC595 shift register.

Namespace: IO.Devices.SN74HC595
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI_Mode = 0

Field Value

Int32
See Also

Reference

Device Class
IO.Devices.SN74HC595 Namespace


IO.Devices.SN74HC595.GPIO Namespace

SN74HC595 8-Bit Shift Register GPIO Pin Services
Classes
 | Class | Description
Public class | Pin | Encapsulates SN74HC595 GPIO outputs.


Pin Class

Encapsulates SN74HC595 GPIO outputs.
Inheritance Hierarchy
SystemObject
IO.Devices.SN74HC595.GPIOPin

Namespace: IO.Devices.SN74HC595.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Constructor for a single GPIO output pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO pin state property.
Top
See Also

Reference

IO.Devices.SN74HC595.GPIO Namespace


Pin Constructor

Constructor for a single GPIO output pin.

Namespace: IO.Devices.SN74HC595.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Device dev,
    int pos,
    bool state = false
)

Parameters

dev Device
SN74HC595 device object.
pos Int32
Bit position, numbered left to right. Zero indicates the most significant bit of the first shift register stage.
state Boolean (Optional)
Initial GPIO output state.
See Also

Reference

Pin Class
IO.Devices.SN74HC595.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO pin state property.
Top
See Also

Reference

Pin Class
IO.Devices.SN74HC595.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO pin state property.

Namespace: IO.Devices.SN74HC595.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Devices.SN74HC595.GPIO Namespace


IO.Devices.TH02 Namespace

TH02 I2C Temperature/Humidity Sensor Services
Classes
 | Class | Description
Public class | Device | Encapsulates the TH02 temperature and humidity sensor.


Device Class

Encapsulates the TH02 temperature and humidity sensor.
Inheritance Hierarchy
SystemObject
IO.Devices.TH02Device
IO.Devices.Grove.Temperature_HumidityDevice

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Sensor, Sensor

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for an TH02 temperature and humidity sensor object.
Top
Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | DeviceID | Read-only property returning the device ID.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Humidity | Read-only property returning the percentage relative humidity.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Top
See Also

Reference

IO.Devices.TH02 Namespace


Device Constructor

Constructor for an TH02 temperature and humidity sensor object.

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus
)

Parameters

bus Bus
I2C bus controller.
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | DeviceID | Read-only property returning the device ID.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Humidity | Read-only property returning the percentage relative humidity.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Top
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


Device.Celsius Property

DeviceCelsius Property

Read-only property returning the temperature in degrees Celsius.

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Celsius { get; }

Property Value

Double

Implements

SensorCelsius
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


Device.DeviceID Property

DeviceDeviceID Property

Read-only property returning the device ID.

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte DeviceID { get; }

Property Value

Byte
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


Device.Fahrenheit Property

DeviceFahrenheit Property

Read-only property returning the temperature in degrees Fahrenheit.

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Fahrenheit { get; }

Property Value

Double

Implements

SensorFahrenheit
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


Device.Humidity Property

DeviceHumidity Property

Read-only property returning the percentage relative humidity.

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Humidity { get; }

Property Value

Double

Implements

SensorHumidity
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


Device.Kelvins Property

DeviceKelvins Property

Read-only property returning the temperature in Kelvins.

Namespace: IO.Devices.TH02
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Kelvins { get; }

Property Value

Double

Implements

SensorKelvins
See Also

Reference

Device Class
IO.Devices.TH02 Namespace


IO.Devices.Thermistor Namespace

Thermistor Modeling Services
Classes
 | Class | Description
Public class | NTC_B | Encapsulate an NTC thermistor.


NTC_B Class

Encapsulate an NTC thermistor.
Inheritance Hierarchy
SystemObject
IO.Devices.ThermistorNTC_B

Namespace: IO.Devices.Thermistor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class NTC_B

The NTC_B type exposes the following members.

Constructors
 | Name | Description
Public method | NTC_B | Constructor for a single NTC thermistor object instance.
Top
Methods
 | Name | Description
Public method | Kelvins | Kelvin temperature as a function of the thermistor resistance.
Top
See Also

Reference

IO.Devices.Thermistor Namespace


NTC_B Constructor

Constructor for a single NTC thermistor object instance.

Namespace: IO.Devices.Thermistor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public NTC_B(
    double B,
    double R0,
    double T0 = 298.15
)

Parameters

B Double
Thermistor B parameter.
R0 Double
Thermistor resistance in ohms at the specified reference temperature.
T0 Double (Optional)
Thermistor reference temperature in Kelvins.
See Also

Reference

NTC_B Class
IO.Devices.Thermistor Namespace


NTC_B Methods

The NTC_B type exposes the following members.

Methods
 | Name | Description
Public method | Kelvins | Kelvin temperature as a function of the thermistor resistance.
Top
See Also

Reference

NTC_B Class
IO.Devices.Thermistor Namespace


NTC_B.Kelvins Method

NTC_BKelvins Method

Kelvin temperature as a function of the thermistor resistance.

Namespace: IO.Devices.Thermistor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double Kelvins(
    double R
)

Parameters

R Double
Thermistor resistance in ohms.

Return Value

Double
Temperature in Kelvins.
See Also

Reference

NTC_B Class
IO.Devices.Thermistor Namespace


IO.Devices.USB.Munts Namespace

Vendor and Product Identifiers for Munts Technologies (http://tech.munts.com) USB devices
Classes
 | Class | Description
Public class | HID | USB device constants for Munts Technologies USB HID devices.
Public class | Serial | USB device constants for Munts Technologies USB serial port devices.


HID Class

USB device constants for Munts Technologies USB HID devices.
Inheritance Hierarchy
SystemObject
IO.Devices.USB.MuntsHID

Namespace: IO.Devices.USB.Munts
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class HID

The HID type exposes the following members.

Fields
Name | Description
Product | Product ID for Munts Technologies USB hid devices.
Vendor | Vendor ID for Munts Technologies
Top
See Also

Reference

IO.Devices.USB.Munts Namespace


HID Fields

The HID type exposes the following members.

Fields
Name | Description
Product | Product ID for Munts Technologies USB hid devices.
Vendor | Vendor ID for Munts Technologies
Top
See Also

Reference

HID Class
IO.Devices.USB.Munts Namespace


HID.Product Field

HIDProduct Field

Product ID for Munts Technologies USB hid devices.

Namespace: IO.Devices.USB.Munts
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int Product = 2810

Field Value

Int32
See Also

Reference

HID Class
IO.Devices.USB.Munts Namespace


HID.Vendor Field

HIDVendor Field

Vendor ID for Munts Technologies

Namespace: IO.Devices.USB.Munts
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int Vendor = 5840

Field Value

Int32
See Also

Reference

HID Class
IO.Devices.USB.Munts Namespace


Serial Class

USB device constants for Munts Technologies USB serial port devices.
Inheritance Hierarchy
SystemObject
IO.Devices.USB.MuntsSerial

Namespace: IO.Devices.USB.Munts
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Serial

The Serial type exposes the following members.

Fields
Name | Description
Product | Product ID for Munts Technologies USB serial port devices.
Vendor | Vendor ID for Munts Technologies
Top
See Also

Reference

IO.Devices.USB.Munts Namespace


Serial Fields

The Serial type exposes the following members.

Fields
Name | Description
Product | Product ID for Munts Technologies USB serial port devices.
Vendor | Vendor ID for Munts Technologies
Top
See Also

Reference

Serial Class
IO.Devices.USB.Munts Namespace


Serial.Product Field

SerialProduct Field

Product ID for Munts Technologies USB serial port devices.

Namespace: IO.Devices.USB.Munts
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int Product = 2811

Field Value

Int32
See Also

Reference

Serial Class
IO.Devices.USB.Munts Namespace


Serial.Vendor Field

SerialVendor Field

Vendor ID for Munts Technologies

Namespace: IO.Devices.USB.Munts
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int Vendor = 5840

Field Value

Int32
See Also

Reference

Serial Class
IO.Devices.USB.Munts Namespace


IO.Interfaces.ADC Namespace

Abstract Interface for ADC (Analog to Digital Converter) Inputs
Classes
 | Class | Description
Public class | Input | Encapsulates ADC voltage inputs.
Interfaces
 | Interface | Description
Public interface | Sample | Abstract interface for ADC inputs returning an integer sample value.
Public interface | Voltage | Abstract interface for ADC inputs returning a floating point voltage value.


Input Class

Encapsulates ADC voltage inputs.
Inheritance Hierarchy
SystemObject
IO.Interfaces.ADCInput

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Input : Voltage

The Input type exposes the following members.

Constructors
 | Name | Description
Public method | Input | Create an ADC voltage input.
Top
Properties
 | Name | Description
Public property | voltage | Read-only property returning the analog input voltage.
Top
See Also

Reference

IO.Interfaces.ADC Namespace


Input Constructor

Create an ADC voltage input.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Input(
    Sample input,
    double reference,
    double gain = 1
)

Parameters

input Sample
ADC sample object.
reference Double
ADC reference in volts.
gain Double (Optional)
ADC input gain in volts per volt.
See Also

Reference

Input Class
IO.Interfaces.ADC Namespace


Input Properties

The Input type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning the analog input voltage.
Top
See Also

Reference

Input Class
IO.Interfaces.ADC Namespace


Input.voltage Property

Inputvoltage Property

Read-only property returning the analog input voltage.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double voltage { get; }

Property Value

Double

Implements

Voltagevoltage
See Also

Reference

Input Class
IO.Interfaces.ADC Namespace


Sample Interface

Abstract interface for ADC inputs returning an integer sample value.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Sample

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample value.
Top
See Also

Reference

IO.Interfaces.ADC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample value.
Top
See Also

Reference

Sample Interface
IO.Interfaces.ADC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
int resolution { get; }

Property Value

Int32
See Also

Reference

Sample Interface
IO.Interfaces.ADC Namespace


Sample.sample Property

Samplesample Property

Read-only property returning an integer analog sample value.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
int sample { get; }

Property Value

Int32
See Also

Reference

Sample Interface
IO.Interfaces.ADC Namespace


Voltage Interface

Abstract interface for ADC inputs returning a floating point voltage value.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Voltage

The Voltage type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning a floating point analog voltage value.
Top
See Also

Reference

IO.Interfaces.ADC Namespace


Voltage Properties

The Voltage type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Read-only property returning a floating point analog voltage value.
Top
See Also

Reference

Voltage Interface
IO.Interfaces.ADC Namespace


Voltage.voltage Property

Voltagevoltage Property

Read-only property returning a floating point analog voltage value.

Namespace: IO.Interfaces.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double voltage { get; }

Property Value

Double
See Also

Reference

Voltage Interface
IO.Interfaces.ADC Namespace


IO.Interfaces.DAC Namespace

Abstract Interface for DAC (Digital to Analog Converter) Outputs
Classes
 | Class | Description
Public class | Output | Encapsulates DAC voltage outputs.
Interfaces
 | Interface | Description
Public interface | Sample | Abstract interface for DAC outputs accepting an integer output sample value.
Public interface | Voltage | Abstract interface for DAC outputs accepting a floating point output voltage value.


Output Class

Encapsulates DAC voltage outputs.
Inheritance Hierarchy
SystemObject
IO.Interfaces.DACOutput

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Voltage

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Create an DAC voltage output.
Top
Properties
 | Name | Description
Public property | voltage | Write-only for setting the DAC output voltage.
Top
See Also

Reference

IO.Interfaces.DAC Namespace


Output Constructor

Create an DAC voltage output.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Sample output,
    double reference,
    double gain = 1
)

Parameters

output Sample
DAC output object.
reference Double
DAC output reference in volts.
gain Double (Optional)
DAC output gain in volts per volt.
See Also

Reference

Output Class
IO.Interfaces.DAC Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Write-only for setting the DAC output voltage.
Top
See Also

Reference

Output Class
IO.Interfaces.DAC Namespace


Output.voltage Property

Outputvoltage Property

Write-only for setting the DAC output voltage.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double voltage { set; }

Property Value

Double

Implements

Voltagevoltage
See Also

Reference

Output Class
IO.Interfaces.DAC Namespace


Sample Interface

Abstract interface for DAC outputs accepting an integer output sample value.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Sample

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for setting the DAC output level.
Top
See Also

Reference

IO.Interfaces.DAC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for setting the DAC output level.
Top
See Also

Reference

Sample Interface
IO.Interfaces.DAC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
int resolution { get; }

Property Value

Int32
See Also

Reference

Sample Interface
IO.Interfaces.DAC Namespace


Sample.sample Property

Samplesample Property

Write-only property for setting the DAC output level.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
int sample { set; }

Property Value

Int32
See Also

Reference

Sample Interface
IO.Interfaces.DAC Namespace


Voltage Interface

Abstract interface for DAC outputs accepting a floating point output voltage value.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Voltage

The Voltage type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Write-only property for setting the DAC output voltage.
Top
See Also

Reference

IO.Interfaces.DAC Namespace


Voltage Properties

The Voltage type exposes the following members.

Properties
 | Name | Description
Public property | voltage | Write-only property for setting the DAC output voltage.
Top
See Also

Reference

Voltage Interface
IO.Interfaces.DAC Namespace


Voltage.voltage Property

Voltagevoltage Property

Write-only property for setting the DAC output voltage.

Namespace: IO.Interfaces.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double voltage { set; }

Property Value

Double
See Also

Reference

Voltage Interface
IO.Interfaces.DAC Namespace


IO.Interfaces.GPIO Namespace

Abstract Interface for GPIO (General Purpose Input/Output) Pins
Interfaces
 | Interface | Description
Public interface | Pin | Abstract interface for GPIO pins.
Enumerations
 | Enumeration | Description
Public enumeration | Direction | GPIO pin data direction settings.


Direction Enumeration

GPIO pin data direction settings.

Namespace: IO.Interfaces.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Direction
Members
Member name | Value | Description
Input | 0 | Input pin (read only)
Output | 1 | Output pin (read or write)
See Also

Reference

IO.Interfaces.GPIO Namespace


Pin Interface

Abstract interface for GPIO pins.

Namespace: IO.Interfaces.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Pin

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Interfaces.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Interface
IO.Interfaces.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Interfaces.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
bool state { get; set; }

Property Value

Boolean
See Also

Reference

Pin Interface
IO.Interfaces.GPIO Namespace


IO.Interfaces.Humidity Namespace

Abstract Interface for Humidity Sensors
Interfaces
 | Interface | Description
Public interface | Sensor | Abstract interface for humidity sensors.


Sensor Interface

Abstract interface for humidity sensors.

Namespace: IO.Interfaces.Humidity
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Sensor

The Sensor type exposes the following members.

Properties
 | Name | Description
Public property | Humidity | Read-only property returning the percentage relative humidity.
Top
See Also

Reference

IO.Interfaces.Humidity Namespace


Sensor Properties

The Sensor type exposes the following members.

Properties
 | Name | Description
Public property | Humidity | Read-only property returning the percentage relative humidity.
Top
See Also

Reference

Sensor Interface
IO.Interfaces.Humidity Namespace


Sensor.Humidity Property

SensorHumidity Property

Read-only property returning the percentage relative humidity.

Namespace: IO.Interfaces.Humidity
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double Humidity { get; }

Property Value

Double
See Also

Reference

Sensor Interface
IO.Interfaces.Humidity Namespace


IO.Interfaces.I2C Namespace

Abstract Interface for I2C (Inter-Integrated Circuit) Bus Controllers
Classes
 | Class | Description
Public class | Device | Encapsulates a single I2C slave device.
Public class | Speeds | I2C bus speed constants.
Public class | Utils | I2C utility functions.
Interfaces
 | Interface | Description
Public interface | Bus | Abstract interface for I2C bus controllers.


Bus Interface

Abstract interface for I2C bus controllers.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Bus

The Bus type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an I2C slave device.
Public method | Transaction | Write and read bytes to and from an I2C slave device.
Public method | Write | Write bytes to an I2C slave device.
Top
See Also

Reference

IO.Interfaces.I2C Namespace


Bus Methods

The Bus type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an I2C slave device.
Public method | Transaction | Write and read bytes to and from an I2C slave device.
Public method | Write | Write bytes to an I2C slave device.
Top
See Also

Reference

Bus Interface
IO.Interfaces.I2C Namespace


Bus.Read Method

BusRead Method

Read bytes from an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Read(
    int slaveaddr,
    byte[] resp,
    int resplen
)

Parameters

slaveaddr Int32
I2C slave address.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
See Also

Reference

Bus Interface
IO.Interfaces.I2C Namespace


Bus.Transaction Method

BusTransaction Method

Write and read bytes to and from an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Transaction(
    int slaveaddr,
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus = 0
)

Parameters

slaveaddr Int32
I2C slave address.
cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
delayus Int32 (Optional)
Delay in microseconds between the I2C write and read cycles. Allowed values are 0 to 65535 microseconds.
See Also

Reference

Bus Interface
IO.Interfaces.I2C Namespace


Bus.Write Method

BusWrite Method

Write bytes to an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Write(
    int slaveaddr,
    byte[] cmd,
    int cmdlen
)

Parameters

slaveaddr Int32
I2C slave address.
cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
See Also

Reference

Bus Interface
IO.Interfaces.I2C Namespace


Device Class

Encapsulates a single I2C slave device.
Inheritance Hierarchy
SystemObject
IO.Interfaces.I2CDevice

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Create an I2C slave device.
Top
Methods
 | Name | Description
Public method | Read | Read bytes from an I2C slave device.
Public method | Transaction | Write and read bytes to and from an I2C slave device.
Public method | Write | Write bytes to an I2C slave device.
Top
See Also

Reference

IO.Interfaces.I2C Namespace


Device Constructor

Create an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Bus bus,
    int slaveaddr
)

Parameters

bus Bus
I2C bus controller object.
slaveaddr Int32
I2C slave address.
See Also

Reference

Device Class
IO.Interfaces.I2C Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an I2C slave device.
Public method | Transaction | Write and read bytes to and from an I2C slave device.
Public method | Write | Write bytes to an I2C slave device.
Top
See Also

Reference

Device Class
IO.Interfaces.I2C Namespace


Device.Read Method

DeviceRead Method

Read bytes from an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Read(
    byte[] resp,
    int resplen
)

Parameters

resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
See Also

Reference

Device Class
IO.Interfaces.I2C Namespace


Device.Transaction Method

DeviceTransaction Method

Write and read bytes to and from an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus = 0
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
delayus Int32 (Optional)
Delay in microseconds between the I2C write and read cycles. Allowed values are 0 to 65535 microseconds.
See Also

Reference

Device Class
IO.Interfaces.I2C Namespace


Device.Write Method

DeviceWrite Method

Write bytes to an I2C slave device.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte[] cmd,
    int cmdlen
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
See Also

Reference

Device Class
IO.Interfaces.I2C Namespace


Speeds Class

I2C bus speed constants.
Inheritance Hierarchy
SystemObject
IO.Interfaces.I2CSpeeds

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Speeds

The Speeds type exposes the following members.

Fields
Name | Description
FastMode | Fast Mode
FastModePlus | Fast Mode Plus
StandardMode | Standard Mode
Top
See Also

Reference

IO.Interfaces.I2C Namespace


Speeds Fields

The Speeds type exposes the following members.

Fields
Name | Description
FastMode | Fast Mode
FastModePlus | Fast Mode Plus
StandardMode | Standard Mode
Top
See Also

Reference

Speeds Class
IO.Interfaces.I2C Namespace


Speeds.FastMode Field

SpeedsFastMode Field

Fast Mode

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int FastMode = 400000

Field Value

Int32
See Also

Reference

Speeds Class
IO.Interfaces.I2C Namespace


Speeds.FastModePlus Field

SpeedsFastModePlus Field

Fast Mode Plus

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int FastModePlus = 1000000

Field Value

Int32
See Also

Reference

Speeds Class
IO.Interfaces.I2C Namespace


Speeds.StandardMode Field

SpeedsStandardMode Field

Standard Mode

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int StandardMode = 100000

Field Value

Int32
See Also

Reference

Speeds Class
IO.Interfaces.I2C Namespace


Utils Class

I2C utility functions.
Inheritance Hierarchy
SystemObject
IO.Interfaces.I2CUtils

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Utils

The Utils type exposes the following members.

Methods
Name | Description
GetAddress | Prompt the operator to enter an I2C slave address, with rigorous error checking. Failure raises an exception.
Top
See Also

Reference

IO.Interfaces.I2C Namespace


Utils Methods

The Utils type exposes the following members.

Methods
Name | Description
GetAddress | Prompt the operator to enter an I2C slave address, with rigorous error checking. Failure raises an exception.
Top
See Also

Reference

Utils Class
IO.Interfaces.I2C Namespace


Utils.GetAddress Method

UtilsGetAddress Method

Prompt the operator to enter an I2C slave address, with rigorous error checking. Failure raises an exception.

Namespace: IO.Interfaces.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static int GetAddress(
    string prompt
)

Parameters

prompt String
Prompt string.

Return Value

Int32
I2C slave address.
See Also

Reference

Utils Class
IO.Interfaces.I2C Namespace


IO.Interfaces.Message.Text Namespace

Abstract Interface for Text Message Relays
Interfaces
 | Interface | Description
Public interface | Relay | Abstract interface for a text message relay.


Relay Interface

Abstract interface for a text message relay.

Namespace: IO.Interfaces.Message.Text
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Relay

The Relay type exposes the following members.

Methods
 | Name | Description
Public method | Send | Method for sending a text message.
Top
See Also

Reference

IO.Interfaces.Message.Text Namespace


Relay Methods

The Relay type exposes the following members.

Methods
 | Name | Description
Public method | Send | Method for sending a text message.
Top
See Also

Reference

Relay Interface
IO.Interfaces.Message.Text Namespace


Relay.Send Method

RelaySend Method

Method for sending a text message.

Namespace: IO.Interfaces.Message.Text
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Send(
    string sender,
    string recipient,
    string subject,
    string message
)

Parameters

sender String
Message originator.
recipient String
Message recipient.
subject String
Message subject.
message String
Message text.
See Also

Reference

Relay Interface
IO.Interfaces.Message.Text Namespace


IO.Interfaces.Message64 Namespace

Abstract Interface for 64-Byte Message Services
Classes
 | Class | Description
Public class | Message | Encapsulates 64-byte messages.
Interfaces
 | Interface | Description
Public interface | Messenger | Abstract interface for sending and receiving 64-byte messages.


Message Class

Encapsulates 64-byte messages.
Inheritance Hierarchy
SystemObject
IO.Interfaces.Message64Message

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Message

The Message type exposes the following members.

Constructors
 | Name | Description
Public method | Message | Create a message object without initializing the payload.
Public method | Message(Byte) | Create a message object with an initialized payload.
Top
Fields
 | Name | Description
Public field | payload | Message payload.
 | Size | Message payload size.
Top
See Also

Reference

IO.Interfaces.Message64 Namespace


Message Constructor

Overload List
 | Name | Description
Public method | Message | Create a message object without initializing the payload.
Public method | Message(Byte) | Create a message object with an initialized payload.
Top
See Also

Reference

Message Class
IO.Interfaces.Message64 Namespace


Message Constructor

Create a message object without initializing the payload.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Message()
See Also

Reference

Message Class
Message Overload
IO.Interfaces.Message64 Namespace


Message(Byte) Constructor

Create a message object with an initialized payload.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Message(
    byte fill
)

Parameters

fill Byte
Value to initialize the payload with.
See Also

Reference

Message Class
Message Overload
IO.Interfaces.Message64 Namespace


Message Fields

The Message type exposes the following members.

Fields
 | Name | Description
Public field | payload | Message payload.
 | Size | Message payload size.
Top
See Also

Reference

Message Class
IO.Interfaces.Message64 Namespace


Message.payload Field

Messagepayload Field

Message payload.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public byte[] payload

Field Value

Byte
See Also

Reference

Message Class
IO.Interfaces.Message64 Namespace


Message.Size Field

MessageSize Field

Message payload size.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int Size = 64

Field Value

Int32
See Also

Reference

Message Class
IO.Interfaces.Message64 Namespace


Messenger Interface

Abstract interface for sending and receiving 64-byte messages.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Messenger

The Messenger type exposes the following members.

Methods
 | Name | Description
Public method | Receive | Receive a 64-byte message.
Public method | Send | Send a 64-byte message.
Public method | Transaction | Send a 64-byte command and receive a 64-byte response.
Top
See Also

Reference

IO.Interfaces.Message64 Namespace


Messenger Methods

The Messenger type exposes the following members.

Methods
 | Name | Description
Public method | Receive | Receive a 64-byte message.
Public method | Send | Send a 64-byte message.
Public method | Transaction | Send a 64-byte command and receive a 64-byte response.
Top
See Also

Reference

Messenger Interface
IO.Interfaces.Message64 Namespace


Messenger.Receive Method

MessengerReceive Method

Receive a 64-byte message.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Receive(
    Message resp
)

Parameters

resp Message
Message received.
See Also

Reference

Messenger Interface
IO.Interfaces.Message64 Namespace


Messenger.Send Method

MessengerSend Method

Send a 64-byte message.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Send(
    Message cmd
)

Parameters

cmd Message
Message to be sent.
See Also

Reference

Messenger Interface
IO.Interfaces.Message64 Namespace


Messenger.Transaction Method

MessengerTransaction Method

Send a 64-byte command and receive a 64-byte response.

Namespace: IO.Interfaces.Message64
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Transaction(
    Message cmd,
    Message resp
)

Parameters

cmd Message
Command to be sent.
resp Message
Response to be received.
See Also

Reference

Messenger Interface
IO.Interfaces.Message64 Namespace


IO.Interfaces.Motor Namespace

Abstract Interface For Variable Speed Motor Outputs
Classes
 | Class | Description
Public class | Velocities | Motor velocity contants.
Interfaces
 | Interface | Description
Public interface | Output | Abstract interface for variable speed motor outputs.


Output Interface

Abstract interface for variable speed motor outputs.

Namespace: IO.Interfaces.Motor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Output

The Output type exposes the following members.

Properties
 | Name | Description
Public property | velocity | Write-only motor velocity property.
Top
See Also

Reference

IO.Interfaces.Motor Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | velocity | Write-only motor velocity property.
Top
See Also

Reference

Output Interface
IO.Interfaces.Motor Namespace


Output.velocity Property

Outputvelocity Property

Write-only motor velocity property.

Namespace: IO.Interfaces.Motor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double velocity { set; }

Property Value

Double
See Also

Reference

Output Interface
IO.Interfaces.Motor Namespace


Velocities Class

Motor velocity contants.
Inheritance Hierarchy
SystemObject
IO.Interfaces.MotorVelocities

Namespace: IO.Interfaces.Motor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Velocities

The Velocities type exposes the following members.

Fields
Name | Description
Maximum | Maximum velocity (full speed forward).
Minimum | Minimum velocity (full speed reverse).
Stop | Zero velocity (motor stopped).
Top
See Also

Reference

IO.Interfaces.Motor Namespace


Velocities Fields

The Velocities type exposes the following members.

Fields
Name | Description
Maximum | Maximum velocity (full speed forward).
Minimum | Minimum velocity (full speed reverse).
Stop | Zero velocity (motor stopped).
Top
See Also

Reference

Velocities Class
IO.Interfaces.Motor Namespace


Velocities.Maximum Field

VelocitiesMaximum Field

Maximum velocity (full speed forward).

Namespace: IO.Interfaces.Motor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Maximum = 1

Field Value

Double
See Also

Reference

Velocities Class
IO.Interfaces.Motor Namespace


Velocities.Minimum Field

VelocitiesMinimum Field

Minimum velocity (full speed reverse).

Namespace: IO.Interfaces.Motor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Minimum = -1

Field Value

Double
See Also

Reference

Velocities Class
IO.Interfaces.Motor Namespace


Velocities.Stop Field

VelocitiesStop Field

Zero velocity (motor stopped).

Namespace: IO.Interfaces.Motor
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Stop = 0

Field Value

Double
See Also

Reference

Velocities Class
IO.Interfaces.Motor Namespace


IO.Interfaces.PWM Namespace

Abstract Interface for PWM (Pulse Width Modulated) Outputs
Classes
 | Class | Description
Public class | DutyCycles | PWM dutycycle contants.
Interfaces
 | Interface | Description
Public interface | Output | Abstract interface for PWM outputs.


DutyCycles Class

PWM dutycycle contants.
Inheritance Hierarchy
SystemObject
IO.Interfaces.PWMDutyCycles

Namespace: IO.Interfaces.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class DutyCycles

The DutyCycles type exposes the following members.

Fields
Name | Description
Maximum | Maximum duty cycle (percent).
Minimum | Minimum duty cycle (percent).
Top
See Also

Reference

IO.Interfaces.PWM Namespace


DutyCycles Fields

The DutyCycles type exposes the following members.

Fields
Name | Description
Maximum | Maximum duty cycle (percent).
Minimum | Minimum duty cycle (percent).
Top
See Also

Reference

DutyCycles Class
IO.Interfaces.PWM Namespace


DutyCycles.Maximum Field

DutyCyclesMaximum Field

Maximum duty cycle (percent).

Namespace: IO.Interfaces.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Maximum = 100

Field Value

Double
See Also

Reference

DutyCycles Class
IO.Interfaces.PWM Namespace


DutyCycles.Minimum Field

DutyCyclesMinimum Field

Minimum duty cycle (percent).

Namespace: IO.Interfaces.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Minimum = 0

Field Value

Double
See Also

Reference

DutyCycles Class
IO.Interfaces.PWM Namespace


Output Interface

Abstract interface for PWM outputs.

Namespace: IO.Interfaces.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Output

The Output type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only PWM duty cycle property.
Top
See Also

Reference

IO.Interfaces.PWM Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only PWM duty cycle property.
Top
See Also

Reference

Output Interface
IO.Interfaces.PWM Namespace


Output.dutycycle Property

Outputdutycycle Property

Write-only PWM duty cycle property.

Namespace: IO.Interfaces.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double dutycycle { set; }

Property Value

Double
See Also

Reference

Output Interface
IO.Interfaces.PWM Namespace


IO.Interfaces.Servo Namespace

Abstract Interface for Servo Outputs
Classes
 | Class | Description
Public class | Positions | Servo position contants.
Interfaces
 | Interface | Description
Public interface | Output | Abstract interface for servo outputs.


Output Interface

Abstract interface for servo outputs.

Namespace: IO.Interfaces.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Output

The Output type exposes the following members.

Properties
 | Name | Description
Public property | position | Write-only servo position property.
Top
See Also

Reference

IO.Interfaces.Servo Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | position | Write-only servo position property.
Top
See Also

Reference

Output Interface
IO.Interfaces.Servo Namespace


Output.position Property

Outputposition Property

Write-only servo position property.

Namespace: IO.Interfaces.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double position { set; }

Property Value

Double
See Also

Reference

Output Interface
IO.Interfaces.Servo Namespace


Positions Class

Servo position contants.
Inheritance Hierarchy
SystemObject
IO.Interfaces.ServoPositions

Namespace: IO.Interfaces.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Positions

The Positions type exposes the following members.

Fields
Name | Description
Maximum | Maximum displacement position.
Minimum | Minimum displacement position.
Neutral | Zero displacement (neutral) position.
Top
See Also

Reference

IO.Interfaces.Servo Namespace


Positions Fields

The Positions type exposes the following members.

Fields
Name | Description
Maximum | Maximum displacement position.
Minimum | Minimum displacement position.
Neutral | Zero displacement (neutral) position.
Top
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


Positions.Maximum Field

PositionsMaximum Field

Maximum displacement position.

Namespace: IO.Interfaces.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Maximum = 1

Field Value

Double
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


Positions.Minimum Field

PositionsMinimum Field

Minimum displacement position.

Namespace: IO.Interfaces.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Minimum = -1

Field Value

Double
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


Positions.Neutral Field

PositionsNeutral Field

Zero displacement (neutral) position.

Namespace: IO.Interfaces.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const double Neutral = 0

Field Value

Double
See Also

Reference

Positions Class
IO.Interfaces.Servo Namespace


IO.Interfaces.SPI Namespace

Abstract Interface for SPI (Serial Peripheral Interconnect) Slave Devices
Interfaces
 | Interface | Description
Public interface | Device | Abstract interface for SPI slave devices.


Device Interface

Abstract interface for SPI slave devices.

Namespace: IO.Interfaces.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Device

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an SPI slave device.
Public method | Transaction | Write bytes to and read bytes from an SPI slave device.
Public method | Write | Write bytes to an SPI slave device.
Top
See Also

Reference

IO.Interfaces.SPI Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an SPI slave device.
Public method | Transaction | Write bytes to and read bytes from an SPI slave device.
Public method | Write | Write bytes to an SPI slave device.
Top
See Also

Reference

Device Interface
IO.Interfaces.SPI Namespace


Device.Read Method

DeviceRead Method

Read bytes from an SPI slave device.

Namespace: IO.Interfaces.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Read(
    byte[] resp,
    int resplen
)

Parameters

resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
See Also

Reference

Device Interface
IO.Interfaces.SPI Namespace


Device.Transaction Method

DeviceTransaction Method

Write bytes to and read bytes from an SPI slave device.

Namespace: IO.Interfaces.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Transaction(
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus = 0
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
delayus Int32 (Optional)
Delay in microseconds between write and read operations.
See Also

Reference

Device Interface
IO.Interfaces.SPI Namespace


Device.Write Method

DeviceWrite Method

Write bytes to an SPI slave device.

Namespace: IO.Interfaces.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Write(
    byte[] cmd,
    int cmdlen
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
See Also

Reference

Device Interface
IO.Interfaces.SPI Namespace


IO.Interfaces.Stepper Namespace

Abstract Interface for Stepper Motor Outputs
Interfaces
 | Interface | Description
Public interface | Output | Abstract interface for stepper motor outputs.


Output Interface

Abstract interface for stepper motor outputs.

Namespace: IO.Interfaces.Stepper
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Output

The Output type exposes the following members.

Properties
 | Name | Description
Public property | StepsPerRotation | Read-only property returning the number of steps a stepper motor has.
Top
Methods
 | Name | Description
Public method | Move | Move the stepper motor a specified number of steps at a specified rate.
Public method | Spin | Spin (i.e. continuous rotation) the stepper moter at a specified rate.
Top
See Also

Reference

IO.Interfaces.Stepper Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | StepsPerRotation | Read-only property returning the number of steps a stepper motor has.
Top
See Also

Reference

Output Interface
IO.Interfaces.Stepper Namespace


Output.StepsPerRotation Property

OutputStepsPerRotation Property

Read-only property returning the number of steps a stepper motor has.

Namespace: IO.Interfaces.Stepper
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
int StepsPerRotation { get; }

Property Value

Int32
See Also

Reference

Output Interface
IO.Interfaces.Stepper Namespace


Output Methods

The Output type exposes the following members.

Methods
 | Name | Description
Public method | Move | Move the stepper motor a specified number of steps at a specified rate.
Public method | Spin | Spin (i.e. continuous rotation) the stepper moter at a specified rate.
Top
See Also

Reference

Output Interface
IO.Interfaces.Stepper Namespace


Output.Move Method

OutputMove Method

Move the stepper motor a specified number of steps at a specified rate.

Namespace: IO.Interfaces.Stepper
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Move(
    int steps,
    float rate
)

Parameters

steps Int32
Number of steps to move. Negative values indicate reverse motion and positive values indicate forward motion. (The directions are nominal and depend on how the stepper motor coils are wired). Zero indicates the stepper motor should be stopped.
rate Single
The rate of motion, in steps per second. Negative values indicate reverse motion and positive values indicate forward motion. (The directions are nominal and depend on how the stepper motor coils are wired). Zero indicates the stepper motor should be stopped.
See Also

Reference

Output Interface
IO.Interfaces.Stepper Namespace


Output.Spin Method

OutputSpin Method

Spin (i.e. continuous rotation) the stepper moter at a specified rate.

Namespace: IO.Interfaces.Stepper
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Spin(
    float rate
)

Parameters

rate Single
The rate of motion, in steps per second. Negative values indicate reverse motion and positive values indicate forward motion. (The directions are nominal and depend on how the stepper motor coils are wired). Zero indicates the stepper motor should be stopped.
Remarks
Not all stepper motor drivers support continuous rotation.
See Also

Reference

Output Interface
IO.Interfaces.Stepper Namespace


IO.Interfaces.Temperature Namespace

Abstract Interface for Temperature Sensors
Classes
 | Class | Description
Public class | Conversions | Temperature conversion functions.
Interfaces
 | Interface | Description
Public interface | Sensor | Abstract interface for temperature sensors.


Conversions Class

Temperature conversion functions.
Inheritance Hierarchy
SystemObject
IO.Interfaces.TemperatureConversions

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Conversions

The Conversions type exposes the following members.

Constructors
 | Name | Description
Public method | Conversions | Initializes a new instance of the Conversions class
Top
Methods
Name | Description
CelsiusToFahrenheit | Convert degrees Celsius to degrees Fahrenheit.
CelsiusToKelvins | Convert degrees Celsius to Kelvins.
FahrenheitToCelsius | Convert degrees Fahrenheit to degrees Celsius.
FahrenheitToKelvins | Convert degrees Fahrenheit to Kelvins.
KelvinsToCelsius | Convert Kelvins to degrees Celsius.
KelvinsToFahrenheit | Convert Kelvins to degrees Fahrenheit.
Top
See Also

Reference

IO.Interfaces.Temperature Namespace


Conversions Constructor

Initializes a new instance of the Conversions class

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Conversions()
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions Methods

The Conversions type exposes the following members.

Methods
Name | Description
CelsiusToFahrenheit | Convert degrees Celsius to degrees Fahrenheit.
CelsiusToKelvins | Convert degrees Celsius to Kelvins.
FahrenheitToCelsius | Convert degrees Fahrenheit to degrees Celsius.
FahrenheitToKelvins | Convert degrees Fahrenheit to Kelvins.
KelvinsToCelsius | Convert Kelvins to degrees Celsius.
KelvinsToFahrenheit | Convert Kelvins to degrees Fahrenheit.
Top
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions.CelsiusToFahrenheit Method

ConversionsCelsiusToFahrenheit Method

Convert degrees Celsius to degrees Fahrenheit.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static double CelsiusToFahrenheit(
    double celsius
)

Parameters

celsius Double
Temperature in degrees Celsius.

Return Value

Double
Temperature in degrees Fahrenheit.
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions.CelsiusToKelvins Method

ConversionsCelsiusToKelvins Method

Convert degrees Celsius to Kelvins.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static double CelsiusToKelvins(
    double celsius
)

Parameters

celsius Double
Temperature in degrees Celsius.

Return Value

Double
Temperature in Kelvins.
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions.FahrenheitToCelsius Method

ConversionsFahrenheitToCelsius Method

Convert degrees Fahrenheit to degrees Celsius.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static double FahrenheitToCelsius(
    double fahrenheit
)

Parameters

fahrenheit Double
Temperature in degrees Fahrenheit.

Return Value

Double
Temperature in degrees Celsius.
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions.FahrenheitToKelvins Method

ConversionsFahrenheitToKelvins Method

Convert degrees Fahrenheit to Kelvins.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static double FahrenheitToKelvins(
    double fahrenheit
)

Parameters

fahrenheit Double
Temperature in degrees Fahrenheit.

Return Value

Double
Temperature in Kelvins.
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions.KelvinsToCelsius Method

ConversionsKelvinsToCelsius Method

Convert Kelvins to degrees Celsius.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static double KelvinsToCelsius(
    double kelvins
)

Parameters

kelvins Double
Temperature in Kelvins.

Return Value

Double
Temperature in degrees Celsius.
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Conversions.KelvinsToFahrenheit Method

ConversionsKelvinsToFahrenheit Method

Convert Kelvins to degrees Fahrenheit.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static double KelvinsToFahrenheit(
    double kelvins
)

Parameters

kelvins Double
Temperature in Kelivns.

Return Value

Double
Temperature in degrees Fahrenheit.
See Also

Reference

Conversions Class
IO.Interfaces.Temperature Namespace


Sensor Interface

Abstract interface for temperature sensors.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Sensor

The Sensor type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Top
See Also

Reference

IO.Interfaces.Temperature Namespace


Sensor Properties

The Sensor type exposes the following members.

Properties
 | Name | Description
Public property | Celsius | Read-only property returning the temperature in degrees Celsius.
Public property | Fahrenheit | Read-only property returning the temperature in degrees Fahrenheit.
Public property | Kelvins | Read-only property returning the temperature in Kelvins.
Top
See Also

Reference

Sensor Interface
IO.Interfaces.Temperature Namespace


Sensor.Celsius Property

SensorCelsius Property

Read-only property returning the temperature in degrees Celsius.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double Celsius { get; }

Property Value

Double
See Also

Reference

Sensor Interface
IO.Interfaces.Temperature Namespace


Sensor.Fahrenheit Property

SensorFahrenheit Property

Read-only property returning the temperature in degrees Fahrenheit.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double Fahrenheit { get; }

Property Value

Double
See Also

Reference

Sensor Interface
IO.Interfaces.Temperature Namespace


Sensor.Kelvins Property

SensorKelvins Property

Read-only property returning the temperature in Kelvins.

Namespace: IO.Interfaces.Temperature
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
double Kelvins { get; }

Property Value

Double
See Also

Reference

Sensor Interface
IO.Interfaces.Temperature Namespace


IO.Interfaces.Watchdog Namespace

Abstract Interface for Watchdog Timers
Interfaces
 | Interface | Description
Public interface | Timer | Abstract interface for watchdog timers.


Timer Interface

Abstract interface for watchdog timers.

Namespace: IO.Interfaces.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public interface Timer

The Timer type exposes the following members.

Properties
 | Name | Description
Public property | timeout | Read/Write watchdog timer period property.
Top
Methods
 | Name | Description
Public method | Kick | Reset the watchdog timer.
Top
See Also

Reference

IO.Interfaces.Watchdog Namespace


Timer Properties

The Timer type exposes the following members.

Properties
 | Name | Description
Public property | timeout | Read/Write watchdog timer period property.
Top
See Also

Reference

Timer Interface
IO.Interfaces.Watchdog Namespace


Timer.timeout Property

Timertimeout Property

Read/Write watchdog timer period property.

Namespace: IO.Interfaces.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
int timeout { get; set; }

Property Value

Int32
See Also

Reference

Timer Interface
IO.Interfaces.Watchdog Namespace


Timer Methods

The Timer type exposes the following members.

Methods
 | Name | Description
Public method | Kick | Reset the watchdog timer.
Top
See Also

Reference

Timer Interface
IO.Interfaces.Watchdog Namespace


Timer.Kick Method

TimerKick Method

Reset the watchdog timer.

Namespace: IO.Interfaces.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
void Kick()
See Also

Reference

Timer Interface
IO.Interfaces.Watchdog Namespace


IO.Objects.Email.Mail Namespace

Email Sending Services using /usr/bin/mail
Classes
 | Class | Description
Public class | Relay | This class implements the IO.Interfaces.Messaging.Text.Relay interface, for sending an email message via the Unix program /usr/bin/mail.


Relay Class

This class implements the IO.Interfaces.Messaging.Text.Relay interface, for sending an email message via the Unix program /usr/bin/mail.
Inheritance Hierarchy
SystemObject
IO.Objects.Email.MailRelay

Namespace: IO.Objects.Email.Mail
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Relay : Relay

The Relay type exposes the following members.

Constructors
 | Name | Description
Public method | Relay | Constructor for a single mail relay.
Top
Methods
 | Name | Description
Public method | Send(String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String, String) | Method for sending an email message with an attachment.
Top
See Also

Reference

IO.Objects.Email.Mail Namespace


Relay Constructor

Constructor for a single mail relay.

Namespace: IO.Objects.Email.Mail
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Relay()
See Also

Reference

Relay Class
IO.Objects.Email.Mail Namespace


Relay Methods

The Relay type exposes the following members.

Methods
 | Name | Description
Public method | Send(String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String, String) | Method for sending an email message with an attachment.
Top
See Also

Reference

Relay Class
IO.Objects.Email.Mail Namespace


Relay.Send Method

RelaySend Method

Overload List
 | Name | Description
Public method | Send(String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String, String) | Method for sending an email message with an attachment.
Top
See Also

Reference

Relay Class
IO.Objects.Email.Mail Namespace


Relay.Send(String, String, String) Method

RelaySend(String, String, String) Method

Method for sending an email message.

Namespace: IO.Objects.Email.Mail
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    string recipient,
    string subject,
    string message
)

Parameters

recipient String
Originator email address.
subject String
Recipient email address.
message String
Email message body.
See Also

Reference

Relay Class
Send Overload
IO.Objects.Email.Mail Namespace


Relay.Send(String, String, String, String) Method

RelaySend(String, String, String, String) Method

Method for sending an email message.

Namespace: IO.Objects.Email.Mail
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    string sender,
    string recipient,
    string subject,
    string message
)

Parameters

sender String
Originator email address.
recipient String
Recipient email address.
subject String
Subject of the email message.
message String
Email message body.

Implements

RelaySend(String, String, String, String)
See Also

Reference

Relay Class
Send Overload
IO.Objects.Email.Mail Namespace


Relay.Send(String, String, String, String, String) Method

RelaySend(String, String, String, String, String) Method

Method for sending an email message with an attachment.

Namespace: IO.Objects.Email.Mail
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    string sender,
    string recipient,
    string subject,
    string message,
    string attachment
)

Parameters

sender String
Originator email address.
recipient String
Recipient email address.
subject String
Subject of the email message.
message String
Email message body.
attachment String
Attachment file name.
See Also

Reference

Relay Class
Send Overload
IO.Objects.Email.Mail Namespace


IO.Objects.Email.SMTP Namespace

Email Sending Services using SMTP to localhost:25
Classes
 | Class | Description
Public class | Relay | This class implements the IO.Interfaces.Messaging.Text.Relay interface, for sending an email message via SMTP (Simple Mail Transfer Protocol).


Relay Class

This class implements the IO.Interfaces.Messaging.Text.Relay interface, for sending an email message via SMTP (Simple Mail Transfer Protocol).
Inheritance Hierarchy
SystemObject
IO.Objects.Email.SMTPRelay

Namespace: IO.Objects.Email.SMTP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Relay : Relay

The Relay type exposes the following members.

Constructors
 | Name | Description
Public method | Relay | Constructor for a single SMTP mail relay.
Top
Methods
 | Name | Description
Public method | Send(String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String, String) | Method for sending an email message with an attachment.
Top
See Also

Reference

IO.Objects.Email.SMTP Namespace


Relay Constructor

Constructor for a single SMTP mail relay.

Namespace: IO.Objects.Email.SMTP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Relay(
    string server = "localhost",
    int port = 25
)

Parameters

server String (Optional)
SMTP server domain name or IP addaress.
port Int32 (Optional)
SMTP server TCP port number.
See Also

Reference

Relay Class
IO.Objects.Email.SMTP Namespace


Relay Methods

The Relay type exposes the following members.

Methods
 | Name | Description
Public method | Send(String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String, String) | Method for sending an email message with an attachment.
Top
See Also

Reference

Relay Class
IO.Objects.Email.SMTP Namespace


Relay.Send Method

RelaySend Method

Overload List
 | Name | Description
Public method | Send(String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String) | Method for sending an email message.
Public method | Send(String, String, String, String, String) | Method for sending an email message with an attachment.
Top
See Also

Reference

Relay Class
IO.Objects.Email.SMTP Namespace


Relay.Send(String, String, String) Method

RelaySend(String, String, String) Method

Method for sending an email message.

Namespace: IO.Objects.Email.SMTP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    string recipient,
    string subject,
    string message
)

Parameters

recipient String
Originator email address.
subject String
Recipient email address.
message String
Email message body.
See Also

Reference

Relay Class
Send Overload
IO.Objects.Email.SMTP Namespace


Relay.Send(String, String, String, String) Method

RelaySend(String, String, String, String) Method

Method for sending an email message.

Namespace: IO.Objects.Email.SMTP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    string sender,
    string recipient,
    string subject,
    string message
)

Parameters

sender String
Originator email address.
recipient String
Recipient email address.
subject String
Subject of the email message.
message String
Email message body.

Implements

RelaySend(String, String, String, String)
See Also

Reference

Relay Class
Send Overload
IO.Objects.Email.SMTP Namespace


Relay.Send(String, String, String, String, String) Method

RelaySend(String, String, String, String, String) Method

Method for sending an email message with an attachment.

Namespace: IO.Objects.Email.SMTP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    string sender,
    string recipient,
    string subject,
    string message,
    string attachment
)

Parameters

sender String
Originator email address.
recipient String
Recipient email address.
subject String
Subject of the email message.
message String
Email message body.
attachment String
Attachment file name.
See Also

Reference

Relay Class
Send Overload
IO.Objects.Email.SMTP Namespace


IO.Objects.GPIO.PWM Namespace

PWM Controlled GPIO Output Services
Classes
 | Class | Description
Public class | Pin | Encapsulates GPIO output pins implemented with PWM outputs.


Pin Class

Encapsulates GPIO output pins implemented with PWM outputs.
Inheritance Hierarchy
SystemObject
IO.Objects.GPIO.PWMPin

Namespace: IO.Objects.GPIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Constructor for a single GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
Remarks
Use cases for this class include ON/OFF things like an LED or a solenoid valve driven from a PWM output.
See Also

Reference

IO.Objects.GPIO.PWM Namespace


Pin Constructor

Constructor for a single GPIO pin.

Namespace: IO.Objects.GPIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Output outp,
    bool state = false,
    double dutycycle = 100
)

Parameters

outp Output
PWM output instance.
state Boolean (Optional)
Initial GPIO output state.
dutycycle Double (Optional)
Initial PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.
See Also

Reference

Pin Class
IO.Objects.GPIO.PWM Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Objects.GPIO.PWM Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Objects.GPIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Objects.GPIO.PWM Namespace


IO.Objects.Message64.UDP Namespace

64-Byte Message Services over UDP
Classes
 | Class | Description
Public class | Messenger | 64-Byte Message Transport Client Services using UDP (User Datagram Protocol).


Messenger Class

64-Byte Message Transport Client Services using UDP (User Datagram Protocol).
Inheritance Hierarchy
SystemObject
IO.Objects.Message64.UDPMessenger

Namespace: IO.Objects.Message64.UDP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Messenger : Messenger

The Messenger type exposes the following members.

Constructors
 | Name | Description
Public method | Messenger | Constructor for a 64-byte Messenger instance using UDP.
Top
Methods
 | Name | Description
Public method | Receive | Receive a 64-byte response message from a raw HID device.
Public method | Send | Send a 64-byte command message to a raw HID device.
Public method | Transaction | Send a 64-byte command message and receive a 64-byte response message.
Top
See Also

Reference

IO.Objects.Message64.UDP Namespace


Messenger Constructor

Constructor for a 64-byte Messenger instance using UDP.

Namespace: IO.Objects.Message64.UDP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Messenger(
    string host,
    int port,
    int timeoutms = 1000
)

Parameters

host String
UDP server domain name or IP address.
port Int32
UDP server port number.
timeoutms Int32 (Optional)
Receive timeout in milliseconds. Zero indicates wait forever.
See Also

Reference

Messenger Class
IO.Objects.Message64.UDP Namespace


Messenger Methods

The Messenger type exposes the following members.

Methods
 | Name | Description
Public method | Receive | Receive a 64-byte response message from a raw HID device.
Public method | Send | Send a 64-byte command message to a raw HID device.
Public method | Transaction | Send a 64-byte command message and receive a 64-byte response message.
Top
See Also

Reference

Messenger Class
IO.Objects.Message64.UDP Namespace


Messenger.Receive Method

MessengerReceive Method

Receive a 64-byte response message from a raw HID device.

Namespace: IO.Objects.Message64.UDP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Receive(
    Message resp
)

Parameters

resp Message
64-byte response message.

Implements

MessengerReceive(Message)
See Also

Reference

Messenger Class
IO.Objects.Message64.UDP Namespace


Messenger.Send Method

MessengerSend Method

Send a 64-byte command message to a raw HID device.

Namespace: IO.Objects.Message64.UDP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    Message cmd
)

Parameters

cmd Message
64-byte command message.

Implements

MessengerSend(Message)
See Also

Reference

Messenger Class
IO.Objects.Message64.UDP Namespace


Messenger.Transaction Method

MessengerTransaction Method

Send a 64-byte command message and receive a 64-byte response message.

Namespace: IO.Objects.Message64.UDP
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    Message cmd,
    Message resp
)

Parameters

cmd Message
64-byte command message.
resp Message
64-byte response message.

Implements

MessengerTransaction(Message, Message)
See Also

Reference

Messenger Class
IO.Objects.Message64.UDP Namespace


IO.Objects.Motor.PWM Namespace

PWM Controlled Motor Services
Classes
 | Class | Description
Public class | Output | Encapsulates motors controlled by PWM and GPIO outputs.


Output Class

Encapsulates motors controlled by PWM and GPIO outputs.
Inheritance Hierarchy
SystemObject
IO.Objects.Motor.PWMOutput

Namespace: IO.Objects.Motor.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output(Output, Output, Double) | Constructor for a single motor, using two PWM outputs for clockwise and counterclockwise rotation control.
Public method | Output(Pin, Output, Double) | Constructor for a single motor, using one GPIO pin for direction control, and one PWM output for speed control.
Top
Properties
 | Name | Description
Public property | velocity | Write-only property for setting the normalized motor velocity. Allowed values are -1.0 (full speed reverse) to +1.0 (full speed forward).
Top
See Also

Reference

IO.Objects.Motor.PWM Namespace


Output Constructor

Overload List
 | Name | Description
Public method | Output(Output, Output, Double) | Constructor for a single motor, using two PWM outputs for clockwise and counterclockwise rotation control.
Public method | Output(Pin, Output, Double) | Constructor for a single motor, using one GPIO pin for direction control, and one PWM output for speed control.
Top
See Also

Reference

Output Class
IO.Objects.Motor.PWM Namespace


Output(Output, Output, Double) Constructor

Constructor for a single motor, using two PWM outputs for clockwise and counterclockwise rotation control.

Namespace: IO.Objects.Motor.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Output clockwise,
    Output counterclockwise,
    double velocity = 0
)

Parameters

clockwise Output
PWM output instance (for clockwise rotation control).
counterclockwise Output
PWM output instance (for counterclockwise rotation control).
velocity Double (Optional)
Initial motor velocity.
See Also

Reference

Output Class
Output Overload
IO.Objects.Motor.PWM Namespace


Output(Pin, Output, Double) Constructor

Constructor for a single motor, using one GPIO pin for direction control, and one PWM output for speed control.

Namespace: IO.Objects.Motor.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Pin direction,
    Output speed,
    double velocity = 0
)

Parameters

direction Pin
GPIO pin instance (for direction control).
speed Output
PWM output instance (for speed control).
velocity Double (Optional)
Initial motor velocity.
See Also

Reference

Output Class
Output Overload
IO.Objects.Motor.PWM Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | velocity | Write-only property for setting the normalized motor velocity. Allowed values are -1.0 (full speed reverse) to +1.0 (full speed forward).
Top
See Also

Reference

Output Class
IO.Objects.Motor.PWM Namespace


Output.velocity Property

Outputvelocity Property

Write-only property for setting the normalized motor velocity. Allowed values are -1.0 (full speed reverse) to +1.0 (full speed forward).

Namespace: IO.Objects.Motor.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double velocity { set; }

Property Value

Double

Implements

Outputvelocity
See Also

Reference

Output Class
IO.Objects.Motor.PWM Namespace


IO.Objects.Motor.Servo Namespace

Servo Controlled Motor (e.g. continuous rotation servo) Services
Classes
 | Class | Description
Public class | Output | Encapsulates motors controlled by servo outputs (e.g. continuous rotation servos).


Output Class

Encapsulates motors controlled by servo outputs (e.g. continuous rotation servos).
Inheritance Hierarchy
SystemObject
IO.Objects.Motor.ServoOutput

Namespace: IO.Objects.Motor.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Constructor for a single motor output.
Top
Properties
 | Name | Description
Public property | velocity | Write-only property for setting the normalized motor velocity. Allowed values are -1.0 (full speed reverse) to +1.0 (full speed forward.
Top
See Also

Reference

IO.Objects.Motor.Servo Namespace


Output Constructor

Constructor for a single motor output.

Namespace: IO.Objects.Motor.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Output servo,
    double velocity = 0
)

Parameters

servo Output
Servo output instance.
velocity Double (Optional)
Initial motor velocity.
See Also

Reference

Output Class
IO.Objects.Motor.Servo Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | velocity | Write-only property for setting the normalized motor velocity. Allowed values are -1.0 (full speed reverse) to +1.0 (full speed forward.
Top
See Also

Reference

Output Class
IO.Objects.Motor.Servo Namespace


Output.velocity Property

Outputvelocity Property

Write-only property for setting the normalized motor velocity. Allowed values are -1.0 (full speed reverse) to +1.0 (full speed forward.

Namespace: IO.Objects.Motor.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double velocity { set; }

Property Value

Double

Implements

Outputvelocity
See Also

Reference

Output Class
IO.Objects.Motor.Servo Namespace


IO.Objects.RemoteIO Namespace

Remote I/O Device Framework, for sending commands and receiving response to/from Remote I/O Protocol devices.
Classes
 | Class | Description
Public class | ADC | Encapsulates remote A/D inputs.
Public class | DAC | Encapsulates remote D/A outputs.
Public class | Device | Encasulates a Remote I/O Protocol server device.
Public class | GPIO | Encapsulates remote GPIO pins.
Public class | I2C | Encapsulates remote I2C buses.
Public class | PWM | Encapsulates remote PWM outputs.
Public class | SPI | Encapsulates remote SPI slave devices.
Enumerations
 | Enumeration | Description
Public enumeration | MessageTypes | Remote I/O protocol message types
Public enumeration | PeripheralTypes | Types of remote peripherals


ADC Class

Encapsulates remote A/D inputs.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIOADC

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class ADC : Sample

The ADC type exposes the following members.

Constructors
 | Name | Description
Public method | ADC | Create a remote A/D input.
Top
Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog input sample.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


ADC Constructor

Create a remote A/D input.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public ADC(
    Device dev,
    int num
)

Parameters

dev Device
Remote I/O device object.
num Int32
A/D input number: 0 to 127.
Remarks
Use Device.ADC_Create() instead of this constructor.
See Also

Reference

ADC Class
IO.Objects.RemoteIO Namespace


ADC Properties

The ADC type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog input sample.
Top
See Also

Reference

ADC Class
IO.Objects.RemoteIO Namespace


ADC.resolution Property

ADCresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

ADC Class
IO.Objects.RemoteIO Namespace


ADC.sample Property

ADCsample Property

Read-only property returning an integer analog input sample.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { get; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

ADC Class
IO.Objects.RemoteIO Namespace


DAC Class

Encapsulates remote D/A outputs.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIODAC

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class DAC : Sample

The DAC type exposes the following members.

Constructors
 | Name | Description
Public method | DAC | Create a remote D/A output.
Top
Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for writing an integer analog sample to a DAC output.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


DAC Constructor

Create a remote D/A output.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public DAC(
    Device dev,
    int num,
    int sample = 0
)

Parameters

dev Device
Remote I/O device object.
num Int32
D/A output number: 0 to 127.
sample Int32 (Optional)
Initial DAC output sample.
Remarks
Use Device.DAC_Create() instead of this constructor.
See Also

Reference

DAC Class
IO.Objects.RemoteIO Namespace


DAC Properties

The DAC type exposes the following members.

Properties
 | Name | Description
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for writing an integer analog sample to a DAC output.
Top
See Also

Reference

DAC Class
IO.Objects.RemoteIO Namespace


DAC.resolution Property

DACresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

DAC Class
IO.Objects.RemoteIO Namespace


DAC.sample Property

DACsample Property

Write-only property for writing an integer analog sample to a DAC output.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { set; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

DAC Class
IO.Objects.RemoteIO Namespace


Device Class

Encasulates a Remote I/O Protocol server device.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIODevice

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device(Messenger) | Create a Remote I/O server device object using a Messenger transport object.
Public method | Device(String, Int32, Int32) | Create a Remote I/O server device object using UDP transport.
Public method | Device(Int32, Int32, String, Int32) | Create a Remote I/O server device object using USB Raw HID transport.
Top
Properties
 | Name | Description
Public property | Capabilities | Capability string from the Remote I/O device.
Public property | Version | Version string from the Remote I/O device.
Top
Methods
 | Name | Description
Public method | ADC_Available | Query available A/D inputs.
Public method | ADC_Create | Create a remote A/D input.
Public method | DAC_Available | Query available D/A outputs.
Public method | DAC_Create | Create a remote D/A output.
Public method | Dispatcher | Command dispatcher.
Public method | GPIO_Available | Query available GPIO pins.
Public method | GPIO_Create | Create a remote GPIO pin object.
Public method | I2C_Available | Query available I2C buses.
Public method | I2C_Create | Create a remote I2C bus controller.
Public method | PWM_Available | Query available PWM outputs.
Public method | PWM_Create | Create a remote PWM output.
Public method | SPI_Available | Query available SPI slave devices.
Public method | SPI_Create | Create a remote SPI slave device.
Top
Fields
Name | Description
MAX_CHANNELS | Maximum number of channels each subsystem can support.
Unavailable | Designator for an unavailable channel.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


Device Constructor

Overload List
 | Name | Description
Public method | Device(Messenger) | Create a Remote I/O server device object using a Messenger transport object.
Public method | Device(String, Int32, Int32) | Create a Remote I/O server device object using UDP transport.
Public method | Device(Int32, Int32, String, Int32) | Create a Remote I/O server device object using USB Raw HID transport.
Top
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device(Messenger) Constructor

Create a Remote I/O server device object using a Messenger transport object.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Messenger m
)

Parameters

m Messenger
Messenger transport object.
See Also

Reference

Device Class
Device Overload
IO.Objects.RemoteIO Namespace


Device(String, Int32, Int32) Constructor

Create a Remote I/O server device object using UDP transport.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    string host,
    int port = 8087,
    int timeoutms = 1000
)

Parameters

host String
UDP server domain name or IP address.
port Int32 (Optional)
UDP server port number.
timeoutms Int32 (Optional)
Receive timeout in milliseconds. Zero indicates wait forever.
See Also

Reference

Device Class
Device Overload
IO.Objects.RemoteIO Namespace


Device(Int32, Int32, String, Int32) Constructor

Create a Remote I/O server device object using USB Raw HID transport.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    int VID = 5840,
    int PID = 2810,
    string serialnumber = null,
    int timeoutms = 1000
)

Parameters

VID Int32 (Optional)
Vendor ID
PID Int32 (Optional)
Product
serialnumber String (Optional)
Serial number
timeoutms Int32 (Optional)
Time in milliseconds to wait for read and write operations to complete. Zero means wait forever.
See Also

Reference

Device Class
Device Overload
IO.Objects.RemoteIO Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Capabilities | Capability string from the Remote I/O device.
Public property | Version | Version string from the Remote I/O device.
Top
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.Capabilities Property

DeviceCapabilities Property

Capability string from the Remote I/O device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public string Capabilities { get; }

Property Value

String
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.Version Property

DeviceVersion Property

Version string from the Remote I/O device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public string Version { get; }

Property Value

String
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | ADC_Available | Query available A/D inputs.
Public method | ADC_Create | Create a remote A/D input.
Public method | DAC_Available | Query available D/A outputs.
Public method | DAC_Create | Create a remote D/A output.
Public method | Dispatcher | Command dispatcher.
Public method | GPIO_Available | Query available GPIO pins.
Public method | GPIO_Create | Create a remote GPIO pin object.
Public method | I2C_Available | Query available I2C buses.
Public method | I2C_Create | Create a remote I2C bus controller.
Public method | PWM_Available | Query available PWM outputs.
Public method | PWM_Create | Create a remote PWM output.
Public method | SPI_Available | Query available SPI slave devices.
Public method | SPI_Create | Create a remote SPI slave device.
Top
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.ADC_Available Method

DeviceADC_Available Method

Query available A/D inputs.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public List<int> ADC_Available()

Return Value

List Int32
List of available A/D input numbers.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.ADC_Create Method

DeviceADC_Create Method

Create a remote A/D input.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample ADC_Create(
    int num
)

Parameters

num Int32
A/D input number: 0 to 127.

Return Value

Sample
A/D input object.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.DAC_Available Method

DeviceDAC_Available Method

Query available D/A outputs.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public List<int> DAC_Available()

Return Value

List Int32
List of available D/A output numbers.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.DAC_Create Method

DeviceDAC_Create Method

Create a remote D/A output.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample DAC_Create(
    int num,
    int sample = 0
)

Parameters

num Int32
D/A output number: 0 to 127.
sample Int32 (Optional)
Initial DAC output sample.

Return Value

Sample
D/A output object.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.Dispatcher Method

DeviceDispatcher Method

Command dispatcher.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Dispatcher(
    Message cmd,
    Message resp
)

Parameters

cmd Message
Command to be sent.
resp Message
Response to be received.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.GPIO_Available Method

DeviceGPIO_Available Method

Query available GPIO pins.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public List<int> GPIO_Available()

Return Value

List Int32
List of available GPIO pin numbers.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.GPIO_Create Method

DeviceGPIO_Create Method

Create a remote GPIO pin object.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin GPIO_Create(
    int num,
    Direction dir,
    bool state = false
)

Parameters

num Int32
GPIO pin number: 0 to 127.
dir Direction
GPIO pin data direction: Input or Output.
state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO pin object.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.I2C_Available Method

DeviceI2C_Available Method

Query available I2C buses.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public List<int> I2C_Available()

Return Value

List Int32
List of available I2C bus numbers.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.I2C_Create Method

DeviceI2C_Create Method

Create a remote I2C bus controller.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Bus I2C_Create(
    int num,
    int speed = 100000
)

Parameters

num Int32
I2C bus number: 0 to 127.
speed Int32 (Optional)
I2C bus clock frequency in Hz

Return Value

Bus
I2C bus controller object.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.PWM_Available Method

DevicePWM_Available Method

Query available PWM outputs.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public List<int> PWM_Available()

Return Value

List Int32
List of available PWM output numbers.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.PWM_Create Method

DevicePWM_Create Method

Create a remote PWM output.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output PWM_Create(
    int num,
    int freq,
    double duty = 0
)

Parameters

num Int32
PWM output number: 0 to 127.
freq Int32
PWM pulse frequency in Hz.
duty Double (Optional)
Initial PWM output duty cycle.

Return Value

Output
PWM output object.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.SPI_Available Method

DeviceSPI_Available Method

Query available SPI slave devices.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public List<int> SPI_Available()

Return Value

List Int32
List of available SPI slave device numbers.
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.SPI_Create Method

DeviceSPI_Create Method

Create a remote SPI slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device SPI_Create(
    int num,
    int mode,
    int wordsize,
    int speed
)

Parameters

num Int32
SPI slave device number: 0 to 127.
mode Int32
SPI transfer mode: 0 to 3.
wordsize Int32
SPI transfer word size: 8, 16, or 32.
speed Int32
SPI transfer speed in bits per second.

Return Value

Device
SPI slave device object.
Remarks

The actual SPI transfer rate will be the highest realizable rate that does not exceed the value specified in speed.

See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device Fields

The Device type exposes the following members.

Fields
Name | Description
MAX_CHANNELS | Maximum number of channels each subsystem can support.
Unavailable | Designator for an unavailable channel.
Top
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.MAX_CHANNELS Field

DeviceMAX_CHANNELS Field

Maximum number of channels each subsystem can support.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int MAX_CHANNELS = 128

Field Value

Int32
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


Device.Unavailable Field

DeviceUnavailable Field

Designator for an unavailable channel.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int Unavailable = -1

Field Value

Int32
See Also

Reference

Device Class
IO.Objects.RemoteIO Namespace


GPIO Class

Encapsulates remote GPIO pins.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIOGPIO

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class GPIO : Pin

The GPIO type exposes the following members.

Constructors
 | Name | Description
Public method | GPIO | Create a remote GPIO pin.
Top
Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


GPIO Constructor

Create a remote GPIO pin.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public GPIO(
    Device dev,
    int num,
    Direction dir,
    bool state = false
)

Parameters

dev Device
Remote I/O device object.
num Int32
GPIO pin number: 0 to 127.
dir Direction
GPIO pin data direction: Input or Output.
state Boolean (Optional)
Initial GPIO output state.
Remarks
Use Device.GPIO_Create() instead of this constructor.
See Also

Reference

GPIO Class
IO.Objects.RemoteIO Namespace


GPIO Properties

The GPIO type exposes the following members.

Properties
 | Name | Description
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

GPIO Class
IO.Objects.RemoteIO Namespace


GPIO.state Property

GPIOstate Property

Read/Write GPIO state property.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

GPIO Class
IO.Objects.RemoteIO Namespace


I2C Class

Encapsulates remote I2C buses.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIOI2C

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class I2C : Bus

The I2C type exposes the following members.

Constructors
 | Name | Description
Public method | I2C | Create a remote I2C bus controller.
Top
Methods
 | Name | Description
Public method | Read | Read bytes from an I2C slave device.
Public method | Transaction | Write and read bytes to and from an I2C slave device.
Public method | Write | Write bytes to an I2C slave device.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


I2C Constructor

Create a remote I2C bus controller.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public I2C(
    Device dev,
    int num,
    int speed = 100000
)

Parameters

dev Device
Remote I/O device object.
num Int32
I2C bus number: 0 to 127.
speed Int32 (Optional)
I2C bus clock frequency in Hz
Remarks
Use Device.I2C_Create() instead of this constructor.
See Also

Reference

I2C Class
IO.Objects.RemoteIO Namespace


I2C Methods

The I2C type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an I2C slave device.
Public method | Transaction | Write and read bytes to and from an I2C slave device.
Public method | Write | Write bytes to an I2C slave device.
Top
See Also

Reference

I2C Class
IO.Objects.RemoteIO Namespace


I2C.Read Method

I2CRead Method

Read bytes from an I2C slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Read(
    int slaveaddr,
    byte[] resp,
    int resplen
)

Parameters

slaveaddr Int32
I2C slave address.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.

Implements

BusRead(Int32, Byte, Int32)
See Also

Reference

I2C Class
IO.Objects.RemoteIO Namespace


I2C.Transaction Method

I2CTransaction Method

Write and read bytes to and from an I2C slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    int slaveaddr,
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus
)

Parameters

slaveaddr Int32
I2C slave address.
cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
delayus Int32
Delay in microseconds between the I2C write and read cycles. Allowed values are 0 to 65535 microseconds.

Implements

BusTransaction(Int32, Byte, Int32, Byte, Int32, Int32)
See Also

Reference

I2C Class
IO.Objects.RemoteIO Namespace


I2C.Write Method

I2CWrite Method

Write bytes to an I2C slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    int slaveaddr,
    byte[] cmd,
    int cmdlen
)

Parameters

slaveaddr Int32
I2C slave address.
cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.

Implements

BusWrite(Int32, Byte, Int32)
See Also

Reference

I2C Class
IO.Objects.RemoteIO Namespace


MessageTypes Enumeration

Remote I/O protocol message types

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum MessageTypes
Members
Member name | Value | Description
LOOPBACK_REQUEST | 0 | Loopback request
LOOPBACK_RESPONSE | 1 | Loopback response
VERSION_REQUEST | 2 | Version string request
VERSION_RESPONSE | 3 | Version string response
CAPABILITY_REQUEST | 4 | Capability string request
CAPABILITY_RESPONSE | 5 | Capability string response
GPIO_PRESENT_REQUEST | 6 | GPIO pins available request
GPIO_PRESENT_RESPONSE | 7 | GPIO pins available response
GPIO_CONFIGURE_REQUEST | 8 | GPIO pins configure request
GPIO_CONFIGURE_RESPONSE | 9 | GPIO pins configure response
GPIO_READ_REQUEST | 10 | GPIO pins read request
GPIO_READ_RESPONSE | 11 | GPIO pins read response
GPIO_WRITE_REQUEST | 12 | GPIO pins write request
GPIO_WRITE_RESPONSE | 13 | GPIO pins write response
I2C_PRESENT_REQUEST | 14 | I2C buses available request
I2C_PRESENT_RESPONSE | 15 | I2C buses available response
I2C_CONFIGURE_REQUEST | 16 | I2C bus configure request
I2C_CONFIGURE_RESPONSE | 17 | I2C bus configure response
I2C_TRANSACTION_REQUEST | 18 | I2C bus transaction request
I2C_TRANSACTION_RESPONSE | 19 | I2C bus transaction response
SPI_PRESENT_REQUEST | 20 | SPI slave devices available request
SPI_PRESENT_RESPONSE | 21 | SPI slave devices available response
SPI_CONFIGURE_REQUEST | 22 | SPI slave device configure request
SPI_CONFIGURE_RESPONSE | 23 | SPI slave device configure response
SPI_TRANSACTION_REQUEST | 24 | SPI bus transaction request
SPI_TRANSACTION_RESPONSE | 25 | SPI bus transaction response
ADC_PRESENT_REQUEST | 26 | ADC inputs available request
ADC_PRESENT_RESPONSE | 27 | ADC inputs available response
ADC_CONFIGURE_REQUEST | 28 | ADC input configure request
ADC_CONFIGURE_RESPONSE | 29 | ADC input configure response
ADC_READ_REQUEST | 30 | ADC input read request
ADC_READ_RESPONSE | 31 | ADC input read response
DAC_PRESENT_REQUEST | 32 | DAC outputs available request
DAC_PRESENT_RESPONSE | 33 | DAC outputs available response
DAC_CONFIGURE_REQUEST | 34 | DAC output configure request
DAC_CONFIGURE_RESPONSE | 35 | DAC output configure response
DAC_WRITE_REQUEST | 36 | DAC output write request
DAC_WRITE_RESPONSE | 37 | DAC output write response
PWM_PRESENT_REQUEST | 38 | PWM outputs available request
PWM_PRESENT_RESPONSE | 39 | PWM outputs available response
PWM_CONFIGURE_REQUEST | 40 | PWM input configure request
PWM_CONFIGURE_RESPONSE | 41 | PWM input configure response
PWM_WRITE_REQUEST | 42 | PWM output write request
PWM_WRITE_RESPONSE | 43 | PWM output write response
See Also

Reference

IO.Objects.RemoteIO Namespace


PeripheralTypes Enumeration

Types of remote peripherals

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum PeripheralTypes
Members
Member name | Value | Description
ADC | 0 | A/D inputs
DAC | 1 | D/A outputs
GPIO | 2 | GPIO pins
I2C | 3 | I2C bus controllers
PWM | 4 | SPI slave devices
SPI | 5 | PWM outputs
See Also

Reference

IO.Objects.RemoteIO Namespace


PWM Class

Encapsulates remote PWM outputs.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIOPWM

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class PWM : Output

The PWM type exposes the following members.

Constructors
 | Name | Description
Public method | PWM | Create a remote PWM output.
Top
Properties
 | Name | Description
Public property | dutycycle | Write-only property for setting the PWM output duty cycle.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


PWM Constructor

Create a remote PWM output.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public PWM(
    Device dev,
    int num,
    int freq,
    double duty = 0
)

Parameters

dev Device
Remote I/O device object.
num Int32
PWM output number: 0 to 127.
freq Int32
PWM pulse frequency in Hz.
duty Double (Optional)
Initial PWM output duty cycle.
Remarks
Use Device.PWM_Create() instead of this constructor.
See Also

Reference

PWM Class
IO.Objects.RemoteIO Namespace


PWM Properties

The PWM type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only property for setting the PWM output duty cycle.
Top
See Also

Reference

PWM Class
IO.Objects.RemoteIO Namespace


PWM.dutycycle Property

PWMdutycycle Property

Write-only property for setting the PWM output duty cycle.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double dutycycle { set; }

Property Value

Double

Implements

Outputdutycycle
See Also

Reference

PWM Class
IO.Objects.RemoteIO Namespace


SPI Class

Encapsulates remote SPI slave devices.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIOSPI

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class SPI : Device

The SPI type exposes the following members.

Constructors
 | Name | Description
Public method | SPI | Create a remote SPI slave device.
Top
Methods
 | Name | Description
Public method | Read | Read bytes from an SPI slave device.
Public method | Transaction | Write and read bytes to and from an SPI slave device.
Public method | Write | Write bytes to an SPI slave device.
Top
See Also

Reference

IO.Objects.RemoteIO Namespace


SPI Constructor

Create a remote SPI slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public SPI(
    Device dev,
    int num,
    int mode,
    int wordsize,
    int speed
)

Parameters

dev Device
Remote I/O device object.
num Int32
SPI slave device number: 0 to 127.
mode Int32
SPI transfer mode: 0 to 3.
wordsize Int32
SPI transfer word size: 8, 16, or 32.
speed Int32
SPI transfer speed in bits per second.
Remarks

Use Device.SPI_Create() instead of this constructor.

The actual SPI transfer rate will be the highest realizable rate that does not exceed the value specified in speed.

See Also

Reference

SPI Class
IO.Objects.RemoteIO Namespace


SPI Methods

The SPI type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an SPI slave device.
Public method | Transaction | Write and read bytes to and from an SPI slave device.
Public method | Write | Write bytes to an SPI slave device.
Top
See Also

Reference

SPI Class
IO.Objects.RemoteIO Namespace


SPI.Read Method

SPIRead Method

Read bytes from an SPI slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Read(
    byte[] resp,
    int resplen
)

Parameters

resp Byte
Response buffer.
resplen Int32
Number of bytes to read: 1 to 60.

Implements

DeviceRead(Byte, Int32)
See Also

Reference

SPI Class
IO.Objects.RemoteIO Namespace


SPI.Transaction Method

SPITransaction Method

Write and read bytes to and from an SPI slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus = 0
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write: 0 to 57.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read: 0 to 60.
delayus Int32 (Optional)
Delay in microseconds between write and read operations: 0 to 65535.

Implements

DeviceTransaction(Byte, Int32, Byte, Int32, Int32)
See Also

Reference

SPI Class
IO.Objects.RemoteIO Namespace


SPI.Write Method

SPIWrite Method

Write bytes to an SPI slave device.

Namespace: IO.Objects.RemoteIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte[] cmd,
    int cmdlen
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write: 1 to 57.

Implements

DeviceWrite(Byte, Int32)
See Also

Reference

SPI Class
IO.Objects.RemoteIO Namespace


IO.Objects.RemoteIO.mikroBUS Namespace

Mikroelektronika mikroBUS (https://www.mikroe.com/mikrobus) Remote I/O protocol Server and Socket Services
Classes
 | Class | Description
Public class | Shield | Encapsulates mikroBUS shields on Remote I/O Protocol servers providing mikroBUS sockets).
Public class | Socket | Encapsulates mikroBUS sockets.
Enumerations
 | Enumeration | Description
Public enumeration | ShieldKinds | Supported mikroBUS shields.


Shield Class

Encapsulates mikroBUS shields on Remote I/O Protocol servers providing mikroBUS sockets).
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.mikroBUSShield

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Shield

The Shield type exposes the following members.

Properties
Name | Description
kind | Returns the kind of mikroBUS shield that is installed on the Remote I/O Protocol server, as obtained from the SHIELDNAME environment variable.
Top
Fields
Name | Description
I2CBus | Shared I2C bus that is common to all sockets on this shield.
Top
See Also

Reference

IO.Objects.RemoteIO.mikroBUS Namespace


Shield Properties

The Shield type exposes the following members.

Properties
Name | Description
kind | Returns the kind of mikroBUS shield that is installed on the Remote I/O Protocol server, as obtained from the SHIELDNAME environment variable.
Top
See Also

Reference

Shield Class
IO.Objects.RemoteIO.mikroBUS Namespace


Shield.kind Property

Shieldkind Property

Returns the kind of mikroBUS shield that is installed on the Remote I/O Protocol server, as obtained from the SHIELDNAME environment variable.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static ShieldKinds kind { get; }

Property Value

ShieldKinds
See Also

Reference

Shield Class
IO.Objects.RemoteIO.mikroBUS Namespace


Shield Fields

The Shield type exposes the following members.

Fields
Name | Description
I2CBus | Shared I2C bus that is common to all sockets on this shield.
Top
See Also

Reference

Shield Class
IO.Objects.RemoteIO.mikroBUS Namespace


Shield.I2CBus Field

ShieldI2CBus Field

Shared I2C bus that is common to all sockets on this shield.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Bus I2CBus

Field Value

Bus
See Also

Reference

Shield Class
IO.Objects.RemoteIO.mikroBUS Namespace


Shield.Kinds Enumeration

ShieldKinds Enumeration

Supported mikroBUS shields.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Kinds
Members
Member name | Value | Description
BeagleBoneClick2 | 0 | Mikroelektronika BeagleBone Click Shield MIKROE-1596, with two mikroBUS sockets. (Obsolete, but still useful.)
BeagleBoneClick4 | 1 | Mikroelektronika mikroBUS Cape MIKROE-1857 with four mikroBUS sockets.
PiClick1 | 2 | Raspberry Pi with Mikroelektronika Pi Click Shield MIKROE-1512/1513 for 26-pin expansion header, with one mikroBUS socket (Obsolete.)
PiClick2 | 3 | Raspberry Pi with Mikroelektronika Pi 2 Click Shield MIKROE-1879 for 40-pin expansion header, with two mikroBUS sockets.
PiClick3 | 4 | Mikroelektronika Pi 3 Click Shield MIKROE-2756 for 40-pin expansion header, with selectable on-board A/D converter and two mikroBUS sockets.
PocketBeagle | 5 | PocketBeagle with female headers on top, with two mikroBUS sockets.
Unknown | 2,147,483,647 | No known mikroBUS shield installed.
See Also

Reference

IO.Objects.RemoteIO.mikroBUS Namespace


Socket Class

Encapsulates mikroBUS sockets.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.mikroBUSSocket

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Socket

The Socket type exposes the following members.

Constructors
 | Name | Description
Public method | Socket | Constructor for a single mikroBUS socket.
Top
Properties
 | Name | Description
Public property | AIN | Returns the ADC input designator for AN.
Public property | AN | Returns the GPIO pin designator for AN.
Public property | CS | Returns the GPIO pin designator for CS.
Public property | I2CBus | Returns the I2C bus designator for this socket.
Public property | INT | Returns the GPIO pin designator for INT.
Public property | MISO | Returns the GPIO pin designator for MISO.
Public property | MOSI | Returns the GPIO pin designator for MOSI.
Public property | PWM | Returns the GPIO pin designator for PWM.
Public property | PWMOut | Returns the PWM output designator for PWM.
Public property | RST | Returns the GPIO pin designator for RST.
Public property | RX | Returns the GPIO pin designator for RX.
Public property | SCK | Returns the GPIO pin designator for SCK.
Public property | SCL | Returns the GPIO pin designator for SCL.
Public property | SDA | Returns the GPIO pin designator for SDA.
Public property | SPIDev | Returns the SPI device designator for this socket.
Public property | TX | Returns the GPIO pin designator for TX.
Top
See Also

Reference

IO.Objects.RemoteIO.mikroBUS Namespace


Socket Constructor

Constructor for a single mikroBUS socket.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Socket(
    int num,
    ShieldKinds shield = ShieldKinds.Unknown
)

Parameters

num Int32
Socket number.
shield ShieldKinds (Optional)
mikroBUS shield kind. Zero indicates automatic detection using the Shield.kind property.
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket Properties

The Socket type exposes the following members.

Properties
 | Name | Description
Public property | AIN | Returns the ADC input designator for AN.
Public property | AN | Returns the GPIO pin designator for AN.
Public property | CS | Returns the GPIO pin designator for CS.
Public property | I2CBus | Returns the I2C bus designator for this socket.
Public property | INT | Returns the GPIO pin designator for INT.
Public property | MISO | Returns the GPIO pin designator for MISO.
Public property | MOSI | Returns the GPIO pin designator for MOSI.
Public property | PWM | Returns the GPIO pin designator for PWM.
Public property | PWMOut | Returns the PWM output designator for PWM.
Public property | RST | Returns the GPIO pin designator for RST.
Public property | RX | Returns the GPIO pin designator for RX.
Public property | SCK | Returns the GPIO pin designator for SCK.
Public property | SCL | Returns the GPIO pin designator for SCL.
Public property | SDA | Returns the GPIO pin designator for SDA.
Public property | SPIDev | Returns the SPI device designator for this socket.
Public property | TX | Returns the GPIO pin designator for TX.
Top
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.AIN Property

SocketAIN Property

Returns the ADC input designator for AN.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int AIN { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.AN Property

SocketAN Property

Returns the GPIO pin designator for AN.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int AN { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.CS Property

SocketCS Property

Returns the GPIO pin designator for CS.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int CS { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.I2CBus Property

SocketI2CBus Property

Returns the I2C bus designator for this socket.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int I2CBus { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.INT Property

SocketINT Property

Returns the GPIO pin designator for INT.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int INT { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.MISO Property

SocketMISO Property

Returns the GPIO pin designator for MISO.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int MISO { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.MOSI Property

SocketMOSI Property

Returns the GPIO pin designator for MOSI.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int MOSI { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.PWM Property

SocketPWM Property

Returns the GPIO pin designator for PWM.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int PWM { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.PWMOut Property

SocketPWMOut Property

Returns the PWM output designator for PWM.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int PWMOut { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.RST Property

SocketRST Property

Returns the GPIO pin designator for RST.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int RST { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.RX Property

SocketRX Property

Returns the GPIO pin designator for RX.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int RX { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.SCK Property

SocketSCK Property

Returns the GPIO pin designator for SCK.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int SCK { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.SCL Property

SocketSCL Property

Returns the GPIO pin designator for SCL.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int SCL { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.SDA Property

SocketSDA Property

Returns the GPIO pin designator for SDA.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int SDA { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.SPIDev Property

SocketSPIDev Property

Returns the SPI device designator for this socket.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int SPIDev { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


Socket.TX Property

SocketTX Property

Returns the GPIO pin designator for TX.

Namespace: IO.Objects.RemoteIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int TX { get; }

Property Value

Int32
See Also

Reference

Socket Class
IO.Objects.RemoteIO.mikroBUS Namespace


IO.Objects.RemoteIO.Platforms Namespace

I/O Resource Definitions for particular Remote I/O Protocol Server Platforms
Classes
 | Class | Description
Public class | BeagleBone | I/O resources (channel numbers) available on a BeagleBone Remote I/O Protocol Server
Public class | MUNTS_0008 | I/O resources (channel numbers) available on from a MUNTS-0008 USB Grove Adapter.
Public class | MUNTS_0009 | I/O resources (channel numbers) available on from a MUNTS-0009 USB Grove Adapter.
Public class | MUNTS_0015 | I/O resources (channel numbers) available from a MUNTS-0015 USB Remote I/O Protocol Adapter.
Public class | MUNTS_0016 | I/O resources (channel numbers) available from a MUNTS-0016 USB Grove Adapter Remote I/O Protocol Server.
Public class | MUNTS_0018 | I/O resources (channel numbers) available from a MUNTS-0018 Tutorial I/O Board Remote I/O Protocol Server.
Public class | PocketBeagle | I/O resources (channel numbers) available on a BeagleBone Remote I/O Protocol Server
Public class | RaspberryPi | I/O resources (channel numbers) available on a Raspberry Pi Remote I/O Protocol Server


BeagleBone Class

I/O resources (channel numbers) available on a BeagleBone Remote I/O Protocol Server
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsBeagleBone

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class BeagleBone

The BeagleBone type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN0 at pin P9.39.
AIN1 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN1 at pin P9.40.
AIN2 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN2 at pin P9.37.
AIN3 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN3 at pin P9.38.
AIN4 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN4 at pin P9.33.
AIN5 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN5 at pin P9.36.
AIN6 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN6 at pin P9.35.
EHRPWM1A | PWM output channel number for the remote BeagleBone PWM output EHRPWM1A at pins P8.36 or P9.14.
EHRPWM1B | PWM output channel number for the remote BeagleBone PWM output EHRPWM1B at pins P8.34 or P9.16.
EHRPWM2A | PWM output channel number for the remote BeagleBone PWM output EHRPWM2A at pins P8.19 or P8.45.
EHRPWM2B | PWM output channel number for the remote BeagleBone PWM output EHRPWM2B at pins P8.13 or P8.46.
GPIO10 | GPIO channel number for the remote BeagleBone GPIO pin GPIO10 at pin P8.31.
GPIO11 | GPIO channel number for the remote BeagleBone GPIO pin GPIO11 at pin P8.32.
GPIO110 | GPIO channel number for the remote BeagleBone GPIO pin GPIO110 at pin P9.31.
GPIO111 | GPIO channel number for the remote BeagleBone GPIO pin GPIO111 at pin P9.29.
GPIO112 | GPIO channel number for the remote BeagleBone GPIO pin GPIO112 at pin P9.30.
GPIO113 | GPIO channel number for the remote BeagleBone GPIO pin GPIO113 at pin P9.28.
GPIO115 | GPIO channel number for the remote BeagleBone GPIO pin GPIO115 at pin P9.27.
GPIO117 | GPIO channel number for the remote BeagleBone GPIO pin GPIO117 at pin P9.25.
GPIO12 | GPIO channel number for the remote BeagleBone GPIO pin GPIO12 at pin P9.20.
GPIO13 | GPIO channel number for the remote BeagleBone GPIO pin GPIO13 at pin P9.19.
GPIO14 | GPIO channel number for the remote BeagleBone GPIO pin GPIO14 at pin P9.26.
GPIO15 | GPIO channel number for the remote BeagleBone GPIO pin GPIO15 at pin P9.24.
GPIO2 | GPIO channel number for the remote BeagleBone GPIO pin GPIO2 at pin P9.22.
GPIO20 | GPIO channel number for the remote BeagleBone GPIO pin GPIO20 at pin P9.41.
GPIO22 | GPIO channel number for the remote BeagleBone GPIO pin GPIO22 at pin P8.19.
GPIO23 | GPIO channel number for the remote BeagleBone GPIO pin GPIO23 at pin P8.13.
GPIO26 | GPIO channel number for the remote BeagleBone GPIO pin GPIO26 at pin P8.14.
GPIO27 | GPIO channel number for the remote BeagleBone GPIO pin GPIO27 at pin P8.17.
GPIO3 | GPIO channel number for the remote BeagleBone GPIO pin GPIO3 at pin P9.21.
GPIO30 | GPIO channel number for the remote BeagleBone GPIO pin GPIO30 at pin P9.11.
GPIO31 | GPIO channel number for the remote BeagleBone GPIO pin GPIO31 at pin P9.13.
GPIO32 | GPIO channel number for the remote BeagleBone GPIO pin GPIO32 at pin P8.25.
GPIO33 | GPIO channel number for the remote BeagleBone GPIO pin GPIO33 at pin P8.24.
GPIO34 | GPIO channel number for the remote BeagleBone GPIO pin GPIO34 at pin P8.5.
GPIO35 | GPIO channel number for the remote BeagleBone GPIO pin GPIO35 at pin P8.6.
GPIO36 | GPIO channel number for the remote BeagleBone GPIO pin GPIO36 at pin P8.23.
GPIO37 | GPIO channel number for the remote BeagleBone GPIO pin GPIO37 at pin P8.22.
GPIO38 | GPIO channel number for the remote BeagleBone GPIO pin GPIO38 at pin P8.3.
GPIO39 | GPIO channel number for the remote BeagleBone GPIO pin GPIO39 at pin P8.4.
GPIO4 | GPIO channel number for the remote BeagleBone GPIO pin GPIO4 at pin P9.18.
GPIO44 | GPIO channel number for the remote BeagleBone GPIO pin GPIO44 at pin P8.12.
GPIO45 | GPIO channel number for the remote BeagleBone GPIO pin GPIO45 at pin P8.11.
GPIO46 | GPIO channel number for the remote BeagleBone GPIO pin GPIO46 at pin P8.16.
GPIO47 | GPIO channel number for the remote BeagleBone GPIO pin GPIO47 at pin P8.15.
GPIO48 | GPIO channel number for the remote BeagleBone GPIO pin GPIO48 at pin P9.15.
GPIO49 | GPIO channel number for the remote BeagleBone GPIO pin GPIO49 at pin P9.23.
GPIO5 | GPIO channel number for the remote BeagleBone GPIO pin GPIO5 at pin P9.17.
GPIO50 | GPIO channel number for the remote BeagleBone GPIO pin GPIO50 at pin P9.14.
GPIO51 | GPIO channel number for the remote BeagleBone GPIO pin GPIO51 at pin P9.16.
GPIO60 | GPIO channel number for the remote BeagleBone GPIO pin GPIO60 at pin P9.12.
GPIO61 | GPIO channel number for the remote BeagleBone GPIO pin GPIO61 at pin P8.26.
GPIO62 | GPIO channel number for the remote BeagleBone GPIO pin GPIO62 at pin P8.21.
GPIO63 | GPIO channel number for the remote BeagleBone GPIO pin GPIO63 at pin P8.20.
GPIO65 | GPIO channel number for the remote BeagleBone GPIO pin GPIO65 at pin P8.18.
GPIO66 | GPIO channel number for the remote BeagleBone GPIO pin GPIO66 at pin P8.7.
GPIO67 | GPIO channel number for the remote BeagleBone GPIO pin GPIO67 at pin P8.8.
GPIO68 | GPIO channel number for the remote BeagleBone GPIO pin GPIO68 at pin P8.10.
GPIO69 | GPIO channel number for the remote BeagleBone GPIO pin GPIO69 at pin P8.9.
GPIO7 | GPIO channel number for the remote BeagleBone GPIO pin GPIO7 at pin P9.42.
GPIO70 | GPIO channel number for the remote BeagleBone GPIO pin GPIO70 at pin P8.45.
GPIO71 | GPIO channel number for the remote BeagleBone GPIO pin GPIO71 at pin P8.46.
GPIO72 | GPIO channel number for the remote BeagleBone GPIO pin GPIO72 at pin P8.43.
GPIO73 | GPIO channel number for the remote BeagleBone GPIO pin GPIO73 at pin P8.44.
GPIO74 | GPIO channel number for the remote BeagleBone GPIO pin GPIO74 at pin P8.41.
GPIO75 | GPIO channel number for the remote BeagleBone GPIO pin GPIO75 at pin P8.42.
GPIO76 | GPIO channel number for the remote BeagleBone GPIO pin GPIO76 at pin P8.39.
GPIO77 | GPIO channel number for the remote BeagleBone GPIO pin GPIO77 at pin P8.40.
GPIO78 | GPIO channel number for the remote BeagleBone GPIO pin GPIO78 at pin P8.37.
GPIO79 | GPIO channel number for the remote BeagleBone GPIO pin GPIO79 at pin P8.38.
GPIO8 | GPIO channel number for the remote BeagleBone GPIO pin GPIO8 at pin P8.35.
GPIO80 | GPIO channel number for the remote BeagleBone GPIO pin GPIO80 at pin P8.36.
GPIO81 | GPIO channel number for the remote BeagleBone GPIO pin GPIO81 at pin P8.34.
GPIO86 | GPIO channel number for the remote BeagleBone GPIO pin GPIO86 at pin P8.27.
GPIO87 | GPIO channel number for the remote BeagleBone GPIO pin GPIO87 at pin P8.29.
GPIO88 | GPIO channel number for the remote BeagleBone GPIO pin GPIO88 at pin P8.28.
GPIO89 | GPIO channel number for the remote BeagleBone GPIO pin GPIO89 at pin P8.30.
GPIO9 | GPIO channel number for the remote BeagleBone GPIO pin GPIO9 at pin P8.33.
I2C2 | I2C bus channel number for the remote BeagleBone I2C bus at pins P9.19 and P9.20.
SPI0_0 | SPI slave channel number for the remote BeagleBone SPI slave select SPI0_0 at pin P9.17
SPI1_0 | SPI slave channel number for the remote BeagleBone SPI slave select SPI1_0 at pin P9.28
SPI1_1 | SPI slave channel number for the remote BeagleBone SPI slave select SPI1_1 at pin P9.42
USERLED | GPIO channel number for the remote BeagleBone user LED.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


BeagleBone Fields

The BeagleBone type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN0 at pin P9.39.
AIN1 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN1 at pin P9.40.
AIN2 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN2 at pin P9.37.
AIN3 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN3 at pin P9.38.
AIN4 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN4 at pin P9.33.
AIN5 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN5 at pin P9.36.
AIN6 | Analog input channel number for the remote BeagleBone 1.8V analog input AIN6 at pin P9.35.
EHRPWM1A | PWM output channel number for the remote BeagleBone PWM output EHRPWM1A at pins P8.36 or P9.14.
EHRPWM1B | PWM output channel number for the remote BeagleBone PWM output EHRPWM1B at pins P8.34 or P9.16.
EHRPWM2A | PWM output channel number for the remote BeagleBone PWM output EHRPWM2A at pins P8.19 or P8.45.
EHRPWM2B | PWM output channel number for the remote BeagleBone PWM output EHRPWM2B at pins P8.13 or P8.46.
GPIO10 | GPIO channel number for the remote BeagleBone GPIO pin GPIO10 at pin P8.31.
GPIO11 | GPIO channel number for the remote BeagleBone GPIO pin GPIO11 at pin P8.32.
GPIO110 | GPIO channel number for the remote BeagleBone GPIO pin GPIO110 at pin P9.31.
GPIO111 | GPIO channel number for the remote BeagleBone GPIO pin GPIO111 at pin P9.29.
GPIO112 | GPIO channel number for the remote BeagleBone GPIO pin GPIO112 at pin P9.30.
GPIO113 | GPIO channel number for the remote BeagleBone GPIO pin GPIO113 at pin P9.28.
GPIO115 | GPIO channel number for the remote BeagleBone GPIO pin GPIO115 at pin P9.27.
GPIO117 | GPIO channel number for the remote BeagleBone GPIO pin GPIO117 at pin P9.25.
GPIO12 | GPIO channel number for the remote BeagleBone GPIO pin GPIO12 at pin P9.20.
GPIO13 | GPIO channel number for the remote BeagleBone GPIO pin GPIO13 at pin P9.19.
GPIO14 | GPIO channel number for the remote BeagleBone GPIO pin GPIO14 at pin P9.26.
GPIO15 | GPIO channel number for the remote BeagleBone GPIO pin GPIO15 at pin P9.24.
GPIO2 | GPIO channel number for the remote BeagleBone GPIO pin GPIO2 at pin P9.22.
GPIO20 | GPIO channel number for the remote BeagleBone GPIO pin GPIO20 at pin P9.41.
GPIO22 | GPIO channel number for the remote BeagleBone GPIO pin GPIO22 at pin P8.19.
GPIO23 | GPIO channel number for the remote BeagleBone GPIO pin GPIO23 at pin P8.13.
GPIO26 | GPIO channel number for the remote BeagleBone GPIO pin GPIO26 at pin P8.14.
GPIO27 | GPIO channel number for the remote BeagleBone GPIO pin GPIO27 at pin P8.17.
GPIO3 | GPIO channel number for the remote BeagleBone GPIO pin GPIO3 at pin P9.21.
GPIO30 | GPIO channel number for the remote BeagleBone GPIO pin GPIO30 at pin P9.11.
GPIO31 | GPIO channel number for the remote BeagleBone GPIO pin GPIO31 at pin P9.13.
GPIO32 | GPIO channel number for the remote BeagleBone GPIO pin GPIO32 at pin P8.25.
GPIO33 | GPIO channel number for the remote BeagleBone GPIO pin GPIO33 at pin P8.24.
GPIO34 | GPIO channel number for the remote BeagleBone GPIO pin GPIO34 at pin P8.5.
GPIO35 | GPIO channel number for the remote BeagleBone GPIO pin GPIO35 at pin P8.6.
GPIO36 | GPIO channel number for the remote BeagleBone GPIO pin GPIO36 at pin P8.23.
GPIO37 | GPIO channel number for the remote BeagleBone GPIO pin GPIO37 at pin P8.22.
GPIO38 | GPIO channel number for the remote BeagleBone GPIO pin GPIO38 at pin P8.3.
GPIO39 | GPIO channel number for the remote BeagleBone GPIO pin GPIO39 at pin P8.4.
GPIO4 | GPIO channel number for the remote BeagleBone GPIO pin GPIO4 at pin P9.18.
GPIO44 | GPIO channel number for the remote BeagleBone GPIO pin GPIO44 at pin P8.12.
GPIO45 | GPIO channel number for the remote BeagleBone GPIO pin GPIO45 at pin P8.11.
GPIO46 | GPIO channel number for the remote BeagleBone GPIO pin GPIO46 at pin P8.16.
GPIO47 | GPIO channel number for the remote BeagleBone GPIO pin GPIO47 at pin P8.15.
GPIO48 | GPIO channel number for the remote BeagleBone GPIO pin GPIO48 at pin P9.15.
GPIO49 | GPIO channel number for the remote BeagleBone GPIO pin GPIO49 at pin P9.23.
GPIO5 | GPIO channel number for the remote BeagleBone GPIO pin GPIO5 at pin P9.17.
GPIO50 | GPIO channel number for the remote BeagleBone GPIO pin GPIO50 at pin P9.14.
GPIO51 | GPIO channel number for the remote BeagleBone GPIO pin GPIO51 at pin P9.16.
GPIO60 | GPIO channel number for the remote BeagleBone GPIO pin GPIO60 at pin P9.12.
GPIO61 | GPIO channel number for the remote BeagleBone GPIO pin GPIO61 at pin P8.26.
GPIO62 | GPIO channel number for the remote BeagleBone GPIO pin GPIO62 at pin P8.21.
GPIO63 | GPIO channel number for the remote BeagleBone GPIO pin GPIO63 at pin P8.20.
GPIO65 | GPIO channel number for the remote BeagleBone GPIO pin GPIO65 at pin P8.18.
GPIO66 | GPIO channel number for the remote BeagleBone GPIO pin GPIO66 at pin P8.7.
GPIO67 | GPIO channel number for the remote BeagleBone GPIO pin GPIO67 at pin P8.8.
GPIO68 | GPIO channel number for the remote BeagleBone GPIO pin GPIO68 at pin P8.10.
GPIO69 | GPIO channel number for the remote BeagleBone GPIO pin GPIO69 at pin P8.9.
GPIO7 | GPIO channel number for the remote BeagleBone GPIO pin GPIO7 at pin P9.42.
GPIO70 | GPIO channel number for the remote BeagleBone GPIO pin GPIO70 at pin P8.45.
GPIO71 | GPIO channel number for the remote BeagleBone GPIO pin GPIO71 at pin P8.46.
GPIO72 | GPIO channel number for the remote BeagleBone GPIO pin GPIO72 at pin P8.43.
GPIO73 | GPIO channel number for the remote BeagleBone GPIO pin GPIO73 at pin P8.44.
GPIO74 | GPIO channel number for the remote BeagleBone GPIO pin GPIO74 at pin P8.41.
GPIO75 | GPIO channel number for the remote BeagleBone GPIO pin GPIO75 at pin P8.42.
GPIO76 | GPIO channel number for the remote BeagleBone GPIO pin GPIO76 at pin P8.39.
GPIO77 | GPIO channel number for the remote BeagleBone GPIO pin GPIO77 at pin P8.40.
GPIO78 | GPIO channel number for the remote BeagleBone GPIO pin GPIO78 at pin P8.37.
GPIO79 | GPIO channel number for the remote BeagleBone GPIO pin GPIO79 at pin P8.38.
GPIO8 | GPIO channel number for the remote BeagleBone GPIO pin GPIO8 at pin P8.35.
GPIO80 | GPIO channel number for the remote BeagleBone GPIO pin GPIO80 at pin P8.36.
GPIO81 | GPIO channel number for the remote BeagleBone GPIO pin GPIO81 at pin P8.34.
GPIO86 | GPIO channel number for the remote BeagleBone GPIO pin GPIO86 at pin P8.27.
GPIO87 | GPIO channel number for the remote BeagleBone GPIO pin GPIO87 at pin P8.29.
GPIO88 | GPIO channel number for the remote BeagleBone GPIO pin GPIO88 at pin P8.28.
GPIO89 | GPIO channel number for the remote BeagleBone GPIO pin GPIO89 at pin P8.30.
GPIO9 | GPIO channel number for the remote BeagleBone GPIO pin GPIO9 at pin P8.33.
I2C2 | I2C bus channel number for the remote BeagleBone I2C bus at pins P9.19 and P9.20.
SPI0_0 | SPI slave channel number for the remote BeagleBone SPI slave select SPI0_0 at pin P9.17
SPI1_0 | SPI slave channel number for the remote BeagleBone SPI slave select SPI1_0 at pin P9.28
SPI1_1 | SPI slave channel number for the remote BeagleBone SPI slave select SPI1_1 at pin P9.42
USERLED | GPIO channel number for the remote BeagleBone user LED.
Top
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN0 Field

BeagleBoneAIN0 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN0 at pin P9.39.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN1 Field

BeagleBoneAIN1 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN1 at pin P9.40.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN2 Field

BeagleBoneAIN2 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN2 at pin P9.37.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN2 = 2

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN3 Field

BeagleBoneAIN3 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN3 at pin P9.38.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN3 = 3

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN4 Field

BeagleBoneAIN4 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN4 at pin P9.33.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN4 = 4

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN5 Field

BeagleBoneAIN5 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN5 at pin P9.36.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN5 = 5

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.AIN6 Field

BeagleBoneAIN6 Field

Analog input channel number for the remote BeagleBone 1.8V analog input AIN6 at pin P9.35.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN6 = 6

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.EHRPWM1A Field

BeagleBoneEHRPWM1A Field

PWM output channel number for the remote BeagleBone PWM output EHRPWM1A at pins P8.36 or P9.14.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int EHRPWM1A = 0

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.EHRPWM1B Field

BeagleBoneEHRPWM1B Field

PWM output channel number for the remote BeagleBone PWM output EHRPWM1B at pins P8.34 or P9.16.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int EHRPWM1B = 1

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.EHRPWM2A Field

BeagleBoneEHRPWM2A Field

PWM output channel number for the remote BeagleBone PWM output EHRPWM2A at pins P8.19 or P8.45.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int EHRPWM2A = 2

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.EHRPWM2B Field

BeagleBoneEHRPWM2B Field

PWM output channel number for the remote BeagleBone PWM output EHRPWM2B at pins P8.13 or P8.46.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int EHRPWM2B = 3

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO10 Field

BeagleBoneGPIO10 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO10 at pin P8.31.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO10 = 10

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO11 Field

BeagleBoneGPIO11 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO11 at pin P8.32.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO11 = 11

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO110 Field

BeagleBoneGPIO110 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO110 at pin P9.31.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO110 = 110

Field Value

Int32
Remarks
Conflicts with EHRPWM0A or SPI1 SCLK.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO111 Field

BeagleBoneGPIO111 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO111 at pin P9.29.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO111 = 111

Field Value

Int32
Remarks
Conflicts with SPI1 MISO.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO112 Field

BeagleBoneGPIO112 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO112 at pin P9.30.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO112 = 112

Field Value

Int32
Remarks
Conflicts with SPI1 MOSI.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO113 Field

BeagleBoneGPIO113 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO113 at pin P9.28.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO113 = 113

Field Value

Int32
Remarks
Conflicts with SPI1 SS0.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO115 Field

BeagleBoneGPIO115 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO115 at pin P9.27.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO115 = 115

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO117 Field

BeagleBoneGPIO117 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO117 at pin P9.25.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO117 = 117

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO12 Field

BeagleBoneGPIO12 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO12 at pin P9.20.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO12 = 12

Field Value

Int32
Remarks
Conflicts with I2C2 SDA.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO13 Field

BeagleBoneGPIO13 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO13 at pin P9.19.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO13 = 13

Field Value

Int32
Remarks
Conflicts with I2C2 SCL.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO14 Field

BeagleBoneGPIO14 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO14 at pin P9.26.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO14 = 14

Field Value

Int32
Remarks
Conflicts with UART1 RXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO15 Field

BeagleBoneGPIO15 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO15 at pin P9.24.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO15 = 15

Field Value

Int32
Remarks
Conflicts with UART1 TXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO2 Field

BeagleBoneGPIO2 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO2 at pin P9.22.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
Conflicts with EHRPWM0B, SPI0 SCK or UART2 RXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO20 Field

BeagleBoneGPIO20 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO20 at pin P9.41.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO20 = 20

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO22 Field

BeagleBoneGPIO22 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO22 at pin P8.19.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO22 = 22

Field Value

Int32
Remarks
Conflicts with EHRPWM2A.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO23 Field

BeagleBoneGPIO23 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO23 at pin P8.13.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO23 = 23

Field Value

Int32
Remarks
Conflicts with EHRPWM2B.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO26 Field

BeagleBoneGPIO26 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO26 at pin P8.14.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO26 = 26

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO27 Field

BeagleBoneGPIO27 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO27 at pin P8.17.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO27 = 27

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO3 Field

BeagleBoneGPIO3 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO3 at pin P9.21.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
Conflicts with SPI0 MISO or UART2 TXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO30 Field

BeagleBoneGPIO30 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO30 at pin P9.11.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO30 = 30

Field Value

Int32
Remarks
Conflicts with UART4 RXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO31 Field

BeagleBoneGPIO31 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO31 at pin P9.13.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO31 = 31

Field Value

Int32
Remarks
Conflicts with UART4 TXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO32 Field

BeagleBoneGPIO32 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO32 at pin P8.25.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO32 = 32

Field Value

Int32
Remarks
Conflicts with MMC1 DAT0.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO33 Field

BeagleBoneGPIO33 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO33 at pin P8.24.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO33 = 33

Field Value

Int32
Remarks
Conflicts with MMC1 DAT1.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO34 Field

BeagleBoneGPIO34 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO34 at pin P8.5.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO34 = 34

Field Value

Int32
Remarks
Conflicts with MMC1 DAT2.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO35 Field

BeagleBoneGPIO35 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO35 at pin P8.6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO35 = 35

Field Value

Int32
Remarks
Conflicts with MMC1 DAT3.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO36 Field

BeagleBoneGPIO36 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO36 at pin P8.23.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO36 = 36

Field Value

Int32
Remarks
Conflicts with MMC1 DAT4.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO37 Field

BeagleBoneGPIO37 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO37 at pin P8.22.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO37 = 37

Field Value

Int32
Remarks
Conflicts with MMC1 DAT5.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO38 Field

BeagleBoneGPIO38 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO38 at pin P8.3.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO38 = 38

Field Value

Int32
Remarks
Conflicts with MMC1 DAT6.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO39 Field

BeagleBoneGPIO39 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO39 at pin P8.4.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO39 = 39

Field Value

Int32
Remarks
Conflicts with MMC1 DAT7.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO4 Field

BeagleBoneGPIO4 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO4 at pin P9.18.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
Remarks
Conflicts with SPI0 MOSI.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO44 Field

BeagleBoneGPIO44 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO44 at pin P8.12.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO44 = 44

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO45 Field

BeagleBoneGPIO45 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO45 at pin P8.11.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO45 = 45

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO46 Field

BeagleBoneGPIO46 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO46 at pin P8.16.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO46 = 46

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO47 Field

BeagleBoneGPIO47 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO47 at pin P8.15.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO47 = 47

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO48 Field

BeagleBoneGPIO48 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO48 at pin P9.15.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO48 = 48

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO49 Field

BeagleBoneGPIO49 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO49 at pin P9.23.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO49 = 49

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO5 Field

BeagleBoneGPIO5 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO5 at pin P9.17.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
Remarks
Conflicts with SPI0 SS0.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO50 Field

BeagleBoneGPIO50 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO50 at pin P9.14.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO50 = 50

Field Value

Int32
Remarks
Conflicts with EHRPWM1A.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO51 Field

BeagleBoneGPIO51 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO51 at pin P9.16.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO51 = 51

Field Value

Int32
Remarks
Conflicts with EHRPWM1B.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO60 Field

BeagleBoneGPIO60 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO60 at pin P9.12.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO60 = 60

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO61 Field

BeagleBoneGPIO61 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO61 at pin P8.26.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO61 = 61

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO62 Field

BeagleBoneGPIO62 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO62 at pin P8.21.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO62 = 62

Field Value

Int32
Remarks
Conflicts with MMC1 CLK.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO63 Field

BeagleBoneGPIO63 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO63 at pin P8.20.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO63 = 63

Field Value

Int32
Remarks
Conflicts with MMC1 CMD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO65 Field

BeagleBoneGPIO65 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO65 at pin P8.18.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO65 = 65

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO66 Field

BeagleBoneGPIO66 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO66 at pin P8.7.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO66 = 66

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO67 Field

BeagleBoneGPIO67 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO67 at pin P8.8.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO67 = 67

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO68 Field

BeagleBoneGPIO68 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO68 at pin P8.10.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO68 = 68

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO69 Field

BeagleBoneGPIO69 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO69 at pin P8.9.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO69 = 69

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO7 Field

BeagleBoneGPIO7 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO7 at pin P9.42.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
Conflicts with SPI1 SS1.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO70 Field

BeagleBoneGPIO70 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO70 at pin P8.45.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO70 = 70

Field Value

Int32
Remarks
Conflicts with EHRPWM2A.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO71 Field

BeagleBoneGPIO71 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO71 at pin P8.46.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO71 = 71

Field Value

Int32
Remarks
Conflicts with EHRPWM2B.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO72 Field

BeagleBoneGPIO72 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO72 at pin P8.43.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO72 = 72

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO73 Field

BeagleBoneGPIO73 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO73 at pin P8.44.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO73 = 73

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO74 Field

BeagleBoneGPIO74 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO74 at pin P8.41.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO74 = 74

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO75 Field

BeagleBoneGPIO75 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO75 at pin P8.42.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO75 = 75

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO76 Field

BeagleBoneGPIO76 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO76 at pin P8.39.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO76 = 76

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO77 Field

BeagleBoneGPIO77 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO77 at pin P8.40.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO77 = 77

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO78 Field

BeagleBoneGPIO78 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO78 at pin P8.37.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO78 = 78

Field Value

Int32
Remarks
Conflicts with UART5 TXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO79 Field

BeagleBoneGPIO79 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO79 at pin P8.38.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO79 = 79

Field Value

Int32
Remarks
Conflicts with UART5 RXD.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO8 Field

BeagleBoneGPIO8 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO8 at pin P8.35.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO8 = 8

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO80 Field

BeagleBoneGPIO80 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO80 at pin P8.36.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO80 = 80

Field Value

Int32
Remarks
Conflicts with EHRPWM1A.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO81 Field

BeagleBoneGPIO81 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO81 at pin P8.34.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO81 = 81

Field Value

Int32
Remarks
Conflicts with EHRPWM1B.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO86 Field

BeagleBoneGPIO86 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO86 at pin P8.27.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO86 = 86

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO87 Field

BeagleBoneGPIO87 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO87 at pin P8.29.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO87 = 87

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO88 Field

BeagleBoneGPIO88 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO88 at pin P8.28.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO88 = 88

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO89 Field

BeagleBoneGPIO89 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO89 at pin P8.30.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO89 = 89

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.GPIO9 Field

BeagleBoneGPIO9 Field

GPIO channel number for the remote BeagleBone GPIO pin GPIO9 at pin P8.33.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO9 = 9

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.I2C2 Field

BeagleBoneI2C2 Field

I2C bus channel number for the remote BeagleBone I2C bus at pins P9.19 and P9.20.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C2 = 0

Field Value

Int32
Remarks
Conflicts with GPIO12 and GPIO13.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.SPI0_0 Field

BeagleBoneSPI0_0 Field

SPI slave channel number for the remote BeagleBone SPI slave select SPI0_0 at pin P9.17

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0_0 = 2

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.SPI1_0 Field

BeagleBoneSPI1_0 Field

SPI slave channel number for the remote BeagleBone SPI slave select SPI1_0 at pin P9.28

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI1_0 = 0

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.SPI1_1 Field

BeagleBoneSPI1_1 Field

SPI slave channel number for the remote BeagleBone SPI slave select SPI1_1 at pin P9.42

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI1_1 = 1

Field Value

Int32
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


BeagleBone.USERLED Field

BeagleBoneUSERLED Field

GPIO channel number for the remote BeagleBone user LED.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int USERLED = 0

Field Value

Int32
Remarks
This GPIO channel cannot be configured as an input.
See Also

Reference

BeagleBone Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008 Class

I/O resources (channel numbers) available on from a MUNTS-0008 USB Grove Adapter.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsMUNTS_0008

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class MUNTS_0008

The MUNTS_0008 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for Grove Connector J3 pin 1.
AIN1 | Analog input channel number for Grove Connector J4 pin 1.
AIN2 | Analog input channel number for Grove Connector J4 pin 2.
AIN3 | Analog input channel number for Grove Connector J6 pin 1.
AIN4 | Analog input channel number for Grove Connector J6 pin 2.
GPIO1 | GPIO channel number for Grove Connector J3 pin 1.
GPIO2 | GPIO channel number for Grove Connector J3 pin 2.
GPIO3 | GPIO channel number for Grove Connector J4 pin 1.
GPIO4 | GPIO channel number for Grove Connector J4 pin 2.
GPIO5 | GPIO channel number for Grove Connector J5 pin 1.
GPIO6 | GPIO channel number for Grove Connector J5 pin 2.
GPIO7 | GPIO channel number for Grove Connector J6 pin 1.
GPIO8 | GPIO channel number for Grove Connector J6 pin 2.
I2C0 | I2C bus channel number for Grove Connector J6.
LED | GPIO channel number for the on-board LED.
SPI0 | SPI slave device channel number for Grove Connectors J4 and J6.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008 Fields

The MUNTS_0008 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for Grove Connector J3 pin 1.
AIN1 | Analog input channel number for Grove Connector J4 pin 1.
AIN2 | Analog input channel number for Grove Connector J4 pin 2.
AIN3 | Analog input channel number for Grove Connector J6 pin 1.
AIN4 | Analog input channel number for Grove Connector J6 pin 2.
GPIO1 | GPIO channel number for Grove Connector J3 pin 1.
GPIO2 | GPIO channel number for Grove Connector J3 pin 2.
GPIO3 | GPIO channel number for Grove Connector J4 pin 1.
GPIO4 | GPIO channel number for Grove Connector J4 pin 2.
GPIO5 | GPIO channel number for Grove Connector J5 pin 1.
GPIO6 | GPIO channel number for Grove Connector J5 pin 2.
GPIO7 | GPIO channel number for Grove Connector J6 pin 1.
GPIO8 | GPIO channel number for Grove Connector J6 pin 2.
I2C0 | I2C bus channel number for Grove Connector J6.
LED | GPIO channel number for the on-board LED.
SPI0 | SPI slave device channel number for Grove Connectors J4 and J6.
Top
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.AIN0 Field

MUNTS_0008AIN0 Field

Analog input channel number for Grove Connector J3 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
Remarks
Conflicts with GPIO1.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.AIN1 Field

MUNTS_0008AIN1 Field

Analog input channel number for Grove Connector J4 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
Remarks
Conflicts with GPIO3 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.AIN2 Field

MUNTS_0008AIN2 Field

Analog input channel number for Grove Connector J4 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN2 = 2

Field Value

Int32
Remarks
Conflicts with GPIO4 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.AIN3 Field

MUNTS_0008AIN3 Field

Analog input channel number for Grove Connector J6 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN3 = 3

Field Value

Int32
Remarks
Conflicts with GPIO7 and I2C0 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.AIN4 Field

MUNTS_0008AIN4 Field

Analog input channel number for Grove Connector J6 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN4 = 4

Field Value

Int32
Remarks
Conflicts with GPIO8 and I2C0 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO1 Field

MUNTS_0008GPIO1 Field

GPIO channel number for Grove Connector J3 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO1 = 1

Field Value

Int32
Remarks
Conflicts with AIN0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO2 Field

MUNTS_0008GPIO2 Field

GPIO channel number for Grove Connector J3 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
Cannot be configured as an output.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO3 Field

MUNTS_0008GPIO3 Field

GPIO channel number for Grove Connector J4 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
Conflicts with AIN1 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO4 Field

MUNTS_0008GPIO4 Field

GPIO channel number for Grove Connector J4 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
Remarks
Conflicts with AIN02 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO5 Field

MUNTS_0008GPIO5 Field

GPIO channel number for Grove Connector J5 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO6 Field

MUNTS_0008GPIO6 Field

GPIO channel number for Grove Connector J5 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO6 = 6

Field Value

Int32
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO7 Field

MUNTS_0008GPIO7 Field

GPIO channel number for Grove Connector J6 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
Conflicts with AIN3 and I2C0 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.GPIO8 Field

MUNTS_0008GPIO8 Field

GPIO channel number for Grove Connector J6 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO8 = 8

Field Value

Int32
Remarks
Conflicts with AIN4 and I2C0 and SPI0.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.I2C0 Field

MUNTS_0008I2C0 Field

I2C bus channel number for Grove Connector J6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.LED Field

MUNTS_0008LED Field

GPIO channel number for the on-board LED.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LED = 0

Field Value

Int32
Remarks
Cannot be configured as an input.
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0008.SPI0 Field

MUNTS_0008SPI0 Field

SPI slave device channel number for Grove Connectors J4 and J6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0008 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009 Class

I/O resources (channel numbers) available on from a MUNTS-0009 USB Grove Adapter.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsMUNTS_0009

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class MUNTS_0009

The MUNTS_0009 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for Grove Connector J3 pin 1.
AIN1 | Analog input channel number for Grove Connector J4 pin 1.
AIN2 | Analog input channel number for Grove Connector J4 pin 2.
AIN3 | Analog input channel number for Grove Connector J6 pin 1.
AIN4 | Analog input channel number for Grove Connector J6 pin 2.
GPIO1 | GPIO channel number for Grove Connector J3 pin 1.
GPIO2 | GPIO channel number for Grove Connector J3 pin 2.
GPIO3 | GPIO channel number for Grove Connector J4 pin 1.
GPIO4 | GPIO channel number for Grove Connector J4 pin 2.
GPIO5 | GPIO channel number for Grove Connector J5 pin 1.
GPIO6 | GPIO channel number for Grove Connector J5 pin 2.
GPIO7 | GPIO channel number for Grove Connector J6 pin 1.
GPIO8 | GPIO channel number for Grove Connector J6 pin 2.
I2C0 | I2C bus channel number for Grove Connector J6.
LED | GPIO channel number for the on-board LED.
SPI0 | SPI slave device channel number for Grove Connectors J4 and J6.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009 Fields

The MUNTS_0009 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for Grove Connector J3 pin 1.
AIN1 | Analog input channel number for Grove Connector J4 pin 1.
AIN2 | Analog input channel number for Grove Connector J4 pin 2.
AIN3 | Analog input channel number for Grove Connector J6 pin 1.
AIN4 | Analog input channel number for Grove Connector J6 pin 2.
GPIO1 | GPIO channel number for Grove Connector J3 pin 1.
GPIO2 | GPIO channel number for Grove Connector J3 pin 2.
GPIO3 | GPIO channel number for Grove Connector J4 pin 1.
GPIO4 | GPIO channel number for Grove Connector J4 pin 2.
GPIO5 | GPIO channel number for Grove Connector J5 pin 1.
GPIO6 | GPIO channel number for Grove Connector J5 pin 2.
GPIO7 | GPIO channel number for Grove Connector J6 pin 1.
GPIO8 | GPIO channel number for Grove Connector J6 pin 2.
I2C0 | I2C bus channel number for Grove Connector J6.
LED | GPIO channel number for the on-board LED.
SPI0 | SPI slave device channel number for Grove Connectors J4 and J6.
Top
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.AIN0 Field

MUNTS_0009AIN0 Field

Analog input channel number for Grove Connector J3 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
Remarks
Conflicts with GPIO1.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.AIN1 Field

MUNTS_0009AIN1 Field

Analog input channel number for Grove Connector J4 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
Remarks
Conflicts with GPIO3 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.AIN2 Field

MUNTS_0009AIN2 Field

Analog input channel number for Grove Connector J4 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN2 = 2

Field Value

Int32
Remarks
Conflicts with GPIO4 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.AIN3 Field

MUNTS_0009AIN3 Field

Analog input channel number for Grove Connector J6 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN3 = 3

Field Value

Int32
Remarks
Conflicts with GPIO7 and I2C0 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.AIN4 Field

MUNTS_0009AIN4 Field

Analog input channel number for Grove Connector J6 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN4 = 4

Field Value

Int32
Remarks
Conflicts with GPIO8 and I2C0 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO1 Field

MUNTS_0009GPIO1 Field

GPIO channel number for Grove Connector J3 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO1 = 1

Field Value

Int32
Remarks
Conflicts with AIN0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO2 Field

MUNTS_0009GPIO2 Field

GPIO channel number for Grove Connector J3 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
Cannot be configured as an output.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO3 Field

MUNTS_0009GPIO3 Field

GPIO channel number for Grove Connector J4 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
Conflicts with AIN1 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO4 Field

MUNTS_0009GPIO4 Field

GPIO channel number for Grove Connector J4 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
Remarks
Conflicts with AIN02 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO5 Field

MUNTS_0009GPIO5 Field

GPIO channel number for Grove Connector J5 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO6 Field

MUNTS_0009GPIO6 Field

GPIO channel number for Grove Connector J5 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO6 = 6

Field Value

Int32
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO7 Field

MUNTS_0009GPIO7 Field

GPIO channel number for Grove Connector J6 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
Conflicts with AIN3 and I2C0 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.GPIO8 Field

MUNTS_0009GPIO8 Field

GPIO channel number for Grove Connector J6 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO8 = 8

Field Value

Int32
Remarks
Conflicts with AIN4 and I2C0 and SPI0.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.I2C0 Field

MUNTS_0009I2C0 Field

I2C bus channel number for Grove Connector J6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.LED Field

MUNTS_0009LED Field

GPIO channel number for the on-board LED.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LED = 0

Field Value

Int32
Remarks
Cannot be configured as an input.
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0009.SPI0 Field

MUNTS_0009SPI0 Field

SPI slave device channel number for Grove Connectors J4 and J6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0009 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015 Class

I/O resources (channel numbers) available from a MUNTS-0015 USB Remote I/O Protocol Adapter.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsMUNTS_0015

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class MUNTS_0015

The MUNTS_0015 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for pin G1.
AIN1 | Analog input channel number for pin G2.
AIN2 | Analog input channel number for pin G3.
AIN3 | Analog input channel number for pin SDA.
AIN4 | Analog input channel number for pin SCL.
GPIO0 | GPIO channel number for pin G0.
GPIO1 | GPIO channel number for pin G1.
GPIO2 | GPIO channel number for pin G2.
GPIO3 | GPIO channel number for pin G3.
GPIO4 | GPIO channel number for pin TX.
GPIO5 | GPIO channel number for pin RX.
GPIO6 | GPIO channel number for pin SDA.
GPIO7 | GPIO channel number for pin SCL.
I2C0 | I2C bus channel number.
SPI0 | SPI slave device channel number.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015 Fields

The MUNTS_0015 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for pin G1.
AIN1 | Analog input channel number for pin G2.
AIN2 | Analog input channel number for pin G3.
AIN3 | Analog input channel number for pin SDA.
AIN4 | Analog input channel number for pin SCL.
GPIO0 | GPIO channel number for pin G0.
GPIO1 | GPIO channel number for pin G1.
GPIO2 | GPIO channel number for pin G2.
GPIO3 | GPIO channel number for pin G3.
GPIO4 | GPIO channel number for pin TX.
GPIO5 | GPIO channel number for pin RX.
GPIO6 | GPIO channel number for pin SDA.
GPIO7 | GPIO channel number for pin SCL.
I2C0 | I2C bus channel number.
SPI0 | SPI slave device channel number.
Top
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.AIN0 Field

MUNTS_0015AIN0 Field

Analog input channel number for pin G1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
Remarks
Conflicts with GPIO1.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.AIN1 Field

MUNTS_0015AIN1 Field

Analog input channel number for pin G2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
Remarks
Conflicts with GPIO2 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.AIN2 Field

MUNTS_0015AIN2 Field

Analog input channel number for pin G3.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN2 = 2

Field Value

Int32
Remarks
Conflicts with GPIO3 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.AIN3 Field

MUNTS_0015AIN3 Field

Analog input channel number for pin SDA.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN3 = 3

Field Value

Int32
Remarks
Conflicts with GPIO6 and I2C0 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.AIN4 Field

MUNTS_0015AIN4 Field

Analog input channel number for pin SCL.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN4 = 4

Field Value

Int32
Remarks
Conflicts with GPIO7 and I2C0 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO0 Field

MUNTS_0015GPIO0 Field

GPIO channel number for pin G0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO1 Field

MUNTS_0015GPIO1 Field

GPIO channel number for pin G1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO1 = 1

Field Value

Int32
Remarks
Conflicts with AIN0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO2 Field

MUNTS_0015GPIO2 Field

GPIO channel number for pin G2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
Conflicts with AIN1 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO3 Field

MUNTS_0015GPIO3 Field

GPIO channel number for pin G3.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
Conflicts with AIN2 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO4 Field

MUNTS_0015GPIO4 Field

GPIO channel number for pin TX.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO5 Field

MUNTS_0015GPIO5 Field

GPIO channel number for pin RX.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO6 Field

MUNTS_0015GPIO6 Field

GPIO channel number for pin SDA.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO6 = 6

Field Value

Int32
Remarks
Conflicts with AIN3 and I2C0 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.GPIO7 Field

MUNTS_0015GPIO7 Field

GPIO channel number for pin SCL.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
Conflicts with AIN4 and I2C0 and SPI0.
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.I2C0 Field

MUNTS_0015I2C0 Field

I2C bus channel number.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0015.SPI0 Field

MUNTS_0015SPI0 Field

SPI slave device channel number.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0015 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016 Class

I/O resources (channel numbers) available from a MUNTS-0016 USB Grove Adapter Remote I/O Protocol Server.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsMUNTS_0016

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class MUNTS_0016

The MUNTS_0016 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for Grove Connector J3 pin 1.
AIN1 | Analog input channel number for Grove Connector J4 pin 1.
AIN2 | Analog input channel number for Grove Connector J4 pin 2.
AIN3 | Analog input channel number for Grove Connector J6 pin 1.
AIN4 | Analog input channel number for Grove Connector J6 pin 2.
GPIO0 | GPIO channel number for Grove Connector J3 pin 1.
GPIO1 | GPIO channel number for Grove Connector J3 pin 2.
GPIO2 | GPIO channel number for Grove Connector J4 pin 1.
GPIO3 | GPIO channel number for Grove Connector J4 pin 2.
GPIO4 | GPIO channel number for Grove Connector J5 pin 1.
GPIO5 | GPIO channel number for Grove Connector J5 pin 2.
GPIO6 | GPIO channel number for Grove Connector J6 pin 1.
GPIO7 | GPIO channel number for Grove Connector J6 pin 2.
I2C0 | I2C bus channel number for Grove Connector J6.
SPI0 | SPI slave device channel number for Grove Connectors J4 and J6.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016 Fields

The MUNTS_0016 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for Grove Connector J3 pin 1.
AIN1 | Analog input channel number for Grove Connector J4 pin 1.
AIN2 | Analog input channel number for Grove Connector J4 pin 2.
AIN3 | Analog input channel number for Grove Connector J6 pin 1.
AIN4 | Analog input channel number for Grove Connector J6 pin 2.
GPIO0 | GPIO channel number for Grove Connector J3 pin 1.
GPIO1 | GPIO channel number for Grove Connector J3 pin 2.
GPIO2 | GPIO channel number for Grove Connector J4 pin 1.
GPIO3 | GPIO channel number for Grove Connector J4 pin 2.
GPIO4 | GPIO channel number for Grove Connector J5 pin 1.
GPIO5 | GPIO channel number for Grove Connector J5 pin 2.
GPIO6 | GPIO channel number for Grove Connector J6 pin 1.
GPIO7 | GPIO channel number for Grove Connector J6 pin 2.
I2C0 | I2C bus channel number for Grove Connector J6.
SPI0 | SPI slave device channel number for Grove Connectors J4 and J6.
Top
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.AIN0 Field

MUNTS_0016AIN0 Field

Analog input channel number for Grove Connector J3 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
Remarks
Conflicts with GPIO0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.AIN1 Field

MUNTS_0016AIN1 Field

Analog input channel number for Grove Connector J4 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
Remarks
Conflicts with GPIO2 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.AIN2 Field

MUNTS_0016AIN2 Field

Analog input channel number for Grove Connector J4 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN2 = 2

Field Value

Int32
Remarks
Conflicts with GPIO3 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.AIN3 Field

MUNTS_0016AIN3 Field

Analog input channel number for Grove Connector J6 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN3 = 3

Field Value

Int32
Remarks
Conflicts with GPIO6 and I2C0 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.AIN4 Field

MUNTS_0016AIN4 Field

Analog input channel number for Grove Connector J6 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN4 = 4

Field Value

Int32
Remarks
Conflicts with GPIO7 and I2C0 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO0 Field

MUNTS_0016GPIO0 Field

GPIO channel number for Grove Connector J3 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO0 = 0

Field Value

Int32
Remarks
Conflicts with AIN0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO1 Field

MUNTS_0016GPIO1 Field

GPIO channel number for Grove Connector J3 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO1 = 1

Field Value

Int32
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO2 Field

MUNTS_0016GPIO2 Field

GPIO channel number for Grove Connector J4 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
Conflicts with AIN1 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO3 Field

MUNTS_0016GPIO3 Field

GPIO channel number for Grove Connector J4 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
Conflicts with AIN2 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO4 Field

MUNTS_0016GPIO4 Field

GPIO channel number for Grove Connector J5 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO5 Field

MUNTS_0016GPIO5 Field

GPIO channel number for Grove Connector J5 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO6 Field

MUNTS_0016GPIO6 Field

GPIO channel number for Grove Connector J6 pin 1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO6 = 6

Field Value

Int32
Remarks
Conflicts with AIN3 and I2C0 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.GPIO7 Field

MUNTS_0016GPIO7 Field

GPIO channel number for Grove Connector J6 pin 2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
Conflicts with AIN4 and I2C0 and SPI0.
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.I2C0 Field

MUNTS_0016I2C0 Field

I2C bus channel number for Grove Connector J6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0016.SPI0 Field

MUNTS_0016SPI0 Field

SPI slave device channel number for Grove Connectors J4 and J6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0016 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018 Class

I/O resources (channel numbers) available from a MUNTS-0018 Tutorial I/O Board Remote I/O Protocol Server.
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsMUNTS_0018

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class MUNTS_0018

The MUNTS_0018 type exposes the following members.

Fields
Name | Description
D1 | GPIO channel number for the on-board LED D1. Cannot be configured as an input.
J10A0 | Analog input channel number for Grove Analog Input Connector J10 pin A0 (MCP3204 input CH2).
J10A1 | Analog input channel number for Grove Analog Input Connector J10 pin A1 (MCP3204 input CH3).
J11A0 | Analog input channel number for Grove Analog Input Connector J11 pin A0 (MCP3204 input CH0).
J11A1 | Analog input channel number for Grove Analog Input Connector J11 pin A1 (MCP3204 input CH1).
J2PWM | PWM channel number for Servo Header J2.
J3PWM | PWM channel number for Servo Header J3.
J4D0 | GPIO channel number for Grove Digital I/O Connector J4 pin D0.
J4D1 | GPIO channel number for Grove Digital I/O Connector J4 pin D1.
J5D0 | GPIO channel number for Grove Digital I/O Connector J5 pin D0.
J5D1 | GPIO channel number for Grove Digital I/O Connector J5 pin D1.
J6D0 | GPIO channel number for Grove DC Motor Driver Connector J6 pin D0.
J6D1 | GPIO channel number for Grove DC Motor Driver Connector J6 pin D1.
J6DIR | GPIO channel number for DC Motor Driver Grove Connector J6 pin D1.
J6PWM | PWM channel number for DC Motor Driver Grove Connector J6 pin D0.
J7D0 | GPIO channel number for Grove DC Motor Driver Connector J7 pin D0.
J7D1 | GPIO channel number for Grove DC Motor Driver Connector J7 pin D1.
J7DIR | GPIO channel number for Grove DC Motor Driver Connector J7 pin D1.
J7PWM | PWM channel number for Grove DC Motor Driver Connector J7 pin D0.
J9I2C | I2C bus channel number for Grove I2C Connector J9.
SW1 | GPIO channel number for the on-board momentary switch SW1. Cannot be configured as an output.
USERLED | GPIO channel number for the remote Raspberry Pi user LED. Cannot be configured as an input.
Top
Remarks
The following device tree overlay commands must be added to config.txt on the Raspberry Pi hosting the MUNTS-0018 Tutorial I/O Board Remote I/O Protocol Server:
C#
Copy
dtoverlay=anyspi,spi0-1,dev="microchip,mcp3204",speed=1000000
dtoverlay=pwm-2chan,pin=12,func=4,pin2=19,func2=2
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018 Fields

The MUNTS_0018 type exposes the following members.

Fields
Name | Description
D1 | GPIO channel number for the on-board LED D1. Cannot be configured as an input.
J10A0 | Analog input channel number for Grove Analog Input Connector J10 pin A0 (MCP3204 input CH2).
J10A1 | Analog input channel number for Grove Analog Input Connector J10 pin A1 (MCP3204 input CH3).
J11A0 | Analog input channel number for Grove Analog Input Connector J11 pin A0 (MCP3204 input CH0).
J11A1 | Analog input channel number for Grove Analog Input Connector J11 pin A1 (MCP3204 input CH1).
J2PWM | PWM channel number for Servo Header J2.
J3PWM | PWM channel number for Servo Header J3.
J4D0 | GPIO channel number for Grove Digital I/O Connector J4 pin D0.
J4D1 | GPIO channel number for Grove Digital I/O Connector J4 pin D1.
J5D0 | GPIO channel number for Grove Digital I/O Connector J5 pin D0.
J5D1 | GPIO channel number for Grove Digital I/O Connector J5 pin D1.
J6D0 | GPIO channel number for Grove DC Motor Driver Connector J6 pin D0.
J6D1 | GPIO channel number for Grove DC Motor Driver Connector J6 pin D1.
J6DIR | GPIO channel number for DC Motor Driver Grove Connector J6 pin D1.
J6PWM | PWM channel number for DC Motor Driver Grove Connector J6 pin D0.
J7D0 | GPIO channel number for Grove DC Motor Driver Connector J7 pin D0.
J7D1 | GPIO channel number for Grove DC Motor Driver Connector J7 pin D1.
J7DIR | GPIO channel number for Grove DC Motor Driver Connector J7 pin D1.
J7PWM | PWM channel number for Grove DC Motor Driver Connector J7 pin D0.
J9I2C | I2C bus channel number for Grove I2C Connector J9.
SW1 | GPIO channel number for the on-board momentary switch SW1. Cannot be configured as an output.
USERLED | GPIO channel number for the remote Raspberry Pi user LED. Cannot be configured as an input.
Top
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.D1 Field

MUNTS_0018D1 Field

GPIO channel number for the on-board LED D1. Cannot be configured as an input.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int D1 = 26

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J10A0 Field

MUNTS_0018J10A0 Field

Analog input channel number for Grove Analog Input Connector J10 pin A0 (MCP3204 input CH2).

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J10A0 = 2

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J10A1 Field

MUNTS_0018J10A1 Field

Analog input channel number for Grove Analog Input Connector J10 pin A1 (MCP3204 input CH3).

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J10A1 = 3

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J11A0 Field

MUNTS_0018J11A0 Field

Analog input channel number for Grove Analog Input Connector J11 pin A0 (MCP3204 input CH0).

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J11A0 = 0

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J11A1 Field

MUNTS_0018J11A1 Field

Analog input channel number for Grove Analog Input Connector J11 pin A1 (MCP3204 input CH1).

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J11A1 = 1

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J2PWM Field

MUNTS_0018J2PWM Field

PWM channel number for Servo Header J2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J2PWM = 0

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J3PWM Field

MUNTS_0018J3PWM Field

PWM channel number for Servo Header J3.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J3PWM = 1

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J4D0 Field

MUNTS_0018J4D0 Field

GPIO channel number for Grove Digital I/O Connector J4 pin D0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J4D0 = 23

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J4D1 Field

MUNTS_0018J4D1 Field

GPIO channel number for Grove Digital I/O Connector J4 pin D1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J4D1 = 24

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J5D0 Field

MUNTS_0018J5D0 Field

GPIO channel number for Grove Digital I/O Connector J5 pin D0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J5D0 = 5

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J5D1 Field

MUNTS_0018J5D1 Field

GPIO channel number for Grove Digital I/O Connector J5 pin D1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J5D1 = 4

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J6D0 Field

MUNTS_0018J6D0 Field

GPIO channel number for Grove DC Motor Driver Connector J6 pin D0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J6D0 = 12

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO12 is mapped to PWM0.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J6D1 Field

MUNTS_0018J6D1 Field

GPIO channel number for Grove DC Motor Driver Connector J6 pin D1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J6D1 = 13

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J6DIR Field

MUNTS_0018J6DIR Field

GPIO channel number for DC Motor Driver Grove Connector J6 pin D1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J6DIR = 13

Field Value

Int32
Remarks
J6DIR controls the motor direction.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J6PWM Field

MUNTS_0018J6PWM Field

PWM channel number for DC Motor Driver Grove Connector J6 pin D0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J6PWM = 0

Field Value

Int32
Remarks
J6PWM controls the motor speed.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J7D0 Field

MUNTS_0018J7D0 Field

GPIO channel number for Grove DC Motor Driver Connector J7 pin D0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J7D0 = 19

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO19 is mapped to PWM1.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J7D1 Field

MUNTS_0018J7D1 Field

GPIO channel number for Grove DC Motor Driver Connector J7 pin D1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J7D1 = 18

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J7DIR Field

MUNTS_0018J7DIR Field

GPIO channel number for Grove DC Motor Driver Connector J7 pin D1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J7DIR = 18

Field Value

Int32
Remarks
J7DIR controls the motor direction.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J7PWM Field

MUNTS_0018J7PWM Field

PWM channel number for Grove DC Motor Driver Connector J7 pin D0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J7PWM = 1

Field Value

Int32
Remarks
J7PWM controls the motor speed.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.J9I2C Field

MUNTS_0018J9I2C Field

I2C bus channel number for Grove I2C Connector J9.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int J9I2C = 0

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.SW1 Field

MUNTS_0018SW1 Field

GPIO channel number for the on-board momentary switch SW1. Cannot be configured as an output.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SW1 = 6

Field Value

Int32
Remarks
This GPIO pin cannot be configured as an output.
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


MUNTS_0018.USERLED Field

MUNTS_0018USERLED Field

GPIO channel number for the remote Raspberry Pi user LED. Cannot be configured as an input.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int USERLED = 0

Field Value

Int32
See Also

Reference

MUNTS_0018 Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle Class

I/O resources (channel numbers) available on a BeagleBone Remote I/O Protocol Server
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsPocketBeagle

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class PocketBeagle

The PocketBeagle type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN0 at pin P1.19.
AIN1 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN1 at pin P1.21.
AIN2 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN2 at pin P1.23.
AIN3 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN3 at pin P1.24.
AIN4 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN4 at pin P1.25.
AIN5 | Analog input channel number for the remote PocketBeagle 3.6V analog input AIN5 at pin P2.35.
AIN6 | Analog input channel number for the remote PocketBeagle 3.6V analog input AIN6 at pin P1.2.
AIN7 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN7 at pin P2.36.
GPIO110 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO110 at pin P1.36.
GPIO111 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO111 at pin P1.33.
GPIO112 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO112 at pin P2.32.
GPIO113 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO113 at pin P2.30.
GPIO114 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO114 at pin P1.31.
GPIO115 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO115 at pin P2.34.
GPIO116 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO116 at pin P2.28.
GPIO117 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO117 at pin P1.29.
GPIO12 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO12 at pin P1.26.
GPIO13 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO13 at pin P1.28.
GPIO14 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO14 at pin P2.11.
GPIO15 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO15 at pin P2.9.
GPIO19 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO19 at pin P2.31.
GPIO2 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO2 at pin P1.8.
GPIO20 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO20 at pin P1.20.
GPIO23 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO23 at pin P2.3.
GPIO26 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO26 at pin P1.34.
GPIO27 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO27 at pin P2.19.
GPIO3 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO3 at pin P1.10.
GPIO30 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO30 at pin P2.5.
GPIO31 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO31 at pin P2.7.
GPIO4 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO4 at pin P1.12.
GPIO40 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO40 at pin P2.27.
GPIO41 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO41 at pin P2.25.
GPIO42 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO42 at pin P1.32.
GPIO43 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO43 at pin P1.30.
GPIO44 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO44 at pin P2.24.
GPIO45 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO45 at pin P2.33.
GPIO46 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO46 at pin P2.22.
GPIO47 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO47 at pin P2.18.
GPIO5 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO5 at pin P1.6.
GPIO50 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO50 at pin P2.1.
GPIO52 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO52 at pin P2.10.
GPIO57 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO57 at pin P2.6.
GPIO58 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO58 at pin P2.4.
GPIO59 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO59 at pin P2.2.
GPIO60 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO60 at pin P2.8.
GPIO64 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO64 at pin P2.20.
GPIO65 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO65 at pin P2.17.
GPIO7 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO7 at pin P2.29.
GPIO86 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO86 at pin P2.35.
GPIO87 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO87 at pin P1.2.
GPIO88 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO88 at pin P1.35.
GPIO89 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO89 at pin P1.4.
I2C1 | I2C bus channel number for the remote BeagleBone I2C bus I2C at pins P2.9 and P2.11.
I2C2 | I2C bus channel number for the remote BeagleBone I2C bus I2C at pins P1.26 and P1.28.
PWM0_0 | PWM output channel number for the remote PocketBeagle PWM output PWM0_0 at pin P1.36
PWM2_0 | PWM output channel number for the remote PocketBeagle PWM output PWM2_0 at pin P2.1
SPI0_0 | SPI slave channel number for the remote PocketBeagle SPI slave select SPI0_0 at pin P1.6
SPI1_1 | SPI slave channel number for the remote PocketBeagle SPI slave select SPI1_1 at pin P2.31
USERLED | GPIO channel number for the remote PocketBeagle user LED.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle Fields

The PocketBeagle type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN0 at pin P1.19.
AIN1 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN1 at pin P1.21.
AIN2 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN2 at pin P1.23.
AIN3 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN3 at pin P1.24.
AIN4 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN4 at pin P1.25.
AIN5 | Analog input channel number for the remote PocketBeagle 3.6V analog input AIN5 at pin P2.35.
AIN6 | Analog input channel number for the remote PocketBeagle 3.6V analog input AIN6 at pin P1.2.
AIN7 | Analog input channel number for the remote PocketBeagle 1.8V analog input AIN7 at pin P2.36.
GPIO110 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO110 at pin P1.36.
GPIO111 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO111 at pin P1.33.
GPIO112 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO112 at pin P2.32.
GPIO113 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO113 at pin P2.30.
GPIO114 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO114 at pin P1.31.
GPIO115 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO115 at pin P2.34.
GPIO116 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO116 at pin P2.28.
GPIO117 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO117 at pin P1.29.
GPIO12 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO12 at pin P1.26.
GPIO13 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO13 at pin P1.28.
GPIO14 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO14 at pin P2.11.
GPIO15 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO15 at pin P2.9.
GPIO19 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO19 at pin P2.31.
GPIO2 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO2 at pin P1.8.
GPIO20 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO20 at pin P1.20.
GPIO23 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO23 at pin P2.3.
GPIO26 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO26 at pin P1.34.
GPIO27 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO27 at pin P2.19.
GPIO3 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO3 at pin P1.10.
GPIO30 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO30 at pin P2.5.
GPIO31 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO31 at pin P2.7.
GPIO4 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO4 at pin P1.12.
GPIO40 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO40 at pin P2.27.
GPIO41 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO41 at pin P2.25.
GPIO42 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO42 at pin P1.32.
GPIO43 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO43 at pin P1.30.
GPIO44 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO44 at pin P2.24.
GPIO45 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO45 at pin P2.33.
GPIO46 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO46 at pin P2.22.
GPIO47 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO47 at pin P2.18.
GPIO5 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO5 at pin P1.6.
GPIO50 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO50 at pin P2.1.
GPIO52 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO52 at pin P2.10.
GPIO57 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO57 at pin P2.6.
GPIO58 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO58 at pin P2.4.
GPIO59 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO59 at pin P2.2.
GPIO60 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO60 at pin P2.8.
GPIO64 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO64 at pin P2.20.
GPIO65 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO65 at pin P2.17.
GPIO7 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO7 at pin P2.29.
GPIO86 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO86 at pin P2.35.
GPIO87 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO87 at pin P1.2.
GPIO88 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO88 at pin P1.35.
GPIO89 | GPIO channel number for the remote PocketBeagle GPIO pin GPIO89 at pin P1.4.
I2C1 | I2C bus channel number for the remote BeagleBone I2C bus I2C at pins P2.9 and P2.11.
I2C2 | I2C bus channel number for the remote BeagleBone I2C bus I2C at pins P1.26 and P1.28.
PWM0_0 | PWM output channel number for the remote PocketBeagle PWM output PWM0_0 at pin P1.36
PWM2_0 | PWM output channel number for the remote PocketBeagle PWM output PWM2_0 at pin P2.1
SPI0_0 | SPI slave channel number for the remote PocketBeagle SPI slave select SPI0_0 at pin P1.6
SPI1_1 | SPI slave channel number for the remote PocketBeagle SPI slave select SPI1_1 at pin P2.31
USERLED | GPIO channel number for the remote PocketBeagle user LED.
Top
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN0 Field

PocketBeagleAIN0 Field

Analog input channel number for the remote PocketBeagle 1.8V analog input AIN0 at pin P1.19.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN1 Field

PocketBeagleAIN1 Field

Analog input channel number for the remote PocketBeagle 1.8V analog input AIN1 at pin P1.21.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN2 Field

PocketBeagleAIN2 Field

Analog input channel number for the remote PocketBeagle 1.8V analog input AIN2 at pin P1.23.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN2 = 2

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN3 Field

PocketBeagleAIN3 Field

Analog input channel number for the remote PocketBeagle 1.8V analog input AIN3 at pin P1.24.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN3 = 3

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN4 Field

PocketBeagleAIN4 Field

Analog input channel number for the remote PocketBeagle 1.8V analog input AIN4 at pin P1.25.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN4 = 4

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN5 Field

PocketBeagleAIN5 Field

Analog input channel number for the remote PocketBeagle 3.6V analog input AIN5 at pin P2.35.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN5 = 5

Field Value

Int32
Remarks
Conflicts with GPIO86.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN6 Field

PocketBeagleAIN6 Field

Analog input channel number for the remote PocketBeagle 3.6V analog input AIN6 at pin P1.2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN6 = 6

Field Value

Int32
Remarks
Conflicts with GPIO87.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.AIN7 Field

PocketBeagleAIN7 Field

Analog input channel number for the remote PocketBeagle 1.8V analog input AIN7 at pin P2.36.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN7 = 7

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO110 Field

PocketBeagleGPIO110 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO110 at pin P1.36.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO110 = 110

Field Value

Int32
Remarks
Conflicts with PWM0:0.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO111 Field

PocketBeagleGPIO111 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO111 at pin P1.33.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO111 = 111

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO112 Field

PocketBeagleGPIO112 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO112 at pin P2.32.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO112 = 112

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO113 Field

PocketBeagleGPIO113 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO113 at pin P2.30.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO113 = 113

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO114 Field

PocketBeagleGPIO114 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO114 at pin P1.31.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO114 = 114

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO115 Field

PocketBeagleGPIO115 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO115 at pin P2.34.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO115 = 115

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO116 Field

PocketBeagleGPIO116 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO116 at pin P2.28.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO116 = 116

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO117 Field

PocketBeagleGPIO117 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO117 at pin P1.29.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO117 = 117

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO12 Field

PocketBeagleGPIO12 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO12 at pin P1.26.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO12 = 12

Field Value

Int32
Remarks
Conflicts with I2C2 SDA.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO13 Field

PocketBeagleGPIO13 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO13 at pin P1.28.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO13 = 13

Field Value

Int32
Remarks
Conflicts with I2C2 SCL.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO14 Field

PocketBeagleGPIO14 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO14 at pin P2.11.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO14 = 14

Field Value

Int32
Remarks
Conflicts with I2C1 SDA.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO15 Field

PocketBeagleGPIO15 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO15 at pin P2.9.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO15 = 15

Field Value

Int32
Remarks
Conflicts with I2C1 SCL.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO19 Field

PocketBeagleGPIO19 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO19 at pin P2.31.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO19 = 19

Field Value

Int32
Remarks
Conflicts with SPI1 CS1.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO2 Field

PocketBeagleGPIO2 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO2 at pin P1.8.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
Conflicts with SPI0 SCLK.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO20 Field

PocketBeagleGPIO20 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO20 at pin P1.20.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO20 = 20

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO23 Field

PocketBeagleGPIO23 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO23 at pin P2.3.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO23 = 23

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO26 Field

PocketBeagleGPIO26 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO26 at pin P1.34.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO26 = 26

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO27 Field

PocketBeagleGPIO27 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO27 at pin P2.19.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO27 = 27

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO3 Field

PocketBeagleGPIO3 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO3 at pin P1.10.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
Conflicts with SPI0 MISO.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO30 Field

PocketBeagleGPIO30 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO30 at pin P2.5.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO30 = 30

Field Value

Int32
Remarks
Conflicts with RXD4.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO31 Field

PocketBeagleGPIO31 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO31 at pin P2.7.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO31 = 31

Field Value

Int32
Remarks
Conflicts with TXD4.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO4 Field

PocketBeagleGPIO4 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO4 at pin P1.12.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
Remarks
Conflicts with SPI0 MOSI.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO40 Field

PocketBeagleGPIO40 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO40 at pin P2.27.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO40 = 40

Field Value

Int32
Remarks
Conflicts with SPI1 MISO.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO41 Field

PocketBeagleGPIO41 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO41 at pin P2.25.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO41 = 41

Field Value

Int32
Remarks
Conflicts with SPI1 MOSI.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO42 Field

PocketBeagleGPIO42 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO42 at pin P1.32.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO42 = 42

Field Value

Int32
Remarks
Conflicts with RXD0.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO43 Field

PocketBeagleGPIO43 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO43 at pin P1.30.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO43 = 43

Field Value

Int32
Remarks
Conflicts with TXD0.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO44 Field

PocketBeagleGPIO44 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO44 at pin P2.24.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO44 = 44

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO45 Field

PocketBeagleGPIO45 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO45 at pin P2.33.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO45 = 45

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO46 Field

PocketBeagleGPIO46 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO46 at pin P2.22.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO46 = 46

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO47 Field

PocketBeagleGPIO47 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO47 at pin P2.18.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO47 = 47

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO5 Field

PocketBeagleGPIO5 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO5 at pin P1.6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
Remarks
Conflicts with SPI0 CS0.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO50 Field

PocketBeagleGPIO50 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO50 at pin P2.1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO50 = 50

Field Value

Int32
Remarks
Conflicts with PWM2:0.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO52 Field

PocketBeagleGPIO52 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO52 at pin P2.10.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO52 = 52

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO57 Field

PocketBeagleGPIO57 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO57 at pin P2.6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO57 = 57

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO58 Field

PocketBeagleGPIO58 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO58 at pin P2.4.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO58 = 58

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO59 Field

PocketBeagleGPIO59 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO59 at pin P2.2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO59 = 59

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO60 Field

PocketBeagleGPIO60 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO60 at pin P2.8.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO60 = 60

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO64 Field

PocketBeagleGPIO64 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO64 at pin P2.20.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO64 = 64

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO65 Field

PocketBeagleGPIO65 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO65 at pin P2.17.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO65 = 65

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO7 Field

PocketBeagleGPIO7 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO7 at pin P2.29.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
Conflicts with SPI1 SCLK.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO86 Field

PocketBeagleGPIO86 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO86 at pin P2.35.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO86 = 86

Field Value

Int32
Remarks
Conflicts with AIN5.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO87 Field

PocketBeagleGPIO87 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO87 at pin P1.2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO87 = 87

Field Value

Int32
Remarks
Conflicts with AIN6.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO88 Field

PocketBeagleGPIO88 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO88 at pin P1.35.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO88 = 88

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.GPIO89 Field

PocketBeagleGPIO89 Field

GPIO channel number for the remote PocketBeagle GPIO pin GPIO89 at pin P1.4.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO89 = 89

Field Value

Int32
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.I2C1 Field

PocketBeagleI2C1 Field

I2C bus channel number for the remote BeagleBone I2C bus I2C at pins P2.9 and P2.11.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C1 = 1

Field Value

Int32
Remarks
Conflicts with GPIO14 and GPIO15.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.I2C2 Field

PocketBeagleI2C2 Field

I2C bus channel number for the remote BeagleBone I2C bus I2C at pins P1.26 and P1.28.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C2 = 2

Field Value

Int32
Remarks
Conflicts with GPIO12 and GPIO13.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.PWM0_0 Field

PocketBeaglePWM0_0 Field

PWM output channel number for the remote PocketBeagle PWM output PWM0_0 at pin P1.36

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int PWM0_0 = 0

Field Value

Int32
Remarks
Conflicts with GPIO110.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.PWM2_0 Field

PocketBeaglePWM2_0 Field

PWM output channel number for the remote PocketBeagle PWM output PWM2_0 at pin P2.1

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int PWM2_0 = 1

Field Value

Int32
Remarks
Conflicts with GPIO50.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.SPI0_0 Field

PocketBeagleSPI0_0 Field

SPI slave channel number for the remote PocketBeagle SPI slave select SPI0_0 at pin P1.6

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0_0 = 0

Field Value

Int32
Remarks
Conflicts with GPIO5.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.SPI1_1 Field

PocketBeagleSPI1_1 Field

SPI slave channel number for the remote PocketBeagle SPI slave select SPI1_1 at pin P2.31

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI1_1 = 1

Field Value

Int32
Remarks
Conflicts with GPIO19.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


PocketBeagle.USERLED Field

PocketBeagleUSERLED Field

GPIO channel number for the remote PocketBeagle user LED.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int USERLED = 0

Field Value

Int32
Remarks
This GPIO channel cannot be configured as an input.
See Also

Reference

PocketBeagle Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi Class

I/O resources (channel numbers) available on a Raspberry Pi Remote I/O Protocol Server
Inheritance Hierarchy
SystemObject
IO.Objects.RemoteIO.PlatformsRaspberryPi

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class RaspberryPi

The RaspberryPi type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for the remote Raspberry Pi analog input AIN0.
AIN1 | Analog input channel number for the remote Raspberry Pi analog input AIN1.
GPIO10 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO10.
GPIO11 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO11.
GPIO12 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO12.
GPIO13 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO13.
GPIO14 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO14.
GPIO15 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO15.
GPIO16 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO16.
GPIO17 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO17.
GPIO18 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO18.
GPIO19 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO19.
GPIO2 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO2.
GPIO20 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO20.
GPIO21 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO21.
GPIO22 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO22.
GPIO23 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO23.
GPIO24 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO24.
GPIO25 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO25.
GPIO26 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO26.
GPIO27 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO27.
GPIO3 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO3.
GPIO4 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO4.
GPIO5 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO5.
GPIO6 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO6.
GPIO7 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO7.
GPIO8 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO8.
GPIO9 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO9.
I2C1 | I2C bus channel number for the remote Raspberry Pi I2C bus controller I2C1.
PWM0 | PWM output channel number for the remote Raspberry Pi PWM output PWM0.
PWM1 | PWM output channel number for the remote Raspberry Pi PWM output PWM1.
SPI0_0 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev0.0.
SPI0_1 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev0.1.
SPI1_0 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.0.
SPI1_1 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.1.
SPI1_2 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.2.
USERLED | GPIO channel number for the remote Raspberry Pi user LED.
Top
See Also

Reference

IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi Fields

The RaspberryPi type exposes the following members.

Fields
Name | Description
AIN0 | Analog input channel number for the remote Raspberry Pi analog input AIN0.
AIN1 | Analog input channel number for the remote Raspberry Pi analog input AIN1.
GPIO10 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO10.
GPIO11 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO11.
GPIO12 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO12.
GPIO13 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO13.
GPIO14 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO14.
GPIO15 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO15.
GPIO16 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO16.
GPIO17 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO17.
GPIO18 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO18.
GPIO19 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO19.
GPIO2 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO2.
GPIO20 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO20.
GPIO21 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO21.
GPIO22 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO22.
GPIO23 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO23.
GPIO24 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO24.
GPIO25 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO25.
GPIO26 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO26.
GPIO27 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO27.
GPIO3 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO3.
GPIO4 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO4.
GPIO5 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO5.
GPIO6 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO6.
GPIO7 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO7.
GPIO8 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO8.
GPIO9 | GPIO channel number for the remote Raspberry Pi GPIO pin GPIO9.
I2C1 | I2C bus channel number for the remote Raspberry Pi I2C bus controller I2C1.
PWM0 | PWM output channel number for the remote Raspberry Pi PWM output PWM0.
PWM1 | PWM output channel number for the remote Raspberry Pi PWM output PWM1.
SPI0_0 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev0.0.
SPI0_1 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev0.1.
SPI1_0 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.0.
SPI1_1 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.1.
SPI1_2 | SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.2.
USERLED | GPIO channel number for the remote Raspberry Pi user LED.
Top
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.AIN0 Field

RaspberryPiAIN0 Field

Analog input channel number for the remote Raspberry Pi analog input AIN0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN0 = 0

Field Value

Int32
Remarks
This analog input is only available if a Mikroelektronika Pi 3 Click Shield (MIKROE-2756) is installed and the following device tree overlay command added to config.txt:
C#
Copy
dtoverlay=Pi3ClickShield
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.AIN1 Field

RaspberryPiAIN1 Field

Analog input channel number for the remote Raspberry Pi analog input AIN1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int AIN1 = 1

Field Value

Int32
Remarks
This analog input is only available if a Mikroelektronika Pi 3 Click Shield (MIKROE-2756) is installed and the following device tree overlay command added to config.txt:
C#
Copy
dtoverlay=Pi3ClickShield
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO10 Field

RaspberryPiGPIO10 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO10.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO10 = 10

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO10 is mapped to SPI signal SPI0_MOSI.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO11 Field

RaspberryPiGPIO11 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO11.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO11 = 11

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO11 is mapped to SPI signal SPI0_SCLK.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO12 Field

RaspberryPiGPIO12 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO12.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO12 = 12

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO13 Field

RaspberryPiGPIO13 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO13.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO13 = 13

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO14 Field

RaspberryPiGPIO14 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO14.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO14 = 14

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO14 is mapped to UART signal UART0_TXD.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO15 Field

RaspberryPiGPIO15 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO15.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO15 = 15

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO15 is mapped to UART signal UART0_RXD.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO16 Field

RaspberryPiGPIO16 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO16.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO16 = 16

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO17 Field

RaspberryPiGPIO17 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO17.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO17 = 17

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO18 Field

RaspberryPiGPIO18 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO18.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO18 = 18

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO18 is mapped to PWM output PWM0.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO19 Field

RaspberryPiGPIO19 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO19.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO19 = 19

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO2 Field

RaspberryPiGPIO2 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO2 = 2

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO2 is mapped to I2C signal SDA1.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO20 Field

RaspberryPiGPIO20 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO20.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO20 = 20

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO21 Field

RaspberryPiGPIO21 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO21.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO21 = 21

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO22 Field

RaspberryPiGPIO22 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO22.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO22 = 22

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO23 Field

RaspberryPiGPIO23 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO23.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO23 = 23

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO24 Field

RaspberryPiGPIO24 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO24.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO24 = 24

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO25 Field

RaspberryPiGPIO25 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO25.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO25 = 25

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO26 Field

RaspberryPiGPIO26 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO26.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO26 = 26

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO27 Field

RaspberryPiGPIO27 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO27.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO27 = 27

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO3 Field

RaspberryPiGPIO3 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO3.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO3 = 3

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO3 is mapped to to I2C signal SCL1.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO4 Field

RaspberryPiGPIO4 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO4.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO4 = 4

Field Value

Int32
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO5 Field

RaspberryPiGPIO5 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO5.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO5 = 5

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO6 Field

RaspberryPiGPIO6 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO6.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO6 = 6

Field Value

Int32
Remarks
This GPIO channel is not usable when the Remote I/O server is running on an original Raspberry Pi 1 Model A or B with a 26-pin expansion header.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO7 Field

RaspberryPiGPIO7 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO7.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO7 = 7

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO7 is mapped to SPI signal SPI0_CE1.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO8 Field

RaspberryPiGPIO8 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO8.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO8 = 8

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO8 is mapped to SPI signal SPI0_CE0.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.GPIO9 Field

RaspberryPiGPIO9 Field

GPIO channel number for the remote Raspberry Pi GPIO pin GPIO9.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int GPIO9 = 9

Field Value

Int32
Remarks
This GPIO channel is normally unusable because GPIO9 is mapped to SPI signal SPI0_MISO.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.I2C1 Field

RaspberryPiI2C1 Field

I2C bus channel number for the remote Raspberry Pi I2C bus controller I2C1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int I2C1 = 0

Field Value

Int32
Remarks
The following device tree overlay command must be added to config.txt on the Raspberry Pi Remote I/O server to enable I2C bus controller I2C1:
C#
Copy
dtparam=i2c=on
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.PWM0 Field

RaspberryPiPWM0 Field

PWM output channel number for the remote Raspberry Pi PWM output PWM0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int PWM0 = 0

Field Value

Int32
Remarks
The following device tree overlay command must be added to config.txt on the Raspberry Pi Remote I/O server to enable PWM output PWM0:
C#
Copy
dtoverlay=pwm
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.PWM1 Field

RaspberryPiPWM1 Field

PWM output channel number for the remote Raspberry Pi PWM output PWM1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int PWM1 = 1

Field Value

Int32
Remarks
PWM1 is not normally enabled. You can enable it with one of the device tree overlay command variationss described in https://github.com/raspberrypi/firmware/blob/master/boot/overlays/README.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.SPI0_0 Field

RaspberryPiSPI0_0 Field

SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev0.0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0_0 = 0

Field Value

Int32
Remarks
/dev/spidev0.0 uses GPIO8 for slave select. The following device tree overlay command must be added to config.txt on the Raspberry Pi Remote I/O server to enable SPI bus controller SPI0:
C#
Copy
dtparam=spi=on
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.SPI0_1 Field

RaspberryPiSPI0_1 Field

SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev0.1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI0_1 = 1

Field Value

Int32
Remarks
/dev/spidev0.1 uses GPIO7 for slave select. The following device tree overlay command must be added to config.txt on the Raspberry Pi Remote I/O server to enable SPI bus controller SPI0:
C#
Copy
dtparam=spi=on
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.SPI1_0 Field

RaspberryPiSPI1_0 Field

SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.0.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI1_0 = 2

Field Value

Int32
Remarks
/dev/spidev1.0 uses GPIO18 for slave select.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.SPI1_1 Field

RaspberryPiSPI1_1 Field

SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.1.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI1_1 = 3

Field Value

Int32
Remarks
/dev/spidev1.1 uses GPIO17 for slave select.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.SPI1_2 Field

RaspberryPiSPI1_2 Field

SPI slave device channel number for the remote Raspberry Pi SPI slave device /dev/spidev1.2.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int SPI1_2 = 4

Field Value

Int32
Remarks
/dev/spidev1.2 uses GPIO16 for slave select.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


RaspberryPi.USERLED Field

RaspberryPiUSERLED Field

GPIO channel number for the remote Raspberry Pi user LED.

Namespace: IO.Objects.RemoteIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int USERLED = 0

Field Value

Int32
Remarks
This GPIO channel cannot be configured as an input.
See Also

Reference

RaspberryPi Class
IO.Objects.RemoteIO.Platforms Namespace


IO.Objects.Servo.PWM Namespace

PWM Controlled Servo Services
Classes
 | Class | Description
Public class | Output | Encapsulates servo outputs using PWM outputs.


Output Class

Encapsulates servo outputs using PWM outputs.
Inheritance Hierarchy
SystemObject
IO.Objects.Servo.PWMOutput

Namespace: IO.Objects.Servo.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Constructor for a single servo output.
Top
Properties
 | Name | Description
Public property | position | Write-only property for setting the servo position. Allowed values are -1.0 to +1.0.
Top
See Also

Reference

IO.Objects.Servo.PWM Namespace


Output Constructor

Constructor for a single servo output.

Namespace: IO.Objects.Servo.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Output pwm,
    int freq = 50,
    double position = 0
)

Parameters

pwm Output
PWM output instance.
freq Int32 (Optional)
PWM pulse frequency.
position Double (Optional)
Initial servo position.
See Also

Reference

Output Class
IO.Objects.Servo.PWM Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | position | Write-only property for setting the servo position. Allowed values are -1.0 to +1.0.
Top
See Also

Reference

Output Class
IO.Objects.Servo.PWM Namespace


Output.position Property

Outputposition Property

Write-only property for setting the servo position. Allowed values are -1.0 to +1.0.

Namespace: IO.Objects.Servo.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double position { set; }

Property Value

Double

Implements

Outputposition
See Also

Reference

Output Class
IO.Objects.Servo.PWM Namespace


IO.Objects.SimpleIO.ADC Namespace

ADC (Analog to Digital Converter) Input Services
Classes
 | Class | Description
Public class | Sample | Encapsulates Linux Industrial I/O Subsystem ADC inputs usingi libsimpleio.


Sample Class

Encapsulates Linux Industrial I/O Subsystem ADC inputs usingi libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.ADCSample

Namespace: IO.Objects.SimpleIO.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Sample : Sample

The Sample type exposes the following members.

Constructors
 | Name | Description
Public method | Sample | Constructor for a single ADC input.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the ADC input.
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample from an ADC input.
Top
Methods
Name | Description
name | Retrieve the subsystem name string for a Linux Industrial I/O Subsystem ADC device.
Top
See Also

Reference

IO.Objects.SimpleIO.ADC Namespace


Sample Constructor

Constructor for a single ADC input.

Namespace: IO.Objects.SimpleIO.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample(
    Designator desg,
    int resolution
)

Parameters

desg Designator
ADC input designator.
resolution Int32
Bits of resolution.
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the ADC input.
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Read-only property returning an integer analog sample from an ADC input.
Top
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


Sample.fd Property

Samplefd Property

Read-only property returning the Linux file descriptor for the ADC input.

Namespace: IO.Objects.SimpleIO.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Objects.SimpleIO.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


Sample.sample Property

Samplesample Property

Read-only property returning an integer analog sample from an ADC input.

Namespace: IO.Objects.SimpleIO.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { get; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


Sample Methods

The Sample type exposes the following members.

Methods
Name | Description
name | Retrieve the subsystem name string for a Linux Industrial I/O Subsystem ADC device.
Top
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


Sample.name Method

Samplename Method

Retrieve the subsystem name string for a Linux Industrial I/O Subsystem ADC device.

Namespace: IO.Objects.SimpleIO.ADC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static string name(
    int chip
)

Parameters

chip Int32
ADC chip number.

Return Value

String
Subsystem name.
See Also

Reference

Sample Class
IO.Objects.SimpleIO.ADC Namespace


IO.Objects.SimpleIO.DAC Namespace

DAC (Digital to Analog Converter) Output Services
Classes
 | Class | Description
Public class | Sample | Encapsulates Linux Industrial I/O Subsystem DAC outputs using libsimpleio.


Sample Class

Encapsulates Linux Industrial I/O Subsystem DAC outputs using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.DACSample

Namespace: IO.Objects.SimpleIO.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Sample : Sample

The Sample type exposes the following members.

Constructors
 | Name | Description
Public method | Sample | Constructor for a single DAC output.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the DAC output.
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for writing an integer analog sample to a DAC output.
Top
Methods
Name | Description
name | Retrieve the subsystem name string for a Linux Industrial I/O Subsystem DAC device.
Top
See Also

Reference

IO.Objects.SimpleIO.DAC Namespace


Sample Constructor

Constructor for a single DAC output.

Namespace: IO.Objects.SimpleIO.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Sample(
    Designator desg,
    int resolution,
    int sample = 0
)

Parameters

desg Designator
DAC output designator.
resolution Int32
Bits of resolution.
sample Int32 (Optional)
Initial DAC output sample.
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


Sample Properties

The Sample type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the DAC output.
Public property | resolution | Read-only property returning the number of bits of resolution.
Public property | sample | Write-only property for writing an integer analog sample to a DAC output.
Top
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


Sample.fd Property

Samplefd Property

Read-only property returning the Linux file descriptor for the DAC output.

Namespace: IO.Objects.SimpleIO.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


Sample.resolution Property

Sampleresolution Property

Read-only property returning the number of bits of resolution.

Namespace: IO.Objects.SimpleIO.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int resolution { get; }

Property Value

Int32

Implements

Sampleresolution
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


Sample.sample Property

Samplesample Property

Write-only property for writing an integer analog sample to a DAC output.

Namespace: IO.Objects.SimpleIO.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int sample { set; }

Property Value

Int32

Implements

Samplesample
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


Sample Methods

The Sample type exposes the following members.

Methods
Name | Description
name | Retrieve the subsystem name string for a Linux Industrial I/O Subsystem DAC device.
Top
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


Sample.name Method

Samplename Method

Retrieve the subsystem name string for a Linux Industrial I/O Subsystem DAC device.

Namespace: IO.Objects.SimpleIO.DAC
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static string name(
    int chip
)

Parameters

chip Int32
DAC chip number.

Return Value

String
Subsystem name.
See Also

Reference

Sample Class
IO.Objects.SimpleIO.DAC Namespace


IO.Objects.SimpleIO.Device Namespace

Common device declarations
Structures
 | Structure | Description
Public structure | Designator | Linux kernel I/O device designator.


Designator Structure

Linux kernel I/O device designator.
Inheritance Hierarchy
SystemObject
SystemValueType
IO.Objects.SimpleIO.DeviceDesignator

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public struct Designator

The Designator type exposes the following members.

Constructors
 | Name | Description
Public method | Designator(String, UInt32) | Linux kernel I/O device designator constructor. The chip and channel numbers shall be obtained from the operator via System.Console.ReadLine
Public method | Designator(UInt32, UInt32) | Linux kernel I/O device designator constructor.
Top
Properties
 | Name | Description
Public property | available | Returns true if this device designator is not equal to Unavailable.
Top
Fields
 | Name | Description
Public field | chan | Linux kernel I/O device channel number.
Public field | chip | Linux kernel I/O device chip number.
 | Unavailable | Linux kernel I/O device designator for an unavailable device.
Top
Remarks
Many Linux kernel I/O devices, including ADC inputs, DAC outputs, GPIO pins, I2C buses, PWM outputs, and SPI devices, are selected by a tuple of integers: chip and channel.
See Also

Reference

IO.Objects.SimpleIO.Device Namespace


Designator Constructor

Overload List
 | Name | Description
Public method | Designator(String, UInt32) | Linux kernel I/O device designator constructor. The chip and channel numbers shall be obtained from the operator via System.Console.ReadLine
Public method | Designator(UInt32, UInt32) | Linux kernel I/O device designator constructor.
Top
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


Designator(String, UInt32) Constructor

Linux kernel I/O device designator constructor. The chip and channel numbers shall be obtained from the operator via System.Console.ReadLine

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator(
    string prompt,
    uint chip = 4294967295
)

Parameters

prompt String
Operator prompt string of the form "Enter XXX channel:".
chip UInt32 (Optional)
Linux kernel I/O device chip number. If a value is supplied, the operator will not be prompted for for the chip number.
See Also

Reference

Designator Structure
Designator Overload
IO.Objects.SimpleIO.Device Namespace


Designator(UInt32, UInt32) Constructor

Linux kernel I/O device designator constructor.

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator(
    uint chip = 4294967295,
    uint chan = 4294967295
)

Parameters

chip UInt32 (Optional)
Linux kernel I/O device chip number.
chan UInt32 (Optional)
Linux kernel I/O device channel number.
See Also

Reference

Designator Structure
Designator Overload
IO.Objects.SimpleIO.Device Namespace


Designator Properties

The Designator type exposes the following members.

Properties
 | Name | Description
Public property | available | Returns true if this device designator is not equal to Unavailable.
Top
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


Designator.available Property

Designatoravailable Property

Returns true if this device designator is not equal to Unavailable.

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool available { get; }

Property Value

Boolean
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


Designator Fields

The Designator type exposes the following members.

Fields
 | Name | Description
Public field | chan | Linux kernel I/O device channel number.
Public field | chip | Linux kernel I/O device chip number.
 | Unavailable | Linux kernel I/O device designator for an unavailable device.
Top
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


Designator.chan Field

Designatorchan Field

Linux kernel I/O device channel number.

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint chan

Field Value

UInt32
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


Designator.chip Field

Designatorchip Field

Linux kernel I/O device chip number.

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public uint chip

Field Value

UInt32
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


Designator.Unavailable Field

DesignatorUnavailable Field

Linux kernel I/O device designator for an unavailable device.

Namespace: IO.Objects.SimpleIO.Device
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator Unavailable

Field Value

Designator
See Also

Reference

Designator Structure
IO.Objects.SimpleIO.Device Namespace


IO.Objects.SimpleIO.GPIO Namespace

GPIO (General Purpose Input/Output) Pin Services
Classes
 | Class | Description
Public class | Pin | Encapsulates Linux GPIO pins using libsimpleio.
Enumerations
 | Enumeration | Description
Public enumeration | Driver | GPIO output driver settings.
Public enumeration | Edge | GPIO input interrupt edge settings.
Public enumeration | Polarity | GPIO polarity settings


Driver Enumeration

GPIO output driver settings.

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Driver
Members
Member name | Value | Description
PushPull | 0 | Push Pull (current source/sink) output driver.
OpenDrain | 1 | Open Drain (current sink) output driver.
OpenSource | 2 | Open Source (current source) output driver.
See Also

Reference

IO.Objects.SimpleIO.GPIO Namespace


Edge Enumeration

GPIO input interrupt edge settings.

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Edge
Members
Member name | Value | Description
None | 0 | Configure GPIO input pin with interrupt disabled.
Rising | 1 | Configure GPIO input pin to interrupt on rising edge.
Falling | 2 | Configure GPIO pin to interrupt on falling edge.
Both | 3 | Configure GPIO pin to interrupt on both edges.
See Also

Reference

IO.Objects.SimpleIO.GPIO Namespace


Pin Class

Encapsulates Linux GPIO pins using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.GPIOPin

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Pin : Pin

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Constructor for a single GPIO pin.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the GPIO pin.
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

IO.Objects.SimpleIO.GPIO Namespace


Pin Constructor

Constructor for a single GPIO pin.

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Pin(
    Designator desg,
    Direction dir,
    bool state = false,
    Driver driver = Driver.PushPull,
    Edge edge = Edge.None,
    Polarity polarity = Polarity.ActiveHigh
)

Parameters

desg Designator
GPIO pin designator.
dir Direction
Data direction.
state Boolean (Optional)
Initial GPIO output state.
driver Driver (Optional)
Output driver setting.
edge Edge (Optional)
Interrupt edge setting.
polarity Polarity (Optional)
Polarity setting.
See Also

Reference

Pin Class
IO.Objects.SimpleIO.GPIO Namespace


Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the GPIO pin.
Public property | state | Read/Write GPIO state property.
Top
See Also

Reference

Pin Class
IO.Objects.SimpleIO.GPIO Namespace


Pin.fd Property

Pinfd Property

Read-only property returning the Linux file descriptor for the GPIO pin.

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Pin Class
IO.Objects.SimpleIO.GPIO Namespace


Pin.state Property

Pinstate Property

Read/Write GPIO state property.

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public bool state { get; set; }

Property Value

Boolean

Implements

Pinstate
See Also

Reference

Pin Class
IO.Objects.SimpleIO.GPIO Namespace


Polarity Enumeration

GPIO polarity settings

Namespace: IO.Objects.SimpleIO.GPIO
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Polarity
Members
Member name | Value | Description
ActiveLow | 0 | Configure GPIO pin as active low (inverted logic).
ActiveHigh | 1 | Configure GPIO pin as active high (normal logic).
See Also

Reference

IO.Objects.SimpleIO.GPIO Namespace


IO.Objects.SimpleIO.HID Namespace

Raw HID (Human Interface Device) Services
Classes
 | Class | Description
Public class | Messenger | Encapsulates Linux raw HID devices using libsimpleio.


Messenger Class

Encapsulates Linux raw HID devices using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.HIDMessenger

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Messenger : Messenger

The Messenger type exposes the following members.

Constructors
 | Name | Description
Public method | Messenger | Constructor for a single raw HID device.
Top
Properties
 | Name | Description
Public property | bustype | Read-only property returning the bus type identifier for a raw HID device.
Public property | fd | Read-only property returning the Linux file descriptor for a raw HID device.
Public property | name | Read-only property returning the device information string for a raw HID device.
Public property | product | Read-only property returning the product identifier for a raw HID device.
Public property | vendor | Read-only property returning the vendor identifier for a raw HID device.
Top
Methods
 | Name | Description
Public method | Receive | Receive a 64-byte response message from a raw HID device.
Public method | Send | Send a 64-byte command message to a raw HID device.
Public method | Transaction | Send a 64-byte command message and receive a 64-byte response message.
Top
See Also

Reference

IO.Objects.SimpleIO.HID Namespace


Messenger Constructor

Constructor for a single raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Messenger(
    int VID = 5840,
    int PID = 2810,
    string serial = null,
    int timeoutms = 1000
)

Parameters

VID Int32 (Optional)
Vendor ID.
PID Int32 (Optional)
Product ID.
serial String (Optional)
Serial Number.
timeoutms Int32 (Optional)
Time in milliseconds to wait for read and write operations to complete. Zero means wait forever.
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger Properties

The Messenger type exposes the following members.

Properties
 | Name | Description
Public property | bustype | Read-only property returning the bus type identifier for a raw HID device.
Public property | fd | Read-only property returning the Linux file descriptor for a raw HID device.
Public property | name | Read-only property returning the device information string for a raw HID device.
Public property | product | Read-only property returning the product identifier for a raw HID device.
Public property | vendor | Read-only property returning the vendor identifier for a raw HID device.
Top
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.bustype Property

Messengerbustype Property

Read-only property returning the bus type identifier for a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int bustype { get; }

Property Value

Int32
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.fd Property

Messengerfd Property

Read-only property returning the Linux file descriptor for a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.name Property

Messengername Property

Read-only property returning the device information string for a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public string name { get; }

Property Value

String
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.product Property

Messengerproduct Property

Read-only property returning the product identifier for a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int product { get; }

Property Value

Int32
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.vendor Property

Messengervendor Property

Read-only property returning the vendor identifier for a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int vendor { get; }

Property Value

Int32
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger Methods

The Messenger type exposes the following members.

Methods
 | Name | Description
Public method | Receive | Receive a 64-byte response message from a raw HID device.
Public method | Send | Send a 64-byte command message to a raw HID device.
Public method | Transaction | Send a 64-byte command message and receive a 64-byte response message.
Top
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.Receive Method

MessengerReceive Method

Receive a 64-byte response message from a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Receive(
    Message resp
)

Parameters

resp Message
64-byte response message.

Implements

MessengerReceive(Message)
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.Send Method

MessengerSend Method

Send a 64-byte command message to a raw HID device.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Send(
    Message cmd
)

Parameters

cmd Message
64-byte command message.

Implements

MessengerSend(Message)
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


Messenger.Transaction Method

MessengerTransaction Method

Send a 64-byte command message and receive a 64-byte response message.

Namespace: IO.Objects.SimpleIO.HID
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    Message cmd,
    Message resp
)

Parameters

cmd Message
64-byte command message.
resp Message
64-byte response message.

Implements

MessengerTransaction(Message, Message)
See Also

Reference

Messenger Class
IO.Objects.SimpleIO.HID Namespace


IO.Objects.SimpleIO.I2C Namespace

I2C (Inter-Integrated Circuit) Bus Controller Services
Classes
 | Class | Description
Public class | Bus | Encapsulates Linux I2C bus controllers using libsimpleio.


Bus Class

Encapsulates Linux I2C bus controllers using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.I2CBus

Namespace: IO.Objects.SimpleIO.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Bus : Bus

The Bus type exposes the following members.

Constructors
 | Name | Description
Public method | Bus | Constructor for a single I2C bus controller.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the I2C bus controller.
Top
Methods
 | Name | Description
Public method | Read | Read bytes from an I2C device.
Public method | Transaction | Write and receive bytes to/from an I2C device.
Public method | Write | Write bytes to an I2C device.
Top
See Also

Reference

IO.Objects.SimpleIO.I2C Namespace


Bus Constructor

Constructor for a single I2C bus controller.

Namespace: IO.Objects.SimpleIO.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Bus(
    Designator desg
)

Parameters

desg Designator
I2 bus designator.
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


Bus Properties

The Bus type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the I2C bus controller.
Top
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


Bus.fd Property

Busfd Property

Read-only property returning the Linux file descriptor for the I2C bus controller.

Namespace: IO.Objects.SimpleIO.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


Bus Methods

The Bus type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an I2C device.
Public method | Transaction | Write and receive bytes to/from an I2C device.
Public method | Write | Write bytes to an I2C device.
Top
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


Bus.Read Method

BusRead Method

Read bytes from an I2C device.

Namespace: IO.Objects.SimpleIO.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Read(
    int slaveaddr,
    byte[] resp,
    int resplen
)

Parameters

slaveaddr Int32
Slave device address.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.

Implements

BusRead(Int32, Byte, Int32)
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


Bus.Transaction Method

BusTransaction Method

Write and receive bytes to/from an I2C device.

Namespace: IO.Objects.SimpleIO.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    int slaveaddr,
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus = 0
)

Parameters

slaveaddr Int32
Device slave address.
cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
delayus Int32 (Optional)
Delay in microseconds between the I2C write and read cycles. Allowed values are 0 to 65535 microseconds.

Implements

BusTransaction(Int32, Byte, Int32, Byte, Int32, Int32)
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


Bus.Write Method

BusWrite Method

Write bytes to an I2C device.

Namespace: IO.Objects.SimpleIO.I2C
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    int slaveaddr,
    byte[] cmd,
    int cmdlen
)

Parameters

slaveaddr Int32
Slave device address.
cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.

Implements

BusWrite(Int32, Byte, Int32)
See Also

Reference

Bus Class
IO.Objects.SimpleIO.I2C Namespace


IO.Objects.SimpleIO.mikroBUS Namespace

Mikroelektronika mikroBUS (https://www.mikroe.com/mikrobus) Shield and Socket Services
Classes
 | Class | Description
Public class | Shield | Encapsulates mikroBUS shields (add-on boards providing mikroBUS sockets).
Public class | Socket | Encapsulates mikroBUS sockets.
Enumerations
 | Enumeration | Description
Public enumeration | ShieldKinds | Supported mikroBUS shields.


Shield Class

Encapsulates mikroBUS shields (add-on boards providing mikroBUS sockets).
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.mikroBUSShield

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class Shield

The Shield type exposes the following members.

Properties
Name | Description
kind | Returns the kind of mikroBUS shield that is installed on the target board, as obtained from the SHIELDNAME environment variable or guessed from the BOARDNAME environment variable. The guessed value for BeagleBone family target boards (BOARDNAME == "BeagleBone*") is BeagleBoneClick4. The guessed value for Raspberry Pi family target boards (BOARDNAME == "RaspberryPi*") is PiClick3.
Top
See Also

Reference

IO.Objects.SimpleIO.mikroBUS Namespace


Shield Properties

The Shield type exposes the following members.

Properties
Name | Description
kind | Returns the kind of mikroBUS shield that is installed on the target board, as obtained from the SHIELDNAME environment variable or guessed from the BOARDNAME environment variable. The guessed value for BeagleBone family target boards (BOARDNAME == "BeagleBone*") is BeagleBoneClick4. The guessed value for Raspberry Pi family target boards (BOARDNAME == "RaspberryPi*") is PiClick3.
Top
See Also

Reference

Shield Class
IO.Objects.SimpleIO.mikroBUS Namespace


Shield.kind Property

Shieldkind Property

Returns the kind of mikroBUS shield that is installed on the target board, as obtained from the SHIELDNAME environment variable or guessed from the BOARDNAME environment variable. The guessed value for BeagleBone family target boards (BOARDNAME == "BeagleBone*") is BeagleBoneClick4. The guessed value for Raspberry Pi family target boards (BOARDNAME == "RaspberryPi*") is PiClick3.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static ShieldKinds kind { get; }

Property Value

ShieldKinds
See Also

Reference

Shield Class
IO.Objects.SimpleIO.mikroBUS Namespace


Shield.Kinds Enumeration

ShieldKinds Enumeration

Supported mikroBUS shields.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public enum Kinds
Members
Member name | Value | Description
BeagleBoneClick2 | 0 | Mikroelektronika BeagleBone Click Shield MIKROE-1596, with two mikroBUS sockets. (Obsolete, but still useful.)
BeagleBoneClick4 | 1 | Mikroelektronika mikroBUS Cape MIKROE-1857 with four mikroBUS sockets.
PiClick1 | 2 | Mikroelektronika Pi Click Shield MIKROE-1512/1513 for 26-pin expansion header, with one mikroBUS socket (Obsolete.)
PiClick2 | 3 | Mikroelektronika Pi 2 Click Shield MIKROE-1879 for 40-pin expansion header, with two mikroBUS sockets.
PiClick3 | 4 | Mikroelektronika Pi 3 Click Shield MIKROE-2756 for 40-pin expansion header, with selectable on-board A/D converter and two mikroBUS sockets.
PocketBeagle | 5 | PocketBeagle with female headers on top, with two mikroBUS sockets.
Unknown | 2,147,483,647 | No known mikroBUS shield installed.
See Also

Reference

IO.Objects.SimpleIO.mikroBUS Namespace


Socket Class

Encapsulates mikroBUS sockets.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.mikroBUSSocket

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Socket

The Socket type exposes the following members.

Constructors
 | Name | Description
Public method | Socket | Constructor for a single mikroBUS socket.
Top
Properties
 | Name | Description
Public property | AIN | Returns the ADC input designator for AN.
Public property | AN | Returns the GPIO pin designator for AN.
Public property | CS | Returns the GPIO pin designator for CS.
Public property | I2CBus | Returns the I2C bus designator for this socket.
Public property | INT | Returns the GPIO pin designator for INT.
Public property | MISO | Returns the GPIO pin designator for MISO.
Public property | MOSI | Returns the GPIO pin designator for MOSI.
Public property | PWM | Returns the GPIO pin designator for PWM.
Public property | PWMOut | Returns the PWM output designator for this socket.
Public property | RST | Returns the GPIO pin designator for RST.
Public property | RX | Returns the GPIO pin designator for RX.
Public property | SCK | Returns the GPIO pin designator for SCK.
Public property | SCL | Returns the GPIO pin designator for SCL.
Public property | SDA | Returns the GPIO pin designator for SDA.
Public property | SPIDev | Returns the SPI device designator for this socket.
Public property | TX | Returns the GPIO pin designator for TX.
Public property | UART | Returns the UART device name for this socket.
Top
See Also

Reference

IO.Objects.SimpleIO.mikroBUS Namespace


Socket Constructor

Constructor for a single mikroBUS socket.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Socket(
    int num,
    ShieldKinds shield = ShieldKinds.Unknown
)

Parameters

num Int32
Socket number.
shield ShieldKinds (Optional)
mikroBUS shield kind. Shield.Kinds.Unknown indicates automatic detection using using the Shield.kind property.
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket Properties

The Socket type exposes the following members.

Properties
 | Name | Description
Public property | AIN | Returns the ADC input designator for AN.
Public property | AN | Returns the GPIO pin designator for AN.
Public property | CS | Returns the GPIO pin designator for CS.
Public property | I2CBus | Returns the I2C bus designator for this socket.
Public property | INT | Returns the GPIO pin designator for INT.
Public property | MISO | Returns the GPIO pin designator for MISO.
Public property | MOSI | Returns the GPIO pin designator for MOSI.
Public property | PWM | Returns the GPIO pin designator for PWM.
Public property | PWMOut | Returns the PWM output designator for this socket.
Public property | RST | Returns the GPIO pin designator for RST.
Public property | RX | Returns the GPIO pin designator for RX.
Public property | SCK | Returns the GPIO pin designator for SCK.
Public property | SCL | Returns the GPIO pin designator for SCL.
Public property | SDA | Returns the GPIO pin designator for SDA.
Public property | SPIDev | Returns the SPI device designator for this socket.
Public property | TX | Returns the GPIO pin designator for TX.
Public property | UART | Returns the UART device name for this socket.
Top
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.AIN Property

SocketAIN Property

Returns the ADC input designator for AN.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator AIN { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.AN Property

SocketAN Property

Returns the GPIO pin designator for AN.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator AN { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.CS Property

SocketCS Property

Returns the GPIO pin designator for CS.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator CS { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.I2CBus Property

SocketI2CBus Property

Returns the I2C bus designator for this socket.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator I2CBus { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.INT Property

SocketINT Property

Returns the GPIO pin designator for INT.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator INT { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.MISO Property

SocketMISO Property

Returns the GPIO pin designator for MISO.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator MISO { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.MOSI Property

SocketMOSI Property

Returns the GPIO pin designator for MOSI.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator MOSI { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.PWM Property

SocketPWM Property

Returns the GPIO pin designator for PWM.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator PWM { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.PWMOut Property

SocketPWMOut Property

Returns the PWM output designator for this socket.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator PWMOut { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.RST Property

SocketRST Property

Returns the GPIO pin designator for RST.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator RST { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.RX Property

SocketRX Property

Returns the GPIO pin designator for RX.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator RX { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.SCK Property

SocketSCK Property

Returns the GPIO pin designator for SCK.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator SCK { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.SCL Property

SocketSCL Property

Returns the GPIO pin designator for SCL.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator SCL { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.SDA Property

SocketSDA Property

Returns the GPIO pin designator for SDA.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator SDA { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.SPIDev Property

SocketSPIDev Property

Returns the SPI device designator for this socket.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator SPIDev { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.TX Property

SocketTX Property

Returns the GPIO pin designator for TX.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Designator TX { get; }

Property Value

Designator
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


Socket.UART Property

SocketUART Property

Returns the UART device name for this socket.

Namespace: IO.Objects.SimpleIO.mikroBUS
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public string UART { get; }

Property Value

String
See Also

Reference

Socket Class
IO.Objects.SimpleIO.mikroBUS Namespace


IO.Objects.SimpleIO.Platforms Namespace

Platform Definition Classes
Classes
 | Class | Description
Public class | BeagleBone | This class defines identifiers for the devices provided by the BeagleBone hardware platform.
Public class | MUNTS_0018 | This class provides designators for I/O resources available on the MUNTS-0018 Tutorial I/O Board.
Public class | MUNTS_0018OrangePiZero2W | This class provides designators specific to the 64-Bit Orange Pi Zero 2W interface computer.
Public class | MUNTS_0018RaspberryPi | This class provides designators specific to the 64-Bit Raspberry Pi Zero 2W interface computer.
Public class | OrangePiZero2W | This class provides designators for the devices available on the Orange Pi Zero 2W Linux microcomputer board.
Public class | OrangePiZero2W_RaspberryPi | This class provides Raspberry Pi compatible designator aliases for the devices available on the Orange Pi Zero 2W Linux microcomputer board.
Public class | PocketBeagle | This class defines identifiers for the devices provided by the PocketBeagle hardware platform. .
Public class | RaspberryPi | This class defines identifiers for the devices provided by the Raspberry Pi hardware platform.
Public class | RaspberryPi4 | This class defines identifiers for the devices provided by the Raspberry Pi 4 hardware platform.
Public class | RaspberryPi5 | This class defines identifiers for the devices provided by the Raspberry Pi 5 hardware platform.


BeagleBone Class

This class defines identifiers for the devices provided by the BeagleBone hardware platform.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsBeagleBone

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class BeagleBone

The BeagleBone type exposes the following members.

Fields
Name | Description
AIN0 | ADC input designator (0, 0) for P9.39 (1.8V).
AIN1 | ADC input designator (0, 1) for P9.40 (1.8V).
AIN2 | ADC input designator (0, 2) for P9.37 (1.8V).
AIN3 | ADC input designator (0, 3) for P9.38 (1.8V).
AIN4 | ADC input designator (0, 4) for P9.33 (1.8V).
AIN5 | ADC input designator (0, 5) for P9.36 (1.8V).
AIN6 | ADC input designator (0, 6) for P9.35 (1.8V).
EHRPWM0A | PWM output designator (1, 0) for P9.22 or P9.31. Conflicts with GPIO2 or GPIO110.
EHRPWM0B | PWM output designator (1, 1) for P9.21 or P9.29. Conflicts with GPIO3 or GPIO111.
EHRPWM1A | PWM output designator (3, 0) for P8.36 or P9.14. Conflicts with GPIO80 or GPIO50.
EHRPWM1B | PWM output designator (3, 1) for P8.34 or P9.16. Conflicts with GPIO81 or GPIO51.
EHRPWM2A | PWM output designator (6, 0) for P8.19 or P8.45. Conflicts with GPIO22 or GPIO70.
EHRPWM2B | PWM output designator (6, 1) for P8.13 or P8.46. Conflicts with GPIO23 or GPIO71.
GPIO10 | GPIO pin designator (0, 10) for P8.31.
GPIO11 | GPIO pin designator (0, 11) for P8.32.
GPIO110 | GPIO pin designator (3, 14) for P9.31. Conflicts with SPI1 SCLK or EHRPWM0A.
GPIO111 | GPIO pin designator (3, 15) for P9.29. Conflicts with SPI1 MISO.
GPIO112 | GPIO pin designator (3, 16) for P9.30. Conflicts with SPI1 MOSI.
GPIO113 | GPIO pin designator (3, 17) for P9.28. Conflicts with SPI1 SS0.
GPIO115 | GPIO pin designator (3, 19) for P9.27.
GPIO117 | GPIO pin designator (3, 21) for P9.25.
GPIO12 | GPIO pin designator (0, 12) for P9.20. Conflicts with I2C2 SDA.
GPIO13 | GPIO pin designator (0, 13) for P9.19. Conflicts with I2C2 SCL.
GPIO14 | GPIO pin designator (0, 14) for P9.26. Conflicts with UART1 RXD.
GPIO15 | GPIO pin designator (0, 15) for P9.24. Conflicts with UART1 TXD.
GPIO2 | GPIO pin designator (0, 2) for P9.22. Conflicts with SPI0 SCK, UART 2RXD or EHRPWM0A.
GPIO20 | GPIO pin designator (0, 20) for P9.41.
GPIO22 | GPIO pin designator (0, 22) for P8.19. Conflicts with EHRPWM2A.
GPIO23 | GPIO pin designator (0, 23) for P8.13. Conflicts with EHRPWM2B.
GPIO26 | GPIO pin designator (0, 26) for P8.14.
GPIO27 | GPIO pin designator (0, 27) for P8.17.
GPIO3 | GPIO pin designator (0, 3) for P9.21. Conflicts with SPI0 MISO or UART2 TXD.
GPIO30 | GPIO pin designator (0, 30) for P9.11. Conflicts with UART4 RXD.
GPIO31 | GPIO pin designator (0, 31) for P9.13. Conflicts with UART4 TXD.
GPIO32 | GPIO pin designator (1, 0) for P8.25. Conflicts with MMC DAT0.
GPIO33 | GPIO pin designator (1, 1) for P8.24. Conflicts with MMC1 DAT1.
GPIO34 | GPIO pin designator (1, 2) for P8.5. Conflicts with MMC1 DAT2.
GPIO35 | GPIO pin designator (1, 3) for P8.6. Conflicts with MMC1 DAT3.
GPIO36 | GPIO pin designator (1, 4) for P8.23. Conflicts with MMC DAT4.
GPIO37 | GPIO pin designator (1, 5) for P8.22. Conflicts with MMC1 DAT5.
GPIO38 | GPIO pin designator (1, 6) for P8.3. Conflicts with MMC1 DAT6.
GPIO39 | GPIO pin designator (1, 7) for P8.4. Conflicts with MMC1 DAT7.
GPIO4 | GPIO pin designator (0, 4) for P9.18. Conflicts with SPI0 MOSI.
GPIO44 | GPIO pin designator (1, 12) for P8.12.
GPIO45 | GPIO pin designator (1, 13) for P8.11.
GPIO46 | GPIO pin designator (1, 14) for P8.16.
GPIO47 | GPIO pin designator (1, 15) for P8.15.
GPIO48 | GPIO pin designator (1, 16) for P9.15.
GPIO49 | GPIO pin designator (1, 17) for P9.23.
GPIO5 | GPIO pin designator (0, 5) for P9.17. Conflicts with SPI0 SS0.
GPIO50 | GPIO pin designator (1, 18) for P9.14. Conflicts with EHRPWM1A.
GPIO51 | GPIO pin designator (1, 19) for P9.16. Conflicts with EHRPWM1B.
GPIO60 | GPIO pin designator (1, 28) for P9.12.
GPIO61 | GPIO pin designator (1, 29) for P8.26.
GPIO62 | GPIO pin designator (1, 30) for P8.21. Conflicts with MMC1 CLK.
GPIO63 | GPIO pin designator (1, 31) for P8.20. Conflicts with MMC1 CMD.
GPIO65 | GPIO pin designator (2, 1) for P8.18.
GPIO66 | GPIO pin designator (2, 2) for P8.7.
GPIO67 | GPIO pin designator (2, 3) for P8.8.
GPIO68 | GPIO pin designator (2, 4) for P8.10.
GPIO69 | GPIO pin designator (2, 5) for P8.9.
GPIO7 | GPIO pin designator (0, 7) for P9.42. Conflicts with SPI1 SS1.
GPIO70 | GPIO pin designator (2, 6) for P8.45. Conflicts with EHRPWM2A.
GPIO71 | GPIO pin designator (2, 7) for P8.46. Conflicts with EHRPWM2B.
GPIO72 | GPIO pin designator (2, 8) for P8.43.
GPIO73 | GPIO pin designator (2, 9) for P8.44.
GPIO74 | GPIO pin designator (2, 10) for P8.41.
GPIO75 | GPIO pin designator (2, 11) for P8.42.
GPIO76 | GPIO pin designator (2, 12) for P8.39.
GPIO77 | GPIO pin designator (2, 13) for P8.40.
GPIO78 | GPIO pin designator (2, 14) for P8.37. Conflicts with UART5 TXD.
GPIO79 | GPIO pin designator (2, 15) for P8.38. Conflicts with UART5 RXD.
GPIO8 | GPIO pin designator (0, 8) for P8.35.
GPIO80 | GPIO pin designator (2, 16) for P8.36. Conflicts with EHRPWM1A.
GPIO81 | GPIO pin designator (2, 17) for P8.34. Conflicts with EHRPWM1B.
GPIO86 | GPIO pin designator (2, 22) for P8.27.
GPIO87 | GPIO pin designator (2, 23) for P8.29.
GPIO88 | GPIO pin designator (2, 24) for P8.28.
GPIO89 | GPIO pin designator (2, 25) for P8.30.
GPIO9 | GPIO pin designator (0, 9) for P8.33.
I2C2 | I2C bus designator for P9.19 and P9.20. Conflicts with GPIO13 or GPIO12.
SPI0_0 | SPI slave designator (0, 0) for P9.17. Conflicts with GPIO5.
SPI1_0 | SPI slave designator (1, 0) for P9.28. Conflicts with GPIO113.
SPI1_1 | SPI slave designator (1, 1) for P9.42. Conflicts with GPIO7.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


BeagleBone Fields

The BeagleBone type exposes the following members.

Fields
Name | Description
AIN0 | ADC input designator (0, 0) for P9.39 (1.8V).
AIN1 | ADC input designator (0, 1) for P9.40 (1.8V).
AIN2 | ADC input designator (0, 2) for P9.37 (1.8V).
AIN3 | ADC input designator (0, 3) for P9.38 (1.8V).
AIN4 | ADC input designator (0, 4) for P9.33 (1.8V).
AIN5 | ADC input designator (0, 5) for P9.36 (1.8V).
AIN6 | ADC input designator (0, 6) for P9.35 (1.8V).
EHRPWM0A | PWM output designator (1, 0) for P9.22 or P9.31. Conflicts with GPIO2 or GPIO110.
EHRPWM0B | PWM output designator (1, 1) for P9.21 or P9.29. Conflicts with GPIO3 or GPIO111.
EHRPWM1A | PWM output designator (3, 0) for P8.36 or P9.14. Conflicts with GPIO80 or GPIO50.
EHRPWM1B | PWM output designator (3, 1) for P8.34 or P9.16. Conflicts with GPIO81 or GPIO51.
EHRPWM2A | PWM output designator (6, 0) for P8.19 or P8.45. Conflicts with GPIO22 or GPIO70.
EHRPWM2B | PWM output designator (6, 1) for P8.13 or P8.46. Conflicts with GPIO23 or GPIO71.
GPIO10 | GPIO pin designator (0, 10) for P8.31.
GPIO11 | GPIO pin designator (0, 11) for P8.32.
GPIO110 | GPIO pin designator (3, 14) for P9.31. Conflicts with SPI1 SCLK or EHRPWM0A.
GPIO111 | GPIO pin designator (3, 15) for P9.29. Conflicts with SPI1 MISO.
GPIO112 | GPIO pin designator (3, 16) for P9.30. Conflicts with SPI1 MOSI.
GPIO113 | GPIO pin designator (3, 17) for P9.28. Conflicts with SPI1 SS0.
GPIO115 | GPIO pin designator (3, 19) for P9.27.
GPIO117 | GPIO pin designator (3, 21) for P9.25.
GPIO12 | GPIO pin designator (0, 12) for P9.20. Conflicts with I2C2 SDA.
GPIO13 | GPIO pin designator (0, 13) for P9.19. Conflicts with I2C2 SCL.
GPIO14 | GPIO pin designator (0, 14) for P9.26. Conflicts with UART1 RXD.
GPIO15 | GPIO pin designator (0, 15) for P9.24. Conflicts with UART1 TXD.
GPIO2 | GPIO pin designator (0, 2) for P9.22. Conflicts with SPI0 SCK, UART 2RXD or EHRPWM0A.
GPIO20 | GPIO pin designator (0, 20) for P9.41.
GPIO22 | GPIO pin designator (0, 22) for P8.19. Conflicts with EHRPWM2A.
GPIO23 | GPIO pin designator (0, 23) for P8.13. Conflicts with EHRPWM2B.
GPIO26 | GPIO pin designator (0, 26) for P8.14.
GPIO27 | GPIO pin designator (0, 27) for P8.17.
GPIO3 | GPIO pin designator (0, 3) for P9.21. Conflicts with SPI0 MISO or UART2 TXD.
GPIO30 | GPIO pin designator (0, 30) for P9.11. Conflicts with UART4 RXD.
GPIO31 | GPIO pin designator (0, 31) for P9.13. Conflicts with UART4 TXD.
GPIO32 | GPIO pin designator (1, 0) for P8.25. Conflicts with MMC DAT0.
GPIO33 | GPIO pin designator (1, 1) for P8.24. Conflicts with MMC1 DAT1.
GPIO34 | GPIO pin designator (1, 2) for P8.5. Conflicts with MMC1 DAT2.
GPIO35 | GPIO pin designator (1, 3) for P8.6. Conflicts with MMC1 DAT3.
GPIO36 | GPIO pin designator (1, 4) for P8.23. Conflicts with MMC DAT4.
GPIO37 | GPIO pin designator (1, 5) for P8.22. Conflicts with MMC1 DAT5.
GPIO38 | GPIO pin designator (1, 6) for P8.3. Conflicts with MMC1 DAT6.
GPIO39 | GPIO pin designator (1, 7) for P8.4. Conflicts with MMC1 DAT7.
GPIO4 | GPIO pin designator (0, 4) for P9.18. Conflicts with SPI0 MOSI.
GPIO44 | GPIO pin designator (1, 12) for P8.12.
GPIO45 | GPIO pin designator (1, 13) for P8.11.
GPIO46 | GPIO pin designator (1, 14) for P8.16.
GPIO47 | GPIO pin designator (1, 15) for P8.15.
GPIO48 | GPIO pin designator (1, 16) for P9.15.
GPIO49 | GPIO pin designator (1, 17) for P9.23.
GPIO5 | GPIO pin designator (0, 5) for P9.17. Conflicts with SPI0 SS0.
GPIO50 | GPIO pin designator (1, 18) for P9.14. Conflicts with EHRPWM1A.
GPIO51 | GPIO pin designator (1, 19) for P9.16. Conflicts with EHRPWM1B.
GPIO60 | GPIO pin designator (1, 28) for P9.12.
GPIO61 | GPIO pin designator (1, 29) for P8.26.
GPIO62 | GPIO pin designator (1, 30) for P8.21. Conflicts with MMC1 CLK.
GPIO63 | GPIO pin designator (1, 31) for P8.20. Conflicts with MMC1 CMD.
GPIO65 | GPIO pin designator (2, 1) for P8.18.
GPIO66 | GPIO pin designator (2, 2) for P8.7.
GPIO67 | GPIO pin designator (2, 3) for P8.8.
GPIO68 | GPIO pin designator (2, 4) for P8.10.
GPIO69 | GPIO pin designator (2, 5) for P8.9.
GPIO7 | GPIO pin designator (0, 7) for P9.42. Conflicts with SPI1 SS1.
GPIO70 | GPIO pin designator (2, 6) for P8.45. Conflicts with EHRPWM2A.
GPIO71 | GPIO pin designator (2, 7) for P8.46. Conflicts with EHRPWM2B.
GPIO72 | GPIO pin designator (2, 8) for P8.43.
GPIO73 | GPIO pin designator (2, 9) for P8.44.
GPIO74 | GPIO pin designator (2, 10) for P8.41.
GPIO75 | GPIO pin designator (2, 11) for P8.42.
GPIO76 | GPIO pin designator (2, 12) for P8.39.
GPIO77 | GPIO pin designator (2, 13) for P8.40.
GPIO78 | GPIO pin designator (2, 14) for P8.37. Conflicts with UART5 TXD.
GPIO79 | GPIO pin designator (2, 15) for P8.38. Conflicts with UART5 RXD.
GPIO8 | GPIO pin designator (0, 8) for P8.35.
GPIO80 | GPIO pin designator (2, 16) for P8.36. Conflicts with EHRPWM1A.
GPIO81 | GPIO pin designator (2, 17) for P8.34. Conflicts with EHRPWM1B.
GPIO86 | GPIO pin designator (2, 22) for P8.27.
GPIO87 | GPIO pin designator (2, 23) for P8.29.
GPIO88 | GPIO pin designator (2, 24) for P8.28.
GPIO89 | GPIO pin designator (2, 25) for P8.30.
GPIO9 | GPIO pin designator (0, 9) for P8.33.
I2C2 | I2C bus designator for P9.19 and P9.20. Conflicts with GPIO13 or GPIO12.
SPI0_0 | SPI slave designator (0, 0) for P9.17. Conflicts with GPIO5.
SPI1_0 | SPI slave designator (1, 0) for P9.28. Conflicts with GPIO113.
SPI1_1 | SPI slave designator (1, 1) for P9.42. Conflicts with GPIO7.
Top
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN0 Field

BeagleBoneAIN0 Field

ADC input designator (0, 0) for P9.39 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN0

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN1 Field

BeagleBoneAIN1 Field

ADC input designator (0, 1) for P9.40 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN1

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN2 Field

BeagleBoneAIN2 Field

ADC input designator (0, 2) for P9.37 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN2

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN3 Field

BeagleBoneAIN3 Field

ADC input designator (0, 3) for P9.38 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN3

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN4 Field

BeagleBoneAIN4 Field

ADC input designator (0, 4) for P9.33 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN4

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN5 Field

BeagleBoneAIN5 Field

ADC input designator (0, 5) for P9.36 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN5

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.AIN6 Field

BeagleBoneAIN6 Field

ADC input designator (0, 6) for P9.35 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN6

Field Value

Designator
Remarks
Requires the BB-ADC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.EHRPWM0A Field

BeagleBoneEHRPWM0A Field

PWM output designator (1, 0) for P9.22 or P9.31. Conflicts with GPIO2 or GPIO110.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator EHRPWM0A

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.EHRPWM0B Field

BeagleBoneEHRPWM0B Field

PWM output designator (1, 1) for P9.21 or P9.29. Conflicts with GPIO3 or GPIO111.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator EHRPWM0B

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.EHRPWM1A Field

BeagleBoneEHRPWM1A Field

PWM output designator (3, 0) for P8.36 or P9.14. Conflicts with GPIO80 or GPIO50.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator EHRPWM1A

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.EHRPWM1B Field

BeagleBoneEHRPWM1B Field

PWM output designator (3, 1) for P8.34 or P9.16. Conflicts with GPIO81 or GPIO51.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator EHRPWM1B

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.EHRPWM2A Field

BeagleBoneEHRPWM2A Field

PWM output designator (6, 0) for P8.19 or P8.45. Conflicts with GPIO22 or GPIO70.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator EHRPWM2A

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.EHRPWM2B Field

BeagleBoneEHRPWM2B Field

PWM output designator (6, 1) for P8.13 or P8.46. Conflicts with GPIO23 or GPIO71.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator EHRPWM2B

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO10 Field

BeagleBoneGPIO10 Field

GPIO pin designator (0, 10) for P8.31.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO10

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO11 Field

BeagleBoneGPIO11 Field

GPIO pin designator (0, 11) for P8.32.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO11

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO110 Field

BeagleBoneGPIO110 Field

GPIO pin designator (3, 14) for P9.31. Conflicts with SPI1 SCLK or EHRPWM0A.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO110

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO111 Field

BeagleBoneGPIO111 Field

GPIO pin designator (3, 15) for P9.29. Conflicts with SPI1 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO111

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO112 Field

BeagleBoneGPIO112 Field

GPIO pin designator (3, 16) for P9.30. Conflicts with SPI1 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO112

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO113 Field

BeagleBoneGPIO113 Field

GPIO pin designator (3, 17) for P9.28. Conflicts with SPI1 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO113

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO115 Field

BeagleBoneGPIO115 Field

GPIO pin designator (3, 19) for P9.27.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO115

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO117 Field

BeagleBoneGPIO117 Field

GPIO pin designator (3, 21) for P9.25.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO117

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO12 Field

BeagleBoneGPIO12 Field

GPIO pin designator (0, 12) for P9.20. Conflicts with I2C2 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO12

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO13 Field

BeagleBoneGPIO13 Field

GPIO pin designator (0, 13) for P9.19. Conflicts with I2C2 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO13

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO14 Field

BeagleBoneGPIO14 Field

GPIO pin designator (0, 14) for P9.26. Conflicts with UART1 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO14

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO15 Field

BeagleBoneGPIO15 Field

GPIO pin designator (0, 15) for P9.24. Conflicts with UART1 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO15

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO2 Field

BeagleBoneGPIO2 Field

GPIO pin designator (0, 2) for P9.22. Conflicts with SPI0 SCK, UART 2RXD or EHRPWM0A.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO2

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO20 Field

BeagleBoneGPIO20 Field

GPIO pin designator (0, 20) for P9.41.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO20

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO22 Field

BeagleBoneGPIO22 Field

GPIO pin designator (0, 22) for P8.19. Conflicts with EHRPWM2A.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO22

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO23 Field

BeagleBoneGPIO23 Field

GPIO pin designator (0, 23) for P8.13. Conflicts with EHRPWM2B.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO23

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO26 Field

BeagleBoneGPIO26 Field

GPIO pin designator (0, 26) for P8.14.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO26

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO27 Field

BeagleBoneGPIO27 Field

GPIO pin designator (0, 27) for P8.17.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO27

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO3 Field

BeagleBoneGPIO3 Field

GPIO pin designator (0, 3) for P9.21. Conflicts with SPI0 MISO or UART2 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO3

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO30 Field

BeagleBoneGPIO30 Field

GPIO pin designator (0, 30) for P9.11. Conflicts with UART4 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO30

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO31 Field

BeagleBoneGPIO31 Field

GPIO pin designator (0, 31) for P9.13. Conflicts with UART4 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO31

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO32 Field

BeagleBoneGPIO32 Field

GPIO pin designator (1, 0) for P8.25. Conflicts with MMC DAT0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO32

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO33 Field

BeagleBoneGPIO33 Field

GPIO pin designator (1, 1) for P8.24. Conflicts with MMC1 DAT1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO33

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO34 Field

BeagleBoneGPIO34 Field

GPIO pin designator (1, 2) for P8.5. Conflicts with MMC1 DAT2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO34

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO35 Field

BeagleBoneGPIO35 Field

GPIO pin designator (1, 3) for P8.6. Conflicts with MMC1 DAT3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO35

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO36 Field

BeagleBoneGPIO36 Field

GPIO pin designator (1, 4) for P8.23. Conflicts with MMC DAT4.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO36

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO37 Field

BeagleBoneGPIO37 Field

GPIO pin designator (1, 5) for P8.22. Conflicts with MMC1 DAT5.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO37

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO38 Field

BeagleBoneGPIO38 Field

GPIO pin designator (1, 6) for P8.3. Conflicts with MMC1 DAT6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO38

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO39 Field

BeagleBoneGPIO39 Field

GPIO pin designator (1, 7) for P8.4. Conflicts with MMC1 DAT7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO39

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO4 Field

BeagleBoneGPIO4 Field

GPIO pin designator (0, 4) for P9.18. Conflicts with SPI0 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO4

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO44 Field

BeagleBoneGPIO44 Field

GPIO pin designator (1, 12) for P8.12.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO44

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO45 Field

BeagleBoneGPIO45 Field

GPIO pin designator (1, 13) for P8.11.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO45

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO46 Field

BeagleBoneGPIO46 Field

GPIO pin designator (1, 14) for P8.16.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO46

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO47 Field

BeagleBoneGPIO47 Field

GPIO pin designator (1, 15) for P8.15.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO47

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO48 Field

BeagleBoneGPIO48 Field

GPIO pin designator (1, 16) for P9.15.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO48

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO49 Field

BeagleBoneGPIO49 Field

GPIO pin designator (1, 17) for P9.23.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO49

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO5 Field

BeagleBoneGPIO5 Field

GPIO pin designator (0, 5) for P9.17. Conflicts with SPI0 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO5

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO50 Field

BeagleBoneGPIO50 Field

GPIO pin designator (1, 18) for P9.14. Conflicts with EHRPWM1A.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO50

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO51 Field

BeagleBoneGPIO51 Field

GPIO pin designator (1, 19) for P9.16. Conflicts with EHRPWM1B.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO51

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO60 Field

BeagleBoneGPIO60 Field

GPIO pin designator (1, 28) for P9.12.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO60

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO61 Field

BeagleBoneGPIO61 Field

GPIO pin designator (1, 29) for P8.26.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO61

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO62 Field

BeagleBoneGPIO62 Field

GPIO pin designator (1, 30) for P8.21. Conflicts with MMC1 CLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO62

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO63 Field

BeagleBoneGPIO63 Field

GPIO pin designator (1, 31) for P8.20. Conflicts with MMC1 CMD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO63

Field Value

Designator
Remarks
Requires the BeagleBone White and the BB-NOEMMC device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO65 Field

BeagleBoneGPIO65 Field

GPIO pin designator (2, 1) for P8.18.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO65

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO66 Field

BeagleBoneGPIO66 Field

GPIO pin designator (2, 2) for P8.7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO66

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO67 Field

BeagleBoneGPIO67 Field

GPIO pin designator (2, 3) for P8.8.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO67

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO68 Field

BeagleBoneGPIO68 Field

GPIO pin designator (2, 4) for P8.10.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO68

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO69 Field

BeagleBoneGPIO69 Field

GPIO pin designator (2, 5) for P8.9.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO69

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO7 Field

BeagleBoneGPIO7 Field

GPIO pin designator (0, 7) for P9.42. Conflicts with SPI1 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO7

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO70 Field

BeagleBoneGPIO70 Field

GPIO pin designator (2, 6) for P8.45. Conflicts with EHRPWM2A.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO70

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO71 Field

BeagleBoneGPIO71 Field

GPIO pin designator (2, 7) for P8.46. Conflicts with EHRPWM2B.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO71

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO72 Field

BeagleBoneGPIO72 Field

GPIO pin designator (2, 8) for P8.43.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO72

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO73 Field

BeagleBoneGPIO73 Field

GPIO pin designator (2, 9) for P8.44.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO73

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO74 Field

BeagleBoneGPIO74 Field

GPIO pin designator (2, 10) for P8.41.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO74

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO75 Field

BeagleBoneGPIO75 Field

GPIO pin designator (2, 11) for P8.42.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO75

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO76 Field

BeagleBoneGPIO76 Field

GPIO pin designator (2, 12) for P8.39.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO76

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO77 Field

BeagleBoneGPIO77 Field

GPIO pin designator (2, 13) for P8.40.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO77

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO78 Field

BeagleBoneGPIO78 Field

GPIO pin designator (2, 14) for P8.37. Conflicts with UART5 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO78

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO79 Field

BeagleBoneGPIO79 Field

GPIO pin designator (2, 15) for P8.38. Conflicts with UART5 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO79

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO8 Field

BeagleBoneGPIO8 Field

GPIO pin designator (0, 8) for P8.35.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO8

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO80 Field

BeagleBoneGPIO80 Field

GPIO pin designator (2, 16) for P8.36. Conflicts with EHRPWM1A.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO80

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO81 Field

BeagleBoneGPIO81 Field

GPIO pin designator (2, 17) for P8.34. Conflicts with EHRPWM1B.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO81

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO86 Field

BeagleBoneGPIO86 Field

GPIO pin designator (2, 22) for P8.27.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO86

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO87 Field

BeagleBoneGPIO87 Field

GPIO pin designator (2, 23) for P8.29.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO87

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO88 Field

BeagleBoneGPIO88 Field

GPIO pin designator (2, 24) for P8.28.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO88

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO89 Field

BeagleBoneGPIO89 Field

GPIO pin designator (2, 25) for P8.30.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO89

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.GPIO9 Field

BeagleBoneGPIO9 Field

GPIO pin designator (0, 9) for P8.33.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO9

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.I2C2 Field

BeagleBoneI2C2 Field

I2C bus designator for P9.19 and P9.20. Conflicts with GPIO13 or GPIO12.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C2

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.SPI0_0 Field

BeagleBoneSPI0_0 Field

SPI slave designator (0, 0) for P9.17. Conflicts with GPIO5.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_0

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.SPI1_0 Field

BeagleBoneSPI1_0 Field

SPI slave designator (1, 0) for P9.28. Conflicts with GPIO113.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_0

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


BeagleBone.SPI1_1 Field

BeagleBoneSPI1_1 Field

SPI slave designator (1, 1) for P9.42. Conflicts with GPIO7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_1

Field Value

Designator
Remarks
Requires the BB-GPIO device tree overlay.
See Also

Reference

BeagleBone Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018 Class

This class provides designators for I/O resources available on the MUNTS-0018 Tutorial I/O Board.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsMUNTS_0018

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class MUNTS_0018
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W Class

MUNTS_0018OrangePiZero2W Class

This class provides designators specific to the 64-Bit Orange Pi Zero 2W interface computer.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsMUNTS_0018OrangePiZero2W

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class OrangePiZero2W

The MUNTS_0018OrangePiZero2W type exposes the following members.

Methods
Name | Description
AnalogInputFactory | Analog input object factory for the on-board analog inputs at connectors J10 and J11.
ButtonInputFactory | GPIO pin object factory for the on-board button switch at SW1.
GPIOPinFactory | GPIO pin object factory for GPIO pins at connectors J4 to J7.
I2CBusFactory | I2C bus object factory for the on-board I2C bus at connector J9.
LEDOutputFactory | GPIO pin object factory for the on-board LED at D1.
MotorOutputFactory | Motor output object factory for the on-board motor output at connector J6.
ServoOutputFactory | Servo output object factory for the on-board servo output at header J2.
Top
Fields
Name | Description
D1 | GPIO pin Designator for the on-board LED D1.
J10A0 | Analog input Designator for Analog Input Grove Connector J10 pin A0 (MCP3204 input CH2.
J10A1 | Analog input Designator for Analog Input Grove Connector J10 pin A1 (MCP3204 input CH3.
J11A0 | Analog input Designator for Analog Input Grove Connector J11 pin A0 (MCP3204 input CH0.
J11A1 | Analog input Designator for Analog Input Grove Connector J11 pin A1 (MCP3204 input CH1.
J2PWM | PWM output Designator for Servo Header J2.
J4D0 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D0.
J4D1 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D1.
J5D0 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D0.
J5D1 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D1.
J6D0 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D0.
J6D1 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D1.
J6DIR | Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.
J6DIR_MD13S | Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ6 as configured for the Cytron MD13S Grove motor driver board.
J6PWM | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6.
J6PWM_MD13S | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6 as configured for the Cytron MD13S Grove motor driver board.
J7D0 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D0.
J7D1 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D1.
J9I2C | I2C bus Designator for I2C Grove Connector J9.
SW1 | GPIO pin Designator for the on-board momentary switch SW1.
Top
Remarks
The Orange Pi Zero 2 W does not route PWM signals to GPIO18 or GPIO19, so servo header J2 and PWM Grove socket J7 are not usable except as extro GPIO pins.
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W Methods

The MUNTS_0018OrangePiZero2W type exposes the following members.

Methods
Name | Description
AnalogInputFactory | Analog input object factory for the on-board analog inputs at connectors J10 and J11.
ButtonInputFactory | GPIO pin object factory for the on-board button switch at SW1.
GPIOPinFactory | GPIO pin object factory for GPIO pins at connectors J4 to J7.
I2CBusFactory | I2C bus object factory for the on-board I2C bus at connector J9.
LEDOutputFactory | GPIO pin object factory for the on-board LED at D1.
MotorOutputFactory | Motor output object factory for the on-board motor output at connector J6.
ServoOutputFactory | Servo output object factory for the on-board servo output at header J2.
Top
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.AnalogInputFactory Method

MUNTS_0018OrangePiZero2WAnalogInputFactory Method

Analog input object factory for the on-board analog inputs at connectors J10 and J11.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Voltage AnalogInputFactory(
    Designator desg
)

Parameters

desg Designator
Device designator for one of the on-board analog inputs (J10A0, J10A1, J11A0, or J11A1).

Return Value

Voltage
Analog input object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.ButtonInputFactory Method

MUNTS_0018OrangePiZero2WButtonInputFactory Method

GPIO pin object factory for the on-board button switch at SW1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Pin ButtonInputFactory(
    Edge edge = Edge.None
)

Parameters

edge Edge (Optional)
Interrupt edge setting.

Return Value

Pin
GPIO input pin object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.GPIOPinFactory Method

MUNTS_0018OrangePiZero2WGPIOPinFactory Method

GPIO pin object factory for GPIO pins at connectors J4 to J7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Pin GPIOPinFactory(
    Designator desg,
    Direction dir,
    bool state = false,
    Driver driver = Driver.PushPull,
    Edge edge = Edge.None,
    Polarity polarity = Polarity.ActiveHigh
)

Parameters

desg Designator
Device designator for one of the on-board GPIO pins (J4D0 to J7D1.
dir Direction
Data direction.
state Boolean (Optional)
Initial GPIO output state.
driver Driver (Optional)
Output driver setting.
edge Edge (Optional)
Interrupt edge setting.
polarity Polarity (Optional)
Polarity setting.

Return Value

Pin
GPIO pin object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.I2CBusFactory Method

MUNTS_0018OrangePiZero2WI2CBusFactory Method

I2C bus object factory for the on-board I2C bus at connector J9.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Bus I2CBusFactory()

Return Value

Bus
I2C bus object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.LEDOutputFactory Method

MUNTS_0018OrangePiZero2WLEDOutputFactory Method

GPIO pin object factory for the on-board LED at D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Pin LEDOutputFactory(
    bool state = false
)

Parameters

state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO output pin object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.MotorOutputFactory Method

MUNTS_0018OrangePiZero2WMotorOutputFactory Method

Motor output object factory for the on-board motor output at connector J6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Output MotorOutputFactory(
    Designator speed,
    Designator direction,
    int frequency,
    double velocity = 0
)

Parameters

speed Designator
Device designator for the motor speed PWM output (J6PWM).
direction Designator
Device designator for the motor direction GPIO output (J6DIR).
frequency Int32
PWM pulse frequency.
velocity Double (Optional)
Initial motor velocity.

Return Value

Output
Motor output object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.ServoOutputFactory Method

MUNTS_0018OrangePiZero2WServoOutputFactory Method

Servo output object factory for the on-board servo output at header J2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Output ServoOutputFactory(
    Designator desg,
    int frequency = 50
)

Parameters

desg Designator
Device designator for one of the on-board PWM outputs (J2PWM).
frequency Int32 (Optional)
PWM pulse frequency. Ordinary analog servos operate best at 50 Hz.

Return Value

Output
Servo output object.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W Fields

The MUNTS_0018OrangePiZero2W type exposes the following members.

Fields
Name | Description
D1 | GPIO pin Designator for the on-board LED D1.
J10A0 | Analog input Designator for Analog Input Grove Connector J10 pin A0 (MCP3204 input CH2.
J10A1 | Analog input Designator for Analog Input Grove Connector J10 pin A1 (MCP3204 input CH3.
J11A0 | Analog input Designator for Analog Input Grove Connector J11 pin A0 (MCP3204 input CH0.
J11A1 | Analog input Designator for Analog Input Grove Connector J11 pin A1 (MCP3204 input CH1.
J2PWM | PWM output Designator for Servo Header J2.
J4D0 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D0.
J4D1 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D1.
J5D0 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D0.
J5D1 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D1.
J6D0 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D0.
J6D1 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D1.
J6DIR | Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.
J6DIR_MD13S | Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ6 as configured for the Cytron MD13S Grove motor driver board.
J6PWM | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6.
J6PWM_MD13S | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6 as configured for the Cytron MD13S Grove motor driver board.
J7D0 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D0.
J7D1 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D1.
J9I2C | I2C bus Designator for I2C Grove Connector J9.
SW1 | GPIO pin Designator for the on-board momentary switch SW1.
Top
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.D1 Field

MUNTS_0018OrangePiZero2WD1 Field

GPIO pin Designator for the on-board LED D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator D1

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J10A0 Field

MUNTS_0018OrangePiZero2WJ10A0 Field

Analog input Designator for Analog Input Grove Connector J10 pin A0 (MCP3204 input CH2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J10A0

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J10A1 Field

MUNTS_0018OrangePiZero2WJ10A1 Field

Analog input Designator for Analog Input Grove Connector J10 pin A1 (MCP3204 input CH3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J10A1

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J11A0 Field

MUNTS_0018OrangePiZero2WJ11A0 Field

Analog input Designator for Analog Input Grove Connector J11 pin A0 (MCP3204 input CH0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J11A0

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J11A1 Field

MUNTS_0018OrangePiZero2WJ11A1 Field

Analog input Designator for Analog Input Grove Connector J11 pin A1 (MCP3204 input CH1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J11A1

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J2PWM Field

MUNTS_0018OrangePiZero2WJ2PWM Field

PWM output Designator for Servo Header J2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J2PWM

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J4D0 Field

MUNTS_0018OrangePiZero2WJ4D0 Field

GPIO pin Designator for Digital I/O Grove Connector J4 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J4D0

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J4D1 Field

MUNTS_0018OrangePiZero2WJ4D1 Field

GPIO pin Designator for Digital I/O Grove Connector J4 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J4D1

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J5D0 Field

MUNTS_0018OrangePiZero2WJ5D0 Field

GPIO pin Designator for Digital I/O Grove Connector J5 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J5D0

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J5D1 Field

MUNTS_0018OrangePiZero2WJ5D1 Field

GPIO pin Designator for Digital I/O Grove Connector J5 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J5D1

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J6D0 Field

MUNTS_0018OrangePiZero2WJ6D0 Field

GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6D0

Field Value

Designator
Remarks
This GPIO pin is normally unusable because it is configured as a motor speed control PWM output.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J6D1 Field

MUNTS_0018OrangePiZero2WJ6D1 Field

GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6D1

Field Value

Designator
Remarks
This GPIO pin is normally unusable because it is configured as a motor direction control GPIO output.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J6DIR Field

MUNTS_0018OrangePiZero2WJ6DIR Field

Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6DIR

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J6DIR_MD13S Field

MUNTS_0018OrangePiZero2WJ6DIR_MD13S Field

Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ6 as configured for the Cytron MD13S Grove motor driver board.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6DIR_MD13S

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J6PWM Field

MUNTS_0018OrangePiZero2WJ6PWM Field

Motor speed PWM output Designator for DC Motor Driver Grove Connector J6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6PWM

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J6PWM_MD13S Field

MUNTS_0018OrangePiZero2WJ6PWM_MD13S Field

Motor speed PWM output Designator for DC Motor Driver Grove Connector J6 as configured for the Cytron MD13S Grove motor driver board.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6PWM_MD13S

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J7D0 Field

MUNTS_0018OrangePiZero2WJ7D0 Field

GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7D0

Field Value

Designator
Remarks
Unlike the Raspberry Pi, the Orange Pi Zero 2 W cannot route a PWM output to this pin.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J7D1 Field

MUNTS_0018OrangePiZero2WJ7D1 Field

GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7D1

Field Value

Designator
Remarks
Unlike the Raspberry Pi, the Orange Pi Zero 2 W cannot route a PWM output to this pin.
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.J9I2C Field

MUNTS_0018OrangePiZero2WJ9I2C Field

I2C bus Designator for I2C Grove Connector J9.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J9I2C

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.OrangePiZero2W.SW1 Field

MUNTS_0018OrangePiZero2WSW1 Field

GPIO pin Designator for the on-board momentary switch SW1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SW1

Field Value

Designator
See Also

Reference

MUNTS_0018OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi Class

MUNTS_0018RaspberryPi Class

This class provides designators specific to the 64-Bit Raspberry Pi Zero 2W interface computer.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsMUNTS_0018RaspberryPi

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class RaspberryPi

The MUNTS_0018RaspberryPi type exposes the following members.

Methods
Name | Description
AnalogInputFactory | Analog input object factory for the on-board analog inputs at connectors J10 and J11.
ButtonInputFactory | GPIO pin object factory for the on-board button switch at SW1.
GPIOPinFactory | GPIO pin object factory for GPIO pins at connectors J4 to J7.
I2CBusFactory | I2C bus object factory for the on-board I2C bus at connector J9.
LEDOutputFactory | GPIO pin object factory for the on-board LED at D1.
MotorOutputFactory | Motor output object factory for the on-board motor outputs at connectors J6 and J7.
ServoOutputFactory | Servo output object factory for the on-board servo outputs at headers J2 and J3.
Top
Fields
Name | Description
D1 | GPIO pin Designator for the on-board LED D1.
J10A0 | Analog input Designator for Analog Input Grove Connector J10 pin A0 (MCP3204 input CH2.
J10A1 | Analog input Designator for Analog Input Grove Connector J10 pin A1 (MCP3204 input CH3.
J11A0 | Analog input Designator for Analog Input Grove Connector J11 pin A0 (MCP3204 input CH0.
J11A1 | Analog input Designator for Analog Input Grove Connector J11 pin A1 (MCP3204 input CH1.
J2PWM | Servo position PWM output Designator for Servo Header J2.
J3PWM | Servo position PWM output Designator for Servo Header J3.
J4D0 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D0.
J4D1 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D1.
J5D0 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D0.
J5D1 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D1.
J6D0 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D0.
J6D1 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D1.
J6DIR | Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.
J6DIR_MD13S | Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ6 as configured for the Cytron MD13S Grove motor driver board.
J6PWM | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6.
J6PWM_MD13S | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6 as configured for the Cytron MD13S Grove motor driver board.
J7D0 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D0.
J7D1 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D1.
J7DIR | Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.
J7DIR_MD13S | Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ7 as configured for the Cytron MD13S Grove motor driver board.
J7PWM | Motor speed PWM output Designator for DC Motor Driver Grove Connector J7.
J7PWM_MD13S | Motor speed PWM output Designator for DC Motor Driver Grove Connector J7 as configured for the Cytron MD13S Grove motor driver board.
J9I2C | I2C bus Designator for /dev/i2c-1 on I2C Grove Connector J9.
SW1 | GPIO pin Designator for the on-board momentary switch SW1.
Top
Remarks
The following device tree overlay commands must be added to /boot/config.txt:
C#
Copy
dtoverlay=anyspi,spi0-1,dev="microchip,mcp3204",speed=1000000
dtoverlay=pwm-2chan,pin=12,func=4,pin2=19,func2=2
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi Methods

The MUNTS_0018RaspberryPi type exposes the following members.

Methods
Name | Description
AnalogInputFactory | Analog input object factory for the on-board analog inputs at connectors J10 and J11.
ButtonInputFactory | GPIO pin object factory for the on-board button switch at SW1.
GPIOPinFactory | GPIO pin object factory for GPIO pins at connectors J4 to J7.
I2CBusFactory | I2C bus object factory for the on-board I2C bus at connector J9.
LEDOutputFactory | GPIO pin object factory for the on-board LED at D1.
MotorOutputFactory | Motor output object factory for the on-board motor outputs at connectors J6 and J7.
ServoOutputFactory | Servo output object factory for the on-board servo outputs at headers J2 and J3.
Top
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.AnalogInputFactory Method

MUNTS_0018RaspberryPiAnalogInputFactory Method

Analog input object factory for the on-board analog inputs at connectors J10 and J11.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Voltage AnalogInputFactory(
    Designator desg
)

Parameters

desg Designator
Device designator for one of the on-board analog inputs (J10A0, J10A1, J11A0, or J11A1).

Return Value

Voltage
Analog input object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.ButtonInputFactory Method

MUNTS_0018RaspberryPiButtonInputFactory Method

GPIO pin object factory for the on-board button switch at SW1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Pin ButtonInputFactory(
    Edge edge = Edge.None
)

Parameters

edge Edge (Optional)
Interrupt edge setting.

Return Value

Pin
GPIO input pin object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.GPIOPinFactory Method

MUNTS_0018RaspberryPiGPIOPinFactory Method

GPIO pin object factory for GPIO pins at connectors J4 to J7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Pin GPIOPinFactory(
    Designator desg,
    Direction dir,
    bool state = false,
    Driver driver = Driver.PushPull,
    Edge edge = Edge.None,
    Polarity polarity = Polarity.ActiveHigh
)

Parameters

desg Designator
Device designator for one of the on-board GPIO pins (J4D0 to J7D1.
dir Direction
Data direction.
state Boolean (Optional)
Initial GPIO output state.
driver Driver (Optional)
Output driver setting.
edge Edge (Optional)
Interrupt edge setting.
polarity Polarity (Optional)
Polarity setting.

Return Value

Pin
GPIO pin object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.I2CBusFactory Method

MUNTS_0018RaspberryPiI2CBusFactory Method

I2C bus object factory for the on-board I2C bus at connector J9.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Bus I2CBusFactory()

Return Value

Bus
I2C bus object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.LEDOutputFactory Method

MUNTS_0018RaspberryPiLEDOutputFactory Method

GPIO pin object factory for the on-board LED at D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Pin LEDOutputFactory(
    bool state = false
)

Parameters

state Boolean (Optional)
Initial GPIO output state.

Return Value

Pin
GPIO output pin object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.MotorOutputFactory Method

MUNTS_0018RaspberryPiMotorOutputFactory Method

Motor output object factory for the on-board motor outputs at connectors J6 and J7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Output MotorOutputFactory(
    Designator speed,
    Designator direction,
    int frequency,
    double velocity = 0
)

Parameters

speed Designator
Device designator for the motor speed PWM output (J6PWM or J7PWM).
direction Designator
Device designator for the motor direction GPIO output (J6DIR or J7DIR).
frequency Int32
PWM pulse frequency.
velocity Double (Optional)
Initial motor velocity.

Return Value

Output
Motor output object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.ServoOutputFactory Method

MUNTS_0018RaspberryPiServoOutputFactory Method

Servo output object factory for the on-board servo outputs at headers J2 and J3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static Output ServoOutputFactory(
    Designator desg,
    int frequency = 50
)

Parameters

desg Designator
Device designator for one of the on-board PWM outputs (J2PWM or J3PWM).
frequency Int32 (Optional)
PWM pulse frequency. Ordinary analog servos operate best at 50 Hz.

Return Value

Output
Servo output object.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi Fields

The MUNTS_0018RaspberryPi type exposes the following members.

Fields
Name | Description
D1 | GPIO pin Designator for the on-board LED D1.
J10A0 | Analog input Designator for Analog Input Grove Connector J10 pin A0 (MCP3204 input CH2.
J10A1 | Analog input Designator for Analog Input Grove Connector J10 pin A1 (MCP3204 input CH3.
J11A0 | Analog input Designator for Analog Input Grove Connector J11 pin A0 (MCP3204 input CH0.
J11A1 | Analog input Designator for Analog Input Grove Connector J11 pin A1 (MCP3204 input CH1.
J2PWM | Servo position PWM output Designator for Servo Header J2.
J3PWM | Servo position PWM output Designator for Servo Header J3.
J4D0 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D0.
J4D1 | GPIO pin Designator for Digital I/O Grove Connector J4 pin D1.
J5D0 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D0.
J5D1 | GPIO pin Designator for Digital I/O Grove Connector J5 pin D1.
J6D0 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D0.
J6D1 | GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D1.
J6DIR | Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.
J6DIR_MD13S | Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ6 as configured for the Cytron MD13S Grove motor driver board.
J6PWM | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6.
J6PWM_MD13S | Motor speed PWM output Designator for DC Motor Driver Grove Connector J6 as configured for the Cytron MD13S Grove motor driver board.
J7D0 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D0.
J7D1 | GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D1.
J7DIR | Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.
J7DIR_MD13S | Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ7 as configured for the Cytron MD13S Grove motor driver board.
J7PWM | Motor speed PWM output Designator for DC Motor Driver Grove Connector J7.
J7PWM_MD13S | Motor speed PWM output Designator for DC Motor Driver Grove Connector J7 as configured for the Cytron MD13S Grove motor driver board.
J9I2C | I2C bus Designator for /dev/i2c-1 on I2C Grove Connector J9.
SW1 | GPIO pin Designator for the on-board momentary switch SW1.
Top
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.D1 Field

MUNTS_0018RaspberryPiD1 Field

GPIO pin Designator for the on-board LED D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator D1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J10A0 Field

MUNTS_0018RaspberryPiJ10A0 Field

Analog input Designator for Analog Input Grove Connector J10 pin A0 (MCP3204 input CH2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J10A0

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J10A1 Field

MUNTS_0018RaspberryPiJ10A1 Field

Analog input Designator for Analog Input Grove Connector J10 pin A1 (MCP3204 input CH3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J10A1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J11A0 Field

MUNTS_0018RaspberryPiJ11A0 Field

Analog input Designator for Analog Input Grove Connector J11 pin A0 (MCP3204 input CH0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J11A0

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J11A1 Field

MUNTS_0018RaspberryPiJ11A1 Field

Analog input Designator for Analog Input Grove Connector J11 pin A1 (MCP3204 input CH1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J11A1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J2PWM Field

MUNTS_0018RaspberryPiJ2PWM Field

Servo position PWM output Designator for Servo Header J2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J2PWM

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J3PWM Field

MUNTS_0018RaspberryPiJ3PWM Field

Servo position PWM output Designator for Servo Header J3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J3PWM

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J4D0 Field

MUNTS_0018RaspberryPiJ4D0 Field

GPIO pin Designator for Digital I/O Grove Connector J4 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J4D0

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J4D1 Field

MUNTS_0018RaspberryPiJ4D1 Field

GPIO pin Designator for Digital I/O Grove Connector J4 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J4D1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J5D0 Field

MUNTS_0018RaspberryPiJ5D0 Field

GPIO pin Designator for Digital I/O Grove Connector J5 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J5D0

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J5D1 Field

MUNTS_0018RaspberryPiJ5D1 Field

GPIO pin Designator for Digital I/O Grove Connector J5 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J5D1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J6D0 Field

MUNTS_0018RaspberryPiJ6D0 Field

GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6D0

Field Value

Designator
Remarks
This GPIO pin is normally unusable because GPIO12 is mapped to PWM output PWM0.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J6D1 Field

MUNTS_0018RaspberryPiJ6D1 Field

GPIO pin Designator for DC Motor Driver Grove Connector J6 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6D1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J6DIR Field

MUNTS_0018RaspberryPiJ6DIR Field

Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6DIR

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J6DIR_MD13S Field

MUNTS_0018RaspberryPiJ6DIR_MD13S Field

Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ6 as configured for the Cytron MD13S Grove motor driver board.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6DIR_MD13S

Field Value

Designator
Remarks
The speed and direction pins need to be swapped for the MD13S. This requires using the MUNTS-0018-MD13S device tree overlay instead of MUNTS-0018 to arrange the Raspberry Pi expansion bus PWM and GPIO pins properly for the MD13S.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J6PWM Field

MUNTS_0018RaspberryPiJ6PWM Field

Motor speed PWM output Designator for DC Motor Driver Grove Connector J6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6PWM

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J6PWM_MD13S Field

MUNTS_0018RaspberryPiJ6PWM_MD13S Field

Motor speed PWM output Designator for DC Motor Driver Grove Connector J6 as configured for the Cytron MD13S Grove motor driver board.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J6PWM_MD13S

Field Value

Designator
Remarks
The speed and direction pins need to be swapped for the MD13S. This requires using the MUNTS-0018-MD13S device tree overlay instead of MUNTS-0018 to arrange the Raspberry Pi expansion bus PWM and GPIO pins properly for the MD13S.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J7D0 Field

MUNTS_0018RaspberryPiJ7D0 Field

GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7D0

Field Value

Designator
Remarks
This GPIO pin is normally unusable because GPIO19 is mapped to PWM output PWM1.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J7D1 Field

MUNTS_0018RaspberryPiJ7D1 Field

GPIO pin Designator for DC Motor Driver Grove Connector J7 pin D1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7D1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J7DIR Field

MUNTS_0018RaspberryPiJ7DIR Field

Motor direction GPIO output pin Designator for DC Motor Driver Grove Connector J6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7DIR

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J7DIR_MD13S Field

MUNTS_0018RaspberryPiJ7DIR_MD13S Field

Motor direction GPIO output pin Designator for DC Motor Driver Grove ConnectorJ7 as configured for the Cytron MD13S Grove motor driver board.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7DIR_MD13S

Field Value

Designator
Remarks
The speed and direction pins need to be swapped for the MD13S. This requires using the MUNTS-0018-MD13S device tree overlay instead of MUNTS-0018 to arrange the Raspberry Pi expansion bus PWM and GPIO pins properly for the MD13S.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J7PWM Field

MUNTS_0018RaspberryPiJ7PWM Field

Motor speed PWM output Designator for DC Motor Driver Grove Connector J7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7PWM

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J7PWM_MD13S Field

MUNTS_0018RaspberryPiJ7PWM_MD13S Field

Motor speed PWM output Designator for DC Motor Driver Grove Connector J7 as configured for the Cytron MD13S Grove motor driver board.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J7PWM_MD13S

Field Value

Designator
Remarks
The speed and direction pins need to be swapped for the MD13S. This requires using the MUNTS-0018-MD13S device tree overlay instead of MUNTS-0018 to arrange the Raspberry Pi expansion bus PWM and GPIO pins properly for the MD13S.
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.J9I2C Field

MUNTS_0018RaspberryPiJ9I2C Field

I2C bus Designator for /dev/i2c-1 on I2C Grove Connector J9.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator J9I2C

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


MUNTS_0018.RaspberryPi.SW1 Field

MUNTS_0018RaspberryPiSW1 Field

GPIO pin Designator for the on-board momentary switch SW1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SW1

Field Value

Designator
See Also

Reference

MUNTS_0018RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W Class

This class provides designators for the devices available on the Orange Pi Zero 2W Linux microcomputer board.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsOrangePiZero2W

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class OrangePiZero2W

The OrangePiZero2W type exposes the following members.

Fields
Name | Description
GPIO224 | GPIO pin designator for expansion header pin 8. Conflicts with UART0 TXD.
GPIO225 | GPIO pin designator for expansion header pin 10. Conflicts with UART0 RXD.
GPIO226 | GPIO pin designator for expansion header pin 11. Conflicts with UART5 TXD.
GPIO227 | GPIO pin designator for expansion header pin 13. Conflicts with UART5 RXD.
GPIO228 | GPIO pin designator for expansion header pin 18.
GPIO229 | GPIO pin designator for expansion header pin 24. Conflicts with SPI1 CS0.
GPIO230 | GPIO pin designator for expansion header pin 23. Conflicts with SPI1 SCLK.
GPIO231 | GPIO pin designator for expansion header pin 19. Conflicts with SPI1 MOSI.
GPIO232 | GPIO pin designator for expansion header pin 21. Conflicts with SPI1 MISO.
GPIO233 | GPIO pin designator for expansion header pin 26. Conflicts with SPI1 CS1.
GPIO256 | GPIO pin designator for expansion header pin 29.
GPIO257 | GPIO pin designator for expansion header pin 12.
GPIO258 | GPIO pin designator for expansion header pin 35.
GPIO259 | GPIO pin designator for expansion header pin 40.
GPIO260 | GPIO pin designator for expansion header pin 38.
GPIO261 | GPIO pin designator for expansion header pin 15. Conflicts with I2C0 SCL and UART2 TXD.
GPIO262 | GPIO pin designator for expansion header pin 22. Conflicts with I2C0 SDA and UART2 RXD.
GPIO263 | GPIO pin designator for expansion header pin 5. Conflicts with I2C1 SCL.
GPIO264 | GPIO pin designator for expansion header pin 3. Conflicts with I2C1 SDA.
GPIO265 | GPIO pin designator for expansion header pin 28. Conflicts with I2C2 SCL and UART3 RXD.
GPIO266 | GPIO pin designator for expansion header pin 27. Conflicts with I2C2 SDA and UART3 TXD.
GPIO267 | GPIO pin designator for expansion header pin 32. Conflicts with PWM1.
GPIO268 | GPIO pin designator for expansion header pin 33. Conflicts with PWM2.
GPIO269 | GPIO pin designator for expansion header pin 7. Conflicts with PWM3 and UART4 TXD.
GPIO270 | GPIO pin designator for expansion header pin 16. Conflicts with PWM4 and UART4 RXD.
GPIO271 | GPIO pin designator for expansion header pin 31.
GPIO272 | GPIO pin designator for expansion header pin 37.
GPIO76 | GPIO pin designator for expansion header pin 36.
I2C0 | I2C bus designator for expansion header pins 15 and 22. Conflicts with GPIO261, GPIO262, UART2 TXD> and and UART2 RXD.
I2C1 | I2C bus designator for expansion header pins 3 and 5. Conflicts with GPIO263 and GPIO264.
I2C2 | I2C bus designator for expansion header pins 27 and 28. Conflicts with GPIO265, GPIO266, UART3 RXD and UART3 TXD.
PWM1 | PWM output designator for expansion header pin 32. Conflicts with GPIO267.
PWM2 | PWM output designator for expansion header pin 33. Conflicts with GPIO268.
PWM3 | PWM output designator for expansion header pin 7. Conflicts with GPIO269 and UART4 TXD.
PWM4 | PWM output designator for expansion header pin 16. Conflicts with GPIO270 and UART4 RXD.
SPI1_0 | SPI slave select designator for expansion header pin 24. Conflicts with GPIO229.
SPI1_1 | SPI slave select designator for expansion header pin 26. Conflicts with GPIO233.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W Fields

The OrangePiZero2W type exposes the following members.

Fields
Name | Description
GPIO224 | GPIO pin designator for expansion header pin 8. Conflicts with UART0 TXD.
GPIO225 | GPIO pin designator for expansion header pin 10. Conflicts with UART0 RXD.
GPIO226 | GPIO pin designator for expansion header pin 11. Conflicts with UART5 TXD.
GPIO227 | GPIO pin designator for expansion header pin 13. Conflicts with UART5 RXD.
GPIO228 | GPIO pin designator for expansion header pin 18.
GPIO229 | GPIO pin designator for expansion header pin 24. Conflicts with SPI1 CS0.
GPIO230 | GPIO pin designator for expansion header pin 23. Conflicts with SPI1 SCLK.
GPIO231 | GPIO pin designator for expansion header pin 19. Conflicts with SPI1 MOSI.
GPIO232 | GPIO pin designator for expansion header pin 21. Conflicts with SPI1 MISO.
GPIO233 | GPIO pin designator for expansion header pin 26. Conflicts with SPI1 CS1.
GPIO256 | GPIO pin designator for expansion header pin 29.
GPIO257 | GPIO pin designator for expansion header pin 12.
GPIO258 | GPIO pin designator for expansion header pin 35.
GPIO259 | GPIO pin designator for expansion header pin 40.
GPIO260 | GPIO pin designator for expansion header pin 38.
GPIO261 | GPIO pin designator for expansion header pin 15. Conflicts with I2C0 SCL and UART2 TXD.
GPIO262 | GPIO pin designator for expansion header pin 22. Conflicts with I2C0 SDA and UART2 RXD.
GPIO263 | GPIO pin designator for expansion header pin 5. Conflicts with I2C1 SCL.
GPIO264 | GPIO pin designator for expansion header pin 3. Conflicts with I2C1 SDA.
GPIO265 | GPIO pin designator for expansion header pin 28. Conflicts with I2C2 SCL and UART3 RXD.
GPIO266 | GPIO pin designator for expansion header pin 27. Conflicts with I2C2 SDA and UART3 TXD.
GPIO267 | GPIO pin designator for expansion header pin 32. Conflicts with PWM1.
GPIO268 | GPIO pin designator for expansion header pin 33. Conflicts with PWM2.
GPIO269 | GPIO pin designator for expansion header pin 7. Conflicts with PWM3 and UART4 TXD.
GPIO270 | GPIO pin designator for expansion header pin 16. Conflicts with PWM4 and UART4 RXD.
GPIO271 | GPIO pin designator for expansion header pin 31.
GPIO272 | GPIO pin designator for expansion header pin 37.
GPIO76 | GPIO pin designator for expansion header pin 36.
I2C0 | I2C bus designator for expansion header pins 15 and 22. Conflicts with GPIO261, GPIO262, UART2 TXD> and and UART2 RXD.
I2C1 | I2C bus designator for expansion header pins 3 and 5. Conflicts with GPIO263 and GPIO264.
I2C2 | I2C bus designator for expansion header pins 27 and 28. Conflicts with GPIO265, GPIO266, UART3 RXD and UART3 TXD.
PWM1 | PWM output designator for expansion header pin 32. Conflicts with GPIO267.
PWM2 | PWM output designator for expansion header pin 33. Conflicts with GPIO268.
PWM3 | PWM output designator for expansion header pin 7. Conflicts with GPIO269 and UART4 TXD.
PWM4 | PWM output designator for expansion header pin 16. Conflicts with GPIO270 and UART4 RXD.
SPI1_0 | SPI slave select designator for expansion header pin 24. Conflicts with GPIO229.
SPI1_1 | SPI slave select designator for expansion header pin 26. Conflicts with GPIO233.
Top
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO224 Field

OrangePiZero2WGPIO224 Field

GPIO pin designator for expansion header pin 8. Conflicts with UART0 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO224

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO225 Field

OrangePiZero2WGPIO225 Field

GPIO pin designator for expansion header pin 10. Conflicts with UART0 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO225

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO226 Field

OrangePiZero2WGPIO226 Field

GPIO pin designator for expansion header pin 11. Conflicts with UART5 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO226

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO227 Field

OrangePiZero2WGPIO227 Field

GPIO pin designator for expansion header pin 13. Conflicts with UART5 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO227

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO228 Field

OrangePiZero2WGPIO228 Field

GPIO pin designator for expansion header pin 18.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO228

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO229 Field

OrangePiZero2WGPIO229 Field

GPIO pin designator for expansion header pin 24. Conflicts with SPI1 CS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO229

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO230 Field

OrangePiZero2WGPIO230 Field

GPIO pin designator for expansion header pin 23. Conflicts with SPI1 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO230

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO231 Field

OrangePiZero2WGPIO231 Field

GPIO pin designator for expansion header pin 19. Conflicts with SPI1 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO231

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO232 Field

OrangePiZero2WGPIO232 Field

GPIO pin designator for expansion header pin 21. Conflicts with SPI1 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO232

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO233 Field

OrangePiZero2WGPIO233 Field

GPIO pin designator for expansion header pin 26. Conflicts with SPI1 CS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO233

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO256 Field

OrangePiZero2WGPIO256 Field

GPIO pin designator for expansion header pin 29.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO256

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO257 Field

OrangePiZero2WGPIO257 Field

GPIO pin designator for expansion header pin 12.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO257

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO258 Field

OrangePiZero2WGPIO258 Field

GPIO pin designator for expansion header pin 35.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO258

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO259 Field

OrangePiZero2WGPIO259 Field

GPIO pin designator for expansion header pin 40.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO259

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO260 Field

OrangePiZero2WGPIO260 Field

GPIO pin designator for expansion header pin 38.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO260

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO261 Field

OrangePiZero2WGPIO261 Field

GPIO pin designator for expansion header pin 15. Conflicts with I2C0 SCL and UART2 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO261

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO262 Field

OrangePiZero2WGPIO262 Field

GPIO pin designator for expansion header pin 22. Conflicts with I2C0 SDA and UART2 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO262

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO263 Field

OrangePiZero2WGPIO263 Field

GPIO pin designator for expansion header pin 5. Conflicts with I2C1 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO263

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO264 Field

OrangePiZero2WGPIO264 Field

GPIO pin designator for expansion header pin 3. Conflicts with I2C1 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO264

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO265 Field

OrangePiZero2WGPIO265 Field

GPIO pin designator for expansion header pin 28. Conflicts with I2C2 SCL and UART3 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO265

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO266 Field

OrangePiZero2WGPIO266 Field

GPIO pin designator for expansion header pin 27. Conflicts with I2C2 SDA and UART3 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO266

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO267 Field

OrangePiZero2WGPIO267 Field

GPIO pin designator for expansion header pin 32. Conflicts with PWM1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO267

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO268 Field

OrangePiZero2WGPIO268 Field

GPIO pin designator for expansion header pin 33. Conflicts with PWM2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO268

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO269 Field

OrangePiZero2WGPIO269 Field

GPIO pin designator for expansion header pin 7. Conflicts with PWM3 and UART4 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO269

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO270 Field

OrangePiZero2WGPIO270 Field

GPIO pin designator for expansion header pin 16. Conflicts with PWM4 and UART4 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO270

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO271 Field

OrangePiZero2WGPIO271 Field

GPIO pin designator for expansion header pin 31.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO271

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO272 Field

OrangePiZero2WGPIO272 Field

GPIO pin designator for expansion header pin 37.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO272

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.GPIO76 Field

OrangePiZero2WGPIO76 Field

GPIO pin designator for expansion header pin 36.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO76

Field Value

Designator
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.I2C0 Field

OrangePiZero2WI2C0 Field

I2C bus designator for expansion header pins 15 and 22. Conflicts with GPIO261, GPIO262, UART2 TXD> and and UART2 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C0

Field Value

Designator
Remarks
The pi-i2c0 device tree overlay is required to enable this I2C bus.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.I2C1 Field

OrangePiZero2WI2C1 Field

I2C bus designator for expansion header pins 3 and 5. Conflicts with GPIO263 and GPIO264.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C1

Field Value

Designator
Remarks
The pi-i2c1 device tree overlay is required to enable this I2C bus.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.I2C2 Field

OrangePiZero2WI2C2 Field

I2C bus designator for expansion header pins 27 and 28. Conflicts with GPIO265, GPIO266, UART3 RXD and UART3 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C2

Field Value

Designator
Remarks
The pi-i2c2 device tree overlay is required to enable this I2C bus. It is reserved for Raspberry Pi expansion board identification and configuration.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.PWM1 Field

OrangePiZero2WPWM1 Field

PWM output designator for expansion header pin 32. Conflicts with GPIO267.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM1

Field Value

Designator
Remarks
The pi-pwm1 device tree overlay is required to enable this PWM output.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.PWM2 Field

OrangePiZero2WPWM2 Field

PWM output designator for expansion header pin 33. Conflicts with GPIO268.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM2

Field Value

Designator
Remarks
The pi-pwm2 device tree overlay is required to enable this PWM output.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.PWM3 Field

OrangePiZero2WPWM3 Field

PWM output designator for expansion header pin 7. Conflicts with GPIO269 and UART4 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM3

Field Value

Designator
Remarks
The pi-pwm3 device tree overlay is required to enable this PWM output.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.PWM4 Field

OrangePiZero2WPWM4 Field

PWM output designator for expansion header pin 16. Conflicts with GPIO270 and UART4 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM4

Field Value

Designator
Remarks
The pi-pwm4 device tree overlay is required to enable this PWM output.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.SPI1_0 Field

OrangePiZero2WSPI1_0 Field

SPI slave select designator for expansion header pin 24. Conflicts with GPIO229.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_0

Field Value

Designator
Remarks
Expansion header pin 24 is SPI0_0 on a Raspberry Pi.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W.SPI1_1 Field

OrangePiZero2WSPI1_1 Field

SPI slave select designator for expansion header pin 26. Conflicts with GPIO233.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_1

Field Value

Designator
Remarks
Expansion pin header 26 is SPI0_1 on a Raspberry Pi.
See Also

Reference

OrangePiZero2W Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi Class

This class provides Raspberry Pi compatible designator aliases for the devices available on the Orange Pi Zero 2W Linux microcomputer board.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsOrangePiZero2W_RaspberryPi

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class OrangePiZero2W_RaspberryPi

The OrangePiZero2W_RaspberryPi type exposes the following members.

Fields
Name | Description
GPIO10 | Raspberry Pi compatible alias for GPIO231.
GPIO11 | Raspberry Pi compatible alias for GPIO230.
GPIO12 | Raspberry Pi compatible alias for GPIO267.
GPIO13 | Raspberry Pi compatible alias for GPIO268.
GPIO14 | Raspberry Pi compatible alias for GPIO224.
GPIO15 | Raspberry Pi compatible alias for GPIO225.
GPIO16 | Raspberry Pi compatible alias for GPIO76.
GPIO17 | Raspberry Pi compatible alias for GPIO226.
GPIO18 | Raspberry Pi compatible alias for GPIO257.
GPIO19 | Raspberry Pi compatible alias for GPIO258.
GPIO2 | Raspberry Pi compatible alias for GPIO264.
GPIO20 | Raspberry Pi compatible alias for GPIO260.
GPIO21 | Raspberry Pi compatible alias for GPIO259.
GPIO22 | Raspberry Pi compatible alias for GPIO261.
GPIO23 | Raspberry Pi compatible alias for GPIO270.
GPIO24 | Raspberry Pi compatible alias for GPIO228.
GPIO25 | Raspberry Pi compatible alias for GPIO262.
GPIO26 | Raspberry Pi compatible alias for GPIO272.
GPIO27 | Raspberry Pi compatible alias for GPIO227.
GPIO3 | Raspberry Pi compatible alias for GPIO263.
GPIO4 | Raspberry Pi compatible alias for GPIO269.
GPIO5 | Raspberry Pi compatible alias for GPIO256.
GPIO6 | Raspberry Pi compatible alias for GPIO271.
GPIO7 | Raspberry Pi compatible alias for GPIO233.
GPIO8 | Raspberry Pi compatible alias for GPIO229.
GPIO9 | Raspberry Pi compatible alias for GPIO232.
I2C1 | Raspberry Pi compatible alias for I2C1.
PWM0 | Raspberry Pi compatible alias for PWM1.
PWM1 | Raspberry Pi compatible alias for PWM1.
SPI0_0 | Raspberry Pi compatible alias for SPI1_0.
SPI0_1 | Raspberry Pi compatible alias for SPI1_1.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi Fields

The OrangePiZero2W_RaspberryPi type exposes the following members.

Fields
Name | Description
GPIO10 | Raspberry Pi compatible alias for GPIO231.
GPIO11 | Raspberry Pi compatible alias for GPIO230.
GPIO12 | Raspberry Pi compatible alias for GPIO267.
GPIO13 | Raspberry Pi compatible alias for GPIO268.
GPIO14 | Raspberry Pi compatible alias for GPIO224.
GPIO15 | Raspberry Pi compatible alias for GPIO225.
GPIO16 | Raspberry Pi compatible alias for GPIO76.
GPIO17 | Raspberry Pi compatible alias for GPIO226.
GPIO18 | Raspberry Pi compatible alias for GPIO257.
GPIO19 | Raspberry Pi compatible alias for GPIO258.
GPIO2 | Raspberry Pi compatible alias for GPIO264.
GPIO20 | Raspberry Pi compatible alias for GPIO260.
GPIO21 | Raspberry Pi compatible alias for GPIO259.
GPIO22 | Raspberry Pi compatible alias for GPIO261.
GPIO23 | Raspberry Pi compatible alias for GPIO270.
GPIO24 | Raspberry Pi compatible alias for GPIO228.
GPIO25 | Raspberry Pi compatible alias for GPIO262.
GPIO26 | Raspberry Pi compatible alias for GPIO272.
GPIO27 | Raspberry Pi compatible alias for GPIO227.
GPIO3 | Raspberry Pi compatible alias for GPIO263.
GPIO4 | Raspberry Pi compatible alias for GPIO269.
GPIO5 | Raspberry Pi compatible alias for GPIO256.
GPIO6 | Raspberry Pi compatible alias for GPIO271.
GPIO7 | Raspberry Pi compatible alias for GPIO233.
GPIO8 | Raspberry Pi compatible alias for GPIO229.
GPIO9 | Raspberry Pi compatible alias for GPIO232.
I2C1 | Raspberry Pi compatible alias for I2C1.
PWM0 | Raspberry Pi compatible alias for PWM1.
PWM1 | Raspberry Pi compatible alias for PWM1.
SPI0_0 | Raspberry Pi compatible alias for SPI1_0.
SPI0_1 | Raspberry Pi compatible alias for SPI1_1.
Top
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO10 Field

OrangePiZero2W_RaspberryPiGPIO10 Field

Raspberry Pi compatible alias for GPIO231.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO10

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO11 Field

OrangePiZero2W_RaspberryPiGPIO11 Field

Raspberry Pi compatible alias for GPIO230.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO11

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO12 Field

OrangePiZero2W_RaspberryPiGPIO12 Field

Raspberry Pi compatible alias for GPIO267.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO12

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO13 Field

OrangePiZero2W_RaspberryPiGPIO13 Field

Raspberry Pi compatible alias for GPIO268.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO13

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO14 Field

OrangePiZero2W_RaspberryPiGPIO14 Field

Raspberry Pi compatible alias for GPIO224.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO14

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO15 Field

OrangePiZero2W_RaspberryPiGPIO15 Field

Raspberry Pi compatible alias for GPIO225.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO15

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO16 Field

OrangePiZero2W_RaspberryPiGPIO16 Field

Raspberry Pi compatible alias for GPIO76.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO16

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO17 Field

OrangePiZero2W_RaspberryPiGPIO17 Field

Raspberry Pi compatible alias for GPIO226.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO17

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO18 Field

OrangePiZero2W_RaspberryPiGPIO18 Field

Raspberry Pi compatible alias for GPIO257.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO18

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO19 Field

OrangePiZero2W_RaspberryPiGPIO19 Field

Raspberry Pi compatible alias for GPIO258.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO19

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO2 Field

OrangePiZero2W_RaspberryPiGPIO2 Field

Raspberry Pi compatible alias for GPIO264.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO2

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO20 Field

OrangePiZero2W_RaspberryPiGPIO20 Field

Raspberry Pi compatible alias for GPIO260.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO20

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO21 Field

OrangePiZero2W_RaspberryPiGPIO21 Field

Raspberry Pi compatible alias for GPIO259.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO21

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO22 Field

OrangePiZero2W_RaspberryPiGPIO22 Field

Raspberry Pi compatible alias for GPIO261.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO22

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO23 Field

OrangePiZero2W_RaspberryPiGPIO23 Field

Raspberry Pi compatible alias for GPIO270.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO23

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO24 Field

OrangePiZero2W_RaspberryPiGPIO24 Field

Raspberry Pi compatible alias for GPIO228.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO24

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO25 Field

OrangePiZero2W_RaspberryPiGPIO25 Field

Raspberry Pi compatible alias for GPIO262.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO25

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO26 Field

OrangePiZero2W_RaspberryPiGPIO26 Field

Raspberry Pi compatible alias for GPIO272.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO26

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO27 Field

OrangePiZero2W_RaspberryPiGPIO27 Field

Raspberry Pi compatible alias for GPIO227.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO27

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO3 Field

OrangePiZero2W_RaspberryPiGPIO3 Field

Raspberry Pi compatible alias for GPIO263.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO3

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO4 Field

OrangePiZero2W_RaspberryPiGPIO4 Field

Raspberry Pi compatible alias for GPIO269.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO4

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO5 Field

OrangePiZero2W_RaspberryPiGPIO5 Field

Raspberry Pi compatible alias for GPIO256.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO5

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO6 Field

OrangePiZero2W_RaspberryPiGPIO6 Field

Raspberry Pi compatible alias for GPIO271.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO6

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO7 Field

OrangePiZero2W_RaspberryPiGPIO7 Field

Raspberry Pi compatible alias for GPIO233.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO7

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO8 Field

OrangePiZero2W_RaspberryPiGPIO8 Field

Raspberry Pi compatible alias for GPIO229.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO8

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.GPIO9 Field

OrangePiZero2W_RaspberryPiGPIO9 Field

Raspberry Pi compatible alias for GPIO232.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO9

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.I2C1 Field

OrangePiZero2W_RaspberryPiI2C1 Field

Raspberry Pi compatible alias for I2C1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C1

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.PWM0 Field

OrangePiZero2W_RaspberryPiPWM0 Field

Raspberry Pi compatible alias for PWM1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM0

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.PWM1 Field

OrangePiZero2W_RaspberryPiPWM1 Field

Raspberry Pi compatible alias for PWM1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM1

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.SPI0_0 Field

OrangePiZero2W_RaspberryPiSPI0_0 Field

Raspberry Pi compatible alias for SPI1_0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_0

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


OrangePiZero2W_RaspberryPi.SPI0_1 Field

OrangePiZero2W_RaspberryPiSPI0_1 Field

Raspberry Pi compatible alias for SPI1_1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_1

Field Value

Designator
See Also

Reference

OrangePiZero2W_RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle Class

This class defines identifiers for the devices provided by the PocketBeagle hardware platform. .
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsPocketBeagle

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class PocketBeagle

The PocketBeagle type exposes the following members.

Fields
Name | Description
AIN0 | ADC input designator (0, 0) for P1.19 (1.8V).
AIN1 | ADC input designator (0, 1) for P1.21 (1.8V).
AIN2 | ADC input designator (0, 2) for P1.23 (1.8V).
AIN3 | ADC input designator (0, 3) for P1.25 (1.8V).
AIN4 | ADC input designator (0, 4) for P1.27 (1.8V).
AIN5 | ADC input designator (0, 5) for P2.35 (3.6V). Conflicts with GPIO86.
AIN6 | ADC input designator (0, 6) for P1.2 (3.6V). Conflicts with GPIO87.
AIN7 | ADC input designator (0, 7) for P2.36 (1.8V).
GPIO110 | GPIO pin designator (3, 14) for P1.36.
GPIO111 | GPIO pin designator (3, 15) for P1.33.
GPIO112 | GPIO pin designator (3, 16) for P2.32.
GPIO113 | GPIO pin designator (3, 17) for P2.30.
GPIO114 | GPIO pin designator (3, 18) for P1.31.
GPIO115 | GPIO pin designator (3, 19) for P2.34.
GPIO116 | GPIO pin designator (3, 20) for P2.28.
GPIO117 | GPIO pin designator (3, 21) for P1.29.
GPIO12 | GPIO pin designator (0, 12) for P1.26. Conflicts with I2C2 SDA.
GPIO13 | GPIO pin designator (0, 13) for P1.28. Conflicts with I2C2 SCL.
GPIO14 | GPIO pin designator (0, 14) for P2.11. Conflicts with I2C1 SDA.
GPIO15 | GPIO pin designator (0, 15) for P2.9. Conflicts with I2C1 SCL.
GPIO19 | GPIO pin designator (0, 19) for P2.31. Conflicts with SPI1 CS1.
GPIO2 | GPIO pin designator (0, 2) for P1.8. Conflicts with SPI0 SCLK.
GPIO20 | GPIO pin designator (0, 20) for P1.20.
GPIO23 | GPIO pin designator (0, 23) for P2.3.
GPIO26 | GPIO pin designator (0, 26) for P1.34.
GPIO27 | GPIO pin designator (0, 27) for P2.19.
GPIO3 | GPIO pin designator (0, 3) for P1.10. Conflicts with SPI0 MISO.
GPIO30 | GPIO pin designator (0, 30) for P2.5. Conflicts with RXD4.
GPIO31 | GPIO pin designator (0, 31) for P2.7. Conflicts with TXD4.
GPIO4 | GPIO pin designator (0, 4) for P1.12. Conflicts with SPI0 MOSI.
GPIO40 | GPIO pin designator (1, 8) for P2.27. Conflicts with SPI1 MISO.
GPIO41 | GPIO pin designator (1, 9) for P2.25. Conflicts with SPI1 MOSI.
GPIO42 | GPIO pin designator (1, 10) for P1.32. Conflicts with RXD0.
GPIO43 | GPIO pin designator (1, 11) for P1.30. Conflicts with TXD0.
GPIO44 | GPIO pin designator (1, 12) for P2.24.
GPIO45 | GPIO pin designator (1, 13) for P2.33.
GPIO46 | GPIO pin designator (1, 14) for P2.22.
GPIO47 | GPIO pin designator (1, 15) for P2.18.
GPIO5 | GPIO pin designator (0, 5) for P1.6. Conflicts with SPI0 CS0.
GPIO50 | GPIO pin designator (1, 18) for P2.1.
GPIO52 | GPIO pin designator (1, 20) for P2.10.
GPIO57 | GPIO pin designator (1, 25) for P2.6.
GPIO58 | GPIO pin designator (1, 26) for P2.4.
GPIO59 | GPIO pin designator (1, 27) for P2.2.
GPIO60 | GPIO pin designator (1, 28) for P2.8.
GPIO64 | GPIO pin designator (2, 0) for P2.20.
GPIO65 | GPIO pin designator (2, 1) for P2.17.
GPIO7 | GPIO pin designator (0, 7) for P2.29. Conflicts with SPI1 SCLK.
GPIO86 | GPIO pin designator (2, 22) for P2.35. Conflicts with AIN5.
GPIO87 | GPIO pin designator (2, 23) for P1.2. Conflicts with AIN6.
GPIO88 | GPIO pin designator (2, 24) for P1.35.
GPIO89 | GPIO pin designator (2, 25) for P1.4.
I2C1 | I2C bus designator (0, 1) for P2.9 and P2.11. Conflicts with GPIO15 and GPIO14.
I2C2 | I2C bus designator (0, 2) for P1.26 and P1.28. Conflicts with GPIO12 and GPIO13.
PWM0_0 | PWM output designator (0, 0) for P1.36. Conflicts with GPIO110.
PWM2_0 | PWM output designator (2, 0) for P2.1. Conflicts with GPIO50.
SPI0_0 | SPI slave designator (0, 0) for P1.6. Conflicts with GPIO5.
SPI1_1 | SPI slave designator (1, 1) for P2.31. Conflicts with GPIO19.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle Fields

The PocketBeagle type exposes the following members.

Fields
Name | Description
AIN0 | ADC input designator (0, 0) for P1.19 (1.8V).
AIN1 | ADC input designator (0, 1) for P1.21 (1.8V).
AIN2 | ADC input designator (0, 2) for P1.23 (1.8V).
AIN3 | ADC input designator (0, 3) for P1.25 (1.8V).
AIN4 | ADC input designator (0, 4) for P1.27 (1.8V).
AIN5 | ADC input designator (0, 5) for P2.35 (3.6V). Conflicts with GPIO86.
AIN6 | ADC input designator (0, 6) for P1.2 (3.6V). Conflicts with GPIO87.
AIN7 | ADC input designator (0, 7) for P2.36 (1.8V).
GPIO110 | GPIO pin designator (3, 14) for P1.36.
GPIO111 | GPIO pin designator (3, 15) for P1.33.
GPIO112 | GPIO pin designator (3, 16) for P2.32.
GPIO113 | GPIO pin designator (3, 17) for P2.30.
GPIO114 | GPIO pin designator (3, 18) for P1.31.
GPIO115 | GPIO pin designator (3, 19) for P2.34.
GPIO116 | GPIO pin designator (3, 20) for P2.28.
GPIO117 | GPIO pin designator (3, 21) for P1.29.
GPIO12 | GPIO pin designator (0, 12) for P1.26. Conflicts with I2C2 SDA.
GPIO13 | GPIO pin designator (0, 13) for P1.28. Conflicts with I2C2 SCL.
GPIO14 | GPIO pin designator (0, 14) for P2.11. Conflicts with I2C1 SDA.
GPIO15 | GPIO pin designator (0, 15) for P2.9. Conflicts with I2C1 SCL.
GPIO19 | GPIO pin designator (0, 19) for P2.31. Conflicts with SPI1 CS1.
GPIO2 | GPIO pin designator (0, 2) for P1.8. Conflicts with SPI0 SCLK.
GPIO20 | GPIO pin designator (0, 20) for P1.20.
GPIO23 | GPIO pin designator (0, 23) for P2.3.
GPIO26 | GPIO pin designator (0, 26) for P1.34.
GPIO27 | GPIO pin designator (0, 27) for P2.19.
GPIO3 | GPIO pin designator (0, 3) for P1.10. Conflicts with SPI0 MISO.
GPIO30 | GPIO pin designator (0, 30) for P2.5. Conflicts with RXD4.
GPIO31 | GPIO pin designator (0, 31) for P2.7. Conflicts with TXD4.
GPIO4 | GPIO pin designator (0, 4) for P1.12. Conflicts with SPI0 MOSI.
GPIO40 | GPIO pin designator (1, 8) for P2.27. Conflicts with SPI1 MISO.
GPIO41 | GPIO pin designator (1, 9) for P2.25. Conflicts with SPI1 MOSI.
GPIO42 | GPIO pin designator (1, 10) for P1.32. Conflicts with RXD0.
GPIO43 | GPIO pin designator (1, 11) for P1.30. Conflicts with TXD0.
GPIO44 | GPIO pin designator (1, 12) for P2.24.
GPIO45 | GPIO pin designator (1, 13) for P2.33.
GPIO46 | GPIO pin designator (1, 14) for P2.22.
GPIO47 | GPIO pin designator (1, 15) for P2.18.
GPIO5 | GPIO pin designator (0, 5) for P1.6. Conflicts with SPI0 CS0.
GPIO50 | GPIO pin designator (1, 18) for P2.1.
GPIO52 | GPIO pin designator (1, 20) for P2.10.
GPIO57 | GPIO pin designator (1, 25) for P2.6.
GPIO58 | GPIO pin designator (1, 26) for P2.4.
GPIO59 | GPIO pin designator (1, 27) for P2.2.
GPIO60 | GPIO pin designator (1, 28) for P2.8.
GPIO64 | GPIO pin designator (2, 0) for P2.20.
GPIO65 | GPIO pin designator (2, 1) for P2.17.
GPIO7 | GPIO pin designator (0, 7) for P2.29. Conflicts with SPI1 SCLK.
GPIO86 | GPIO pin designator (2, 22) for P2.35. Conflicts with AIN5.
GPIO87 | GPIO pin designator (2, 23) for P1.2. Conflicts with AIN6.
GPIO88 | GPIO pin designator (2, 24) for P1.35.
GPIO89 | GPIO pin designator (2, 25) for P1.4.
I2C1 | I2C bus designator (0, 1) for P2.9 and P2.11. Conflicts with GPIO15 and GPIO14.
I2C2 | I2C bus designator (0, 2) for P1.26 and P1.28. Conflicts with GPIO12 and GPIO13.
PWM0_0 | PWM output designator (0, 0) for P1.36. Conflicts with GPIO110.
PWM2_0 | PWM output designator (2, 0) for P2.1. Conflicts with GPIO50.
SPI0_0 | SPI slave designator (0, 0) for P1.6. Conflicts with GPIO5.
SPI1_1 | SPI slave designator (1, 1) for P2.31. Conflicts with GPIO19.
Top
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN0 Field

PocketBeagleAIN0 Field

ADC input designator (0, 0) for P1.19 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN0

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN1 Field

PocketBeagleAIN1 Field

ADC input designator (0, 1) for P1.21 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN1

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN2 Field

PocketBeagleAIN2 Field

ADC input designator (0, 2) for P1.23 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN2

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN3 Field

PocketBeagleAIN3 Field

ADC input designator (0, 3) for P1.25 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN3

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN4 Field

PocketBeagleAIN4 Field

ADC input designator (0, 4) for P1.27 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN4

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN5 Field

PocketBeagleAIN5 Field

ADC input designator (0, 5) for P2.35 (3.6V). Conflicts with GPIO86.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN5

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN6 Field

PocketBeagleAIN6 Field

ADC input designator (0, 6) for P1.2 (3.6V). Conflicts with GPIO87.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN6

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.AIN7 Field

PocketBeagleAIN7 Field

ADC input designator (0, 7) for P2.36 (1.8V).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN7

Field Value

Designator
Remarks
Requires the PB-ADC device tree overlay.
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO110 Field

PocketBeagleGPIO110 Field

GPIO pin designator (3, 14) for P1.36.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO110

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO111 Field

PocketBeagleGPIO111 Field

GPIO pin designator (3, 15) for P1.33.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO111

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO112 Field

PocketBeagleGPIO112 Field

GPIO pin designator (3, 16) for P2.32.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO112

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO113 Field

PocketBeagleGPIO113 Field

GPIO pin designator (3, 17) for P2.30.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO113

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO114 Field

PocketBeagleGPIO114 Field

GPIO pin designator (3, 18) for P1.31.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO114

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO115 Field

PocketBeagleGPIO115 Field

GPIO pin designator (3, 19) for P2.34.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO115

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO116 Field

PocketBeagleGPIO116 Field

GPIO pin designator (3, 20) for P2.28.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO116

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO117 Field

PocketBeagleGPIO117 Field

GPIO pin designator (3, 21) for P1.29.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO117

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO12 Field

PocketBeagleGPIO12 Field

GPIO pin designator (0, 12) for P1.26. Conflicts with I2C2 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO12

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO13 Field

PocketBeagleGPIO13 Field

GPIO pin designator (0, 13) for P1.28. Conflicts with I2C2 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO13

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO14 Field

PocketBeagleGPIO14 Field

GPIO pin designator (0, 14) for P2.11. Conflicts with I2C1 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO14

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO15 Field

PocketBeagleGPIO15 Field

GPIO pin designator (0, 15) for P2.9. Conflicts with I2C1 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO15

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO19 Field

PocketBeagleGPIO19 Field

GPIO pin designator (0, 19) for P2.31. Conflicts with SPI1 CS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO19

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO2 Field

PocketBeagleGPIO2 Field

GPIO pin designator (0, 2) for P1.8. Conflicts with SPI0 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO2

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO20 Field

PocketBeagleGPIO20 Field

GPIO pin designator (0, 20) for P1.20.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO20

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO23 Field

PocketBeagleGPIO23 Field

GPIO pin designator (0, 23) for P2.3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO23

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO26 Field

PocketBeagleGPIO26 Field

GPIO pin designator (0, 26) for P1.34.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO26

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO27 Field

PocketBeagleGPIO27 Field

GPIO pin designator (0, 27) for P2.19.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO27

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO3 Field

PocketBeagleGPIO3 Field

GPIO pin designator (0, 3) for P1.10. Conflicts with SPI0 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO3

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO30 Field

PocketBeagleGPIO30 Field

GPIO pin designator (0, 30) for P2.5. Conflicts with RXD4.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO30

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO31 Field

PocketBeagleGPIO31 Field

GPIO pin designator (0, 31) for P2.7. Conflicts with TXD4.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO31

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO4 Field

PocketBeagleGPIO4 Field

GPIO pin designator (0, 4) for P1.12. Conflicts with SPI0 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO4

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO40 Field

PocketBeagleGPIO40 Field

GPIO pin designator (1, 8) for P2.27. Conflicts with SPI1 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO40

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO41 Field

PocketBeagleGPIO41 Field

GPIO pin designator (1, 9) for P2.25. Conflicts with SPI1 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO41

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO42 Field

PocketBeagleGPIO42 Field

GPIO pin designator (1, 10) for P1.32. Conflicts with RXD0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO42

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO43 Field

PocketBeagleGPIO43 Field

GPIO pin designator (1, 11) for P1.30. Conflicts with TXD0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO43

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO44 Field

PocketBeagleGPIO44 Field

GPIO pin designator (1, 12) for P2.24.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO44

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO45 Field

PocketBeagleGPIO45 Field

GPIO pin designator (1, 13) for P2.33.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO45

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO46 Field

PocketBeagleGPIO46 Field

GPIO pin designator (1, 14) for P2.22.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO46

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO47 Field

PocketBeagleGPIO47 Field

GPIO pin designator (1, 15) for P2.18.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO47

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO5 Field

PocketBeagleGPIO5 Field

GPIO pin designator (0, 5) for P1.6. Conflicts with SPI0 CS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO5

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO50 Field

PocketBeagleGPIO50 Field

GPIO pin designator (1, 18) for P2.1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO50

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO52 Field

PocketBeagleGPIO52 Field

GPIO pin designator (1, 20) for P2.10.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO52

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO57 Field

PocketBeagleGPIO57 Field

GPIO pin designator (1, 25) for P2.6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO57

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO58 Field

PocketBeagleGPIO58 Field

GPIO pin designator (1, 26) for P2.4.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO58

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO59 Field

PocketBeagleGPIO59 Field

GPIO pin designator (1, 27) for P2.2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO59

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO60 Field

PocketBeagleGPIO60 Field

GPIO pin designator (1, 28) for P2.8.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO60

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO64 Field

PocketBeagleGPIO64 Field

GPIO pin designator (2, 0) for P2.20.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO64

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO65 Field

PocketBeagleGPIO65 Field

GPIO pin designator (2, 1) for P2.17.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO65

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO7 Field

PocketBeagleGPIO7 Field

GPIO pin designator (0, 7) for P2.29. Conflicts with SPI1 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO7

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO86 Field

PocketBeagleGPIO86 Field

GPIO pin designator (2, 22) for P2.35. Conflicts with AIN5.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO86

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO87 Field

PocketBeagleGPIO87 Field

GPIO pin designator (2, 23) for P1.2. Conflicts with AIN6.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO87

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO88 Field

PocketBeagleGPIO88 Field

GPIO pin designator (2, 24) for P1.35.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO88

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.GPIO89 Field

PocketBeagleGPIO89 Field

GPIO pin designator (2, 25) for P1.4.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO89

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.I2C1 Field

PocketBeagleI2C1 Field

I2C bus designator (0, 1) for P2.9 and P2.11. Conflicts with GPIO15 and GPIO14.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C1

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.I2C2 Field

PocketBeagleI2C2 Field

I2C bus designator (0, 2) for P1.26 and P1.28. Conflicts with GPIO12 and GPIO13.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C2

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.PWM0_0 Field

PocketBeaglePWM0_0 Field

PWM output designator (0, 0) for P1.36. Conflicts with GPIO110.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM0_0

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.PWM2_0 Field

PocketBeaglePWM2_0 Field

PWM output designator (2, 0) for P2.1. Conflicts with GPIO50.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM2_0

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.SPI0_0 Field

PocketBeagleSPI0_0 Field

SPI slave designator (0, 0) for P1.6. Conflicts with GPIO5.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_0

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


PocketBeagle.SPI1_1 Field

PocketBeagleSPI1_1 Field

SPI slave designator (1, 1) for P2.31. Conflicts with GPIO19.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_1

Field Value

Designator
See Also

Reference

PocketBeagle Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi Class

This class defines identifiers for the devices provided by the Raspberry Pi hardware platform.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsRaspberryPi

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class RaspberryPi

The RaspberryPi type exposes the following members.

Fields
Name | Description
AIN0 | Analog input designator (0, 0).
AIN1 | Analog input designator (0, 1).
AIN2 | Analog input designator (0, 2).
AIN3 | Analog input designator (0, 3).
AIN4 | Analog input designator (0, 4).
AIN5 | Analog input designator (0, 5).
AIN6 | Analog input designator (0, 6).
AIN7 | Analog input designator (0, 7).
GPIO10 | GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.
GPIO11 | GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.
GPIO12 | GPIO pin designator (0, 12). Not available on early boards with 26 pin expansion headers.
GPIO13 | GPIO pin designator (0, 13). Not available on early boards with 26 pin expansion headers.
GPIO14 | GPIO pin designator (0, 14). Conflicts with UART0 TXD.
GPIO15 | GPIO pin designator (0, 15). Conflicts with UART0 RXD.
GPIO16 | GPIO pin designator (0, 16). Conflicts with SPI1 SS2. Not available on early boards with 26 pin expansion headers.
GPIO17 | GPIO pin designator (0, 17). Conflicts with SPI1 SS1.
GPIO18 | GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.
GPIO19 | GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO. Not available on early boards with 26 pin expansion headers.
GPIO2 | GPIO pin designator (0, 2). Conflicts with I2C1 SDA.
GPIO20 | GPIO pin designator (0, 20). Conflicts with SPI1 MOSI. Not available on early boards with 26 pin expansion headers.
GPIO21 | GPIO pin designator (0, 21). Conflicts with SPI1 SCLK. Not available on early boards with 26 pin expansion headers.
GPIO22 | GPIO pin designator (0, 22).
GPIO23 | GPIO pin designator (0, 23).
GPIO24 | GPIO pin designator (0, 24).
GPIO25 | GPIO pin designator (0, 25).
GPIO26 | GPIO pin designator (0, 26). Not available on early boards with 26 pin expansion headers.
GPIO27 | GPIO pin designator (0, 27).
GPIO3 | GPIO pin designator (0, 3). Conflicts with I2C1 SCL.
GPIO4 | GPIO pin designator (0, 4).
GPIO5 | GPIO pin designator (0, 5). Not available on early boards with 26 pin expansion headers.
GPIO6 | GPIO pin designator (0, 6). Not available on early boards with 26 pin expansion headers.
GPIO7 | GPIO pin designator (0, 7). Conflicts with SPI0 SS1.
GPIO8 | GPIO pin designator (0, 8). Conflicts with SPI0 SS0.
GPIO9 | GPIO pin designator (0, 9). Conflicts with SPI0 MISO.
I2C1 | I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.
PWM0 | PWM output designator (0, 0). Conflicts with GPIO12 or GPIO18. Requires the pwm.dtbo device tree overlay.
PWM1 | PWM output designator (0, 1). Conflicts with GPIO13 or GPIO19. Requires the pwm.dtbo device tree overlay.
SPI0_0 | SPI slave designator (0, 0). Conflicts with GPIO8.
SPI0_1 | SPI slave designator (0, 1). Conflicts with GPIO7.
SPI1_0 | SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_1 | SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_2 | SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi Fields

The RaspberryPi type exposes the following members.

Fields
Name | Description
AIN0 | Analog input designator (0, 0).
AIN1 | Analog input designator (0, 1).
AIN2 | Analog input designator (0, 2).
AIN3 | Analog input designator (0, 3).
AIN4 | Analog input designator (0, 4).
AIN5 | Analog input designator (0, 5).
AIN6 | Analog input designator (0, 6).
AIN7 | Analog input designator (0, 7).
GPIO10 | GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.
GPIO11 | GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.
GPIO12 | GPIO pin designator (0, 12). Not available on early boards with 26 pin expansion headers.
GPIO13 | GPIO pin designator (0, 13). Not available on early boards with 26 pin expansion headers.
GPIO14 | GPIO pin designator (0, 14). Conflicts with UART0 TXD.
GPIO15 | GPIO pin designator (0, 15). Conflicts with UART0 RXD.
GPIO16 | GPIO pin designator (0, 16). Conflicts with SPI1 SS2. Not available on early boards with 26 pin expansion headers.
GPIO17 | GPIO pin designator (0, 17). Conflicts with SPI1 SS1.
GPIO18 | GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.
GPIO19 | GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO. Not available on early boards with 26 pin expansion headers.
GPIO2 | GPIO pin designator (0, 2). Conflicts with I2C1 SDA.
GPIO20 | GPIO pin designator (0, 20). Conflicts with SPI1 MOSI. Not available on early boards with 26 pin expansion headers.
GPIO21 | GPIO pin designator (0, 21). Conflicts with SPI1 SCLK. Not available on early boards with 26 pin expansion headers.
GPIO22 | GPIO pin designator (0, 22).
GPIO23 | GPIO pin designator (0, 23).
GPIO24 | GPIO pin designator (0, 24).
GPIO25 | GPIO pin designator (0, 25).
GPIO26 | GPIO pin designator (0, 26). Not available on early boards with 26 pin expansion headers.
GPIO27 | GPIO pin designator (0, 27).
GPIO3 | GPIO pin designator (0, 3). Conflicts with I2C1 SCL.
GPIO4 | GPIO pin designator (0, 4).
GPIO5 | GPIO pin designator (0, 5). Not available on early boards with 26 pin expansion headers.
GPIO6 | GPIO pin designator (0, 6). Not available on early boards with 26 pin expansion headers.
GPIO7 | GPIO pin designator (0, 7). Conflicts with SPI0 SS1.
GPIO8 | GPIO pin designator (0, 8). Conflicts with SPI0 SS0.
GPIO9 | GPIO pin designator (0, 9). Conflicts with SPI0 MISO.
I2C1 | I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.
PWM0 | PWM output designator (0, 0). Conflicts with GPIO12 or GPIO18. Requires the pwm.dtbo device tree overlay.
PWM1 | PWM output designator (0, 1). Conflicts with GPIO13 or GPIO19. Requires the pwm.dtbo device tree overlay.
SPI0_0 | SPI slave designator (0, 0). Conflicts with GPIO8.
SPI0_1 | SPI slave designator (0, 1). Conflicts with GPIO7.
SPI1_0 | SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_1 | SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_2 | SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
Top
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN0 Field

RaspberryPiAIN0 Field

Analog input designator (0, 0).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN0

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN1 Field

RaspberryPiAIN1 Field

Analog input designator (0, 1).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN1

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN2 Field

RaspberryPiAIN2 Field

Analog input designator (0, 2).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN2

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN3 Field

RaspberryPiAIN3 Field

Analog input designator (0, 3).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN3

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN4 Field

RaspberryPiAIN4 Field

Analog input designator (0, 4).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN4

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN5 Field

RaspberryPiAIN5 Field

Analog input designator (0, 5).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN5

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN6 Field

RaspberryPiAIN6 Field

Analog input designator (0, 6).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN6

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.AIN7 Field

RaspberryPiAIN7 Field

Analog input designator (0, 7).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN7

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO10 Field

RaspberryPiGPIO10 Field

GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO10

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO11 Field

RaspberryPiGPIO11 Field

GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO11

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO12 Field

RaspberryPiGPIO12 Field

GPIO pin designator (0, 12). Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO12

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO13 Field

RaspberryPiGPIO13 Field

GPIO pin designator (0, 13). Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO13

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO14 Field

RaspberryPiGPIO14 Field

GPIO pin designator (0, 14). Conflicts with UART0 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO14

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO15 Field

RaspberryPiGPIO15 Field

GPIO pin designator (0, 15). Conflicts with UART0 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO15

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO16 Field

RaspberryPiGPIO16 Field

GPIO pin designator (0, 16). Conflicts with SPI1 SS2. Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO16

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO17 Field

RaspberryPiGPIO17 Field

GPIO pin designator (0, 17). Conflicts with SPI1 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO17

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO18 Field

RaspberryPiGPIO18 Field

GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO18

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO19 Field

RaspberryPiGPIO19 Field

GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO. Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO19

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO2 Field

RaspberryPiGPIO2 Field

GPIO pin designator (0, 2). Conflicts with I2C1 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO2

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO20 Field

RaspberryPiGPIO20 Field

GPIO pin designator (0, 20). Conflicts with SPI1 MOSI. Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO20

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO21 Field

RaspberryPiGPIO21 Field

GPIO pin designator (0, 21). Conflicts with SPI1 SCLK. Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO21

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO22 Field

RaspberryPiGPIO22 Field

GPIO pin designator (0, 22).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO22

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO23 Field

RaspberryPiGPIO23 Field

GPIO pin designator (0, 23).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO23

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO24 Field

RaspberryPiGPIO24 Field

GPIO pin designator (0, 24).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO24

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO25 Field

RaspberryPiGPIO25 Field

GPIO pin designator (0, 25).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO25

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO26 Field

RaspberryPiGPIO26 Field

GPIO pin designator (0, 26). Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO26

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO27 Field

RaspberryPiGPIO27 Field

GPIO pin designator (0, 27).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO27

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO3 Field

RaspberryPiGPIO3 Field

GPIO pin designator (0, 3). Conflicts with I2C1 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO3

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO4 Field

RaspberryPiGPIO4 Field

GPIO pin designator (0, 4).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO4

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO5 Field

RaspberryPiGPIO5 Field

GPIO pin designator (0, 5). Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO5

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO6 Field

RaspberryPiGPIO6 Field

GPIO pin designator (0, 6). Not available on early boards with 26 pin expansion headers.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO6

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO7 Field

RaspberryPiGPIO7 Field

GPIO pin designator (0, 7). Conflicts with SPI0 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO7

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO8 Field

RaspberryPiGPIO8 Field

GPIO pin designator (0, 8). Conflicts with SPI0 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO8

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.GPIO9 Field

RaspberryPiGPIO9 Field

GPIO pin designator (0, 9). Conflicts with SPI0 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO9

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.I2C1 Field

RaspberryPiI2C1 Field

I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C1

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.PWM0 Field

RaspberryPiPWM0 Field

PWM output designator (0, 0). Conflicts with GPIO12 or GPIO18. Requires the pwm.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM0

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.PWM1 Field

RaspberryPiPWM1 Field

PWM output designator (0, 1). Conflicts with GPIO13 or GPIO19. Requires the pwm.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM1

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.SPI0_0 Field

RaspberryPiSPI0_0 Field

SPI slave designator (0, 0). Conflicts with GPIO8.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_0

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.SPI0_1 Field

RaspberryPiSPI0_1 Field

SPI slave designator (0, 1). Conflicts with GPIO7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_1

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.SPI1_0 Field

RaspberryPiSPI1_0 Field

SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_0

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.SPI1_1 Field

RaspberryPiSPI1_1 Field

SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_1

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi.SPI1_2 Field

RaspberryPiSPI1_2 Field

SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_2

Field Value

Designator
See Also

Reference

RaspberryPi Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4 Class

This class defines identifiers for the devices provided by the Raspberry Pi 4 hardware platform.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsRaspberryPi4

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class RaspberryPi4

The RaspberryPi4 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input designator (0, 0).
AIN1 | Analog input designator (0, 1).
AIN2 | Analog input designator (0, 2).
AIN3 | Analog input designator (0, 3).
AIN4 | Analog input designator (0, 4).
AIN5 | Analog input designator (0, 5).
AIN6 | Analog input designator (0, 6).
AIN7 | Analog input designator (0, 7).
GPIO10 | GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.
GPIO11 | GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.
GPIO12 | GPIO pin designator (0, 12).
GPIO13 | GPIO pin designator (0, 13).
GPIO14 | GPIO pin designator (0, 14). Conflicts with UART0 TXD.
GPIO15 | GPIO pin designator (0, 15). Conflicts with UART0 RXD.
GPIO16 | GPIO pin designator (0, 16). Conflicts with SPI1 SS2.
GPIO17 | GPIO pin designator (0, 17). Conflicts with SPI1 SS1.
GPIO18 | GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.
GPIO19 | GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO.
GPIO2 | GPIO pin designator (0, 2). Conflicts with I2C1 SDA.
GPIO20 | GPIO pin designator (0, 20). Conflicts with SPI1 MOSI.
GPIO21 | GPIO pin designator (0, 21). Conflicts with SPI1 SCLK.
GPIO22 | GPIO pin designator (0, 22).
GPIO23 | GPIO pin designator (0, 23).
GPIO24 | GPIO pin designator (0, 24).
GPIO25 | GPIO pin designator (0, 25).
GPIO26 | GPIO pin designator (0, 26).
GPIO27 | GPIO pin designator (0, 27).
GPIO3 | GPIO pin designator (0, 3). Conflicts with I2C1 SCL.
GPIO4 | GPIO pin designator (0, 4).
GPIO5 | GPIO pin designator (0, 5).
GPIO6 | GPIO pin designator (0, 6).
GPIO7 | GPIO pin designator (0, 7). Conflicts with SPI0 SS1.
GPIO8 | GPIO pin designator (0, 8). Conflicts with SPI0 SS0.
GPIO9 | GPIO pin designator (0, 9). Conflicts with SPI0 MISO.
I2C1 | I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.
I2C3 | I2C bus designator (0, 3). Requires the i2c3.dtbo device tree overlay).
I2C4 | I2C bus designator (0, 4). Requires the i2c4.dtbo device tree overlay).
I2C5 | I2C bus designator (0, 5). Requires the i2c5.dtbo device tree overlay).
I2C6 | I2C bus designator (0, 6). Requires the i2c6.dtbo device tree overlay).
PWM0 | PWM output designator (0, 0). Conflicts with GPIO12 or GPIO18. Requires the pwm.dtbo device tree overlay.
PWM1 | PWM output designator (0, 1). Conflicts with GPIO13 or GPIO19. Requires the pwm.dtbo device tree overlay.
SPI0_0 | SPI slave designator (0, 0). Conflicts with GPIO8.
SPI0_1 | SPI slave designator (0, 1). Conflicts with GPIO7.
SPI1_0 | SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_1 | SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_2 | SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4 Fields

The RaspberryPi4 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input designator (0, 0).
AIN1 | Analog input designator (0, 1).
AIN2 | Analog input designator (0, 2).
AIN3 | Analog input designator (0, 3).
AIN4 | Analog input designator (0, 4).
AIN5 | Analog input designator (0, 5).
AIN6 | Analog input designator (0, 6).
AIN7 | Analog input designator (0, 7).
GPIO10 | GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.
GPIO11 | GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.
GPIO12 | GPIO pin designator (0, 12).
GPIO13 | GPIO pin designator (0, 13).
GPIO14 | GPIO pin designator (0, 14). Conflicts with UART0 TXD.
GPIO15 | GPIO pin designator (0, 15). Conflicts with UART0 RXD.
GPIO16 | GPIO pin designator (0, 16). Conflicts with SPI1 SS2.
GPIO17 | GPIO pin designator (0, 17). Conflicts with SPI1 SS1.
GPIO18 | GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.
GPIO19 | GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO.
GPIO2 | GPIO pin designator (0, 2). Conflicts with I2C1 SDA.
GPIO20 | GPIO pin designator (0, 20). Conflicts with SPI1 MOSI.
GPIO21 | GPIO pin designator (0, 21). Conflicts with SPI1 SCLK.
GPIO22 | GPIO pin designator (0, 22).
GPIO23 | GPIO pin designator (0, 23).
GPIO24 | GPIO pin designator (0, 24).
GPIO25 | GPIO pin designator (0, 25).
GPIO26 | GPIO pin designator (0, 26).
GPIO27 | GPIO pin designator (0, 27).
GPIO3 | GPIO pin designator (0, 3). Conflicts with I2C1 SCL.
GPIO4 | GPIO pin designator (0, 4).
GPIO5 | GPIO pin designator (0, 5).
GPIO6 | GPIO pin designator (0, 6).
GPIO7 | GPIO pin designator (0, 7). Conflicts with SPI0 SS1.
GPIO8 | GPIO pin designator (0, 8). Conflicts with SPI0 SS0.
GPIO9 | GPIO pin designator (0, 9). Conflicts with SPI0 MISO.
I2C1 | I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.
I2C3 | I2C bus designator (0, 3). Requires the i2c3.dtbo device tree overlay).
I2C4 | I2C bus designator (0, 4). Requires the i2c4.dtbo device tree overlay).
I2C5 | I2C bus designator (0, 5). Requires the i2c5.dtbo device tree overlay).
I2C6 | I2C bus designator (0, 6). Requires the i2c6.dtbo device tree overlay).
PWM0 | PWM output designator (0, 0). Conflicts with GPIO12 or GPIO18. Requires the pwm.dtbo device tree overlay.
PWM1 | PWM output designator (0, 1). Conflicts with GPIO13 or GPIO19. Requires the pwm.dtbo device tree overlay.
SPI0_0 | SPI slave designator (0, 0). Conflicts with GPIO8.
SPI0_1 | SPI slave designator (0, 1). Conflicts with GPIO7.
SPI1_0 | SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_1 | SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_2 | SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
Top
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN0 Field

RaspberryPi4AIN0 Field

Analog input designator (0, 0).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN0

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN1 Field

RaspberryPi4AIN1 Field

Analog input designator (0, 1).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN1

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN2 Field

RaspberryPi4AIN2 Field

Analog input designator (0, 2).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN2

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN3 Field

RaspberryPi4AIN3 Field

Analog input designator (0, 3).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN3

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN4 Field

RaspberryPi4AIN4 Field

Analog input designator (0, 4).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN4

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN5 Field

RaspberryPi4AIN5 Field

Analog input designator (0, 5).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN5

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN6 Field

RaspberryPi4AIN6 Field

Analog input designator (0, 6).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN6

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.AIN7 Field

RaspberryPi4AIN7 Field

Analog input designator (0, 7).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN7

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO10 Field

RaspberryPi4GPIO10 Field

GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO10

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO11 Field

RaspberryPi4GPIO11 Field

GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO11

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO12 Field

RaspberryPi4GPIO12 Field

GPIO pin designator (0, 12).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO12

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO13 Field

RaspberryPi4GPIO13 Field

GPIO pin designator (0, 13).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO13

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO14 Field

RaspberryPi4GPIO14 Field

GPIO pin designator (0, 14). Conflicts with UART0 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO14

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO15 Field

RaspberryPi4GPIO15 Field

GPIO pin designator (0, 15). Conflicts with UART0 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO15

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO16 Field

RaspberryPi4GPIO16 Field

GPIO pin designator (0, 16). Conflicts with SPI1 SS2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO16

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO17 Field

RaspberryPi4GPIO17 Field

GPIO pin designator (0, 17). Conflicts with SPI1 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO17

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO18 Field

RaspberryPi4GPIO18 Field

GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO18

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO19 Field

RaspberryPi4GPIO19 Field

GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO19

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO2 Field

RaspberryPi4GPIO2 Field

GPIO pin designator (0, 2). Conflicts with I2C1 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO2

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO20 Field

RaspberryPi4GPIO20 Field

GPIO pin designator (0, 20). Conflicts with SPI1 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO20

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO21 Field

RaspberryPi4GPIO21 Field

GPIO pin designator (0, 21). Conflicts with SPI1 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO21

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO22 Field

RaspberryPi4GPIO22 Field

GPIO pin designator (0, 22).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO22

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO23 Field

RaspberryPi4GPIO23 Field

GPIO pin designator (0, 23).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO23

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO24 Field

RaspberryPi4GPIO24 Field

GPIO pin designator (0, 24).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO24

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO25 Field

RaspberryPi4GPIO25 Field

GPIO pin designator (0, 25).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO25

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO26 Field

RaspberryPi4GPIO26 Field

GPIO pin designator (0, 26).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO26

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO27 Field

RaspberryPi4GPIO27 Field

GPIO pin designator (0, 27).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO27

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO3 Field

RaspberryPi4GPIO3 Field

GPIO pin designator (0, 3). Conflicts with I2C1 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO3

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO4 Field

RaspberryPi4GPIO4 Field

GPIO pin designator (0, 4).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO4

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO5 Field

RaspberryPi4GPIO5 Field

GPIO pin designator (0, 5).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO5

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO6 Field

RaspberryPi4GPIO6 Field

GPIO pin designator (0, 6).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO6

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO7 Field

RaspberryPi4GPIO7 Field

GPIO pin designator (0, 7). Conflicts with SPI0 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO7

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO8 Field

RaspberryPi4GPIO8 Field

GPIO pin designator (0, 8). Conflicts with SPI0 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO8

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.GPIO9 Field

RaspberryPi4GPIO9 Field

GPIO pin designator (0, 9). Conflicts with SPI0 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO9

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.I2C1 Field

RaspberryPi4I2C1 Field

I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C1

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.I2C3 Field

RaspberryPi4I2C3 Field

I2C bus designator (0, 3). Requires the i2c3.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C3

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.I2C4 Field

RaspberryPi4I2C4 Field

I2C bus designator (0, 4). Requires the i2c4.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C4

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.I2C5 Field

RaspberryPi4I2C5 Field

I2C bus designator (0, 5). Requires the i2c5.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C5

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.I2C6 Field

RaspberryPi4I2C6 Field

I2C bus designator (0, 6). Requires the i2c6.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C6

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.PWM0 Field

RaspberryPi4PWM0 Field

PWM output designator (0, 0). Conflicts with GPIO12 or GPIO18. Requires the pwm.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM0

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.PWM1 Field

RaspberryPi4PWM1 Field

PWM output designator (0, 1). Conflicts with GPIO13 or GPIO19. Requires the pwm.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM1

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.SPI0_0 Field

RaspberryPi4SPI0_0 Field

SPI slave designator (0, 0). Conflicts with GPIO8.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_0

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.SPI0_1 Field

RaspberryPi4SPI0_1 Field

SPI slave designator (0, 1). Conflicts with GPIO7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_1

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.SPI1_0 Field

RaspberryPi4SPI1_0 Field

SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_0

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.SPI1_1 Field

RaspberryPi4SPI1_1 Field

SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_1

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi4.SPI1_2 Field

RaspberryPi4SPI1_2 Field

SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_2

Field Value

Designator
See Also

Reference

RaspberryPi4 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5 Class

This class defines identifiers for the devices provided by the Raspberry Pi 5 hardware platform.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PlatformsRaspberryPi5

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static class RaspberryPi5

The RaspberryPi5 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input designator (0, 0).
AIN1 | Analog input designator (0, 1).
AIN2 | Analog input designator (0, 2).
AIN3 | Analog input designator (0, 3).
AIN4 | Analog input designator (0, 4).
AIN5 | Analog input designator (0, 5).
AIN6 | Analog input designator (0, 6).
AIN7 | Analog input designator (0, 7).
GPIO0 | GPIO pin designator (0, 0). Conflicts with I2C0 SDA.
GPIO1 | GPIO pin designator (0, 1). Conflicts with I2C0 SDA.
GPIO10 | GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.
GPIO11 | GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.
GPIO12 | GPIO pin designator (0, 12).
GPIO13 | GPIO pin designator (0, 13).
GPIO14 | GPIO pin designator (0, 14). Conflicts with UART0 TXD.
GPIO15 | GPIO pin designator (0, 15). Conflicts with UART0 RXD.
GPIO16 | GPIO pin designator (0, 16). Conflicts with SPI1 SS2.
GPIO17 | GPIO pin designator (0, 17). Conflicts with SPI1 SS1.
GPIO18 | GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.
GPIO19 | GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO.
GPIO2 | GPIO pin designator (0, 2). Conflicts with I2C1 SDA.
GPIO20 | GPIO pin designator (0, 20). Conflicts with SPI1 MOSI.
GPIO21 | GPIO pin designator (0, 21). Conflicts with SPI1 SCLK.
GPIO22 | GPIO pin designator (0, 22).
GPIO23 | GPIO pin designator (0, 23).
GPIO24 | GPIO pin designator (0, 24).
GPIO25 | GPIO pin designator (0, 25).
GPIO26 | GPIO pin designator (0, 26).
GPIO27 | GPIO pin designator (0, 27).
GPIO3 | GPIO pin designator (0, 3). Conflicts with I2C1 SCL.
GPIO4 | GPIO pin designator (0, 4).
GPIO5 | GPIO pin designator (0, 5).
GPIO6 | GPIO pin designator (0, 6).
GPIO7 | GPIO pin designator (0, 7). Conflicts with SPI0 SS1.
GPIO8 | GPIO pin designator (0, 8). Conflicts with SPI0 SS0.
GPIO9 | GPIO pin designator (0, 9). Conflicts with SPI0 MISO.
I2C0 | I2C bus designator (0, 0). Conflicts with GPIO0 and GPIO1 or GPIO8 and GPIO9. Requires the i2c0.dtbo device tree overlay).
I2C1 | I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.
I2C2 | I2C bus designator (0, 2). Conflicts with GPIO4 and GPIO5 or GPIO12 and GPIO13. Requires the i2c2.dtbo device tree overlay).
I2C3 | I2C bus designator (0, 3). Conflicts with GPIO6 and GPIO7 or GPIO14 and GPIO15. Requires the i2c3.dtbo device tree overlay).
PWM0 | PWM output designator (2, 0). Conflicts with GPIO12. Requires the pwmchip.dtbo device tree overlay.
PWM1 | PWM output designator (2, 1). Conflicts with GPIO13. Requires the pwmchip.dtbo device tree overlay.
PWM2 | PWM output designator (2, 2). Conflicts with GPIO14 or GPIO18. Requires the pwmchip.dtbo device tree overlay.
PWM3 | PWM output designator (2, 3). Conflicts with GPIO15 or GPIO19. Requires the pwmchip.dtbo device tree overlay.
SPI0_0 | SPI slave designator (0, 0). Conflicts with GPIO8.
SPI0_1 | SPI slave designator (0, 1). Conflicts with GPIO7.
SPI1_0 | SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_1 | SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_2 | SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
Top
See Also

Reference

IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5 Fields

The RaspberryPi5 type exposes the following members.

Fields
Name | Description
AIN0 | Analog input designator (0, 0).
AIN1 | Analog input designator (0, 1).
AIN2 | Analog input designator (0, 2).
AIN3 | Analog input designator (0, 3).
AIN4 | Analog input designator (0, 4).
AIN5 | Analog input designator (0, 5).
AIN6 | Analog input designator (0, 6).
AIN7 | Analog input designator (0, 7).
GPIO0 | GPIO pin designator (0, 0). Conflicts with I2C0 SDA.
GPIO1 | GPIO pin designator (0, 1). Conflicts with I2C0 SDA.
GPIO10 | GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.
GPIO11 | GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.
GPIO12 | GPIO pin designator (0, 12).
GPIO13 | GPIO pin designator (0, 13).
GPIO14 | GPIO pin designator (0, 14). Conflicts with UART0 TXD.
GPIO15 | GPIO pin designator (0, 15). Conflicts with UART0 RXD.
GPIO16 | GPIO pin designator (0, 16). Conflicts with SPI1 SS2.
GPIO17 | GPIO pin designator (0, 17). Conflicts with SPI1 SS1.
GPIO18 | GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.
GPIO19 | GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO.
GPIO2 | GPIO pin designator (0, 2). Conflicts with I2C1 SDA.
GPIO20 | GPIO pin designator (0, 20). Conflicts with SPI1 MOSI.
GPIO21 | GPIO pin designator (0, 21). Conflicts with SPI1 SCLK.
GPIO22 | GPIO pin designator (0, 22).
GPIO23 | GPIO pin designator (0, 23).
GPIO24 | GPIO pin designator (0, 24).
GPIO25 | GPIO pin designator (0, 25).
GPIO26 | GPIO pin designator (0, 26).
GPIO27 | GPIO pin designator (0, 27).
GPIO3 | GPIO pin designator (0, 3). Conflicts with I2C1 SCL.
GPIO4 | GPIO pin designator (0, 4).
GPIO5 | GPIO pin designator (0, 5).
GPIO6 | GPIO pin designator (0, 6).
GPIO7 | GPIO pin designator (0, 7). Conflicts with SPI0 SS1.
GPIO8 | GPIO pin designator (0, 8). Conflicts with SPI0 SS0.
GPIO9 | GPIO pin designator (0, 9). Conflicts with SPI0 MISO.
I2C0 | I2C bus designator (0, 0). Conflicts with GPIO0 and GPIO1 or GPIO8 and GPIO9. Requires the i2c0.dtbo device tree overlay).
I2C1 | I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.
I2C2 | I2C bus designator (0, 2). Conflicts with GPIO4 and GPIO5 or GPIO12 and GPIO13. Requires the i2c2.dtbo device tree overlay).
I2C3 | I2C bus designator (0, 3). Conflicts with GPIO6 and GPIO7 or GPIO14 and GPIO15. Requires the i2c3.dtbo device tree overlay).
PWM0 | PWM output designator (2, 0). Conflicts with GPIO12. Requires the pwmchip.dtbo device tree overlay.
PWM1 | PWM output designator (2, 1). Conflicts with GPIO13. Requires the pwmchip.dtbo device tree overlay.
PWM2 | PWM output designator (2, 2). Conflicts with GPIO14 or GPIO18. Requires the pwmchip.dtbo device tree overlay.
PWM3 | PWM output designator (2, 3). Conflicts with GPIO15 or GPIO19. Requires the pwmchip.dtbo device tree overlay.
SPI0_0 | SPI slave designator (0, 0). Conflicts with GPIO8.
SPI0_1 | SPI slave designator (0, 1). Conflicts with GPIO7.
SPI1_0 | SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_1 | SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
SPI1_2 | SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.
Top
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN0 Field

RaspberryPi5AIN0 Field

Analog input designator (0, 0).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN0

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN1 Field

RaspberryPi5AIN1 Field

Analog input designator (0, 1).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN1

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN2 Field

RaspberryPi5AIN2 Field

Analog input designator (0, 2).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN2

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN3 Field

RaspberryPi5AIN3 Field

Analog input designator (0, 3).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN3

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN4 Field

RaspberryPi5AIN4 Field

Analog input designator (0, 4).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN4

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN5 Field

RaspberryPi5AIN5 Field

Analog input designator (0, 5).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN5

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN6 Field

RaspberryPi5AIN6 Field

Analog input designator (0, 6).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN6

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.AIN7 Field

RaspberryPi5AIN7 Field

Analog input designator (0, 7).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator AIN7

Field Value

Designator
Remarks
Raspberry Pi boards don't have a built-in ADC (Analog to Digital Converter) subsystem, so this is just a placeholder for the first IIO (Industrial I/O) ADC device.
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO0 Field

RaspberryPi5GPIO0 Field

GPIO pin designator (0, 0). Conflicts with I2C0 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO0

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO1 Field

RaspberryPi5GPIO1 Field

GPIO pin designator (0, 1). Conflicts with I2C0 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO1

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO10 Field

RaspberryPi5GPIO10 Field

GPIO pin designator (0, 10). Conflicts with SPI0 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO10

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO11 Field

RaspberryPi5GPIO11 Field

GPIO pin designator (0, 11). Conflicts with SPI0 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO11

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO12 Field

RaspberryPi5GPIO12 Field

GPIO pin designator (0, 12).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO12

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO13 Field

RaspberryPi5GPIO13 Field

GPIO pin designator (0, 13).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO13

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO14 Field

RaspberryPi5GPIO14 Field

GPIO pin designator (0, 14). Conflicts with UART0 TXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO14

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO15 Field

RaspberryPi5GPIO15 Field

GPIO pin designator (0, 15). Conflicts with UART0 RXD.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO15

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO16 Field

RaspberryPi5GPIO16 Field

GPIO pin designator (0, 16). Conflicts with SPI1 SS2.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO16

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO17 Field

RaspberryPi5GPIO17 Field

GPIO pin designator (0, 17). Conflicts with SPI1 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO17

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO18 Field

RaspberryPi5GPIO18 Field

GPIO pin designator (0, 18). Conflicts with PWM0 or SPI1 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO18

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO19 Field

RaspberryPi5GPIO19 Field

GPIO pin designator (0, 19). Conflicts with PWM1 or SPI1 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO19

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO2 Field

RaspberryPi5GPIO2 Field

GPIO pin designator (0, 2). Conflicts with I2C1 SDA.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO2

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO20 Field

RaspberryPi5GPIO20 Field

GPIO pin designator (0, 20). Conflicts with SPI1 MOSI.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO20

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO21 Field

RaspberryPi5GPIO21 Field

GPIO pin designator (0, 21). Conflicts with SPI1 SCLK.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO21

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO22 Field

RaspberryPi5GPIO22 Field

GPIO pin designator (0, 22).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO22

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO23 Field

RaspberryPi5GPIO23 Field

GPIO pin designator (0, 23).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO23

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO24 Field

RaspberryPi5GPIO24 Field

GPIO pin designator (0, 24).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO24

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO25 Field

RaspberryPi5GPIO25 Field

GPIO pin designator (0, 25).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO25

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO26 Field

RaspberryPi5GPIO26 Field

GPIO pin designator (0, 26).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO26

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO27 Field

RaspberryPi5GPIO27 Field

GPIO pin designator (0, 27).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO27

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO3 Field

RaspberryPi5GPIO3 Field

GPIO pin designator (0, 3). Conflicts with I2C1 SCL.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO3

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO4 Field

RaspberryPi5GPIO4 Field

GPIO pin designator (0, 4).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO4

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO5 Field

RaspberryPi5GPIO5 Field

GPIO pin designator (0, 5).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO5

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO6 Field

RaspberryPi5GPIO6 Field

GPIO pin designator (0, 6).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO6

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO7 Field

RaspberryPi5GPIO7 Field

GPIO pin designator (0, 7). Conflicts with SPI0 SS1.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO7

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO8 Field

RaspberryPi5GPIO8 Field

GPIO pin designator (0, 8). Conflicts with SPI0 SS0.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO8

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.GPIO9 Field

RaspberryPi5GPIO9 Field

GPIO pin designator (0, 9). Conflicts with SPI0 MISO.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator GPIO9

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.I2C0 Field

RaspberryPi5I2C0 Field

I2C bus designator (0, 0). Conflicts with GPIO0 and GPIO1 or GPIO8 and GPIO9. Requires the i2c0.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C0

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.I2C1 Field

RaspberryPi5I2C1 Field

I2C bus designator (0, 1). Conflicts with GPIO2 and GPIO3.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C1

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.I2C2 Field

RaspberryPi5I2C2 Field

I2C bus designator (0, 2). Conflicts with GPIO4 and GPIO5 or GPIO12 and GPIO13. Requires the i2c2.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C2

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.I2C3 Field

RaspberryPi5I2C3 Field

I2C bus designator (0, 3). Conflicts with GPIO6 and GPIO7 or GPIO14 and GPIO15. Requires the i2c3.dtbo device tree overlay).

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator I2C3

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.PWM0 Field

RaspberryPi5PWM0 Field

PWM output designator (2, 0). Conflicts with GPIO12. Requires the pwmchip.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM0

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.PWM1 Field

RaspberryPi5PWM1 Field

PWM output designator (2, 1). Conflicts with GPIO13. Requires the pwmchip.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM1

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.PWM2 Field

RaspberryPi5PWM2 Field

PWM output designator (2, 2). Conflicts with GPIO14 or GPIO18. Requires the pwmchip.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM2

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.PWM3 Field

RaspberryPi5PWM3 Field

PWM output designator (2, 3). Conflicts with GPIO15 or GPIO19. Requires the pwmchip.dtbo device tree overlay.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator PWM3

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.SPI0_0 Field

RaspberryPi5SPI0_0 Field

SPI slave designator (0, 0). Conflicts with GPIO8.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_0

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.SPI0_1 Field

RaspberryPi5SPI0_1 Field

SPI slave designator (0, 1). Conflicts with GPIO7.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI0_1

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.SPI1_0 Field

RaspberryPi5SPI1_0 Field

SPI slave designator (1, 0). Conflicts with GPIO18 or PWM0. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_0

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.SPI1_1 Field

RaspberryPi5SPI1_1 Field

SPI slave designator (1, 1). Conflicts with GPIO17. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_1

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


RaspberryPi5.SPI1_2 Field

RaspberryPi5SPI1_2 Field

SPI slave designator (1, 2). Conflicts with GPIO16. Requires one of the spi1-1cs.dtbo, spi1-2cs.dtbo or spi1-3cs.dtbo device tree overlays.

Namespace: IO.Objects.SimpleIO.Platforms
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public static readonly Designator SPI1_2

Field Value

Designator
See Also

Reference

RaspberryPi5 Class
IO.Objects.SimpleIO.Platforms Namespace


IO.Objects.SimpleIO.PWM Namespace

PWM (Pulse Width Modulated) Output Services
Classes
 | Class | Description
Public class | Output | Encapsulates Linux PWM outputs using libsimpleio.


Output Class

Encapsulates Linux PWM outputs using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.PWMOutput

Namespace: IO.Objects.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Constructor for a single PWM output.
Top
Properties
 | Name | Description
Public property | dutycycle | Write-only property for setting the PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.
Public property | fd | Read-only property returning the Linux file descriptor for the PWM output.
Top
See Also

Reference

IO.Objects.SimpleIO.PWM Namespace


Output Constructor

Constructor for a single PWM output.

Namespace: IO.Objects.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Designator desg,
    int frequency,
    double dutycycle = 0,
    int polarity = 1
)

Parameters

desg Designator
PWM output designator.
frequency Int32
PWM pulse frequency.
dutycycle Double (Optional)
Initial PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.
polarity Int32 (Optional)
PWM output polarity.
See Also

Reference

Output Class
IO.Objects.SimpleIO.PWM Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | dutycycle | Write-only property for setting the PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.
Public property | fd | Read-only property returning the Linux file descriptor for the PWM output.
Top
See Also

Reference

Output Class
IO.Objects.SimpleIO.PWM Namespace


Output.dutycycle Property

Outputdutycycle Property

Write-only property for setting the PWM output duty cycle. Allowed values are 0.0 to 100.0 percent.

Namespace: IO.Objects.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double dutycycle { set; }

Property Value

Double

Implements

Outputdutycycle
See Also

Reference

Output Class
IO.Objects.SimpleIO.PWM Namespace


Output.fd Property

Outputfd Property

Read-only property returning the Linux file descriptor for the PWM output.

Namespace: IO.Objects.SimpleIO.PWM
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Output Class
IO.Objects.SimpleIO.PWM Namespace


IO.Objects.SimpleIO.Servo Namespace

Servo Output Services
Classes
 | Class | Description
Public class | Output | Encapsulates Linux servo outputs using libsimpleio.


Output Class

Encapsulates Linux servo outputs using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.ServoOutput

Namespace: IO.Objects.SimpleIO.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Output : Output

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Constructor for a single servo output.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the servo output.
Public property | position | Write-only property for setting the servo position. Allowed values are -1.0 to +1.0.
Top
See Also

Reference

IO.Objects.SimpleIO.Servo Namespace


Output Constructor

Constructor for a single servo output.

Namespace: IO.Objects.SimpleIO.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Output(
    Designator desg,
    int frequency = 50,
    double position = 0
)

Parameters

desg Designator
PWM output designator.
frequency Int32 (Optional)
PWM pulse frequency.
position Double (Optional)
Initial servo position.
See Also

Reference

Output Class
IO.Objects.SimpleIO.Servo Namespace


Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the servo output.
Public property | position | Write-only property for setting the servo position. Allowed values are -1.0 to +1.0.
Top
See Also

Reference

Output Class
IO.Objects.SimpleIO.Servo Namespace


Output.fd Property

Outputfd Property

Read-only property returning the Linux file descriptor for the servo output.

Namespace: IO.Objects.SimpleIO.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Output Class
IO.Objects.SimpleIO.Servo Namespace


Output.position Property

Outputposition Property

Write-only property for setting the servo position. Allowed values are -1.0 to +1.0.

Namespace: IO.Objects.SimpleIO.Servo
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public double position { set; }

Property Value

Double

Implements

Outputposition
See Also

Reference

Output Class
IO.Objects.SimpleIO.Servo Namespace


IO.Objects.SimpleIO.SPI Namespace

SPI (Serial Peripheral Interconnect) Device Services
Classes
 | Class | Description
Public class | Device | Encapsulates Linux SPI slave devices using libsimpleio.


Device Class

Encapsulates Linux SPI slave devices using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.SPIDevice

Namespace: IO.Objects.SimpleIO.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Device : Device

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Constructor for a single SPI device.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the SPI slave device.
Top
Methods
 | Name | Description
Public method | Read | Read bytes from an SPI slave device.
Public method | Transaction | Write and read bytes to and from an SPI slave device.
Public method | Write | Write bytes to an SPI slave device.
Top
See Also

Reference

IO.Objects.SimpleIO.SPI Namespace


Device Constructor

Constructor for a single SPI device.

Namespace: IO.Objects.SimpleIO.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Device(
    Designator desg,
    int mode,
    int wordsize,
    int speed,
    Designator? cspin = null
)

Parameters

desg Designator
SPI slave device designator.
mode Int32
SPI clock mode.
wordsize Int32
SPI transfer word size.
speed Int32
SPI transfer speed.
cspin Nullable Designator (Optional)
SPI software slave select GPIO pin designator, or null.
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the SPI slave device.
Top
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


Device.fd Property

Devicefd Property

Read-only property returning the Linux file descriptor for the SPI slave device.

Namespace: IO.Objects.SimpleIO.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Read | Read bytes from an SPI slave device.
Public method | Transaction | Write and read bytes to and from an SPI slave device.
Public method | Write | Write bytes to an SPI slave device.
Top
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


Device.Read Method

DeviceRead Method

Read bytes from an SPI slave device.

Namespace: IO.Objects.SimpleIO.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Read(
    byte[] resp,
    int resplen
)

Parameters

resp Byte
Response buffer.
resplen Int32
Number of bytes to read.

Implements

DeviceRead(Byte, Int32)
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


Device.Transaction Method

DeviceTransaction Method

Write and read bytes to and from an SPI slave device.

Namespace: IO.Objects.SimpleIO.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Transaction(
    byte[] cmd,
    int cmdlen,
    byte[] resp,
    int resplen,
    int delayus = 0
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.
resp Byte
Response buffer.
resplen Int32
Number of bytes to read.
delayus Int32 (Optional)
Delay in microseconds between write and read operations.

Implements

DeviceTransaction(Byte, Int32, Byte, Int32, Int32)
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


Device.Write Method

DeviceWrite Method

Write bytes to an SPI slave device.

Namespace: IO.Objects.SimpleIO.SPI
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Write(
    byte[] cmd,
    int cmdlen
)

Parameters

cmd Byte
Command buffer.
cmdlen Int32
Number of bytes to write.

Implements

DeviceWrite(Byte, Int32)
See Also

Reference

Device Class
IO.Objects.SimpleIO.SPI Namespace


IO.Objects.SimpleIO.syslog Namespace

Error Logging Services Using the Linux syslog Subsystem
Classes
Class | Description
Logger | Encapsulates system logging services using libsimpleio.


Logger Class

Encapsulates system logging services using libsimpleio.
Inheritance Hierarchy
System.DiagnosticsTraceListener
IO.Objects.SimpleIO.syslogLogger

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Logger : TraceListener

The Logger type exposes the following members.

Constructors
 | Name | Description
Public method | Logger | Constructor for a logging object that uses the Linux syslog service.
Top
Methods
 | Name | Description
Public method | Error(String) | Log an error message.
Public method | Error(String, Int32) | Log an error message, including an errno error string.
Public method | Note | Log a notification message.
Public method | Warning | Log a warning message.
Public method | Write | Trace interface method for posting a message.
Public method | WriteLine | Trace interface method for posting a message.
Top
Fields
Name | Description
LOG_ALERT | Alert condition message.
LOG_AUTH | Authentication facility.
LOG_CRIT | Critical condition message.
LOG_DAEMON | System daemon/background process facility.
LOG_DEBUG | Debug message.
LOG_EMERG | Emergency condition message.
LOG_ERR | Error message.
LOG_INFO | Informational message.
LOG_LOCAL0 | Locally defined facility.
LOG_LOCAL1 | Locally defined facility.
LOG_LOCAL2 | Locally defined facility.
LOG_LOCAL3 | Locally defined facility.
LOG_LOCAL4 | Locally defined facility.
LOG_LOCAL5 | Locally defined facility.
LOG_LOCAL6 | Locally defined facility.
LOG_LOCAL7 | Locally defined facility.
LOG_MAIL | Mail subsystem facility.
LOG_NDELAY | Open the connection to the syslog service immediately. Recommended.
LOG_NOTICE | Normal condition message.
LOG_ODELAY | Do not open the connection to the syslog service before logging the first message. Not recommended.
LOG_PERROR | Write message to both syslog service AND stderr.
LOG_PID | Prepend the caller's process ID to the message.
LOG_USER | User program facility. Use LOG_LOCALx instead.
LOG_WARNING | Warning message.
Top
Remarks
An instance of this class can be used either standalone or as a System.Diagnostics.TraceListener. The static methods Systems.Diagnostics.Trace.Write() and Systems.Diagnostics.Trace.WriteIf() most naturally fit the Linux syslog facility.
Example
C#
Copy
var log = new IO.Objects.SimpleIO.syslog.Logger();
log.Note("Hello, Syslog!");

System.Diagnostics.Trace.Listeners.Clear();
System.Diagnostics.Trace.Listeners.Add(log);
System.Diagnostics.Trace.Write("Hello, Trace!");
See Also

Reference

IO.Objects.SimpleIO.syslog Namespace


Logger Constructor

Constructor for a logging object that uses the Linux syslog service.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Logger(
    string id = "@@APPNAME@@",
    int facility = 128,
    int options = 8,
    int severity = 6
)

Parameters

id String (Optional)
Program identifier string.
facility Int32 (Optional)
syslog facility.
options Int32 (Optional)
syslog options.
severity Int32 (Optional)
syslog severity level.
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger Methods

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | Error(String) | Log an error message.
Public method | Error(String, Int32) | Log an error message, including an errno error string.
Public method | Note | Log a notification message.
Public method | Warning | Log a warning message.
Public method | Write | Trace interface method for posting a message.
Public method | WriteLine | Trace interface method for posting a message.
Top
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.Error Method

LoggerError Method

Overload List
 | Name | Description
Public method | Error(String) | Log an error message.
Public method | Error(String, Int32) | Log an error message, including an errno error string.
Top
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.Error(String) Method

LoggerError(String) Method

Log an error message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Error(
    string message
)

Parameters

message String
Error message.
See Also

Reference

Logger Class
Error Overload
IO.Objects.SimpleIO.syslog Namespace


Logger.Error(String, Int32) Method

LoggerError(String, Int32) Method

Log an error message, including an errno error string.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Error(
    string message,
    int errnum
)

Parameters

message String
Error Message.
errnum Int32
errno error number.
See Also

Reference

Logger Class
Error Overload
IO.Objects.SimpleIO.syslog Namespace


Logger.Note Method

LoggerNote Method

Log a notification message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Note(
    string message
)

Parameters

message String
Notification message.
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.Warning Method

LoggerWarning Method

Log a warning message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Warning(
    string message
)

Parameters

message String
Warning message.
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.Write Method

LoggerWrite Method

Trace interface method for posting a message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public virtual void Write(
    string message
)

Parameters

message String
Trace message.
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.WriteLine Method

LoggerWriteLine Method

Trace interface method for posting a message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public virtual void WriteLine(
    string message
)

Parameters

message String
Trace message.
Remarks
This method implementation is identical to Write(), because syslog is not a line oriented service.
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger Fields

The Logger type exposes the following members.

Fields
Name | Description
LOG_ALERT | Alert condition message.
LOG_AUTH | Authentication facility.
LOG_CRIT | Critical condition message.
LOG_DAEMON | System daemon/background process facility.
LOG_DEBUG | Debug message.
LOG_EMERG | Emergency condition message.
LOG_ERR | Error message.
LOG_INFO | Informational message.
LOG_LOCAL0 | Locally defined facility.
LOG_LOCAL1 | Locally defined facility.
LOG_LOCAL2 | Locally defined facility.
LOG_LOCAL3 | Locally defined facility.
LOG_LOCAL4 | Locally defined facility.
LOG_LOCAL5 | Locally defined facility.
LOG_LOCAL6 | Locally defined facility.
LOG_LOCAL7 | Locally defined facility.
LOG_MAIL | Mail subsystem facility.
LOG_NDELAY | Open the connection to the syslog service immediately. Recommended.
LOG_NOTICE | Normal condition message.
LOG_ODELAY | Do not open the connection to the syslog service before logging the first message. Not recommended.
LOG_PERROR | Write message to both syslog service AND stderr.
LOG_PID | Prepend the caller's process ID to the message.
LOG_USER | User program facility. Use LOG_LOCALx instead.
LOG_WARNING | Warning message.
Top
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_ALERT Field

LoggerLOG_ALERT Field

Alert condition message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_ALERT = 1

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_AUTH Field

LoggerLOG_AUTH Field

Authentication facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_AUTH = 32

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_CRIT Field

LoggerLOG_CRIT Field

Critical condition message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_CRIT = 2

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_DAEMON Field

LoggerLOG_DAEMON Field

System daemon/background process facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_DAEMON = 24

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_DEBUG Field

LoggerLOG_DEBUG Field

Debug message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_DEBUG = 7

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_EMERG Field

LoggerLOG_EMERG Field

Emergency condition message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_EMERG = 0

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_ERR Field

LoggerLOG_ERR Field

Error message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_ERR = 3

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_INFO Field

LoggerLOG_INFO Field

Informational message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_INFO = 6

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL0 Field

LoggerLOG_LOCAL0 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL0 = 128

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL1 Field

LoggerLOG_LOCAL1 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL1 = 136

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL2 Field

LoggerLOG_LOCAL2 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL2 = 144

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL3 Field

LoggerLOG_LOCAL3 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL3 = 152

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL4 Field

LoggerLOG_LOCAL4 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL4 = 160

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL5 Field

LoggerLOG_LOCAL5 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL5 = 168

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL6 Field

LoggerLOG_LOCAL6 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL6 = 176

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_LOCAL7 Field

LoggerLOG_LOCAL7 Field

Locally defined facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_LOCAL7 = 184

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_MAIL Field

LoggerLOG_MAIL Field

Mail subsystem facility.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_MAIL = 16

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_NDELAY Field

LoggerLOG_NDELAY Field

Open the connection to the syslog service immediately. Recommended.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_NDELAY = 8

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_NOTICE Field

LoggerLOG_NOTICE Field

Normal condition message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_NOTICE = 5

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_ODELAY Field

LoggerLOG_ODELAY Field

Do not open the connection to the syslog service before logging the first message. Not recommended.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_ODELAY = 8

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_PERROR Field

LoggerLOG_PERROR Field

Write message to both syslog service AND stderr.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_PERROR = 32

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_PID Field

LoggerLOG_PID Field

Prepend the caller's process ID to the message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_PID = 1

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_USER Field

LoggerLOG_USER Field

User program facility. Use LOG_LOCALx instead.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_USER = 8

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


Logger.LOG_WARNING Field

LoggerLOG_WARNING Field

Warning message.

Namespace: IO.Objects.SimpleIO.syslog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int LOG_WARNING = 4

Field Value

Int32
See Also

Reference

Logger Class
IO.Objects.SimpleIO.syslog Namespace


IO.Objects.SimpleIO.Watchdog Namespace

Watchdog Timer Services
Classes
 | Class | Description
Public class | Timer | Encapsulates Linux watchdog timers using libsimpleio.


Timer Class

Encapsulates Linux watchdog timers using libsimpleio.
Inheritance Hierarchy
SystemObject
IO.Objects.SimpleIO.WatchdogTimer

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public class Timer : Timer

The Timer type exposes the following members.

Constructors
 | Name | Description
Public method | Timer | Constructor for a single watchdog timer.
Top
Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the watchdog timer.
Public property | timeout | Get or set the watchdog timeout. Not all platforms may support this. Even if supported, there may be constraints. For example, some platforms allow shortening the timeout but not lengthening it.
Top
Methods
 | Name | Description
Public method | Kick | Reset the watchdog timer.
Top
Fields
Name | Description
DefaultDevice | Default watchdog timer device name.
DefaultTimeout | Default watchdog timer timeout value (disabled).
Top
See Also

Reference

IO.Objects.SimpleIO.Watchdog Namespace


Timer Constructor

Constructor for a single watchdog timer.

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public Timer(
    string devname = "/dev/watchdog",
    int timeout = 0
)

Parameters

devname String (Optional)
Device node name.
timeout Int32 (Optional)
Watchdog timeout setting in seconds, or DefaultTimeout.
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer Properties

The Timer type exposes the following members.

Properties
 | Name | Description
Public property | fd | Read-only property returning the Linux file descriptor for the watchdog timer.
Public property | timeout | Get or set the watchdog timeout. Not all platforms may support this. Even if supported, there may be constraints. For example, some platforms allow shortening the timeout but not lengthening it.
Top
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer.fd Property

Timerfd Property

Read-only property returning the Linux file descriptor for the watchdog timer.

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int fd { get; }

Property Value

Int32
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer.timeout Property

Timertimeout Property

Get or set the watchdog timeout. Not all platforms may support this. Even if supported, there may be constraints. For example, some platforms allow shortening the timeout but not lengthening it.

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public int timeout { get; set; }

Property Value

Int32

Implements

Timertimeout
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer Methods

The Timer type exposes the following members.

Methods
 | Name | Description
Public method | Kick | Reset the watchdog timer.
Top
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer.Kick Method

TimerKick Method

Reset the watchdog timer.

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public void Kick()

Implements

TimerKick
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer Fields

The Timer type exposes the following members.

Fields
Name | Description
DefaultDevice | Default watchdog timer device name.
DefaultTimeout | Default watchdog timer timeout value (disabled).
Top
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer.DefaultDevice Field

TimerDefaultDevice Field

Default watchdog timer device name.

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const string DefaultDevice = "/dev/watchdog"

Field Value

String
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace


Timer.DefaultTimeout Field

TimerDefaultTimeout Field

Default watchdog timer timeout value (disabled).

Namespace: IO.Objects.SimpleIO.Watchdog
Assembly: libsimpleio (in libsimpleio.dll) Version: 2.2024.45.1
Syntax
C#
Copy
public const int DefaultTimeout = 0

Field Value

Int32
See Also

Reference

Timer Class
IO.Objects.SimpleIO.Watchdog Namespace